Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
This is the install log during the vagrant deployment on a Windows host running Virtual Box
PS C:\users\ewright\Documents\VirtualBoxProjects\Couch_to_OpenStack> vagrant up
Bringing machine 'controller' up with 'virtualbox' provider...
[controller] Importing base box 'precise64'...
←[0K[controller] Matching MAC address for NAT networking...
[controller] Setting the name of the VM...
[controller] Clearing any previously set forwarded ports...
[controller] Fixed port collision for 22 => 2222. Now on port 2200.
[controller] Creating shared folders metadata...
[controller] Clearing any previously set network interfaces...
[controller] Preparing network interfaces based on configuration...
[controller] Forwarding ports...
[controller] -- 22 => 2200 (adapter 1)
[controller] Running any VM customizations...
[controller] Booting VM...
[controller] Waiting for VM to boot. This can take a few minutes.
[controller] VM booted and ready for use!
[controller] Setting hostname...
[controller] Configuring and enabling network interfaces...
[controller] Mounting shared folders...
[controller] -- /vagrant
[controller] Running provisioner: shell...
[controller] Running: C:/Users/rpaulson/AppData/Local/Temp/vagrant-shell20130723-1960-rw0bcp
stdin: is not a tty
E: Invalid operation update
/vagrant/common.sh: line 3: $'\r': command not found
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package ubuntu-cloud-keyring
deb http://ubuntu-cloud.archive.canonical.com/ubuntu precise-proposed/grizzly main
E: Invalid operation update
/vagrant/common.sh: line 8: $'\r': command not found
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
libdbd-mysql-perl libdbi-perl libhtml-template-perl libmysqlclient18
libnet-daemon-perl libplrpc-perl mysql-client-5.5 mysql-client-core-5.5
mysql-common mysql-server-5.5 mysql-server-core-5.5
Suggested packages:
libipc-sharedcache-perl libterm-readkey-perl tinyca mailx
python-egenix-mxdatetime python-mysqldb-dbg
The following NEW packages will be installed:
libdbd-mysql-perl libdbi-perl libhtml-template-perl libmysqlclient18
libnet-daemon-perl libplrpc-perl mysql-client-5.5 mysql-client-core-5.5
mysql-common mysql-server mysql-server-5.5 mysql-server-core-5.5
python-mysqldb
0 upgraded, 13 newly installed, 0 to remove and 66 not upgraded.
Need to get 27.2 MB of archives.
After this operation, 97.3 MB of additional disk space will be used.
Err http://us.archive.ubuntu.com/ubuntu/ precise-updates/main mysql-common all 5.5.24-0ubuntu0.12.04.1
404 Not Found [IP: 91.189.91.13 80]
Get:1 http://us.archive.ubuntu.com/ubuntu/ precise/main libnet-daemon-perl all 0.48-1 [43.1 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ precise/main libplrpc-perl all 0.2020-2 [36.0 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ precise/main libdbi-perl amd64 1.616-1build2 [849 kB]
Err http://security.ubuntu.com/ubuntu/ precise-security/main mysql-common all 5.5.24-0ubuntu0.12.04.1
404 Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com/ubuntu/ precise-security/main libmysqlclient18 amd64 5.5.24-0ubuntu0.12.04.1
404 Not Found [IP: 91.189.92.181 80]
Get:4 http://us.archive.ubuntu.com/ubuntu/ precise/main libdbd-mysql-perl amd64 4.020-1build2 [106 kB]
Err http://us.archive.ubuntu.com/ubuntu/ precise-updates/main mysql-client-core-5.5 amd64 5.5.24-0ubuntu0.12.04.1
404 Not Found [IP: 91.189.91.13 80]
Get:5 http://us.archive.ubuntu.com/ubuntu/ precise/main libhtml-template-perl all 2.10-1 [65.0 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu/ precise/main python-mysqldb amd64 1.2.3-1build1 [63.1 kB]
Err http://security.ubuntu.com/ubuntu/ precise-security/main mysql-client-core-5.5 amd64 5.5.24-0ubuntu0.12.04.1
404 Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com/ubuntu/ precise-security/main mysql-client-5.5 amd64 5.5.24-0ubuntu0.12.04.1
404 Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com/ubuntu/ precise-security/main mysql-server-core-5.5 amd64 5.5.24-0ubuntu0.12.04.1
404 Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com/ubuntu/ precise-security/main mysql-server-5.5 amd64 5.5.24-0ubuntu0.12.04.1
404 Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com/ubuntu/ precise-security/main mysql-server all 5.5.24-0ubuntu0.12.04.1
404 Not Found [IP: 91.189.92.181 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-common_5.5.24-0ubuntu0.12.04.1_all.deb 40
4 Not Found [IP: 91.189.92.181 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.24-0ubuntu0.12.04.1_amd64.d
eb 404 Not Found [IP: 91.189.92.181 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-client-core-5.5_5.5.24-0ubuntu0.12.04.1_am
d64.deb 404 Not Found [IP: 91.189.92.181 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-client-5.5_5.5.24-0ubuntu0.12.04.1_amd64.d
eb 404 Not Found [IP: 91.189.92.181 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-server-core-5.5_5.5.24-0ubuntu0.12.04.1_am
d64.deb 404 Not Found [IP: 91.189.92.181 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-server-5.5_5.5.24-0ubuntu0.12.04.1_amd64.d
eb 404 Not Found [IP: 91.189.92.181 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-server_5.5.24-0ubuntu0.12.04.1_all.deb 40
4 Not Found [IP: 91.189.92.181 80]
Fetched 1,161 kB in 1s (1,131 kB/s)
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
sed: can't read /etc/mysql/my.cnf: No such file or directory
sed: can't read /etc/mysql/my.cnf: No such file or directory
/tmp/vagrant-shell: line 36: /etc/mysql/conf.d/skip-name-resolve.cnf: No such file or directory
restart: Unknown job: mysql
/tmp/vagrant-shell: line 41: mysql: command not found
/tmp/vagrant-shell: line 42: mysql: command not found
/tmp/vagrant-shell: line 43: mysql: command not found
/tmp/vagrant-shell: line 45: mysqladmin: command not found
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
dbconfig-common libjs-jquery libjs-sphinxdoc libjs-underscore libxslt1.1
python-crypto python-decorator python-eventlet python-formencode
python-greenlet python-httplib2 python-iso8601 python-keystone
python-keystoneclient python-lxml python-migrate python-openid
python-openssl python-pam python-passlib python-paste python-pastedeploy
python-pastescript python-pkg-resources python-prettytable python-routes
python-scgi python-setuptools python-sqlalchemy python-sqlalchemy-ext
python-tempita python-webob ssl-cert
Suggested packages:
virtual-mysql-client mysql-client postgresql-client javascript-common
python-crypto-dbg python-crypto-doc python-egenix-mxdatetime python-dns
python-greenlet-doc python-greenlet-dev python-greenlet-dbg python-memcached
python-lxml-dbg python-openssl-doc python-openssl-dbg python-pam-dbg
python-pastewebkit libapache2-mod-wsgi libapache2-mod-python
libapache2-mod-scgi python-pgsql libjs-mochikit python-flup python-cherrypy
python-cheetah python-distribute python-distribute-doc python-sqlalchemy-doc
python-psycopg2 python-mysqldb python-kinterbasdb python-pymssql
openssl-blacklist
The following NEW packages will be installed:
dbconfig-common keystone libjs-jquery libjs-sphinxdoc libjs-underscore
libxslt1.1 python-crypto python-decorator python-eventlet python-formencode
python-greenlet python-httplib2 python-iso8601 python-keyring
python-keystone python-keystoneclient python-lxml python-migrate
python-openid python-openssl python-pam python-passlib python-paste
python-pastedeploy python-pastescript python-pkg-resources
python-prettytable python-routes python-scgi python-setuptools
python-sqlalchemy python-sqlalchemy-ext python-tempita python-webob ssl-cert
0 upgraded, 35 newly installed, 0 to remove and 66 not upgraded.
Need to get 4,806 kB of archives.
After this operation, 22.3 MB of additional disk space will be used.
Err http://us.archive.ubuntu.com/ubuntu/ precise-updates/main libxslt1.1 amd64 1.1.26-8ubuntu1.1
404 Not Found [IP: 91.189.91.15 80]
Get:1 http://us.archive.ubuntu.com/ubuntu/ precise/main dbconfig-common all 1.8.47 [458 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ precise/main libjs-jquery all 1.7.1-1ubuntu1 [111 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ precise/main libjs-underscore all 1.1.6-1ubuntu2 [31.3 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main libjs-sphinxdoc all 1.1.3+dfsg-2ubuntu2.1 [45.1 kB]
Get:5 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main python-crypto amd64 2.4.1-1ubuntu0.1 [293 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu/ precise/main python-decorator all 3.3.2-1 [21.2 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main python-greenlet amd64 0.3.1-1ubuntu5.1 [15.1 kB]
Err http://us.archive.ubuntu.com/ubuntu/ precise-updates/main python-eventlet all 0.9.16-1ubuntu4.1
404 Not Found [IP: 91.189.91.15 80]
Get:8 http://us.archive.ubuntu.com/ubuntu/ precise/main python-pkg-resources all 0.6.24-1ubuntu1 [63.1 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu/ precise/main python-formencode all 1.2.4-2ubuntu2 [110 kB]
Get:10 http://us.archive.ubuntu.com/ubuntu/ precise/main python-httplib2 all 0.7.2-1ubuntu2 [57.2 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu/ precise/main python-keyring all 0.7.1-1fakesync1 [34.2 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu/ precise/main python-lxml amd64 2.3.2-1 [662 kB]
Get:13 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main python-sqlalchemy all 0.7.4-1ubuntu0.1 [452 kB]
Get:14 http://us.archive.ubuntu.com/ubuntu/ precise/main python-tempita all 0.5.1-1build1 [15.1 kB]
Get:15 http://us.archive.ubuntu.com/ubuntu/ precise/main python-migrate all 0.7.2-1ubuntu1 [156 kB]
Get:16 http://us.archive.ubuntu.com/ubuntu/ precise/main python-openid all 2.2.5-3ubuntu1 [118 kB]
Get:17 http://us.archive.ubuntu.com/ubuntu/ precise/main python-openssl amd64 0.12-1ubuntu2 [98.0 kB]
Get:18 http://us.archive.ubuntu.com/ubuntu/ precise/main python-pam amd64 0.4.2-12.2ubuntu4 [11.6 kB]
Get:19 http://us.archive.ubuntu.com/ubuntu/ precise/main python-paste all 1.7.5.1-4ubuntu2 [380 kB]
Get:20 http://us.archive.ubuntu.com/ubuntu/ precise/main python-pastedeploy all 1.5.0-2build1 [28.2 kB]
Get:21 http://us.archive.ubuntu.com/ubuntu/ precise/main python-setuptools all 0.6.24-1ubuntu1 [441 kB]
Get:22 http://us.archive.ubuntu.com/ubuntu/ precise/main python-pastescript all 1.7.5-1 [113 kB]
Get:23 http://us.archive.ubuntu.com/ubuntu/ precise/main python-prettytable all 0.5-1ubuntu2 [8,770 B]
Get:24 http://us.archive.ubuntu.com/ubuntu/ precise/main python-routes all 1.12.3-1ubuntu1 [27.1 kB]
Get:25 http://us.archive.ubuntu.com/ubuntu/ precise/main python-scgi amd64 1.13-1ubuntu1 [20.1 kB]
Get:26 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main python-sqlalchemy-ext amd64 0.7.4-1ubuntu0.1 [13.9 kB]
Get:27 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main ssl-cert all 1.0.28ubuntu0.1 [12.3 kB]
Get:28 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main python-webob all 1.1.1-1ubuntu0 [273 kB]
Get:29 http://us.archive.ubuntu.com/ubuntu/ precise/main python-passlib all 1.5.3-0ubuntu1 [152 kB]
Get:30 http://us.archive.ubuntu.com/ubuntu/ precise/main python-keystoneclient all 2012.1-0ubuntu1 [27.3 kB]
Get:31 http://us.archive.ubuntu.com/ubuntu/ precise/main python-iso8601 all 0.1.4-1ubuntu1 [5,826 B]
Err http://us.archive.ubuntu.com/ubuntu/ precise-updates/main python-keystone all 2012.1+stable~20120824-a16a0ab9-0ubunt
u2.2
404 Not Found [IP: 91.189.91.15 80]
Err http://security.ubuntu.com/ubuntu/ precise-security/main python-keystone all 2012.1+stable~20120824-a16a0ab9-0ubuntu
2.2
404 Not Found [IP: 91.189.92.190 80]
Err http://security.ubuntu.com/ubuntu/ precise-security/main keystone all 2012.1+stable~20120824-a16a0ab9-0ubuntu2.2
404 Not Found [IP: 91.189.92.190 80]
Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/libx/libxslt/libxslt1.1_1.1.26-8ubuntu1.1_amd64.deb 404
Not Found [IP: 91.189.91.15 80]
Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/p/python-eventlet/python-eventlet_0.9.16-1ubuntu4.1_all.de
b 404 Not Found [IP: 91.189.91.15 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/k/keystone/python-keystone_2012.1+stable~20120824-a16a0ab9-0
ubuntu2.2_all.deb 404 Not Found [IP: 91.189.92.190 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/k/keystone/keystone_2012.1+stable~20120824-a16a0ab9-0ubuntu2
.2_all.deb 404 Not Found [IP: 91.189.92.190 80]
Fetched 4,255 kB in 1s (2,297 kB/s)
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
/tmp/vagrant-shell: line 54: mysql: command not found
/tmp/vagrant-shell: line 55: mysql: command not found
/tmp/vagrant-shell: line 56: mysql: command not found
sed: can't read /etc/keystone/keystone.conf: No such file or directory
sed: can't read /etc/keystone/keystone.conf: No such file or directory
stop: Unknown job: keystone
start: Unknown job: keystone
sudo: keystone-manage: command not found
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
python-httplib2 python-prettytable
The following NEW packages will be installed:
python-httplib2 python-keystoneclient python-prettytable
dpkg-preconfigure: unable to re-open stdin: No such file or directory
0 upgraded, 3 newly installed, 0 to remove and 66 not upgraded.
Need to get 0 B/93.2 kB of archives.
After this operation, 471 kB of additional disk space will be used.
Selecting previously unselected package python-httplib2.
(Reading database ...
51095 files and directories currently installed.)
Unpacking python-httplib2 (from .../python-httplib2_0.7.2-1ubuntu2_all.deb) ...
Selecting previously unselected package python-prettytable.
Unpacking python-prettytable (from .../python-prettytable_0.5-1ubuntu2_all.deb) ...
Selecting previously unselected package python-keystoneclient.
Unpacking python-keystoneclient (from .../python-keystoneclient_2012.1-0ubuntu1_all.deb) ...
Setting up python-httplib2 (0.7.2-1ubuntu2) ...
Setting up python-prettytable (0.5-1ubuntu2) ...
Setting up python-keystoneclient (2012.1-0ubuntu1) ...
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Traceback (most recent call last):
File "/usr/bin/keystone", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Ign http://us.archive.ubuntu.com precise InRelease
Ign http://us.archive.ubuntu.com precise-updates InRelease
Ign http://us.archive.ubuntu.com precise-backports InRelease
Hit http://us.archive.ubuntu.com precise Release.gpg
Get:1 http://us.archive.ubuntu.com precise-updates Release.gpg [198 B]
Get:2 http://us.archive.ubuntu.com precise-backports Release.gpg [198 B]
Ign http://security.ubuntu.com precise-security InRelease
Hit http://us.archive.ubuntu.com precise Release
Get:3 http://us.archive.ubuntu.com precise-updates Release [49.6 kB]
Get:4 http://security.ubuntu.com precise-security Release.gpg [198 B]
Get:5 http://us.archive.ubuntu.com precise-backports Release [49.6 kB]
Get:6 http://security.ubuntu.com precise-security Release [49.6 kB]
Hit http://us.archive.ubuntu.com precise/main Sources
Hit http://us.archive.ubuntu.com precise/restricted Sources
Hit http://us.archive.ubuntu.com precise/universe Sources
Hit http://us.archive.ubuntu.com precise/multiverse Sources
Hit http://us.archive.ubuntu.com precise/main amd64 Packages
Hit http://us.archive.ubuntu.com precise/restricted amd64 Packages
Hit http://us.archive.ubuntu.com precise/universe amd64 Packages
Hit http://us.archive.ubuntu.com precise/multiverse amd64 Packages
Hit http://us.archive.ubuntu.com precise/main i386 Packages
Hit http://us.archive.ubuntu.com precise/restricted i386 Packages
Hit http://us.archive.ubuntu.com precise/universe i386 Packages
Hit http://us.archive.ubuntu.com precise/multiverse i386 Packages
Hit http://us.archive.ubuntu.com precise/main TranslationIndex
Hit http://us.archive.ubuntu.com precise/multiverse TranslationIndex
Hit http://us.archive.ubuntu.com precise/restricted TranslationIndex
Hit http://us.archive.ubuntu.com precise/universe TranslationIndex
Get:7 http://us.archive.ubuntu.com precise-updates/main Sources [400 kB]
Get:8 http://security.ubuntu.com precise-security/main Sources [83.5 kB]
Get:9 http://us.archive.ubuntu.com precise-updates/restricted Sources [5,467 B]
Get:10 http://us.archive.ubuntu.com precise-updates/universe Sources [92.0 kB]
Get:11 http://us.archive.ubuntu.com precise-updates/multiverse Sources [6,582 B]
Get:12 http://us.archive.ubuntu.com precise-updates/main amd64 Packages [650 kB]
Get:13 http://us.archive.ubuntu.com precise-updates/restricted amd64 Packages [10.1 kB]
Get:14 http://us.archive.ubuntu.com precise-updates/universe amd64 Packages [209 kB]
Get:15 http://security.ubuntu.com precise-security/restricted Sources [2,494 B]
Get:16 http://security.ubuntu.com precise-security/universe Sources [27.1 kB]
Get:17 http://security.ubuntu.com precise-security/multiverse Sources [1,383 B]
Get:18 http://security.ubuntu.com precise-security/main amd64 Packages [296 kB]
Get:19 http://us.archive.ubuntu.com precise-updates/multiverse amd64 Packages [13.6 kB]
Get:20 http://us.archive.ubuntu.com precise-updates/main i386 Packages [671 kB]
Get:21 http://us.archive.ubuntu.com precise-updates/restricted i386 Packages [10.0 kB]
Get:22 http://us.archive.ubuntu.com precise-updates/universe i386 Packages [213 kB]
Get:23 http://us.archive.ubuntu.com precise-updates/multiverse i386 Packages [13.8 kB]
Get:24 http://us.archive.ubuntu.com precise-updates/main TranslationIndex [3,564 B]
Get:25 http://us.archive.ubuntu.com precise-updates/multiverse TranslationIndex [2,605 B]
Get:26 http://us.archive.ubuntu.com precise-updates/restricted TranslationIndex [2,461 B]
Get:27 http://us.archive.ubuntu.com precise-updates/universe TranslationIndex [2,850 B]
Get:28 http://us.archive.ubuntu.com precise-backports/main Sources [2,935 B]
Get:29 http://us.archive.ubuntu.com precise-backports/restricted Sources [14 B]
Get:30 http://us.archive.ubuntu.com precise-backports/universe Sources [34.8 kB]
Get:31 http://us.archive.ubuntu.com precise-backports/multiverse Sources [5,311 B]
Get:32 http://us.archive.ubuntu.com precise-backports/main amd64 Packages [2,378 B]
Get:33 http://us.archive.ubuntu.com precise-backports/restricted amd64 Packages [14 B]
Get:34 http://us.archive.ubuntu.com precise-backports/universe amd64 Packages [36.1 kB]
Get:35 http://us.archive.ubuntu.com precise-backports/multiverse amd64 Packages [5,206 B]
Get:36 http://us.archive.ubuntu.com precise-backports/main i386 Packages [2,390 B]
Get:37 http://us.archive.ubuntu.com precise-backports/restricted i386 Packages [14 B]
Get:38 http://us.archive.ubuntu.com precise-backports/universe i386 Packages [35.9 kB]
Get:39 http://us.archive.ubuntu.com precise-backports/multiverse i386 Packages [5,178 B]
Get:40 http://us.archive.ubuntu.com precise-backports/main TranslationIndex [72 B]
Get:41 http://us.archive.ubuntu.com precise-backports/multiverse TranslationIndex [72 B]
Get:42 http://us.archive.ubuntu.com precise-backports/restricted TranslationIndex [70 B]
Get:43 http://us.archive.ubuntu.com precise-backports/universe TranslationIndex [73 B]
Hit http://us.archive.ubuntu.com precise/main Translation-en
Hit http://us.archive.ubuntu.com precise/multiverse Translation-en
Hit http://us.archive.ubuntu.com precise/restricted Translation-en
Hit http://us.archive.ubuntu.com precise/universe Translation-en
Get:44 http://us.archive.ubuntu.com precise-updates/main Translation-en [299 kB]
Get:45 http://us.archive.ubuntu.com precise-updates/multiverse Translation-en [7,834 B]
Get:46 http://us.archive.ubuntu.com precise-updates/restricted Translation-en [2,432 B]
Get:47 http://us.archive.ubuntu.com precise-updates/universe Translation-en [123 kB]
Get:48 http://us.archive.ubuntu.com precise-backports/main Translation-en [1,512 B]
Get:49 http://us.archive.ubuntu.com precise-backports/multiverse Translation-en [4,610 B]
Hit http://us.archive.ubuntu.com precise-backports/restricted Translation-en
Get:50 http://us.archive.ubuntu.com precise-backports/universe Translation-en [26.4 kB]
Get:51 http://security.ubuntu.com precise-security/restricted amd64 Packages [4,627 B]
Get:52 http://security.ubuntu.com precise-security/universe amd64 Packages [77.7 kB]
Get:53 http://security.ubuntu.com precise-security/multiverse amd64 Packages [2,186 B]
Get:54 http://security.ubuntu.com precise-security/main i386 Packages [311 kB]
Get:55 http://security.ubuntu.com precise-security/restricted i386 Packages [4,620 B]
Get:56 http://security.ubuntu.com precise-security/universe i386 Packages [80.5 kB]
Get:57 http://security.ubuntu.com precise-security/multiverse i386 Packages [2,371 B]
Get:58 http://security.ubuntu.com precise-security/main TranslationIndex [74 B]
Get:59 http://security.ubuntu.com precise-security/multiverse TranslationIndex [71 B]
Get:60 http://security.ubuntu.com precise-security/restricted TranslationIndex [72 B]
Get:61 http://security.ubuntu.com precise-security/universe TranslationIndex [73 B]
Get:62 http://security.ubuntu.com precise-security/main Translation-en [144 kB]
Hit http://security.ubuntu.com precise-security/multiverse Translation-en
Get:63 http://security.ubuntu.com precise-security/restricted Translation-en [1,253 B]
Get:64 http://security.ubuntu.com precise-security/universe Translation-en [49.6 kB]
Fetched 4,139 kB in 3s (1,276 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
glance-api glance-client glance-common glance-registry libjs-jquery
libjs-sphinxdoc libjs-underscore libyaml-0-2 python-amqplib python-anyjson
python-crypto python-dateutil python-decorator python-eventlet
python-formencode python-glance python-greenlet python-iso8601 python-kombu
python-migrate python-openid python-openssl python-paste python-pastedeploy
python-pastescript python-pkg-resources python-routes python-scgi
python-setuptools python-sqlalchemy python-sqlalchemy-ext python-tempita
python-webob python-xattr python-yaml
Suggested packages:
javascript-common python-amqplib-doc python-crypto-dbg python-crypto-doc
python-egenix-mxdatetime python-dns python-greenlet-doc python-greenlet-dev
python-greenlet-dbg python-boto python-couchdb python-kombu-doc
python-pymongo python-openssl-doc python-openssl-dbg python-pastewebkit
libapache2-mod-wsgi libapache2-mod-python libapache2-mod-scgi python-pgsql
libjs-mochikit python-flup python-cherrypy python-cheetah python-distribute
python-distribute-doc python-sqlalchemy-doc python-psycopg2 python-mysqldb
python-kinterbasdb python-pymssql
The following NEW packages will be installed:
glance glance-api glance-client glance-common glance-registry libjs-jquery
libjs-sphinxdoc libjs-underscore libyaml-0-2 python-amqplib python-anyjson
python-crypto python-dateutil python-decorator python-eventlet
python-formencode python-glance python-greenlet python-iso8601 python-kombu
python-migrate python-openid python-openssl python-paste python-pastedeploy
python-pastescript python-pkg-resources python-routes python-scgi
python-setuptools python-sqlalchemy python-sqlalchemy-ext python-tempita
python-webob python-xattr python-yaml
0 upgraded, 36 newly installed, 0 to remove and 139 not upgraded.
Need to get 934 kB/3,766 kB of archives.
After this operation, 19.1 MB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu/ precise/main libyaml-0-2 amd64 0.1.4-2 [56.9 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ precise/main python-amqplib all 1.0.0+ds-1 [34.5 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ precise/main python-anyjson all 0.3.1-1build1 [7,208 B]
Get:4 http://us.archive.ubuntu.com/ubuntu/ precise/main python-dateutil all 1.5-1 [54.2 kB]
Get:5 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main python-eventlet all 0.9.16-1ubuntu4.2 [283 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu/ precise/main python-kombu all 1.4.3-1 [94.1 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu/ precise/main python-xattr amd64 0.6.2-1ubuntu1 [13.9 kB]
Get:8 http://us.archive.ubuntu.com/ubuntu/ precise/main python-yaml amd64 3.10-2 [122 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main python-glance all 2012.1.3+stable-20130423-74b067df-0ubu
ntu1 [232 kB]
Get:10 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main glance-common all 2012.1.3+stable-20130423-74b067df-0ub
untu1 [6,514 B]
Get:11 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main glance-api all 2012.1.3+stable-20130423-74b067df-0ubunt
u1 [12.1 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main glance-registry all 2012.1.3+stable-20130423-74b067df-0
ubuntu1 [4,734 B]
Get:13 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main glance all 2012.1.3+stable-20130423-74b067df-0ubuntu1 [
1,768 B]
Get:14 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main glance-client all 2012.1.3+stable-20130423-74b067df-0ub
untu1 [11.0 kB]
dpkg-preconfigure: unable to re-open stdin: No such file or directory
Fetched 934 kB in 0s (1,213 kB/s)
Selecting previously unselected package libyaml-0-2.
(Reading database ...
51193 files and directories currently installed.)
Unpacking libyaml-0-2 (from .../libyaml-0-2_0.1.4-2_amd64.deb) ...
Selecting previously unselected package libjs-jquery.
Unpacking libjs-jquery (from .../libjs-jquery_1.7.1-1ubuntu1_all.deb) ...
Selecting previously unselected package libjs-underscore.
Unpacking libjs-underscore (from .../libjs-underscore_1.1.6-1ubuntu2_all.deb) ...
Selecting previously unselected package libjs-sphinxdoc.
Unpacking libjs-sphinxdoc (from .../libjs-sphinxdoc_1.1.3+dfsg-2ubuntu2.1_all.deb) ...
Selecting previously unselected package python-amqplib.
Unpacking python-amqplib (from .../python-amqplib_1.0.0+ds-1_all.deb) ...
Selecting previously unselected package python-anyjson.
Unpacking python-anyjson (from .../python-anyjson_0.3.1-1build1_all.deb) ...
Selecting previously unselected package python-crypto.
Unpacking python-crypto (from .../python-crypto_2.4.1-1ubuntu0.1_amd64.deb) ...
Selecting previously unselected package python-dateutil.
Unpacking python-dateutil (from .../python-dateutil_1.5-1_all.deb) ...
Selecting previously unselected package python-decorator.
Unpacking python-decorator (from .../python-decorator_3.3.2-1_all.deb) ...
Selecting previously unselected package python-greenlet.
Unpacking python-greenlet (from .../python-greenlet_0.3.1-1ubuntu5.1_amd64.deb) ...
Selecting previously unselected package python-eventlet.
Unpacking python-eventlet (from .../python-eventlet_0.9.16-1ubuntu4.2_all.deb) ...
Selecting previously unselected package python-pkg-resources.
Unpacking python-pkg-resources (from .../python-pkg-resources_0.6.24-1ubuntu1_all.deb) ...
Selecting previously unselected package python-formencode.
Unpacking python-formencode (from .../python-formencode_1.2.4-2ubuntu2_all.deb) ...
Selecting previously unselected package python-kombu.
Unpacking python-kombu (from .../python-kombu_1.4.3-1_all.deb) ...
Selecting previously unselected package python-sqlalchemy.
Unpacking python-sqlalchemy (from .../python-sqlalchemy_0.7.4-1ubuntu0.1_all.deb) ...
Selecting previously unselected package python-tempita.
Unpacking python-tempita (from .../python-tempita_0.5.1-1build1_all.deb) ...
Selecting previously unselected package python-migrate.
Unpacking python-migrate (from .../python-migrate_0.7.2-1ubuntu1_all.deb) ...
Selecting previously unselected package python-openid.
Unpacking python-openid (from .../python-openid_2.2.5-3ubuntu1_all.deb) ...
Selecting previously unselected package python-openssl.
Unpacking python-openssl (from .../python-openssl_0.12-1ubuntu2_amd64.deb) ...
Selecting previously unselected package python-paste.
Unpacking python-paste (from .../python-paste_1.7.5.1-4ubuntu2_all.deb) ...
Selecting previously unselected package python-pastedeploy.
Unpacking python-pastedeploy (from .../python-pastedeploy_1.5.0-2build1_all.deb) ...
Selecting previously unselected package python-setuptools.
Unpacking python-setuptools (from .../python-setuptools_0.6.24-1ubuntu1_all.deb) ...
Selecting previously unselected package python-pastescript.
Unpacking python-pastescript (from .../python-pastescript_1.7.5-1_all.deb) ...
Selecting previously unselected package python-routes.
Unpacking python-routes (from .../python-routes_1.12.3-1ubuntu1_all.deb) ...
Selecting previously unselected package python-scgi.
Unpacking python-scgi (from .../python-scgi_1.13-1ubuntu1_amd64.deb) ...
Selecting previously unselected package python-sqlalchemy-ext.
Unpacking python-sqlalchemy-ext (from .../python-sqlalchemy-ext_0.7.4-1ubuntu0.1_amd64.deb) ...
Selecting previously unselected package python-xattr.
Unpacking python-xattr (from .../python-xattr_0.6.2-1ubuntu1_amd64.deb) ...
Selecting previously unselected package python-yaml.
Unpacking python-yaml (from .../python-yaml_3.10-2_amd64.deb) ...
Selecting previously unselected package python-webob.
Unpacking python-webob (from .../python-webob_1.1.1-1ubuntu0_all.deb) ...
Selecting previously unselected package python-iso8601.
Unpacking python-iso8601 (from .../python-iso8601_0.1.4-1ubuntu1_all.deb) ...
Selecting previously unselected package python-glance.
Unpacking python-glance (from .../python-glance_2012.1.3+stable-20130423-74b067df-0ubuntu1_all.deb) ...
Selecting previously unselected package glance-common.
Unpacking glance-common (from .../glance-common_2012.1.3+stable-20130423-74b067df-0ubuntu1_all.deb) ...
Selecting previously unselected package glance-api.
Unpacking glance-api (from .../glance-api_2012.1.3+stable-20130423-74b067df-0ubuntu1_all.deb) ...
Selecting previously unselected package glance-registry.
Unpacking glance-registry (from .../glance-registry_2012.1.3+stable-20130423-74b067df-0ubuntu1_all.deb) ...
Selecting previously unselected package glance.
Unpacking glance (from .../glance_2012.1.3+stable-20130423-74b067df-0ubuntu1_all.deb) ...
Selecting previously unselected package glance-client.
Unpacking glance-client (from .../glance-client_2012.1.3+stable-20130423-74b067df-0ubuntu1_all.deb) ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Setting up libyaml-0-2 (0.1.4-2) ...
Setting up libjs-jquery (1.7.1-1ubuntu1) ...
Setting up libjs-underscore (1.1.6-1ubuntu2) ...
Setting up libjs-sphinxdoc (1.1.3+dfsg-2ubuntu2.1) ...
Setting up python-amqplib (1.0.0+ds-1) ...
Setting up python-anyjson (0.3.1-1build1) ...
Setting up python-crypto (2.4.1-1ubuntu0.1) ...
Setting up python-dateutil (1.5-1) ...
Setting up python-decorator (3.3.2-1) ...
Setting up python-greenlet (0.3.1-1ubuntu5.1) ...
Setting up python-eventlet (0.9.16-1ubuntu4.2) ...
Setting up python-pkg-resources (0.6.24-1ubuntu1) ...
Setting up python-formencode (1.2.4-2ubuntu2) ...
Setting up python-kombu (1.4.3-1) ...
Setting up python-sqlalchemy (0.7.4-1ubuntu0.1) ...
Setting up python-tempita (0.5.1-1build1) ...
Setting up python-migrate (0.7.2-1ubuntu1) ...
Setting up python-openid (2.2.5-3ubuntu1) ...
Setting up python-openssl (0.12-1ubuntu2) ...
Setting up python-paste (1.7.5.1-4ubuntu2) ...
Setting up python-pastedeploy (1.5.0-2build1) ...
Setting up python-setuptools (0.6.24-1ubuntu1) ...
Setting up python-pastescript (1.7.5-1) ...
Setting up python-routes (1.12.3-1ubuntu1) ...
Setting up python-scgi (1.13-1ubuntu1) ...
Setting up python-sqlalchemy-ext (0.7.4-1ubuntu0.1) ...
Setting up python-xattr (0.6.2-1ubuntu1) ...
Setting up python-yaml (3.10-2) ...
Setting up python-webob (1.1.1-1ubuntu0) ...
Setting up python-iso8601 (0.1.4-1ubuntu1) ...
Setting up python-glance (2012.1.3+stable-20130423-74b067df-0ubuntu1) ...
Setting up glance-common (2012.1.3+stable-20130423-74b067df-0ubuntu1) ...
Adding system user `glance' (UID 106) ...
Adding new user `glance' (UID 106) with group `glance' ...
Not creating home directory `/var/lib/glance'.
Setting up glance-api (2012.1.3+stable-20130423-74b067df-0ubuntu1) ...
glance-api start/running, process 2279
Setting up glance-registry (2012.1.3+stable-20130423-74b067df-0ubuntu1) ...
glance-registry start/running, process 2326
Setting up glance (2012.1.3+stable-20130423-74b067df-0ubuntu1) ...
Setting up glance-client (2012.1.3+stable-20130423-74b067df-0ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package python-glanceclient
/tmp/vagrant-shell: line 167: mysql: command not found
/tmp/vagrant-shell: line 168: mysql: command not found
/tmp/vagrant-shell: line 169: mysql: command not found
service_protocol = http
service_host = 172.16.21.200
service_port = 5000
auth_host = 172.16.21.200
auth_port = 35357
auth_protocol = http
auth_uri = http://172.16.21.200:5000/
admin_tenant_name = service
admin_user = glance
admin_password = glance
config_file = /etc/glance/glance-api-paste.ini
flavor = keystone
service_protocol = http
service_host = 172.16.21.200
service_port = 5000
auth_host = 172.16.21.200
auth_port = 35357
auth_protocol = http
auth_uri = http://172.16.21.200:5000/
admin_tenant_name = service
admin_user = glance
admin_password = glance
config_file = /etc/glance/glance-registry-paste.ini
flavor = keystone
glance-registry stop/waiting
glance-registry start/running, process 2366
glance-api stop/waiting
glance-api start/running, process 2372
Traceback (most recent call last):
File "/usr/bin/glance-manage", line 122, in <module>
main()
File "/usr/bin/glance-manage", line 118, in main
dispatch_cmd(conf, args)
File "/usr/bin/glance-manage", line 93, in dispatch_cmd
cmd_func(conf, args)
File "/usr/bin/glance-manage", line 81, in do_db_sync
glance.registry.db.migration.db_sync(conf, version, current_version)
File "/usr/lib/python2.7/dist-packages/glance/registry/db/migration.py", line 130, in db_sync
db_version(conf)
File "/usr/lib/python2.7/dist-packages/glance/registry/db/migration.py", line 46, in db_version
return versioning_api.db_version(sql_connection, repo_path)
File "<string>", line 2, in db_version
File "/usr/lib/python2.7/dist-packages/migrate/versioning/util/__init__.py", line 155, in with_engine
engine = construct_engine(url, **kw)
File "/usr/lib/python2.7/dist-packages/migrate/versioning/util/__init__.py", line 140, in construct_engine
return create_engine(engine, **kwargs)
File "/usr/lib/python2.7/dist-packages/sqlalchemy/engine/__init__.py", line 321, in create_engine
return strategy.create(*args, **kwargs)
File "/usr/lib/python2.7/dist-packages/sqlalchemy/engine/strategies.py", line 64, in create
dbapi = dialect_cls.dbapi(**dbapi_args)
File "/usr/lib/python2.7/dist-packages/sqlalchemy/connectors/mysqldb.py", line 52, in dbapi
return __import__('MySQLdb')
ImportError
:
No module named MySQLdb
Reading package lists...
Building dependency tree...
Reading state information...
wget is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 139 not upgraded.
Usage: glance <command> [options] [args]
Commands:
help <command> Output help for one of the commands below
add Adds a new image to Glance
update Updates an image's metadata in Glance
delete Deletes an image from Glance
index Return brief information about images in Glance
details Return detailed information about images in
Glance
show Show detailed information about an image in
Glance
clear Removes all images and metadata from Glance
Member Commands:
image-members List members an image is shared with
member-images List images shared with a member
member-add Grants a member access to an image
member-delete Revokes a member's access to an image
members-replace Replaces all membership for an image
glance: error: no such option: --name
Usage: glance <command> [options] [args]
Commands:
help <command> Output help for one of the commands below
add Adds a new image to Glance
update Updates an image's metadata in Glance
delete Deletes an image from Glance
index Return brief information about images in Glance
details Return detailed information about images in
Glance
show Show detailed information about an image in
Glance
clear Removes all images and metadata from Glance
Member Commands:
image-members List members an image is shared with
member-images List images shared with a member
member-add Grants a member access to an image
member-delete Revokes a member's access to an image
members-replace Replaces all membership for an image
glance: error: no such option: --name
PS C:\users\ewright\Documents\VirtualBoxProjects\Couch_to_OpenStack>
@VMTrooper

This comment has been minimized.

Copy link

@VMTrooper VMTrooper commented Jul 24, 2013

Possible solution regarding git's treatment of carriage returns on Windows... https://plus.google.com/communities/101663052588382171429

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment