Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Dependency conflict building from PR1464 branch
...<output truncated>...
Requirement already satisfied: zipp>=0.5 in ./samcli374/lib/python3.7/site-packages (from importlib-metadata>=0.12; python_version < "3.8"->pytest==5.2.1; extra == "dev"->aws-sam-cli==0.37.0) (0.6.0)
Requirement already satisfied: wrapt==1.11.* in ./samcli374/lib/python3.7/site-packages (from astroid<3,>=2.2.0->pylint==2.3.1; extra == "dev"->aws-sam-cli==0.37.0) (1.11.2)
Requirement already satisfied: lazy-object-proxy==1.4.* in ./samcli374/lib/python3.7/site-packages (from astroid<3,>=2.2.0->pylint==2.3.1; extra == "dev"->aws-sam-cli==0.37.0) (1.4.3)
Requirement already satisfied: typed-ast<1.5,>=1.4.0; implementation_name == "cpython" and python_version < "3.8" in ./samcli374/lib/python3.7/site-packages (from astroid<3,>=2.2.0->pylint==2.3.1; extra =
= "dev"->aws-sam-cli==0.37.0) (1.4.0)
Requirement already satisfied: apipkg>=1.4 in ./samcli374/lib/python3.7/site-packages (from execnet>=1.1->pytest-xdist==1.30.0; extra == "dev"->aws-sam-cli==0.37.0) (1.5)
ERROR: astroid 2.3.3 has requirement six~=1.12, but you'll have six 1.11.0 which is incompatible.
Installing collected packages: aws-sam-translator, tomlkit, python-dateutil, aws-lambda-builders, pluggy, pyparsing, packaging, wcwidth, pytest, pytest-forked, pytest-rerunfailures, astroid, pylint, param
eterized, pytest-xdist, coverage, pytest-cov, aws-sam-cli
Found existing installation: aws-sam-translator 1.15.1
Uninstalling aws-sam-translator-1.15.1:
Successfully uninstalled aws-sam-translator-1.15.1
Found existing installation: python-dateutil 2.8.1
Uninstalling python-dateutil-2.8.1:
Successfully uninstalled python-dateutil-2.8.1
Found existing installation: aws-lambda-builders 0.5.0
...<output truncated>...
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.