public
Created

Building and running RobotLegs v2

  • Download Gist
1-clone robotlegs
1 2 3 4 5 6 7
$ git clone https://github.com/robotlegs/robotlegs-framework.git
Cloning into robotlegs-framework...
remote: Counting objects: 7066, done.
remote: Compressing objects: 100% (2655/2655), done.
remote: Total 7066 (delta 3684), reused 6809 (delta 3448)
Receiving objects: 100% (7066/7066), 6.27 MiB | 52 KiB/s, done.
Resolving deltas: 100% (3684/3684), done.
2-try to install bundler
1 2 3 4
$ sudo gem install bundler
ERROR: Error installing bundler:
bundler requires RubyGems version >= 1.3.6
3-update RubyGems
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
$ sudo gem update --system
Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.8.11
Updating RubyGems to 1.8.11
Installing RubyGems 1.8.11
RubyGems 1.8.11 installed
 
== 1.8.11 / 2011-10-03
 
* Bug fix:
* Deprecate was moved to Gem::Deprecate to stop polluting the top-level
namespace.
 
 
------------------------------------------------------------------------------
 
RubyGems installed the following executables:
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/gem
4-install bundler
1 2 3 4 5
$ sudo gem install bundler
Successfully installed bundler-1.0.21
1 gem installed
Installing ri documentation for bundler-1.0.21...
Installing RDoc documentation for bundler-1.0.21...
5-try to install dependencies using bundler
1 2 3 4 5 6 7 8 9 10 11 12 13 14
$ bundle install
Fetching source index for http://rubygems.org/
Installing rake (0.8.7)
Installing rjb (1.3.3) with native extensions
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.
 
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby extconf.rb
mkmf.rb can't find header files for ruby at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ruby.h
 
 
Gem files will remain installed in /Library/Ruby/Gems/1.8/gems/rjb-1.3.3 for inspection.
Results logged to /Library/Ruby/Gems/1.8/gems/rjb-1.3.3/ext/gem_make.out
An error occured while installing rjb (1.3.3), and Bundler cannot continue.
Make sure that `gem install rjb -v '1.3.3'` succeeds before bundling.
6-install xcode 3 or 4
1
Install XCode 3 or 4
7-install dependencies using Bundler
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
$ bundle install
Fetching source index for http://rubygems.org/
Using rake (0.8.7)
Installing rjb (1.3.3) with native extensions
Installing atoulme-Antwrap (0.7.1)
Installing builder (2.1.2) WARNING: builder-2.1.2 has an invalid nil value for @cert_chain
 
Installing diff-lcs (1.1.2)
Installing highline (1.5.1)
Installing json_pure (1.4.3)
Installing rubyforge (2.0.3)
Installing hoe (2.3.3)
Installing minitar (0.5.3)
Installing net-ssh (2.0.23)
Installing net-sftp (2.0.4)
Installing rspec-core (2.1.0)
Installing rspec-expectations (2.1.0)
Installing rspec-mocks (2.1.0)
Installing rspec (2.1.0)
Installing rubyzip (0.9.4)
Installing xml-simple (1.0.12)
Installing buildr (1.4.6)
Installing buildr-as3 (0.2.28.pre)
Using bundler (1.0.21)
Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed.
8-build RobotLegs using Buildr
1 2
$ bundle exec buildr test
<snipped lots of output>
9-open test report
1
$ open reports/flexunit4/html/index.html

This link will probably help with installing buildr: http://buildr.apache.org/installing.html
In some configurations a bit of setup needs to be done before it properly installs,
the bundler script should install it for the other cases without a problem.
Once its installed, bundler should be capable of updating the gems without a problem.

On OSX I can only recommend setting up RubyVersionManager from http://beginrescueend.com/

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.