Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
This assumes you've created an environment called "dsi". To use this file, simply click on "raw" then download the contents to a new file on your local system called "environment".
name: dsi
channels:
- conda-forge
- defaults
dependencies:
- appnope=0.1.0=py36_0
- asn1crypto=0.22.0=py36_0
- attrs=17.2.0=py_1
- automat=0.6.0=py36_0
- backports=1.0=py36_1
- backports.functools_lru_cache=1.5=py36_0
- beautifulsoup4=4.5.3=py36_0
- blas=1.1=openblas
- bleach=2.0.0=py36_0
- blinker=1.4=py_0
- bokeh=0.12.9=py36_0
- bzip2=1.0.6=1
- ca-certificates=2017.11.5=0
- cairo=1.14.10=0
- certifi=2017.11.5=py36_0
- cffi=1.10.0=py36_0
- chardet=3.0.4=py36_0
- click=6.7=py_1
- cloudpickle=0.2.2=py36_4
- configurable-http-proxy=3.1.0=0
- constantly=15.1.0=py_0
- cryptography=1.9=py36_0
- cssselect=1.0.1=py_0
- cycler=0.10.0=py36_0
- cython=0.25.2=py36_1
- dask=0.15.3=py_0
- dask-core=0.15.3=py_0
- decorator=4.1.2=py36_0
- dill=0.2.6=py36_0
- distributed=1.19.1=py36_0
- entrypoints=0.2.3=py36_1
- fastcache=1.0.2=py36_0
- ffmpeg=3.2.4=3
- fontconfig=2.12.6=0
- freetype=2.8.1=0
- future=0.16.0=py36_0
- gettext=0.19.8.1=0
- giflib=5.1.4=0
- glib=2.55.0=0
- graphite2=1.3.11=0
- h5py=2.7.1=py36_3
- harfbuzz=1.7.6=0
- hdf5=1.10.1=2
- heapdict=1.0.0=py36_0
- html5lib=0.999999999=py36_0
- hyperlink=17.3.1=py_0
- hypothesis=3.23.0=py36_0
- icu=58.2=0
- idna=2.6=py36_1
- imageio=2.3.0=py36_0
- incremental=17.5.0=py_0
- ipykernel=4.6.1=py36_0
- ipython=6.2.0=py36_0
- ipython_genutils=0.2.0=py36_0
- ipywidgets=7.0.1=py_2
- jasper=1.900.1=4
- jedi=0.10.2=py36_0
- jinja2=2.9.6=py36_0
- jpeg=9b=2
- jsonschema=2.6.0=py36_0
- jupyter_client=5.1.0=py36_0
- jupyter_core=4.3.0=py36_0
- jupyterhub=0.7.2=py36_0
- jupyterlab=0.27.0=py36_2
- jupyterlab_launcher=0.4.2=py36_0
- keras=2.0.9=py36_0
- kiwisolver=1.0.1=py36_1
- libffi=3.2.1=3
- libgfortran=3.0.0=0
- libiconv=1.15=0
- libpng=1.6.34=0
- libpq=9.6.3=0
- libsodium=1.0.15=1
- libtiff=4.0.9=0
- libwebp=0.5.2=7
- libxml2=2.9.7=0
- libxslt=1.1.32=0
- locket=0.2.0=py36_1
- lxml=4.1.0=py36_0
- markupsafe=1.0=py36_0
- matplotlib=2.2.2=py36_0
- mistune=0.7.4=py36_0
- mock=2.0.0=py36_0
- mpmath=0.19=py36_2
- msgpack-python=0.4.8=py36_0
- nb_conda=2.2.1=py36_0
- nb_conda_kernels=2.1.0=py36_0
- nbconvert=5.3.1=py_1
- nbformat=4.4.0=py36_0
- ncurses=5.9=10
- networkx=2.0=py36_1
- nltk=3.2.5=py_0
- nodejs=6.12.2=0
- notebook=5.1.0=py36_0
- numexpr=2.6.2=py36_1
- numpy=1.12.1=py36_blas_openblas_201
- oauthlib=2.0.6=py_0
- olefile=0.44=py36_0
- openblas=0.2.20=7
- opencv=3.4.1=py36_blas_openblas_200
- openssl=1.0.2n=0
- packaging=16.8=py36_0
- pamela=0.3.0=py36_0
- pandas=0.19.2=np112py36_1
- pandoc=2.1=0
- pandocfilters=1.4.1=py36_0
- partd=0.3.8=py36_0
- patsy=0.4.1=py36_0
- pbr=3.1.1=py36_0
- pcre=8.41=1
- pexpect=4.2.1=py36_0
- pickleshare=0.7.4=py36_0
- pillow=5.1.0=py36_0
- pip=9.0.1=py36_1
- pixman=0.34.0=1
- prompt_toolkit=1.0.15=py36_0
- protobuf=3.4.0=py36_1
- psutil=5.2.2=py36_0
- psycopg2=2.7.3.1=py36_0
- ptyprocess=0.5.2=py36_0
- pyasn1=0.3.6=py_0
- pyasn1-modules=0.1.4=py_0
- pycosat=0.6.2=py36_0
- pycparser=2.18=py36_0
- pydispatcher=2.0.5=py36_0
- pydotplus=2.0.2=py36_0
- pygments=2.2.0=py36_0
- pyjwt=1.5.3=py_0
- pympler=0.5=py36_0
- pyopenssl=17.2.0=py36_0
- pyparsing=2.2.0=py36_0
- pysocks=1.6.7=py36_0
- python=3.6.5=0
- python-crfsuite=0.9.2=py36_0
- python-dateutil=2.6.1=py36_0
- pytz=2017.2=py36_0
- pywavelets=0.5.2=py36_1
- pyyaml=3.12=py36_1
- pyzmq=16.0.2=py36_3
- readline=7.0=0
- requests=2.18.4=py36_1
- requests-oauthlib=0.8.0=py36_1
- ruamel_yaml=0.11.14=py36_0
- scikit-image=0.13.1=py36_0
- scikit-learn=0.19.1=py36_blas_openblas_201
- scipy=1.0.1=py36_blas_openblas_200
- scrapy=1.4.0=py36_1
- seaborn=0.7.1=py36_0
- setuptools=38.4.0=py36_0
- simplegeneric=0.8.1=py36_0
- six=1.10.0=py36_1
- smart_open=1.5.6=py36_0
- sortedcontainers=1.5.7=py36_0
- sqlalchemy=1.1.13=py36_0
- sqlite=3.20.1=2
- statsmodels=0.8.0=py36_0
- sympy=1.0=py36_0
- tblib=1.3.2=py36_0
- tensorflow=1.0.0=py36_0
- terminado=0.6=py36_0
- testpath=0.3.1=py36_0
- textblob=0.13.0=py36_0
- tk=8.6.7=0
- toolz=0.8.2=py_2
- tornado=4.5.2=py36_0
- traitlets=4.3.2=py36_0
- twython=3.6.0=py36_0
- urllib3=1.22=py36_0
- vincent=0.4.4=py36_0
- wcwidth=0.1.7=py36_0
- webencodings=0.5=py36_0
- wheel=0.30.0=py36_2
- widgetsnbextension=3.0.3=py36_2
- x264=20131217=3
- xlrd=1.0.0=py36_1
- xz=5.2.3=0
- yaml=0.1.7=0
- zeromq=4.2.1=1
- zict=0.1.3=py_0
- zlib=1.2.11=0
- boto=2.48.0=py36_0
- bz2file=0.98=py36_0
- gensim=2.3.0=np112py36_0
- llvmlite=0.16.0=py36_0
- numba=0.31.0=np112py36_0
- parsel=1.2.0=py36_0
- queuelib=1.4.2=py36_0
- service_identity=17.0.0=py36_0
- twisted=17.5.0=py36_0
- w3lib=1.17.0=py36_0
- zope=1.0=py36_0
- zope.interface=4.4.2=py36_0
- pip:
- backports.functools-lru-cache==1.5
- defusedxml==0.5.0
- frogress==0.9.1
- imutils==0.4.6
- ipython-genutils==0.2.0
- jupyter-client==5.1.0
- jupyter-core==4.3.0
- jupyterlab-launcher==0.4.2
- nb-conda==2.2.1
- nb-conda-kernels==2.1.0
- prompt-toolkit==1.0.15
- pydot2==1.0.33
- python-twitter==3.4
- ruamel-yaml==0.11.14
- selenium==3.9.0
- service-identity==17.0.0
- smart-open==1.5.6
prefix: /opt/conda
@dyerrington

This comment has been minimized.

Copy link
Owner Author

commented Apr 19, 2018

Another way to get this file onto your system is to use your terminal:

curl -H 'Accept: application/vnd.github.v3.raw' -O -L "https://gist.github.com/dyerrington/942bccee4449936df4f45f209d2f9dad/raw/fd6d5611eceda45f4264938c35c9abde038f1b52/environment.yml"

This will download the contents of this file, to a new file in your current working directory in your terminal via the curl console application.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.