Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
How to deal with tmux "protocol version mismatch"
$ tmux attach
protocol version mismatch (client 7, server 6)
$ pgrep tmux
3429
$ /proc/3429/exe attach
@Corona4456

This comment has been minimized.

Copy link

@Corona4456 Corona4456 commented Sep 7, 2016

This saved me from a potential blunder while attempting to update my ubuntu installation! Thank you for this! I know this is 2 years old but thought I would still chime in!

@martingabelmann

This comment has been minimized.

Copy link

@martingabelmann martingabelmann commented Oct 8, 2016

You are my hero! had exactly the same problem while upgrading. I guess this is also useful for many other cases. Thanks a lot!

@backes

This comment has been minimized.

Copy link

@backes backes commented Jan 16, 2017

Wow, this was extremely helpful! Thanks a lot!

@darland

This comment has been minimized.

Copy link

@darland darland commented May 11, 2017

This is awesome! Thanks.

@pmelange

This comment has been minimized.

Copy link

@pmelange pmelange commented Jun 2, 2019

This just helped me too. Thanks

@JHerseth

This comment has been minimized.

Copy link

@JHerseth JHerseth commented May 7, 2020

This helped me with the error "server version is too old for client" which gives a whopping 3 hits on google. Commenting here so that someone else googleing this will find this.

@changloong

This comment has been minimized.

Copy link

@changloong changloong commented May 11, 2020

Is there a solution for macOS ?

@matthewstrasiotto

This comment has been minimized.

Copy link

@matthewstrasiotto matthewstrasiotto commented Sep 5, 2020

By the way, if all else is failing, and you installed your first version from distro, and your second version from source (In my case, i installed tmux 3.0a from apt-get install, then I wanted to upgrade to 3.1b , so installed from source)

apt remove tmux , and then following the source install instructions should work

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment