Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
unicorn error in logs about mongo gem not found ?!
/data/www/firefly/shared/bundle/ruby/1.9.1/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:317:in `rescue in depend_on'/data/www/firefly/shared/bundle/ruby/1.9.1/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:317:in `rescue in depend_on': No such file to load -- mongo (LoadError)
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:312:in `depend_on'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:225:in `require_dependency'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/railties-3.2.13/lib/rails/engine.rb:439:in `block (2 levels) in eager_load!'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/railties-3.2.13/lib/rails/engine.rb:438:in `each'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/railties-3.2.13/lib/rails/engine.rb:438:in `block in eager_load!'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/railties-3.2.13/lib/rails/engine.rb:436:in `each'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/railties-3.2.13/lib/rails/engine.rb:436:in `eager_load!'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/railties-3.2.13/lib/rails/application/finisher.rb:53:in `block in <module:Finisher>'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/railties-3.2.13/lib/rails/initializable.rb:30:in `instance_exec'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/railties-3.2.13/lib/rails/initializable.rb:30:in `run'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/railties-3.2.13/lib/rails/initializable.rb:55:in `block in run_initializers'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/railties-3.2.13/lib/rails/initializable.rb:54:in `each'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/railties-3.2.13/lib/rails/initializable.rb:54:in `run_initializers'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/railties-3.2.13/lib/rails/application.rb:136:in `initialize!'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/railties-3.2.13/lib/rails/railtie/configurable.rb:30:in `method_missing'
from /srv/data/www/firefly/releases/20130501110612/config/environment.rb:5:in `<top (required)>'
from config.ru:4:in `require'
from config.ru:4:in `block in <main>'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:51:in `instance_eval'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:51:in `initialize'
from config.ru:1:in `new'
from config.ru:1:in `<main>'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/unicorn-4.6.2/lib/unicorn.rb:44:in `eval'
from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/unicorn-4.6.2/lib/unicorn.rb:44:in `block in builder'
: from /data/www/firefly/shared/bundle/ruby/1.9.1/gems/unicorn-4.6.2/lib/unicorn/http_server.rb:722:in `call'
@elentras
Copy link
Author

elentras commented May 1, 2013

#Load the rails application
require File.expand_path('../application', __FILE__)

# Initialize the rails application
Firefly::Application.initialize!

Loading

@elentras
Copy link
Author

elentras commented May 1, 2013

$ bundle exec rails s -e production

/usr/local/lib/ruby/gems/1.9.1/gems/bundler-1.2.1/lib/bundler/rubygems_integration.rb:187:in stub_source_index170': uninitialized constant Gem::SourceIndex (NameError) from /usr/local/lib/ruby/gems/1.9.1/gems/bundler-1.2.1/lib/bundler/rubygems_integration.rb:353:instub_rubygems'
from /usr/local/lib/ruby/gems/1.9.1/gems/bundler-1.2.1/lib/bundler/rubygems_integration.rb:250:in replace_entrypoints' from /usr/local/lib/ruby/gems/1.9.1/gems/bundler-1.2.1/lib/bundler/runtime.rb:14:insetup'
from /usr/local/lib/ruby/gems/1.9.1/gems/bundler-1.2.1/lib/bundler.rb:116:in setup' from /usr/local/lib/ruby/gems/1.9.1/gems/bundler-1.2.1/lib/bundler/setup.rb:7:in<top (required)>'
from /home/deploy/.rbenv/versions/1.9.3-p392/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:45:in require' from /home/deploy/.rbenv/versions/1.9.3-p392/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:45:inrequire'

Loading

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment