Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Install font Adobe Source Code Pro on Ubuntu 16.04 LTS
#!/bin/sh
# Userland mode (~$USER/), (~/).
# ~/.fonts is now deprecated and that
#FONT_HOME=~/.fonts
# ~/.local/share/fonts should be used instead
FONT_HOME=~/.local/share/fonts
echo "installing fonts at $PWD to $FONT_HOME"
mkdir -p "$FONT_HOME/adobe-fonts/source-code-pro"
# find "$FONT_HOME" -iname '*.ttf' -exec echo '{}' \;
(git clone \
--branch release \
--depth 1 \
'https://github.com/adobe-fonts/source-code-pro.git' \
"$FONT_HOME/adobe-fonts/source-code-pro" && \
fc-cache -f -v "$FONT_HOME/adobe-fonts/source-code-pro")
@laohyx

This comment has been minimized.

Copy link

laohyx commented Jan 29, 2018

Thanks for sharing!

@benny-sun

This comment has been minimized.

Copy link

benny-sun commented Feb 13, 2018

It worked like a charm! Thanks for sharing!

@mehmetkz61

This comment has been minimized.

Copy link

mehmetkz61 commented Mar 20, 2018

Appreciated!

@lazydao

This comment has been minimized.

Copy link

lazydao commented Mar 31, 2018

good job

@anegg0

This comment has been minimized.

Copy link

anegg0 commented Apr 19, 2018

Thank you so much!

@zirosas

This comment has been minimized.

Copy link

zirosas commented Apr 21, 2018

Great, thanks!

@ClashTheBunny

This comment has been minimized.

Copy link

ClashTheBunny commented Jun 4, 2018

It is called out in the releases, but many people may want to clone the last non-variable fonts:

⚠️ These .otf fonts CANNOT be installed on Windows or macOS systems because the OSes do not currently support the OpenType-CFF2 format. Install the latest non-variable fonts instead.

Do so by checking out the specific tag:

git checkout 2.030R-ro/1.050R-it -C "$FONT_HOME/adobe-fonts/source-code-pro"

This fixed Emacs, for example.

@jonicreide

This comment has been minimized.

Copy link

jonicreide commented Nov 7, 2018

Thanks for the script !! It works for me very well. (Ubuntu 18.04)

@rproenca

This comment has been minimized.

Copy link

rproenca commented Dec 19, 2018

Worked fine for me on Ubuntu 18.04.
Thanks!

@smithaitufe

This comment has been minimized.

Copy link

smithaitufe commented Feb 14, 2019

Thanks so much. It worked for me using LUbuntu.

@Lerrrtaste

This comment has been minimized.

Copy link

Lerrrtaste commented May 22, 2019

Works like expected, thanks for sharing :)

@jbarnetj

This comment has been minimized.

Copy link

jbarnetj commented Jun 17, 2019

Worked. Thank you.

@a-y-khan

This comment has been minimized.

Copy link

a-y-khan commented Sep 25, 2019

Also worked for me on Ubuntu 18.04. Thank you!

@c0f

This comment has been minimized.

Copy link

c0f commented Dec 19, 2019

Worked for me in Ubuntu 19.10. Thank you.

@namthangnguyen

This comment has been minimized.

Copy link

namthangnguyen commented Mar 4, 2020

how can i install it

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.