Skip to content

Instantly share code, notes, and snippets.

@ericdill

ericdill/wtf

Created May 30, 2020
Embed
What would you like to do?
$ conda-lock -f environment.yaml -p linux-64 ⇡ master :: 1d :: ⬡
generating lockfile for linux-64
The following specifications were found to be incompatible with each other:
Output in format: Requested package -> Available versions
Package requests conflicts for:
conda -> requests[version='>=2.12.4|>=2.12.4,<3|>=2.18.4,<3|>=2.5.3']
s3contents -> requests
hybridcontents -> requests[version='>=2.7.0']
jupyterhub -> requests
Package jupyterhub conflicts for:
fargatespawner==0.0.24 -> jupyterhub
jupyterhub
Package python_abi conflicts for:
conda -> python_abi[version='2.7.*|3.6.*|3.6|3.8.*|3.7.*',build='*_cp27mu|*_pypy36_pp73|*_cp38|*_cp36m|*_cp37m']
fargatespawner==0.0.24 -> python_abi=3.7[build=*_cp37m]
Package setuptools conflicts for:
conda -> setuptools[version='>=31.0.1']
pip -> setuptools
Package python conflicts for:
fargatespawner==0.0.24 -> python
conda -> python[version='2.7.*|3.5.*|3.6.*|>=2.7,<2.8.0a0|>=3.6,<3.7.0a0|>=3.8,<3.9.0a0|>=3.7,<3.8.0a0|>=3.5,<3.6.0a0|3.4.*']
pip -> python[version='2.7.*|3.5.*|3.6.*|>=2.7,<2.8.0a0|>=3|>=3.8,<3.9.0a0|>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.5,<3.6.0a0|3.4.*']
hybridcontents -> python
jupyterhub -> python[version='3.4.*|3.5.*|3.6.*|>=3.5,<3.6.0a0|>=3.6,<3.7.0a0|>=3.8,<3.9.0a0|>=3.7,<3.8.0a0']
python==3.8
s3contents -> python[version='>=3']
Package notebook conflicts for:
s3contents -> notebook
hybridcontents -> notebookThe following specifications were found to be incompatible with your CUDA driver:
- feature:/linux-64::__cuda==10.2=0
- feature:|@/linux-64::__cuda==10.2=0
Your installed CUDA driver is: 10.2
Could not lock the environment for platform linux-64
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment