secret
Created

error using eclipse fp

  • Download Gist
gistfile1.txt
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260
/Users/graham/.cabal/bin/cabal-dev install-deps --enable-tests --force-reinstalls -j --sandbox=.dist-buildwrapper/cabal-dev --with-cabal-install=/Users/graham/.cabal/bin/cabal
You are using a version of cabal-install that has the --only-dependencies flag
to the install command. Invoking that instead...
Resolving dependencies...
Configuring Diff-0.3.0...
Configuring HUnit-1.2.5.2...
Configuring abstract-par-0.3.1...
Configuring ansi-terminal-0.6...
Configuring cereal-0.3.5.2...
Configuring base-unicode-symbols-0.2.2.4...
Configuring erf-2.0.0.0...
Configuring dlist-0.5...
Building Diff-0.3.0...
Building HUnit-1.2.5.2...
Building abstract-par-0.3.1...
Building ansi-terminal-0.6...
Configuring extensible-exceptions-0.1.1.4...
Installed abstract-par-0.3.1
Configuring hostname-1.0...
Installed Diff-0.3.0
Building cereal-0.3.5.2...
Configuring binary-0.7.1.0...
Building base-unicode-symbols-0.2.2.4...
Building erf-2.0.0.0...
Installed HUnit-1.2.5.2
Building dlist-0.5...
Building extensible-exceptions-0.1.1.4...
Configuring parallel-3.2.0.3...
Installed dlist-0.5
Building hostname-1.0...
Configuring ieee754-0.7.3...
Installed base-unicode-symbols-0.2.2.4
Building binary-0.7.1.0...
Configuring random-1.0.1.1...
Installed extensible-exceptions-0.1.1.4
Configuring primitive-0.5.1.0...
Installed erf-2.0.0.0
Configuring split-0.2.2...
Installed ansi-terminal-0.6
Configuring transformers-0.3.0.0...
Installed hostname-1.0
Building parallel-3.2.0.3...
Building ieee754-0.7.3...
Building random-1.0.1.1...
Building split-0.2.2...
Building primitive-0.5.1.0...
Configuring utf8-string-0.3.7...
Building transformers-0.3.0.0...
Installed parallel-3.2.0.3
Configuring syb-0.4.1...
Installed split-0.2.2
Building utf8-string-0.3.7...
Configuring text-0.11.3.1...
Installed ieee754-0.7.3
Building syb-0.4.1...
Configuring cpphs-1.17.1...
Installed primitive-0.5.1.0
Building text-0.11.3.1...
Installed cereal-0.3.5.2
Configuring ansi-wl-pprint-0.6.6...
Building cpphs-1.17.1...
Configuring vector-0.10.9.0...
Installed utf8-string-0.3.7
Building ansi-wl-pprint-0.6.6...
Installed random-1.0.1.1
Configuring QuickCheck-2.6...
Installed syb-0.4.1
Installed binary-0.7.1.0
Building vector-0.10.9.0...
Installed transformers-0.3.0.0
Configuring Glob-0.7.2...
Configuring mtl-2.1.2...
Configuring transformers-base-0.4.1...
Building QuickCheck-2.6...
Installed ansi-wl-pprint-0.6.6
Building Glob-0.7.2...
Building transformers-base-0.4.1...
Building mtl-2.1.2...
Installed transformers-base-0.4.1
Configuring monad-control-0.3.2.1...
Building monad-control-0.3.2.1...
Installed mtl-2.1.2
Configuring monad-par-extras-0.3.3...
Configuring regex-base-0.93.2...
Installed Glob-0.7.2
Building monad-par-extras-0.3.3...
Installed monad-control-0.3.2.1
Building regex-base-0.93.2...
Configuring lifted-base-0.2.1.0...
Installed cpphs-1.17.1
Configuring haskell-src-exts-1.14.0...
Installed monad-par-extras-0.3.3
Installed regex-base-0.93.2
Configuring regex-posix-0.95.2...
Building lifted-base-0.2.1.0...
Building regex-posix-0.95.2...
Installed QuickCheck-2.6
Building haskell-src-exts-1.14.0...
Installed lifted-base-0.2.1.0
Installed regex-posix-0.95.2
Configuring regex-compat-0.95.1...
Building regex-compat-0.95.1...
Installed regex-compat-0.95.1
Installed text-0.11.3.1
Configuring attoparsec-0.10.4.0...
Configuring hashable-1.2.1.0...
Configuring blaze-builder-0.3.1.1...
Configuring parsec-3.1.3...
Configuring xml-1.3.13...
Building hashable-1.2.1.0...
Building attoparsec-0.10.4.0...
Building blaze-builder-0.3.1.1...
Building xml-1.3.13...
Building parsec-3.1.3...
Installed hashable-1.2.1.0
Configuring unordered-containers-0.2.2.1...
Building unordered-containers-0.2.2.1...
Installed xml-1.3.13
Configuring test-framework-0.8...
Installed blaze-builder-0.3.1.1
Configuring hastache-0.5.1...
Configuring xmlgen-0.6.2.0...
Building test-framework-0.8...
Building hastache-0.5.1...
Building xmlgen-0.6.2.0...
Installed vector-0.10.9.0
Configuring hashtables-1.1.0.2...
Building hashtables-1.1.0.2...
Installed parsec-3.1.3
Configuring math-functions-0.1.3.0...
Installed hastache-0.5.1
Configuring mwc-random-0.13.0.0...
Building math-functions-0.1.3.0...
Configuring vector-algorithms-0.5.4.2...
Installed xmlgen-0.6.2.0
Configuring vector-binary-instances-0.2.1.0...
Installed test-framework-0.8
Building mwc-random-0.13.0.0...
Building vector-algorithms-0.5.4.2...
Configuring test-framework-hunit-0.3.0...
Installed unordered-containers-0.2.2.1
Building vector-binary-instances-0.2.1.0...
Installed math-functions-0.1.3.0
Building test-framework-hunit-0.3.0...
Installed vector-binary-instances-0.2.1.0
Installed test-framework-hunit-0.3.0
Configuring abstract-deque-0.2.2...
Building abstract-deque-0.2.2...
Installed hashtables-1.1.0.2
Installed abstract-deque-0.2.2
Installed attoparsec-0.10.4.0
Configuring aeson-0.6.2.0...
Installed mwc-random-0.13.0.0
Configuring monad-par-0.3.4.5...
Building aeson-0.6.2.0...
Building monad-par-0.3.4.5...
Installed vector-algorithms-0.5.4.2
Installed monad-par-0.3.4.5
Configuring statistics-0.10.4.1...
Building statistics-0.10.4.1...
Installed aeson-0.6.2.0
Installed statistics-0.10.4.1
Configuring criterion-0.8.0.0...
Building criterion-0.8.0.0...
Installed haskell-src-exts-1.14.0
Configuring HTF-0.11.0.1...
Building HTF-0.11.0.1...
Installed HTF-0.11.0.1
Installed criterion-0.8.0.0
/Users/graham/.cabal/bin/buildwrapper synchronize --force=false --tempfolder=.dist-buildwrapper --cabalpath=/Users/graham/.cabal/bin/cabal-dev --cabalfile=/Users/graham/Development/code/wordcounting/haskell-wordcounting/haskell-wordcounting.cabal --cabalflags= --cabaloption=--sandbox=.dist-buildwrapper/cabal-dev --cabaloption=--with-cabal-install=/Users/graham/.cabal/bin/cabal --logcabal=true
configuring because setup_config not present
'/Users/graham/.cabal/bin/cabal-dev' 'configure' '--verbose=1' '--user' '--enable-tests' '--builddir=/Users/graham/Development/code/wordcounting/haskell-wordcounting/.dist-buildwrapper/dist' '--sandbox=.dist-buildwrapper/cabal-dev' '--with-cabal-install=/Users/graham/.cabal/bin/cabal'
Warning: For packages using 'cabal-version: >= 1.10' the 'extensions' field is
deprecated. The new 'default-extensions' field lists extensions that are used
in all modules in the component, while the 'other-extensions' field lists
extensions that are used in some modules, e.g. via the {-# LANGUAGE #-}
pragma.
 
buildwrapper: user error (You need to re-run the 'configure' command. The version of Cabal being used has changed (was Cabal-1.18.1, now Cabal-1.16.0).)
/Users/graham/.cabal/bin/cabal-dev install-deps --enable-tests --force-reinstalls -j --sandbox=.dist-buildwrapper/cabal-dev --with-cabal-install=/Users/graham/.cabal/bin/cabal
You are using a version of cabal-install that has the --only-dependencies flag
to the install command. Invoking that instead...
Resolving dependencies...
All the requested packages are already installed:
Use --reinstall if you want to reinstall anyway.
/Users/graham/.cabal/bin/buildwrapper build --output=true --cabaltarget=Source --tempfolder=.dist-buildwrapper --cabalpath=/Users/graham/.cabal/bin/cabal-dev --cabalfile=/Users/graham/Development/code/wordcounting/haskell-wordcounting/haskell-wordcounting.cabal --cabalflags= --cabaloption=--sandbox=.dist-buildwrapper/cabal-dev --cabaloption=--with-cabal-install=/Users/graham/.cabal/bin/cabal --logcabal=true
configuring because persist build config not present
'/Users/graham/.cabal/bin/cabal-dev' 'configure' '--verbose=1' '--user' '--enable-tests' '--builddir=/Users/graham/Development/code/wordcounting/haskell-wordcounting/.dist-buildwrapper/dist' '--sandbox=.dist-buildwrapper/cabal-dev' '--with-cabal-install=/Users/graham/.cabal/bin/cabal'
Warning: For packages using 'cabal-version: >= 1.10' the 'extensions' field is
deprecated. The new 'default-extensions' field lists extensions that are used
in all modules in the component, while the 'other-extensions' field lists
extensions that are used in some modules, e.g. via the {-# LANGUAGE #-}
pragma.
 
buildwrapper: user error (You need to re-run the 'configure' command. The version of Cabal being used has changed (was Cabal-1.18.1, now Cabal-1.16.0).)
/Users/graham/.cabal/bin/buildwrapper components --tempfolder=.dist-buildwrapper --cabalpath=/Users/graham/.cabal/bin/cabal-dev --cabalfile=/Users/graham/Development/code/wordcounting/haskell-wordcounting/haskell-wordcounting.cabal --cabalflags= --cabaloption=--sandbox=.dist-buildwrapper/cabal-dev --cabaloption=--with-cabal-install=/Users/graham/.cabal/bin/cabal --logcabal=true
/Users/graham/.cabal/bin/cabal-dev install-deps --enable-tests --force-reinstalls -j --sandbox=.dist-buildwrapper/cabal-dev --with-cabal-install=/Users/graham/.cabal/bin/cabal
You are using a version of cabal-install that has the --only-dependencies flag
to the install command. Invoking that instead...
configuring because persist build config not present
'/Users/graham/.cabal/bin/cabal-dev' 'configure' '--verbose=1' '--user' '--enable-tests' '--builddir=/Users/graham/Development/code/wordcounting/haskell-wordcounting/.dist-buildwrapper/dist' '--sandbox=.dist-buildwrapper/cabal-dev' '--with-cabal-install=/Users/graham/.cabal/bin/cabal'
Warning: For packages using 'cabal-version: >= 1.10' the 'extensions' field is
deprecated. The new 'default-extensions' field lists extensions that are used
in all modules in the component, while the 'other-extensions' field lists
extensions that are used in some modules, e.g. via the {-# LANGUAGE #-}
pragma.
 
buildwrapper: user error (You need to re-run the 'configure' command. The version of Cabal being used has changed (was Cabal-1.18.1, now Cabal-1.16.0).)
Resolving dependencies...
All the requested packages are already installed:
Use --reinstall if you want to reinstall anyway.
/Users/graham/.cabal/bin/buildwrapper synchronize --force=false --tempfolder=.dist-buildwrapper --cabalpath=/Users/graham/.cabal/bin/cabal-dev --cabalfile=/Users/graham/Development/code/wordcounting/haskell-wordcounting/haskell-wordcounting.cabal --cabalflags= --cabaloption=--sandbox=.dist-buildwrapper/cabal-dev --cabaloption=--with-cabal-install=/Users/graham/.cabal/bin/cabal --logcabal=true
configuring because persist build config not present
'/Users/graham/.cabal/bin/cabal-dev' 'configure' '--verbose=1' '--user' '--enable-tests' '--builddir=/Users/graham/Development/code/wordcounting/haskell-wordcounting/.dist-buildwrapper/dist' '--sandbox=.dist-buildwrapper/cabal-dev' '--with-cabal-install=/Users/graham/.cabal/bin/cabal'
Warning: For packages using 'cabal-version: >= 1.10' the 'extensions' field is
deprecated. The new 'default-extensions' field lists extensions that are used
in all modules in the component, while the 'other-extensions' field lists
extensions that are used in some modules, e.g. via the {-# LANGUAGE #-}
pragma.
 
buildwrapper: user error (You need to re-run the 'configure' command. The version of Cabal being used has changed (was Cabal-1.18.1, now Cabal-1.16.0).)
/Users/graham/.cabal/bin/buildwrapper build --output=true --cabaltarget=Source --tempfolder=.dist-buildwrapper --cabalpath=/Users/graham/.cabal/bin/cabal-dev --cabalfile=/Users/graham/Development/code/wordcounting/haskell-wordcounting/haskell-wordcounting.cabal --cabalflags= --cabaloption=--sandbox=.dist-buildwrapper/cabal-dev --cabaloption=--with-cabal-install=/Users/graham/.cabal/bin/cabal --logcabal=true
configuring because persist build config not present
'/Users/graham/.cabal/bin/cabal-dev' 'configure' '--verbose=1' '--user' '--enable-tests' '--builddir=/Users/graham/Development/code/wordcounting/haskell-wordcounting/.dist-buildwrapper/dist' '--sandbox=.dist-buildwrapper/cabal-dev' '--with-cabal-install=/Users/graham/.cabal/bin/cabal'
Warning: For packages using 'cabal-version: >= 1.10' the 'extensions' field is
deprecated. The new 'default-extensions' field lists extensions that are used
in all modules in the component, while the 'other-extensions' field lists
extensions that are used in some modules, e.g. via the {-# LANGUAGE #-}
pragma.
 
buildwrapper: user error (You need to re-run the 'configure' command. The version of Cabal being used has changed (was Cabal-1.18.1, now Cabal-1.16.0).)
/Users/graham/.cabal/bin/buildwrapper configure --cabaltarget=Source --tempfolder=.dist-buildwrapper --cabalpath=/Users/graham/.cabal/bin/cabal-dev --cabalfile=/Users/graham/Development/code/wordcounting/haskell-wordcounting/haskell-wordcounting.cabal --cabalflags= --cabaloption=--sandbox=.dist-buildwrapper/cabal-dev --cabaloption=--with-cabal-install=/Users/graham/.cabal/bin/cabal --logcabal=true
/Users/graham/.cabal/bin/buildwrapper build --output=false --cabaltarget=Source --tempfolder=.dist-buildwrapper --cabalpath=/Users/graham/.cabal/bin/cabal-dev --cabalfile=/Users/graham/Development/code/wordcounting/haskell-wordcounting/haskell-wordcounting.cabal --cabalflags= --cabaloption=--sandbox=.dist-buildwrapper/cabal-dev --cabaloption=--with-cabal-install=/Users/graham/.cabal/bin/cabal --logcabal=true
'/Users/graham/.cabal/bin/cabal-dev' 'configure' '--verbose=1' '--user' '--enable-tests' '--builddir=/Users/graham/Development/code/wordcounting/haskell-wordcounting/.dist-buildwrapper/dist' '--sandbox=.dist-buildwrapper/cabal-dev' '--with-cabal-install=/Users/graham/.cabal/bin/cabal'
cabal: At least the following dependencies are missing:
criterion -any,
hashtables ==1.1.0.2,
split -any,
unordered-containers ==0.2.2.1
 
build-wrapper-json:[false,[{"l":{"l":1,"ec":1,"el":1,"c":1,"f":"haskell-wordcounting.cabal"},"t":"At least the following dependencies are missing:\ncriterion -any,\nhashtables ==1.1.0.2,\nsplit -any,\nunordered-containers ==0.2.2.1\n","s":"Error"}]]
/Users/graham/.cabal/bin/buildwrapper components --tempfolder=.dist-buildwrapper --cabalpath=/Users/graham/.cabal/bin/cabal-dev --cabalfile=/Users/graham/Development/code/wordcounting/haskell-wordcounting/haskell-wordcounting.cabal --tempfolder=.dist-buildwrapper --cabalpath=/Users/graham/.cabal/bin/cabal-dev --cabalfile=/Users/graham/Development/code/wordcounting/haskell-wordcounting/haskell-wordcounting.cabal --cabalflags= --cabaloption=--sandbox=.dist-buildwrapper/cabal-dev --cabaloption=--with-cabal-install=/Users/graham/.cabal/bin/cabal --logcabal=true
configuring because setup_config not present
'/Users/graham/.cabal/bin/cabal-dev' 'configure' '--verbose=1' '--user' '--enable-tests' '--builddir=/Users/graham/Development/code/wordcounting/haskell-wordcounting/.dist-buildwrapper/dist' '--sandbox=.dist-buildwrapper/cabal-dev' '--with-cabal-install=/Users/graham/.cabal/bin/cabal'
cabal: At least the following dependencies are missing:
criterion -any,
hashtables ==1.1.0.2,
split -any,
unordered-containers ==0.2.2.1
 
build-wrapper-json:[{"r":false,"fps":[]},[{"l":{"l":1,"ec":1,"el":1,"c":1,"f":"haskell-wordcounting.cabal"},"t":"At least the following dependencies are missing:\ncriterion -any,\nhashtables ==1.1.0.2,\nsplit -any,\nunordered-containers ==0.2.2.1\n","s":"Error"}]]
configuring because setup_config not present
'/Users/graham/.cabal/bin/cabal-dev' 'configure' '--verbose=1' '--user' '--enable-tests' '--builddir=/Users/graham/Development/code/wordcounting/haskell-wordcounting/.dist-buildwrapper/dist' '--sandbox=.dist-buildwrapper/cabal-dev' '--with-cabal-install=/Users/graham/.cabal/bin/cabal'
cabal: At least the following dependencies are missing:
criterion -any,
hashtables ==1.1.0.2,
split -any,
unordered-containers ==0.2.2.1
 
build-wrapper-json:[[],[{"l":{"l":1,"ec":1,"el":1,"c":1,"f":"haskell-wordcounting.cabal"},"t":"At least the following dependencies are missing:\ncriterion -any,\nhashtables ==1.1.0.2,\nsplit -any,\nunordered-containers ==0.2.2.1\n","s":"Error"}]]

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.