Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Failed comprehensive theme paver run
$ /edx/bin/edxapp-update-assets-lms && sudo /edx/bin/supervisorctl restart edxapp_worker:
mkdir_p path('/edx/app/edxapp/edx-platform/themes/hastexo/lms/static/css')
---> pavelib.assets.update_assets
---> pavelib.prereqs.install_ruby_prereqs
NO_PREREQ_INSTALL is set, not installing prereqs
---> pavelib.prereqs.install_node_prereqs
NO_PREREQ_INSTALL is set, not installing prereqs
python manage.py lms --settings=aws preprocess_assets lms/static/sass/*.scss lms/static/themed_sass
2016-01-06 13:16:46,789 INFO 4841 [dd.dogapi] dog_stats_api.py:66 - Initializing dog api to use statsd: localhost, 8125
System check identified some issues:
WARNINGS:
?: (1_8.W001) The standalone TEMPLATE_* settings were deprecated in Django 1.8 and the TEMPLATES dictionary takes precedence. You must put the values of the following settings into your default TEMPLATES dict: TEMPLATE_DIRS.
wiki.ArticleRevision.ip_address: (fields.W900) IPAddressField has been deprecated. Support for it (except in historical migrations) will be removed in Django 1.9.
HINT: Use GenericIPAddressField instead.
Finished preprocessing lms assets.
xmodule_assets common/static/xmodule
Finished processing xmodule assets.
---> pavelib.assets.compile_coffeescript
node_modules/.bin/coffee --compile `find /edx/app/edxapp/edx-platform/lms /edx/app/edxapp/edx-platform/cms /edx/app/edxapp/edx-platform/common -type f -name "*.coffee"`
---> pavelib.assets.compile_sass
sass --update --cache-location /tmp/sass-cache --default-encoding utf-8 --style compressed --quiet --load-path . --load-path common/static --load-path common/static/sass --load-path lms/static/sass --load-path lms/static/themed_sass --load-path cms/static/sass --load-path common/static/sass --load-path lms/static/certificates/sass --load-path /edx/app/edxapp/edx-platform/themes/hastexo/lms/static/sass lms/static/sass:lms/static/css lms/static/themed_sass:lms/static/css cms/static/sass:cms/static/css common/static/sass:common/static/css lms/static/certificates/sass:lms/static/certificates/css /edx/app/edxapp/edx-platform/themes/hastexo/lms/static/sass:/edx/app/edxapp/edx-platform/themes/hastexo/lms/static/css
Captured Task Output:
---------------------
---> pavelib.assets.update_assets
---> pavelib.prereqs.install_ruby_prereqs
---> pavelib.prereqs.install_node_prereqs
python manage.py lms --settings=aws preprocess_assets lms/static/sass/*.scss lms/static/themed_sass
xmodule_assets common/static/xmodule
---> pavelib.assets.compile_coffeescript
node_modules/.bin/coffee --compile `find /edx/app/edxapp/edx-platform/lms /edx/app/edxapp/edx-platform/cms /edx/app/edxapp/edx-platform/common -type f -name "*.coffee"`
---> pavelib.assets.compile_sass
sass --update --cache-location /tmp/sass-cache --default-encoding utf-8 --style compressed --quiet --load-path . --load-path common/static --load-path common/static/sass --load-path lms/static/sass --load-path lms/static/themed_sass --load-path cms/static/sass --load-path common/static/sass --load-path lms/static/certificates/sass --load-path /edx/app/edxapp/edx-platform/themes/hastexo/lms/static/sass lms/static/sass:lms/static/css lms/static/themed_sass:lms/static/css cms/static/sass:cms/static/css common/static/sass:common/static/css lms/static/certificates/sass:lms/static/certificates/css /edx/app/edxapp/edx-platform/themes/hastexo/lms/static/sass:/edx/app/edxapp/edx-platform/themes/hastexo/lms/static/css
Build failed running pavelib.assets.update_assets: Subprocess return code: 1
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.