Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
[root@P ~]# rpm -qa | grep guest
[root@P ~]# rpm -qa | grep ruby
[root@P ~]# yum install ruby-libguestfs
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package ruby-libguestfs.x86_64 1:1.5.21-1.fc14.4 set to be installed
--> Processing Dependency: libguestfs = 1:1.5.21-1.fc14.4 for package: 1:ruby-libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: ruby(abi) = 1.8 for package: 1:ruby-libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: libruby.so.1.8()(64bit) for package: 1:ruby-libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: libguestfs.so.0()(64bit) for package: 1:ruby-libguestfs-1.5.21-1.fc14.4.x86_64
--> Running transaction check
---> Package libguestfs.x86_64 1:1.5.21-1.fc14.4 set to be installed
--> Processing Dependency: qemu-kvm >= 0.12 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: febootstrap >= 2.9 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: /usr/lib64/libntfs.so.10 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: gfs2-utils for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: /lib64/libhandle.so.1 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: reiserfs-utils for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: parted for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: /usr/lib64/libgnutls-openssl.so.26 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: btrfs-progs for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: /usr/lib64/libconfig.so.9 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: MAKEDEV for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: binutils for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: /lib64/libcryptsetup.so.1 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: nilfs-utils for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: strace for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: augeas-libs for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: /usr/lib64/libgnutlsxx.so.26 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: /usr/lib64/libgnutls.so.26 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: /usr/lib64/libgnutls-extra.so.26 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: lsof for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: dosfstools for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: genisoimage for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: /lib64/libnilfs.so.0 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: /usr/lib64/libfa.so.1 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: /usr/lib64/libaugeas.so.0 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: /usr/lib64/libtasn1.so.3 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: jfsutils for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: zerofree for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: ntfs-3g for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: scrub for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: hfsplus-tools for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: ntfsprogs for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: /usr/lib64/libconfig++.so.9 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: /lib64/libparted.so.0 for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: cryptsetup-luks for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: xfsprogs for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: libaugeas.so.0()(64bit) for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
--> Processing Dependency: libhivex.so.0()(64bit) for package: 1:libguestfs-1.5.21-1.fc14.4.x86_64
---> Package ruby-libs.x86_64 0:1.8.7.302-1.fc14 set to be installed
--> Processing Dependency: libreadline.so.5()(64bit) for package: ruby-libs-1.8.7.302-1.fc14.x86_64
--> Running transaction check
---> Package MAKEDEV.x86_64 0:3.24-6.fc14 set to be installed
---> Package augeas-libs.x86_64 0:0.7.3-1.fc14 set to be installed
---> Package binutils.x86_64 0:2.20.51.0.7-5.fc14 set to be installed
---> Package btrfs-progs.x86_64 0:0.19-12.fc14 set to be installed
---> Package compat-readline5.x86_64 0:5.2-17.fc12 set to be installed
---> Package cryptsetup-luks.x86_64 0:1.1.3-1.fc14 set to be installed
---> Package cryptsetup-luks-libs.x86_64 0:1.1.3-1.fc14 set to be installed
---> Package dosfstools.x86_64 0:3.0.9-3.fc14 set to be installed
---> Package febootstrap.x86_64 0:2.9-1.fc14 set to be installed
--> Processing Dependency: fakeroot >= 1.11 for package: febootstrap-2.9-1.fc14.x86_64
--> Processing Dependency: fakechroot >= 2.9-20 for package: febootstrap-2.9-1.fc14.x86_64
---> Package genisoimage.x86_64 0:1.1.10-2.fc14 set to be installed
---> Package gfs2-utils.x86_64 0:3.0.17-1.fc14 set to be installed
---> Package gnutls.x86_64 0:2.8.6-2.fc14 set to be installed
---> Package hfsplus-tools.x86_64 0:332.14-11.fc13 set to be installed
---> Package hivex.x86_64 0:1.2.2-2.fc14 set to be installed
--> Processing Dependency: /usr/bin/perl for package: hivex-1.2.2-2.fc14.x86_64
--> Processing Dependency: perl(Getopt::Long) for package: hivex-1.2.2-2.fc14.x86_64
--> Processing Dependency: perl(warnings) for package: hivex-1.2.2-2.fc14.x86_64
--> Processing Dependency: perl(Win::Hivex::Regedit) for package: hivex-1.2.2-2.fc14.x86_64
--> Processing Dependency: perl(strict) for package: hivex-1.2.2-2.fc14.x86_64
--> Processing Dependency: perl(Win::Hivex) for package: hivex-1.2.2-2.fc14.x86_64
--> Processing Dependency: perl(Pod::Usage) for package: hivex-1.2.2-2.fc14.x86_64
---> Package jfsutils.x86_64 0:1.1.13-8.fc12 set to be installed
---> Package libconfig.x86_64 0:1.4.5-1.fc14 set to be installed
---> Package libtasn1.x86_64 0:2.7-1.fc14 set to be installed
---> Package lsof.x86_64 0:4.83-2.fc14 set to be installed
---> Package nilfs-utils.x86_64 0:2.0.18-1.fc14 set to be installed
---> Package ntfs-3g.x86_64 2:2010.10.2-1.fc14 set to be installed
---> Package ntfsprogs.x86_64 0:2.0.0-15.fc14 set to be installed
---> Package parted.x86_64 0:2.3-3.fc14 set to be installed
---> Package qemu-kvm.x86_64 2:0.13.0-1.fc14 set to be installed
--> Processing Dependency: qemu-system-x86 = 2:0.13.0-1.fc14 for package: 2:qemu-kvm-0.13.0-1.fc14.x86_64
---> Package reiserfs-utils.x86_64 2:3.6.21-2.fc12 set to be installed
---> Package scrub.x86_64 0:2.2-1.fc14 set to be installed
---> Package strace.x86_64 0:4.5.20-1.fc14 set to be installed
---> Package xfsprogs.x86_64 0:3.1.2-1.fc14 set to be installed
---> Package zerofree.x86_64 0:1.0.1-7.fc14 set to be installed
--> Running transaction check
---> Package fakechroot.x86_64 0:2.9-24.fc12 set to be installed
--> Processing Dependency: fakechroot-libs = 2.9-24.fc12 for package: fakechroot-2.9-24.fc12.x86_64
---> Package fakeroot.x86_64 0:1.12.4-2.fc14 set to be installed
--> Processing Dependency: fakeroot-libs = 1.12.4-2.fc14 for package: fakeroot-1.12.4-2.fc14.x86_64
---> Package perl.x86_64 4:5.12.2-136.fc14 set to be installed
--> Processing Dependency: perl-libs = 4:5.12.2-136.fc14 for package: 4:perl-5.12.2-136.fc14.x86_64
--> Processing Dependency: perl(threads) for package: 4:perl-5.12.2-136.fc14.x86_64
--> Processing Dependency: perl(Pod::Simple) for package: 4:perl-5.12.2-136.fc14.x86_64
--> Processing Dependency: perl-libs for package: 4:perl-5.12.2-136.fc14.x86_64
--> Processing Dependency: perl(Module::Pluggable) for package: 4:perl-5.12.2-136.fc14.x86_64
--> Processing Dependency: libperl.so()(64bit) for package: 4:perl-5.12.2-136.fc14.x86_64
---> Package perl-hivex.x86_64 0:1.2.2-2.fc14 set to be installed
---> Package qemu-system-x86.x86_64 2:0.13.0-1.fc14 set to be installed
--> Processing Dependency: qemu-common = 2:0.13.0-1.fc14 for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: vgabios >= 0.6c-2 for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libaio.so.1(LIBAIO_0.4)(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libpulse.so.0(PULSE_0)(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: seabios-bin for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: /usr/share/gpxe/virtio-net.rom for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: /usr/share/gpxe/rtl8029.rom for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: /usr/share/gpxe/8086100e.rom for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libaio.so.1(LIBAIO_0.1)(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libasound.so.2(ALSA_0.9)(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libpulse-simple.so.0(PULSE_0)(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4)(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: /usr/share/gpxe/pcnet32.rom for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: /usr/share/gpxe/rtl8139.rom for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libXrandr.so.2()(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libspice-server.so.1()(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libSDL-1.2.so.0()(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libpulse.so.0()(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libasound.so.2()(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libcelt051.so.0()(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libXext.so.6()(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libpulse-simple.so.0()(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Processing Dependency: libaio.so.1()(64bit) for package: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
--> Running transaction check
---> Package SDL.x86_64 0:1.2.14-8.fc14 set to be installed
---> Package alsa-lib.x86_64 0:1.0.23-1.fc14 set to be installed
---> Package celt051.x86_64 0:0.5.1.3-2.fc14 set to be installed
--> Processing Dependency: libogg.so.0()(64bit) for package: celt051-0.5.1.3-2.fc14.x86_64
---> Package fakechroot-libs.x86_64 0:2.9-24.fc12 set to be installed
---> Package fakeroot-libs.x86_64 0:1.12.4-2.fc14 set to be installed
---> Package gpxe-roms-qemu.noarch 0:1.0.1-1.fc14 set to be installed
---> Package libXext.x86_64 0:1.1.2-2.fc14 set to be installed
---> Package libXrandr.x86_64 0:1.3.0-5.fc13 set to be installed
---> Package libaio.x86_64 0:0.3.109-2.fc13 set to be installed
---> Package perl-Module-Pluggable.noarch 1:3.90-136.fc14 set to be installed
---> Package perl-Pod-Simple.noarch 1:3.13-136.fc14 set to be installed
--> Processing Dependency: perl(Pod::Escapes) >= 1.04 for package: 1:perl-Pod-Simple-3.13-136.fc14.noarch
---> Package perl-libs.x86_64 4:5.12.2-136.fc14 set to be installed
---> Package perl-threads.x86_64 0:1.81-1.fc14 set to be installed
---> Package pulseaudio-libs.x86_64 0:0.9.21-6.fc13 set to be installed
--> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0)(64bit) for package: pulseaudio-libs-0.9.21-6.fc13.x86_64
--> Processing Dependency: libsndfile.so.1()(64bit) for package: pulseaudio-libs-0.9.21-6.fc13.x86_64
--> Processing Dependency: libXtst.so.6()(64bit) for package: pulseaudio-libs-0.9.21-6.fc13.x86_64
--> Processing Dependency: libICE.so.6()(64bit) for package: pulseaudio-libs-0.9.21-6.fc13.x86_64
--> Processing Dependency: libasyncns.so.0()(64bit) for package: pulseaudio-libs-0.9.21-6.fc13.x86_64
--> Processing Dependency: libSM.so.6()(64bit) for package: pulseaudio-libs-0.9.21-6.fc13.x86_64
---> Package qemu-common.x86_64 2:0.13.0-1.fc14 set to be installed
---> Package seabios-bin.noarch 0:0.6.0-1.fc14 set to be installed
---> Package spice-server.x86_64 0:0.6.0-1.fc14 set to be installed
--> Processing Dependency: libjpeg.so.62()(64bit) for package: spice-server-0.6.0-1.fc14.x86_64
---> Package vgabios.noarch 0:0.6c-2.fc14 set to be installed
--> Running transaction check
---> Package libICE.x86_64 0:1.0.6-2.fc13 set to be installed
---> Package libSM.x86_64 0:1.1.0-7.fc12 set to be installed
---> Package libXtst.x86_64 0:1.0.99.2-3.fc12 set to be installed
--> Processing Dependency: libXi.so.6()(64bit) for package: libXtst-1.0.99.2-3.fc12.x86_64
---> Package libasyncns.x86_64 0:0.8-1.fc13 set to be installed
---> Package libjpeg-turbo.x86_64 0:1.0.1-1.fc14.1 set to be installed
---> Package libogg.x86_64 2:1.2.0-1.fc14 set to be installed
---> Package libsndfile.x86_64 0:1.0.23-1.fc14 set to be installed
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: libsndfile-1.0.23-1.fc14.x86_64
--> Processing Dependency: libvorbis.so.0()(64bit) for package: libsndfile-1.0.23-1.fc14.x86_64
--> Processing Dependency: libFLAC.so.8()(64bit) for package: libsndfile-1.0.23-1.fc14.x86_64
---> Package perl-Pod-Escapes.noarch 1:1.04-136.fc14 set to be installed
--> Running transaction check
---> Package flac.x86_64 0:1.2.1-6.fc12 set to be installed
---> Package libXi.x86_64 0:1.3.2-1.fc14 set to be installed
---> Package libvorbis.x86_64 1:1.3.1-2.fc14 set to be installed
--> Finished Dependency Resolution
Dependencies Resolved
==============================================================================================================================================================================================================================================================================
Package Arch Version Repository Size
==============================================================================================================================================================================================================================================================================
Installing:
ruby-libguestfs x86_64 1:1.5.21-1.fc14.4 fedora 71 k
Installing for dependencies:
MAKEDEV x86_64 3.24-6.fc14 fedora 92 k
SDL x86_64 1.2.14-8.fc14 fedora 194 k
alsa-lib x86_64 1.0.23-1.fc14 fedora 370 k
augeas-libs x86_64 0.7.3-1.fc14 fedora 296 k
binutils x86_64 2.20.51.0.7-5.fc14 fedora 3.5 M
btrfs-progs x86_64 0.19-12.fc14 fedora 192 k
celt051 x86_64 0.5.1.3-2.fc14 fedora 50 k
compat-readline5 x86_64 5.2-17.fc12 fedora 124 k
cryptsetup-luks x86_64 1.1.3-1.fc14 fedora 70 k
cryptsetup-luks-libs x86_64 1.1.3-1.fc14 fedora 46 k
dosfstools x86_64 3.0.9-3.fc14 fedora 77 k
fakechroot x86_64 2.9-24.fc12 fedora 22 k
fakechroot-libs x86_64 2.9-24.fc12 fedora 22 k
fakeroot x86_64 1.12.4-2.fc14 fedora 74 k
fakeroot-libs x86_64 1.12.4-2.fc14 fedora 23 k
febootstrap x86_64 2.9-1.fc14 fedora 339 k
flac x86_64 1.2.1-6.fc12 fedora 230 k
genisoimage x86_64 1.1.10-2.fc14 fedora 353 k
gfs2-utils x86_64 3.0.17-1.fc14 fedora 235 k
gnutls x86_64 2.8.6-2.fc14 fedora 360 k
gpxe-roms-qemu noarch 1.0.1-1.fc14 fedora 226 k
hfsplus-tools x86_64 332.14-11.fc13 fedora 120 k
hivex x86_64 1.2.2-2.fc14 fedora 74 k
jfsutils x86_64 1.1.13-8.fc12 fedora 203 k
libICE x86_64 1.0.6-2.fc13 fedora 53 k
libSM x86_64 1.1.0-7.fc12 fedora 25 k
libXext x86_64 1.1.2-2.fc14 fedora 33 k
libXi x86_64 1.3.2-1.fc14 fedora 33 k
libXrandr x86_64 1.3.0-5.fc13 fedora 30 k
libXtst x86_64 1.0.99.2-3.fc12 fedora 21 k
libaio x86_64 0.3.109-2.fc13 fedora 21 k
libasyncns x86_64 0.8-1.fc13 fedora 24 k
libconfig x86_64 1.4.5-1.fc14 fedora 55 k
libguestfs x86_64 1:1.5.21-1.fc14.4 fedora 1.4 M
libjpeg-turbo x86_64 1.0.1-1.fc14.1 fedora 113 k
libogg x86_64 2:1.2.0-1.fc14 fedora 21 k
libsndfile x86_64 1.0.23-1.fc14 updates 153 k
libtasn1 x86_64 2.7-1.fc14 updates 320 k
libvorbis x86_64 1:1.3.1-2.fc14 fedora 201 k
lsof x86_64 4.83-2.fc14 fedora 318 k
nilfs-utils x86_64 2.0.18-1.fc14 fedora 84 k
ntfs-3g x86_64 2:2010.10.2-1.fc14 updates 244 k
ntfsprogs x86_64 2.0.0-15.fc14 fedora 341 k
parted x86_64 2.3-3.fc14 fedora 632 k
perl x86_64 4:5.12.2-136.fc14 fedora 11 M
perl-Module-Pluggable noarch 1:3.90-136.fc14 fedora 38 k
perl-Pod-Escapes noarch 1:1.04-136.fc14 fedora 30 k
perl-Pod-Simple noarch 1:3.13-136.fc14 fedora 210 k
perl-hivex x86_64 1.2.2-2.fc14 fedora 34 k
perl-libs x86_64 4:5.12.2-136.fc14 fedora 594 k
perl-threads x86_64 1.81-1.fc14 fedora 47 k
pulseaudio-libs x86_64 0.9.21-6.fc13 fedora 428 k
qemu-common x86_64 2:0.13.0-1.fc14 updates 258 k
qemu-kvm x86_64 2:0.13.0-1.fc14 updates 23 k
qemu-system-x86 x86_64 2:0.13.0-1.fc14 updates 2.4 M
reiserfs-utils x86_64 2:3.6.21-2.fc12 fedora 223 k
ruby-libs x86_64 1.8.7.302-1.fc14 fedora 1.9 M
scrub x86_64 2.2-1.fc14 fedora 35 k
seabios-bin noarch 0.6.0-1.fc14 fedora 47 k
spice-server x86_64 0.6.0-1.fc14 fedora 248 k
strace x86_64 4.5.20-1.fc14 fedora 175 k
vgabios noarch 0.6c-2.fc14 fedora 41 k
xfsprogs x86_64 3.1.2-1.fc14 fedora 725 k
zerofree x86_64 1.0.1-7.fc14 fedora 20 k
Transaction Summary
==============================================================================================================================================================================================================================================================================
Install 65 Package(s)
Total download size: 30 M
Installed size: 107 M
Is this ok [y/N]:
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.