Skip to content

Instantly share code, notes, and snippets.

@graingert
Created Apr 10, 2019
Embed
What would you like to do?
bad dockerfile
-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: SKS 1.1.6
Comment: Hostname: keyserver.ubuntu.com
mQINBFl8fYEBEADQmGZ6pDrwY9iH9DVlwNwTOvOZ7q7lHXPl/TLfMs1tckMc/D9ahsdBN9VW
tMmo+RySvhkIe8X15r65TFs2HE8ft6j2e/4K472pObM1hB+ajiU/wYX2Syq7DBlNm6YMP5/S
yQzRxqis4Ja1uUjW4Q5/Csdf5In8uMzXj5D1P7qOiP2aNa0Er3w6PXWRTuTihWZOsHv8npyV
YDBRR6gEZbd3r86snI/7o8Bfmad3KjbxL7aOdNMwAqQFaNKl7Y+UJpv1CNFIf+twcOoC0se1
SrsVJlAH9HNHM7XGQsPUwpNvQlcmvr+t1vVS2m72lk3gyShDuJpi1TifGw+DoTqu54U0k+0s
Zm4pnQVeiizNkefU2UqOoGlt4oiG9nIhSX04xRlGes3Ya0OjNI5b1xbcYoR+r0c3odI+UCw3
VSZtKDX/xlH1o/82b8ouXeE7LA1i4DvGNj4VSvoxv4ggIznxMf+PkWXWKwRGsbAAXF52rr4F
UaeaKoIUDkJqHXAxrB3PQslZ+ZgBEukkQZF76NkqRqP1E7FXzZZMo2eEL7vtnhSzUlanOf42
ECBoWHVoZQaRFMNbGpqlg9aWedHGyetMStS3nH1sqanr+i4I8VR/UH+ilarPTW3TE0apWlsH
8+N3IKbRx2wgrRZNoQEuyVtvyewDFYShJB3Zxt7VCy67vKAl1QARAQABtBxMYXVuY2hwYWQg
UFBBIGZvciBkZWFkc25ha2VziQI4BBMBAgAiBQJZfH2BAhsDBgsJCAcDAgYVCAIJCgsEFgID
AQIeAQIXgAAKCRC6aTI2anVXdvwhD/4oI3yckeKn9aJNNTJsyw4ydMkIAOdG+jbZsYv/rN73
UVQF1RA8HC71SDmbd0Nu80koBOX+USuLvvhoMIsARlD5dLx5f/zaQcYWJm/BtsMF/eZ4s1xs
enwW6PpXd8FpaTn1qtg/8+O999R4uSetAhhyf1vSRb/8U0sgSQd38mpZZFq352UuVisXnmCT
hj621loQubYJ3lwULSLs8wmgo4XIYH7UgdavV9dfplPh0M19RHQL3wTyQP2KRNRq1rG7/n1X
zUwDyqY6eMVhdVhvnxAGztvdFCySVzBRr/rCw6quhcYQwBqdqaXhz63np+4mlUNfd8Eu+Vas
b/tbteF/pDu0yeFMpK4X09Cwn2kYYCpq4XujijW+iRWb4MO3G8LLi8oBAHP/k0CM/QvSRbbG
8JDQkQDH37Efm8iE/EttJTixjKAIfyugmvEHfcrnxaMoBioa6h6McQrMvI8bJirxorJzOVF4
kY7xXvMYwjzaDC8G0fTA8SzQRaShksR3USXZjz8vS6tZ+YNamRHPoZ3Ua0bz4t2aCcu/fknV
GsXcNBazNIK9WF2665Ut/b7lDbojXsUZ3PpuqOoeGQL9LRj7nmCI6ugoKkNp8ZXcGJ8BGw37
Wep2ztyzDohXp6f/4mGgy2KYV9R4S8D5yBDUU6BS7Su5nhQMStfdfr4FffLmnvFC9w==
=7hFk
-----END PGP PUBLIC KEY BLOCK-----
FROM ubuntu:xenial
COPY ./apt-keys.pub /tmp/apt-keys.pub
RUN echo "deb http://ppa.launchpad.net/deadsnakes/ppa/ubuntu xenial main" > /etc/apt/sources.list.d/deadsnakes.list \
&& apt-key add /tmp/apt-keys.pub && rm /tmp/apt-keys.pub \
&& apt-get update && apt-get install -y --no-install-recommends libgtk2.0 libwebkitgtk-3.0 \
build-essential python2.7-dev python3.7-dev python3.7-venv python-virtualenv \
libjpeg8 libtiff5 libsdl1.2debian libnotify4 freeglut3 libsm6 \
libgl1-mesa-glx libgstreamer-plugins-base0.10 libwebkit2gtk-4.0-37 git \
&& rm -rf /var/lib/apt/lists/*
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment