Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
linuxmint 18.1 apt dependency issue
 root  ~  apt install skype
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.
 root  ~  apt install skype-bin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
skype-bin:i386 : Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not going to be installed
Depends: libgl1-mesa-glx:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
 root  ~  apt install libqtwebkit4:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
libqtwebkit4:i386 : Depends: libgl1-mesa-glx:i386 but it is not going to be installed or
libgl1:i386
Depends: libqt4-network:i386 (>= 4:4.7.0~beta1) but it is not going to be installed
Depends: libqt4-opengl:i386 (>= 4:4.5.3) but it is not going to be installed
Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment