Skip to content

Instantly share code, notes, and snippets.

Steve Huff hakamadare

Block or report user

Report or block hakamadare

Hide content and notifications from this user.

Learn more about blocking users

Contact Support about this user’s behavior.

Learn more about reporting abuse

Report abuse
View GitHub Profile
@hakamadare
hakamadare / # mitmproxy - 2017-02-23_11-13-03.txt
Created Feb 23, 2017
mitmproxy on macOS 10.12.3 - Homebrew build logs
View # mitmproxy - 2017-02-23_11-13-03.txt
Homebrew build logs for mitmproxy on macOS 10.12.3
Build date: 2017-02-23 11:13:03
View gist:2fa3824caf6517489d21
anchor { 'stash::start':
} ->
class { 'stash::install':
webappdir => $webappdir
} ->
class { 'stash::config':
} ~>
class { 'stash::service':
} ->
class { 'stash::backup':
View keybase.md

Keybase proof

I hereby claim:

  • I am hakamadare on github.
  • I am hakamadare (https://keybase.io/hakamadare) on keybase.
  • I have a public key whose fingerprint is A92A 1F7E 6D76 16A0 BFF9 E61D AD54 0251 8477 B706

To claim this, I am signing this object:

@hakamadare
hakamadare / gist:9095770
Created Feb 19, 2014
busted installer.pp from openstack-foreman-installer-1.0.4
View gist:9095770
class { 'puppet':
runmode => 'cron',
server => true,
server_common_modules_path => [
'/usr/share/openstack-foreman-installer/puppet/modules',
'/usr/share/packstack/modules',
],
}
include passenger
class { 'foreman':
@hakamadare
hakamadare / gist:8124098
Created Dec 25, 2013
vagrant-2717 debug log
View gist:8124098
INFO global: Vagrant version: 1.4.1
INFO global: Ruby version: 2.0.0
INFO global: RubyGems version: 2.0.14
INFO global: VAGRANT_DEFAULT_PROVIDER="vmware_fusion"
INFO global: VAGRANT_LOG="debug"
INFO global: VAGRANT_INSTALLER_EMBEDDED_DIR="/Applications/Vagrant/bin/../embedded"
INFO global: VAGRANT_INSTALLER_VERSION="2"
INFO global: VAGRANT_DETECTED_OS="Darwin"
INFO global: VAGRANT_INSTALLER_ENV="1"
DEBUG global: Loading core plugin: /Applications/Vagrant/embedded/gems/gems/vagrant-1.4.1/plugins/commands/box/plugin.rb
@hakamadare
hakamadare / gist:7439306
Created Nov 12, 2013
sadface :( this is the result of `python setup.py develop` after pulling in huit/nepho@62a6d82
View gist:7439306
Installed /Users/huit/python/nepho/nepho
Processing dependencies for nepho==0.2.2
Searching for cement>=2.1,==2.1.4-dev
Best match: cement 2.1.4-dev
Doing git clone from git://github.com/cement/cement.git to /var/folders/b2/ps7btgls6bd_npkync0kzjcc0000gq/T/easy_install-p5qOeK/cement.git@2.1.4.dev20131029203905
Checking out 2.1.4.dev20131029203905
Processing cement.git@2.1.4.dev20131029203905
Writing /var/folders/b2/ps7btgls6bd_npkync0kzjcc0000gq/T/easy_install-p5qOeK/cement.git@2.1.4.dev20131029203905/setup.cfg
Running setup.py -q bdist_egg --dist-dir /var/folders/b2/ps7btgls6bd_npkync0kzjcc0000gq/T/easy_install-p5qOeK/cement.git@2.1.4.dev20131029203905/egg-dist-tmp-pqIFGv
Traceback (most recent call last):
@hakamadare
hakamadare / vcsrepo_git_wrapper.pp
Created Jul 5, 2013
first whack at a wrapper for vcsrepo that fixes ownership
View vcsrepo_git_wrapper.pp
define vcsrepo_git_wrapper(
$source,
$ensure = 'present',
$excludes = false,
$force = false,
$group = 'root',
$identity = '~/.ssh/id_rsa',
$owner = 'root',
$revision = 'HEAD',
$user = 'root',
@hakamadare
hakamadare / stack trace from client
Last active Dec 18, 2015
errors from Puppet client 2.7.22 -> master 2.7.22 seen on RHEL6.4 and Ubuntu 10.04 clients
View stack trace from client
# puppet agent -t
notice: Ignoring --listen on onetime run
info: Retrieving plugin
err: /File[/var/lib/puppet/lib]: Failed to generate additional resources using 'eval_generate: Could not intern_multiple from yaml: Invalid option stat_method for Puppet::FileServing::Metadata
err: /File[/var/lib/puppet/lib]: Could not evaluate: Could not intern from yaml: Invalid option stat_method for Puppet::FileServing::Metadata Could not retrieve file metadata for puppet://<puppetmaster>/plugins: Could not intern from yaml: Invalid option stat_method for Puppet::FileServing::Metadata
... (loading various facts, no errors here)
err: Could not retrieve catalog from remote server: Could not intern from yaml: undefined method `type_id' for "name":String
warning: Not using cache on failed catalog
err: Could not retrieve catalog; skipping run
You can’t perform that action at this time.