public
Last active

HTML5 Template for Sublime Text 2

  • Download Gist
html5.sublime-snippet
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53
<snippet>
<content><![CDATA[<!DOCTYPE html>
<!--[if IE 7 ]><html id="ie7" lang="en"><![endif]-->
<!--[if IE 8 ]><html id="ie8" lang="en"><![endif]-->
<!--[if IE 9 ]><html id="ie9" lang="en"><![endif]-->
<!-- BEGIN html -->
<html lang="en">
 
<!-- BEGIN head -->
<head>
 
<!-- Meta Tags -->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11" />
 
<!-- Title -->
<title>$1</title>
 
<!-- Bootstrap -->
<link rel="stylesheet" href="css/bootstrap.css" >
<link rel="stylesheet" href="css/font-awesome.min.css" >
<link rel="stylesheet" href="css/style.css" >
<link rel="stylesheet" href="css/flexslider.css" type="text/css">
 
<!--[if lt IE 8]><link rel="stylesheet" href="css/font-awesome-ie7.min.css" ><![endif]-->
<!--[if lt IE 9]><script src="js/html5.js"></script><![endif]-->
 
</head>
<!-- END head -->
 
<body>
$0
</body>
 
<script src="js/jquery-1.9.1.min.js" type="text/javascript"></script>
<!-- Bootstrap -->
<script src="js/bootstrap.min.js"></script>
<script src="js/twitter-bootstrap-hover-dropdown.js?view=1"></script>
<script src="js/jquery.flexslider.js"></script>
 
<!-- Custom -->
<script src="js/custom.js"></script>
<script>
</script>
 
</body>
</html>]]></content>
<!-- Optional: Set a tabTrigger to define how to trigger the snippet -->
<tabTrigger>html5</tabTrigger>
<!-- Optional: Set a scope to limit where the snippet will trigger -->
<scope>source.html</scope>
</snippet>

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.