public
Created

about my answer to stackoverflow "pip: dealing with multiple Python versions?" question

  • Download Gist
shell-output
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
$ pip install --upgrade pip
Downloading/unpacking pip
Downloading pip-1.2.1.tar.gz (102Kb): 102Kb downloaded
Running setup.py egg_info for package pip
warning: no files found matching '*.html' under directory 'docs'
warning: no previously-included files matching '*.txt' found under directory 'docs/_build'
no previously-included directories found matching 'docs/_build/_sources'
Installing collected packages: pip
Found existing installation: pip 1.0.2
Uninstalling pip:
Successfully uninstalled pip
Running setup.py install for pip
warning: no files found matching '*.html' under directory 'docs'
warning: no previously-included files matching '*.txt' found under directory 'docs/_build'
no previously-included directories found matching 'docs/_build/_sources'
Installing pip script to /Users/hugo/.virtualenvs/stackoverflow/bin
Installing pip-2.7 script to /Users/hugo/.virtualenvs/stackoverflow/bin
Successfully installed pip
Cleaning up...
$ pip --version
pip 1.2.1 from /Users/hugo/.virtualenvs/stackoverflow/lib/python2.7/site-packages (python 2.7)
$ pip-2. # TAB TAB
pip-2.4 pip-2.7
$ which pip-2.7
/Users/hugo/.virtualenvs/stackoverflow/bin/pip-2.7
$ which pip
/Users/hugo/.virtualenvs/stackoverflow/bin/pip
$ which pip-2.4
/Library/Frameworks/Python.framework/Versions/Current/bin/pip-2.4

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.