Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Install YAZ for PHP 7.3
## PHP 7.3
apt update
apt install software-properties-common
apt-add-repository ppa:ondrej/php
apt install yaz libyaz5-dev
apt install php7.3-dev php7.3 php7.3-fpm
pecl channel-update pecl.php.net
pecl install yaz
## Installing '/usr/lib/php/20180731/yaz.so'
## install ok: channel://pecl.php.net/yaz-1.2.3
echo 'extension=yaz.so' > /etc/php/7.3/mods-available/yaz.ini
ln -s /etc/php/7.3/mods-available/yaz.ini /etc/php/7.3/cli/conf.d/20-yaz.ini
ln -s /etc/php/7.3/mods-available/yaz.ini /etc/php/7.3/fpm/conf.d/20-yaz.ini
php -i | grep YAZ
## YAZ Support => enabled
## PHP/YAZ Version => 1.2.3
## YAZ Version => 5.19.2
## Compiled with YAZ version => 5.19.2
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.