Skip to content

Instantly share code, notes, and snippets.

@isaacs isaacs/gist:5239176
Created Mar 25, 2013

Embed
What would you like to do?
$ npm install weak
npm http GET https://registry.npmjs.org/weak
npm http 304 https://registry.npmjs.org/weak
npm http GET https://registry.npmjs.org/bindings
npm http 304 https://registry.npmjs.org/bindings
> weak@0.2.1 install /Users/isaacs/dev/js/lru-cache/node_modules/weak
> node-gyp rebuild
CXX(target) Release/obj.target/weakref/src/weakref.o
../src/weakref.cc: In function ‘bool<unnamed>::IsDead(v8::Handle<v8::Object>)’:
../src/weakref.cc:40: error: ‘class v8::Object’ has no member named ‘GetPointerFromInternalField’
../src/weakref.cc: In function ‘v8::Handle<v8::Object><unnamed>::Unwrap(v8::Handle<v8::Object>)’:
../src/weakref.cc:48: error: ‘class v8::Object’ has no member named ‘GetPointerFromInternalField’
../src/weakref.cc: In function ‘v8::Handle<v8::Array><unnamed>::GetCallbacks(v8::Handle<v8::Object>)’:
../src/weakref.cc:54: error: ‘class v8::Object’ has no member named ‘GetPointerFromInternalField’
../src/weakref.cc: In function ‘void<unnamed>::TargetCallback(v8::Persistent<v8::Value>, void*)’:
../src/weakref.cc:140: warning: ‘IsNearDeath’ is deprecated (declared at /Users/isaacs/dev/js/node-master/deps/v8/include/v8.h:465)
../src/weakref.cc:162: error: ‘class v8::Object’ has no member named ‘SetPointerInInternalField’
../src/weakref.cc:163: warning: ‘Dispose’ is deprecated (declared at /Users/isaacs/dev/js/node-master/deps/v8/include/v8.h:4502)
../src/weakref.cc:165: warning: ‘Dispose’ is deprecated (declared at /Users/isaacs/dev/js/node-master/deps/v8/include/v8.h:4502)
../src/weakref.cc:167: warning: ‘Dispose’ is deprecated (declared at /Users/isaacs/dev/js/node-master/deps/v8/include/v8.h:4502)
../src/weakref.cc: In function ‘v8::Handle<v8::Value><unnamed>::Create(const v8::Arguments&)’:
../src/weakref.cc:184: warning: ‘New’ is deprecated (declared at /Users/isaacs/dev/js/node-master/deps/v8/include/v8.h:4438)
../src/weakref.cc:185: warning: ‘New’ is deprecated (declared at /Users/isaacs/dev/js/node-master/deps/v8/include/v8.h:4438)
../src/weakref.cc:187: warning: ‘New’ is deprecated (declared at /Users/isaacs/dev/js/node-master/deps/v8/include/v8.h:4438)
../src/weakref.cc:188: error: ‘class v8::Object’ has no member named ‘SetPointerInInternalField’
../src/weakref.cc:190: warning: ‘MakeWeak’ is deprecated (declared at /Users/isaacs/dev/js/node-master/deps/v8/include/v8.h:4519)
../src/weakref.cc: In function ‘v8::Handle<v8::Value><unnamed>::IsNearDeath(const v8::Arguments&)’:
../src/weakref.cc:238: error: ‘class v8::Object’ has no member named ‘GetPointerFromInternalField’
../src/weakref.cc:241: warning: ‘IsNearDeath’ is deprecated (declared at /Users/isaacs/dev/js/node-master/deps/v8/include/v8.h:4470)
../src/weakref.cc: In function ‘void<unnamed>::Initialize(v8::Handle<v8::Object>)’:
../src/weakref.cc:290: warning: ‘New’ is deprecated (declared at /Users/isaacs/dev/js/node-master/deps/v8/include/v8.h:4438)
make: *** [Release/obj.target/weakref/src/weakref.o] Error 1
gyp ERR! build error
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack at ChildProcess.onExit (/Users/isaacs/dev/js/npm/node_modules/node-gyp/lib/build.js:256:23)
gyp ERR! stack at ChildProcess.EventEmitter.emit (events.js:98:17)
gyp ERR! stack at Process.ChildProcess._handle.onexit (child_process.js:754:12)
gyp ERR! System Darwin 11.4.2
gyp ERR! command "node" "/Users/isaacs/dev/js/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /Users/isaacs/dev/js/lru-cache/node_modules/weak
gyp ERR! node -v v0.10.2-pre
gyp ERR! node-gyp -v v0.9.2
gyp ERR! not ok
npm ERR! weak@0.2.1 install: `node-gyp rebuild`
npm ERR! `sh "-c" "node-gyp rebuild"` failed with 1
npm ERR!
npm ERR! Failed at the weak@0.2.1 install script.
npm ERR! This is most likely a problem with the weak package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls weak
npm ERR! There is likely additional logging output above.
npm ERR! System Darwin 11.4.2
npm ERR! command "node" "/Users/isaacs/bin/npm" "install" "weak"
npm ERR! cwd /Users/isaacs/dev/js/lru-cache
npm ERR! node -v v0.10.2-pre
npm ERR! npm -v 1.2.15
npm ERR! code ELIFECYCLE
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /Users/isaacs/dev/js/lru-cache/npm-debug.log
npm ERR! not ok code 0
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.