Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Couto
18:41 is just me, or packages that declare hapi >= 8.0.0 as a peerDependency, can't be installed with hapi@8.0.0-rcX ??
18:41 stongo left the room (quit: Quit: Leaving.).
Couto
18:41 e.g: good@5.0.0-rc1
arb
18:42 what varion of node are you using
Couto
18:42 v0.10.33
18:42 npm 2.1.9
arb
18:42 what version of npm
18:42 ah
18:43 npm 2 changed the way RCs work
18:43 they aren't included in 8.x.x
18:43 they were in 1, but not in 2
Couto
18:44 oh man... i gotta hate those little things
arb
18:44 https://github.com/npm/npm/blob/master/CHANGELOG.md#v200-2014-09-12
Couto
18:44 but thanks for the notice :)
arb
18:44 if you install hapi manually, that should clear that error
18:45 this issue has come up a billion times so…
18:45 it's pretty fast to diagnose at this point :-P
18:46 jaw187 left the room (quit: Remote host closed the connection).
Couto
18:48 true, but installing manually is a pain =P
18:48 and reverting npm to the 1.x series is also a pain since some packages with underscore as dependency
18:48 are troublesome
18:48 =P
18:48 oh well manually it is then
@Couto

This comment has been minimized.

Copy link

@Couto Couto commented Jan 27, 2015

ahah! Weird to see this here :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment