Instantly share code, notes, and snippets.

View fakeworld_io_Gemfile
As of June 8, 2018:
source 'https://rubygems.org' do
gem 'rails', '5.1.6'
gem 'mysql2', '0.4.4'
gem 'puma', '~> 3.7'
gem 'sass-rails', '~> 5.0'
View devise-email-with-layout
# Adding CSS to Devise HTML emails
# Rails 4.1+
# ------------
###
### Preview of initial Devise emails from generator:
###
# In spec/mailers/previews/devise_mailer_preview.rb
View .rubocop.yml files
# rubocop config files for small Rails4/Ruby2 project
# blog post: http://joanswork.com/rubocop-rails-getting-started/
# .rubocop.yml
AllCops:
Include:
- Rakefile
- config.ru
Exclude:
View database.yml.mysql
# MySQL. Versions 4.1 and 5.0 are recommended.
#
# Install the MYSQL driver
# gem install mysql2
#
# Ensure the MySQL gem is defined in your Gemfile
# gem 'mysql2'
#
# And be sure to use new-style password hashing:
# http://dev.mysql.com/doc/refman/5.0/en/old-client.html
View rails-header-with-turbolinks