Skip to content

Instantly share code, notes, and snippets.

@jhilker98
Last active August 2, 2023 18:00
  • Star 0 You must be signed in to star a gist
  • Fork 0 You must be signed in to fork a gist
Star You must be signed in to star a gist
Save jhilker98/954a6440e6e86d179b9251704dcec3d8 to your computer and use it in GitHub Desktop.

Installation

$ sudo -E env "PATH=$PATH" npx playwright install-deps

Installing dependencies...
Hit:1 http://security.ubuntu.com/ubuntu jammy-security InRelease
Get:2 https://dl.google.com/linux/chrome/deb stable InRelease [1825 B]
Hit:3 http://archive.ubuntu.com/ubuntu jammy InRelease
Hit:4 http://archive.ubuntu.com/ubuntu jammy-updates InRelease
Hit:5 http://archive.ubuntu.com/ubuntu jammy-backports InRelease
Get:6 https://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1081 B]
Fetched 2906 B in 1s (2126 B/s)
Error: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program org.freedesktop.PackageKit: Permission denied
Reading package lists... Done
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
fonts-freefont-ttf is already the newest version (20120503-10build1).
fonts-liberation is already the newest version (1:1.07.4-11).
libasound2 is already the newest version (1.2.6.1-1ubuntu1).
libatk-bridge2.0-0 is already the newest version (2.38.0-3).
libatk1.0-0 is already the newest version (2.36.0-3build1).
libatspi2.0-0 is already the newest version (2.44.0-3).
libcairo-gobject2 is already the newest version (1.16.0-5ubuntu2).
libcairo2 is already the newest version (1.16.0-5ubuntu2).
libdbus-glib-1-2 is already the newest version (0.112-2build1).
libegl1 is already the newest version (1.4.0-1).
libenchant-2-2 is already the newest version (2.3.2-1ubuntu2).
libepoxy0 is already the newest version (1.5.10-1).
libevdev2 is already the newest version (1.12.1+dfsg-1).
libevent-2.1-7 is already the newest version (2.1.12-stable-1build3).
libfontconfig1 is already the newest version (2.13.1-4.2ubuntu5).
libgles2 is already the newest version (1.4.0-1).
libglx0 is already the newest version (1.4.0-1).
libgudev-1.0-0 is already the newest version (1:237-2build1).
libhyphen0 is already the newest version (2.8.8-7build2).
libicu70 is already the newest version (70.1-2).
libjpeg-turbo8 is already the newest version (2.1.2-0ubuntu1).
liblcms2-2 is already the newest version (2.12~rc1-2build2).
libmanette-0.2-0 is already the newest version (0.2.6-3build1).
libnspr4 is already the newest version (2:4.32-3build1).
libopengl0 is already the newest version (1.4.0-1).
libopenjp2-7 is already the newest version (2.4.0-6).
libopus0 is already the newest version (1.3.1-0.1build2).
libpng16-16 is already the newest version (1.6.37-3build5).
libproxy1v5 is already the newest version (0.4.17-2).
libsecret-1-0 is already the newest version (0.20.5-2).
libsoup2.4-1 is already the newest version (2.74.2-3).
libwoff1 is already the newest version (1.0.2-1build4).
libxcb-shm0 is already the newest version (1.14-3ubuntu3).
libxcb1 is already the newest version (1.14-3ubuntu3).
libxcomposite1 is already the newest version (1:0.4.5-1build2).
libxcursor1 is already the newest version (1:1.2.0-2build4).
libxdamage1 is already the newest version (1:1.1.5-2build2).
libxext6 is already the newest version (2:1.3.4-1build1).
libxfixes3 is already the newest version (1:6.0.0-1).
libxi6 is already the newest version (2:1.8-1build1).
libxkbcommon0 is already the newest version (1.4.0-1).
libxrandr2 is already the newest version (2:1.5.2-1build1).
libxrender1 is already the newest version (1:0.9.10-1build4).
libxtst6 is already the newest version (2:1.2.3-1build4).
xfonts-scalable is already the newest version (1:1.0.3-1.2ubuntu1).
fonts-ipafont-gothic is already the newest version (00303-21ubuntu1).
fonts-tlwg-loma-otf is already the newest version (1:0.7.3-1).
fonts-unifont is already the newest version (1:14.0.01-1).
fonts-wqy-zenhei is already the newest version (0.9.45-8).
libffi7 is already the newest version (3.3-5ubuntu1).
libx264-163 is already the newest version (2:0.163.3060+git5db6aa6-2build1).
xfonts-cyrillic is already the newest version (1:1.0.5).
fonts-noto-color-emoji is already the newest version (2.038-0ubuntu1).
libatomic1 is already the newest version (12.3.0-1ubuntu1~22.04).
libcups2 is already the newest version (2.4.1op1-1ubuntu4.4).
libdbus-1-3 is already the newest version (1.12.20-2ubuntu4.1).
libdrm2 is already the newest version (2.4.113-2~ubuntu0.22.04.1).
libfreetype6 is already the newest version (2.11.1+dfsg-1ubuntu0.2).
libgbm1 is already the newest version (22.2.5-0ubuntu0.1~22.04.3).
libgdk-pixbuf-2.0-0 is already the newest version (2.42.8+dfsg-1ubuntu0.2).
libglib2.0-0 is already the newest version (2.72.4-0ubuntu2.2).
libgstreamer1.0-0 is already the newest version (1.20.3-0ubuntu1).
libgtk-3-0 is already the newest version (3.24.33-1ubuntu2).
libharfbuzz-icu0 is already the newest version (2.7.4-1ubuntu3.1).
libharfbuzz0b is already the newest version (2.7.4-1ubuntu3.1).
libnotify4 is already the newest version (0.7.9-3ubuntu5.22.04.1).
libnss3 is already the newest version (2:3.68.2-0ubuntu1.2).
libpango-1.0-0 is already the newest version (1.50.6+ds-2ubuntu1).
libpangocairo-1.0-0 is already the newest version (1.50.6+ds-2ubuntu1).
libwayland-client0 is already the newest version (1.20.0-1ubuntu0.1).
libwayland-egl1 is already the newest version (1.20.0-1ubuntu0.1).
libwayland-server0 is already the newest version (1.20.0-1ubuntu0.1).
libwebpdemux2 is already the newest version (1.2.2-2ubuntu0.22.04.1).
libx11-6 is already the newest version (2:1.7.5-1ubuntu0.2).
libx11-xcb1 is already the newest version (2:1.7.5-1ubuntu0.2).
libxml2 is already the newest version (2.9.13+dfsg-1ubuntu0.3).
libxslt1.1 is already the newest version (1.1.34-4ubuntu0.22.04.1).
ffmpeg is already the newest version (7:4.4.2-0ubuntu0.22.04.1).
gstreamer1.0-libav is already the newest version (1.20.3-0ubuntu1).
gstreamer1.0-plugins-bad is already the newest version (1.20.3-0ubuntu1).
xvfb is already the newest version (2:21.1.4-2ubuntu1.7~22.04.1).
gstreamer1.0-plugins-base is already the newest version (1.20.1-1ubuntu0.1).
gstreamer1.0-plugins-good is already the newest version (1.20.3-0ubuntu1.1).
libgstreamer-gl1.0-0 is already the newest version (1.20.1-1ubuntu0.1).
libgstreamer-plugins-base1.0-0 is already the newest version (1.20.1-1ubuntu0.1).
The following packages were automatically installed and are no longer required:
  emacs-bin-common emacs-common emacs-el emacs-gtk libgif7 libm17n-0 libotf1 m17n-db wmdocker
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment