Skip to content

Instantly share code, notes, and snippets.

Avatar

Jimmy Huang jimyhuang

View GitHub Profile
View landsat5
#!/usr/bin/env python
# -.- coding: utf-8 -.-
"""
Usage:
landsat5.py <username> <password> <landsat5-filename>
Requirements:
beautifulsoup4==4.0.5
requests==2.0.1
@jimyhuang
jimyhuang / gist:9387233
Last active Aug 29, 2015 — forked from futuremill-ltd/gist:2318876
modified to 545
View gist:9387233
# From a fresh install of squeeze
apt-get install ruby rubygems # Need ruby to use fpm
gem1.8 install fpm --no-ri --no-rdoc
apt-get install build-essential openssl libreadline6 libreadline6-dev zlib1g zlib1g-dev libssl-dev ncurses-dev libyaml-dev
wget ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-p392.tar.gz
tar -zxvf ruby-1.9.3-p392.tar.gz
cd ruby-1.9.3-p392
rm -rf /tmp/ruby193