Skip to content

Instantly share code, notes, and snippets.

@joulgs
Last active June 17, 2024 13:17
Show Gist options
  • Save joulgs/c8a85bb462f48ffc2044dd878ecaa786 to your computer and use it in GitHub Desktop.
Save joulgs/c8a85bb462f48ffc2044dd878ecaa786 to your computer and use it in GitHub Desktop.
How install libssl1.1 on ubuntu 22.04
wget http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.1_1.1.0g-2ubuntu4_amd64.deb
sudo dpkg -i libssl1.1_1.1.0g-2ubuntu4_amd64.deb
@john-julius
Copy link

Thanks

@JoaoMarcelo22
Copy link

Thanks boy

@lightydo
Copy link

Thank you

@Dex-Electronics
Copy link

Thank you!

@proxlu
Copy link

proxlu commented Dec 28, 2023

To be clear, this is for amd64 compatible systems; you'll need to install the arm package if you're on something like an ARM Mac or a RasbperyPi.

Did you have any links to a ARM version of this package?
Edit: find the solution by myself. Installed this version and works like a charm on a RK35588s ARM64 CPU. Think also on Raspbery pi.
http://ports.ubuntu.com/pool/main/o/openssl/libssl1.1_1.1.1f-1ubuntu2_arm64.deb

thank you it worked for me on Kria KV260

Thanks

@radeeyate
Copy link

thank you!

@laidaJ
Copy link

laidaJ commented Feb 4, 2024

Thanks!

@elimarp
Copy link

elimarp commented Feb 4, 2024

GOAT

@mashunterbd
Copy link

To be clear, this is for amd64 compatible systems; you'll need to install the arm package if you're on something like an ARM Mac or a RasbperyPi.

Did you have any links to a ARM version of this package?

Edit: find the solution by myself. Installed this version and works like a charm on a RK35588s ARM64 CPU. Think also on Raspbery pi.

http://ports.ubuntu.com/pool/main/o/openssl/libssl1.1_1.1.1f-1ubuntu2_arm64.deb

Thank you 😊, This solved my problem.

@surajexroasia
Copy link

thanks helped a lot

@jimmyginga
Copy link

Thank you!!

@Ussf-nassrallah
Copy link

Thank you

@Clubnode
Copy link

Good lord, first result on Google, thanks!

@JackyCZJ
Copy link

To be clear, this is for amd64 compatible systems; you'll need to install the arm package if you're on something like an ARM Mac or a RasbperyPi.

Did you have any links to a ARM version of this package?

Edit: find the solution by myself. Installed this version and works like a charm on a RK35588s ARM64 CPU. Think also on Raspbery pi.

http://ports.ubuntu.com/pool/main/o/openssl/libssl1.1_1.1.1f-1ubuntu2_arm64.deb

Thank you!

@geofflangenderfer
Copy link

thank you!

@Moticob
Copy link

Moticob commented Mar 25, 2024

Thank you!

@fernandoreycaires
Copy link

tanks a lot

@Lionze0
Copy link

Lionze0 commented Apr 5, 2024

im having this issue with libssl1.1
HOW CAN I FIX IT?/????? ADD me in discord lionze0 help me is improtant

@ajithsuresh11
Copy link

THank You!

@hmthang96
Copy link

Thank you.
You save me a lot of time about Azure Speech to text on Ubuntu and Wsl

@Amaya217
Copy link

thanks

@yuukiAme
Copy link

Great. I needed this for Mongodb. Thank you so much.

@dev188007
Copy link

Thank you. It works.

@abhishek-singh-manhas
Copy link

Thanks! dear.

@luo1324574369
Copy link

thank you

@josueicq24
Copy link

Great work!!

@okante
Copy link

okante commented May 15, 2024

great work. thanks

@xzeed93
Copy link

xzeed93 commented May 26, 2024

Thanks!

@retlAairtlA
Copy link

thanks

@DarkmatterUAE
Copy link

While it's always possible to install libssl1.1 if you needed it, note that OpenSSL 1.1 is no longer being maintained by OpenSSL dev. and can contain unfixed security vulnerability. If you're a dev, please consider migrating your program to OpenSSL 3. Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment