Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558 build error log
$ nix eval '(import <nixos-unstable> {}).lttng-ust.outPath'
"/nix/store/6ha8bwciirg7zv9cbaw0170dq3b3j6bf-lttng-ust-2.13.0"
$ ls -l /nix/store/6ha8bwciirg7zv9cbaw0170dq3b3j6bf-lttng-ust-2.13.0/lib
.r-xr-xr-x 1.1k root 31 Dec 1969 liblttng-ust-common.la
lrwxrwxrwx 28 root 31 Dec 1969 liblttng-ust-common.so -> liblttng-ust-common.so.1.0.0
lrwxrwxrwx 28 root 31 Dec 1969 liblttng-ust-common.so.1 -> liblttng-ust-common.so.1.0.0
.r-xr-xr-x 84k root 31 Dec 1969 liblttng-ust-common.so.1.0.0
.r-xr-xr-x 1.0k root 31 Dec 1969 liblttng-ust-ctl.la
lrwxrwxrwx 25 root 31 Dec 1969 liblttng-ust-ctl.so -> liblttng-ust-ctl.so.5.0.0
lrwxrwxrwx 25 root 31 Dec 1969 liblttng-ust-ctl.so.5 -> liblttng-ust-ctl.so.5.0.0
.r-xr-xr-x 303k root 31 Dec 1969 liblttng-ust-ctl.so.5.0.0
.r-xr-xr-x 1.1k root 31 Dec 1969 liblttng-ust-cyg-profile-fast.la
lrwxrwxrwx 38 root 31 Dec 1969 liblttng-ust-cyg-profile-fast.so -> liblttng-ust-cyg-profile-fast.so.1.0.0
lrwxrwxrwx 38 root 31 Dec 1969 liblttng-ust-cyg-profile-fast.so.1 -> liblttng-ust-cyg-profile-fast.so.1.0.0
.r-xr-xr-x 25k root 31 Dec 1969 liblttng-ust-cyg-profile-fast.so.1.0.0
.r-xr-xr-x 1.1k root 31 Dec 1969 liblttng-ust-cyg-profile.la
lrwxrwxrwx 33 root 31 Dec 1969 liblttng-ust-cyg-profile.so -> liblttng-ust-cyg-profile.so.1.0.0
lrwxrwxrwx 33 root 31 Dec 1969 liblttng-ust-cyg-profile.so.1 -> liblttng-ust-cyg-profile.so.1.0.0
.r-xr-xr-x 25k root 31 Dec 1969 liblttng-ust-cyg-profile.so.1.0.0
.r-xr-xr-x 1.0k root 31 Dec 1969 liblttng-ust-dl.la
lrwxrwxrwx 24 root 31 Dec 1969 liblttng-ust-dl.so -> liblttng-ust-dl.so.1.0.0
lrwxrwxrwx 24 root 31 Dec 1969 liblttng-ust-dl.so.1 -> liblttng-ust-dl.so.1.0.0
.r-xr-xr-x 88k root 31 Dec 1969 liblttng-ust-dl.so.1.0.0
.r-xr-xr-x 1.0k root 31 Dec 1969 liblttng-ust-fd.la
lrwxrwxrwx 24 root 31 Dec 1969 liblttng-ust-fd.so -> liblttng-ust-fd.so.1.0.0
lrwxrwxrwx 24 root 31 Dec 1969 liblttng-ust-fd.so.1 -> liblttng-ust-fd.so.1.0.0
.r-xr-xr-x 58k root 31 Dec 1969 liblttng-ust-fd.so.1.0.0
.r-xr-xr-x 1.0k root 31 Dec 1969 liblttng-ust-fork.la
lrwxrwxrwx 26 root 31 Dec 1969 liblttng-ust-fork.so -> liblttng-ust-fork.so.1.0.0
lrwxrwxrwx 26 root 31 Dec 1969 liblttng-ust-fork.so.1 -> liblttng-ust-fork.so.1.0.0
.r-xr-xr-x 17k root 31 Dec 1969 liblttng-ust-fork.so.1.0.0
.r-xr-xr-x 1.1k root 31 Dec 1969 liblttng-ust-libc-wrapper.la
lrwxrwxrwx 34 root 31 Dec 1969 liblttng-ust-libc-wrapper.so -> liblttng-ust-libc-wrapper.so.1.0.0
lrwxrwxrwx 34 root 31 Dec 1969 liblttng-ust-libc-wrapper.so.1 -> liblttng-ust-libc-wrapper.so.1.0.0
.r-xr-xr-x 43k root 31 Dec 1969 liblttng-ust-libc-wrapper.so.1.0.0
.r-xr-xr-x 1.1k root 31 Dec 1969 liblttng-ust-pthread-wrapper.la
lrwxrwxrwx 37 root 31 Dec 1969 liblttng-ust-pthread-wrapper.so -> liblttng-ust-pthread-wrapper.so.1.0.0
lrwxrwxrwx 37 root 31 Dec 1969 liblttng-ust-pthread-wrapper.so.1 -> liblttng-ust-pthread-wrapper.so.1.0.0
.r-xr-xr-x 36k root 31 Dec 1969 liblttng-ust-pthread-wrapper.so.1.0.0
.r-xr-xr-x 1.1k root 31 Dec 1969 liblttng-ust-tracepoint.la
lrwxrwxrwx 32 root 31 Dec 1969 liblttng-ust-tracepoint.so -> liblttng-ust-tracepoint.so.1.0.0
lrwxrwxrwx 32 root 31 Dec 1969 liblttng-ust-tracepoint.so.1 -> liblttng-ust-tracepoint.so.1.0.0
.r-xr-xr-x 83k root 31 Dec 1969 liblttng-ust-tracepoint.so.1.0.0
.r-xr-xr-x 1.0k root 31 Dec 1969 liblttng-ust.la
lrwxrwxrwx 21 root 31 Dec 1969 liblttng-ust.so -> liblttng-ust.so.1.0.0
lrwxrwxrwx 21 root 31 Dec 1969 liblttng-ust.so.1 -> liblttng-ust.so.1.0.0
.r-xr-xr-x 633k root 31 Dec 1969 liblttng-ust.so.1.0.0
dr-xr-xr-x - root 31 Dec 1969 pkgconfig
$ nix build -L '(import <nixos-unstable> {}).vscode-extensions.ms-python.python'
vscode-extension-ms-python-python> unpacking sources
vscode-extension-ms-python-python> unpacking source archive /nix/store/lxcn27jsgx7c5pcqw4m5lyz39caqj6hx-ms-python-python.zip
vscode-extension-ms-python-python> source root is extension
vscode-extension-ms-python-python> setting SOURCE_DATE_EPOCH to timestamp 1620673574 of file extension/README.md
vscode-extension-ms-python-python> patching sources
vscode-extension-ms-python-python> configuring
vscode-extension-ms-python-python> building
vscode-extension-ms-python-python> installing
vscode-extension-ms-python-python> post-installation fixup
vscode-extension-ms-python-python> patching script interpreter paths in /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558
vscode-extension-ms-python-python> checking for references to /build/ in /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558...
vscode-extension-ms-python-python> automatically fixing dependencies for ELF files
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/pythonFiles/lib/python/debugpy/_vendored/pydevd/pydevd_attach_to_process/attach_linux_amd64.so
vscode-extension-ms-python-python> libstdc++.so.6 -> found: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib/libstdc++.so.6
vscode-extension-ms-python-python> setting RPATH to: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/pythonFiles/lib/python/debugpy/_vendored/pydevd/pydevd_attach_to_process/attach_linux_x86.so
vscode-extension-ms-python-python> libstdc++.so.6 -> not found!
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/pythonFiles/lib/python/debugpy/_vendored/pydevd/_pydevd_frame_eval/pydevd_frame_evaluator.cpython-38-x86_64-linux-gnu.so
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/pythonFiles/lib/python/debugpy/_vendored/pydevd/_pydevd_frame_eval/pydevd_frame_evaluator.cpython-38-i386-linux-gnu.so
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/pythonFiles/lib/python/debugpy/_vendored/pydevd/_pydevd_bundle/pydevd_cython.cpython-38-i386-linux-gnu.so
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/pythonFiles/lib/python/debugpy/_vendored/pydevd/_pydevd_bundle/pydevd_cython.cpython-38-x86_64-linux-gnu.so
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/libhostfxr.so
vscode-extension-ms-python-python> libstdc++.so.6 -> found: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib/libstdc++.so.6
vscode-extension-ms-python-python> setting RPATH to: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/System.IO.Compression.Native.so
vscode-extension-ms-python-python> libz.so.1 -> found: /nix/store/90f5gc3aqlg1ki5rc3dq3cgrk4ia9rqy-zlib-1.2.11/lib/libz.so.1
vscode-extension-ms-python-python> setting RPATH to: /nix/store/90f5gc3aqlg1ki5rc3dq3cgrk4ia9rqy-zlib-1.2.11/lib
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/libmscordaccore.so
vscode-extension-ms-python-python> libstdc++.so.6 -> found: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib/libstdc++.so.6
vscode-extension-ms-python-python> setting RPATH to: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/libcoreclrtraceptprovider.so
vscode-extension-ms-python-python> liblttng-ust.so.0 -> not found!
vscode-extension-ms-python-python> libstdc++.so.6 -> found: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib/libstdc++.so.6
vscode-extension-ms-python-python> setting RPATH to: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/System.Security.Cryptography.Native.OpenSsl.so
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/System.Native.so
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/libhostpolicy.so
vscode-extension-ms-python-python> libstdc++.so.6 -> found: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib/libstdc++.so.6
vscode-extension-ms-python-python> setting RPATH to: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/createdump
vscode-extension-ms-python-python> libmscordaccore.so -> found: /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/libmscordaccore.so
vscode-extension-ms-python-python> libstdc++.so.6 -> found: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib/libstdc++.so.6
vscode-extension-ms-python-python> setting RPATH to: /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30:/nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/System.Globalization.Native.so
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/libclrjit.so
vscode-extension-ms-python-python> libstdc++.so.6 -> found: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib/libstdc++.so.6
vscode-extension-ms-python-python> setting RPATH to: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/System.Net.Security.Native.so
vscode-extension-ms-python-python> libgssapi_krb5.so.2 -> found: /nix/store/fbih4vd2am0rcgrk2vhw3vpb2vz1ann8-libkrb5-1.18/lib/libgssapi_krb5.so.2
vscode-extension-ms-python-python> setting RPATH to: /nix/store/fbih4vd2am0rcgrk2vhw3vpb2vz1ann8-libkrb5-1.18/lib
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/System.Net.Http.Native.so
vscode-extension-ms-python-python> libcurl.so.4 -> found: /nix/store/idzv23l0syxdmq4nrpz2qim5y3v9i0na-curl-7.76.1/lib/libcurl.so.4
vscode-extension-ms-python-python> setting RPATH to: /nix/store/idzv23l0syxdmq4nrpz2qim5y3v9i0na-curl-7.76.1/lib
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/libcoreclr.so
vscode-extension-ms-python-python> libstdc++.so.6 -> found: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib/libstdc++.so.6
vscode-extension-ms-python-python> setting RPATH to: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/libmscordbi.so
vscode-extension-ms-python-python> libmscordaccore.so -> found: /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/libmscordaccore.so
vscode-extension-ms-python-python> libstdc++.so.6 -> found: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib/libstdc++.so.6
vscode-extension-ms-python-python> setting RPATH to: /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30:/nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/libdbgshim.so
vscode-extension-ms-python-python> libstdc++.so.6 -> found: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib/libstdc++.so.6
vscode-extension-ms-python-python> setting RPATH to: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib
vscode-extension-ms-python-python> searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/Microsoft.Python.LanguageServer
vscode-extension-ms-python-python> libstdc++.so.6 -> found: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib/libstdc++.so.6
vscode-extension-ms-python-python> setting RPATH to: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib
vscode-extension-ms-python-python> autoPatchelfHook could not satisfy dependency libstdc++.so.6 wanted by /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/pythonFiles/lib/python/debugpy/_vendored/pydevd/pydevd_attach_to_process/attach_linux_x86.so
vscode-extension-ms-python-python> autoPatchelfHook could not satisfy dependency liblttng-ust.so.0 wanted by /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/libcoreclrtraceptprovider.so
vscode-extension-ms-python-python> Add the missing dependencies to the build inputs or set autoPatchelfIgnoreMissingDeps=true
builder for '/nix/store/vhgivsg9r1yw00fd5nhlas7hzn5d53nh-vscode-extension-ms-python-python-2021.5.829140558.drv' failed with exit code 1; last 10 log lines:
setting RPATH to: /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30:/nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib
searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/libdbgshim.so
libstdc++.so.6 -> found: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib/libstdc++.so.6
setting RPATH to: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib
searching for dependencies of /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/Microsoft.Python.LanguageServer
libstdc++.so.6 -> found: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib/libstdc++.so.6
setting RPATH to: /nix/store/bg7pq2k5i1ylpq5czsh7zym5nijpj30q-gcc-10.3.0-lib/lib
autoPatchelfHook could not satisfy dependency libstdc++.so.6 wanted by /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/pythonFiles/lib/python/debugpy/_vendored/pydevd/pydevd_attach_to_process/attach_linux_x86.so
autoPatchelfHook could not satisfy dependency liblttng-ust.so.0 wanted by /nix/store/2r606hyvl5w9miwqx1kxz8h8paaiy4fp-vscode-extension-ms-python-python-2021.5.829140558/share/vscode/extensions/ms-python.python/languageServer.0.5.30/libcoreclrtraceptprovider.so
Add the missing dependencies to the build inputs or set autoPatchelfIgnoreMissingDeps=true
[0 built (1 failed), 10 copied (97.0 MiB), 25.1 MiB DL]
error: build of '/nix/store/vhgivsg9r1yw00fd5nhlas7hzn5d53nh-vscode-extension-ms-python-python-2021.5.829140558.drv' failed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment