Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
bash < <(curl -s http://puppet.spreecommerce.com:5000/install?fqdn=xxx.mysite.com\&digest=9c84e8370316f24b7189bb9abb02b6af )
**********************************************************
* Spree Stack Installer *
**********************************************************
WARNING
This installer should only be run on dedicated Spree servers.
It may affect other applications or configuration files that
are already in use on this machine.
To cancel press [CTRL+C] now (continuing in 1 seconds)
bash: line 26: /etc/hostname: Permission denied
hostname: the specified hostname is invalid
bash: line 31: /etc/hosts: Permission denied
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
--2014-01-12 18:11:37-- http://apt.puppetlabs.com/puppetlabs-release-precise.deb
Resolving apt.puppetlabs.com (apt.puppetlabs.com)... 2600:3c00::f03c:91ff:fe69:6bf0, 198.58.114.168
Connecting to apt.puppetlabs.com (apt.puppetlabs.com)|2600:3c00::f03c:91ff:fe69:6bf0|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3430 (3.3K) [application/x-debian-package]
Saving to: `puppetlabs-release-precise.deb'
100%[=============================================================================>] 3,430 --.-K/s in 0s
2014-01-12 18:11:37 (198 MB/s) - `puppetlabs-release-precise.deb' saved [3430/3430]
dpkg: error: requested operation requires superuser privilege
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
dpkg: error: requested operation requires superuser privilege
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
mkdir: cannot create directory `/var/lib/puppet': Permission denied
mkdir: cannot create directory `/var/lib/puppet': Permission denied
/var/lib/puppet/ssl/certs/ca.pem: No such file or directory
/var/lib/puppet/ssl/certs/xxx.mysite.com.pem: No such file or directory
/var/lib/puppet/ssl/private_keys/xxx.mysite.com.pem: No such file or directory
chown: invalid user: `puppet:root'
chmod: cannot access `/var/lib/puppet/ssl/certs/': No such file or directory
chown: invalid user: `puppet:root'
chmod: cannot access `/var/lib/puppet/ssl/private_keys/': No such file or directory
bash: line 54: puppet: command not found
bash: line 55: puppet: command not found
bash: line 56: puppet: command not found
webm@localhost:~$ sudo bash < <(curl -s http://puppet.spreecommerce.com:5000/install?fqdn=xxx.mysite.com\&digest=9c84e8370316f24b7189bb9abb02b6af )
[sudo] password for webm:
**********************************************************
* Spree Stack Installer *
**********************************************************
WARNING
This installer should only be run on dedicated Spree servers.
It may affect other applications or configuration files that
are already in use on this machine.
To cancel press [CTRL+C] now (continuing in 1 seconds)
Hit http://us.archive.ubuntu.com precise Release.gpg
Get:1 http://us.archive.ubuntu.com precise-updates Release.gpg [198 B]
Get:2 http://us.archive.ubuntu.com precise-backports Release.gpg [198 B]
Hit http://us.archive.ubuntu.com precise Release
Get:3 http://us.archive.ubuntu.com precise-updates Release [49.6 kB]
Get:4 http://us.archive.ubuntu.com precise-backports Release [49.6 kB]
Hit http://us.archive.ubuntu.com precise/main Sources
Hit http://us.archive.ubuntu.com precise/restricted Sources
Hit http://us.archive.ubuntu.com precise/universe Sources
Hit http://us.archive.ubuntu.com precise/multiverse Sources
Hit http://us.archive.ubuntu.com precise/main i386 Packages
Hit http://us.archive.ubuntu.com precise/restricted i386 Packages
Hit http://us.archive.ubuntu.com precise/universe i386 Packages
Hit http://us.archive.ubuntu.com precise/multiverse i386 Packages
Hit http://us.archive.ubuntu.com precise/main TranslationIndex
Hit http://us.archive.ubuntu.com precise/multiverse TranslationIndex
Get:5 http://security.ubuntu.com precise-security Release.gpg [198 B]
Hit http://us.archive.ubuntu.com precise/restricted TranslationIndex
Hit http://us.archive.ubuntu.com precise/universe TranslationIndex
Get:6 http://us.archive.ubuntu.com precise-updates/main Sources [444 kB]
Get:7 http://security.ubuntu.com precise-security Release [49.6 kB]
Get:8 http://us.archive.ubuntu.com precise-updates/restricted Sources [7,039 B]
Get:9 http://us.archive.ubuntu.com precise-updates/universe Sources [101 kB]
Get:10 http://us.archive.ubuntu.com precise-updates/multiverse Sources [8,468 B]
Get:11 http://us.archive.ubuntu.com precise-updates/main i386 Packages [764 kB]
Get:12 http://us.archive.ubuntu.com precise-updates/restricted i386 Packages [11.5 kB]
Get:13 http://us.archive.ubuntu.com precise-updates/universe i386 Packages [233 kB]
Get:14 http://us.archive.ubuntu.com precise-updates/multiverse i386 Packages [14.4 kB]
Get:15 http://us.archive.ubuntu.com precise-updates/main TranslationIndex [3,564 B]
Get:16 http://us.archive.ubuntu.com precise-updates/multiverse TranslationIndex [2,605 B]
Get:17 http://us.archive.ubuntu.com precise-updates/restricted TranslationIndex [2,461 B]
Get:18 http://us.archive.ubuntu.com precise-updates/universe TranslationIndex [2,850 B]
Get:19 http://us.archive.ubuntu.com precise-backports/main Sources [4,225 B]
Get:20 http://us.archive.ubuntu.com precise-backports/restricted Sources [14 B]
Get:21 http://us.archive.ubuntu.com precise-backports/universe Sources [36.4 kB]
Get:22 http://us.archive.ubuntu.com precise-backports/multiverse Sources [5,311 B]
Get:23 http://us.archive.ubuntu.com precise-backports/main i386 Packages [4,809 B]
Get:24 http://us.archive.ubuntu.com precise-backports/restricted i386 Packages [14 B]
Get:25 http://us.archive.ubuntu.com precise-backports/universe i386 Packages [37.7 kB]
Get:26 http://us.archive.ubuntu.com precise-backports/multiverse i386 Packages [5,178 B]
Get:27 http://us.archive.ubuntu.com precise-backports/main TranslationIndex [72 B]
Get:28 http://us.archive.ubuntu.com precise-backports/multiverse TranslationIndex [72 B]
Get:29 http://us.archive.ubuntu.com precise-backports/restricted TranslationIndex [70 B]
Get:30 http://us.archive.ubuntu.com precise-backports/universe TranslationIndex [73 B]
Hit http://us.archive.ubuntu.com precise/main Translation-en
Hit http://us.archive.ubuntu.com precise/multiverse Translation-en
Hit http://us.archive.ubuntu.com precise/restricted Translation-en
Hit http://us.archive.ubuntu.com precise/universe Translation-en
Get:31 http://us.archive.ubuntu.com precise-updates/main Translation-en [332 kB]
Get:32 http://us.archive.ubuntu.com precise-updates/multiverse Translation-en [8,293 B]
Get:33 http://us.archive.ubuntu.com precise-updates/restricted Translation-en [2,663 B]
Get:34 http://us.archive.ubuntu.com precise-updates/universe Translation-en [134 kB]
Get:35 http://us.archive.ubuntu.com precise-backports/main Translation-en [4,235 B]
Get:36 http://us.archive.ubuntu.com precise-backports/multiverse Translation-en [4,610 B]
Hit http://us.archive.ubuntu.com precise-backports/restricted Translation-en
Get:37 http://us.archive.ubuntu.com precise-backports/universe Translation-en [27.7 kB]
Get:38 http://security.ubuntu.com precise-security/main Sources [95.4 kB]
Get:39 http://security.ubuntu.com precise-security/restricted Sources [2,494 B]
Get:40 http://security.ubuntu.com precise-security/universe Sources [29.9 kB]
Get:41 http://security.ubuntu.com precise-security/multiverse Sources [1,792 B]
Get:42 http://security.ubuntu.com precise-security/main i386 Packages [375 kB]
Get:43 http://security.ubuntu.com precise-security/restricted i386 Packages [4,620 B]
Get:44 http://security.ubuntu.com precise-security/universe i386 Packages [91.1 kB]
Get:45 http://security.ubuntu.com precise-security/multiverse i386 Packages [2,642 B]
Get:46 http://security.ubuntu.com precise-security/main TranslationIndex [74 B]
Get:47 http://security.ubuntu.com precise-security/multiverse TranslationIndex [72 B]
Get:48 http://security.ubuntu.com precise-security/restricted TranslationIndex [72 B]
Get:49 http://security.ubuntu.com precise-security/universe TranslationIndex [73 B]
Get:50 http://security.ubuntu.com precise-security/main Translation-en [166 kB]
Get:51 http://security.ubuntu.com precise-security/multiverse Translation-en [1,299 B]
Hit http://security.ubuntu.com precise-security/restricted Translation-en
Get:52 http://security.ubuntu.com precise-security/universe Translation-en [54.8 kB]
Fetched 3,176 kB in 4s (775 kB/s)
Reading package lists... Done
--2014-01-12 18:12:10-- http://apt.puppetlabs.com/puppetlabs-release-precise.deb
Resolving apt.puppetlabs.com (apt.puppetlabs.com)... 2600:3c00::f03c:91ff:fe69:6bf0, 198.58.114.168
Connecting to apt.puppetlabs.com (apt.puppetlabs.com)|2600:3c00::f03c:91ff:fe69:6bf0|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3430 (3.3K) [application/x-debian-package]
Saving to: `puppetlabs-release-precise.deb'
100%[=============================================================================>] 3,430 --.-K/s in 0s
2014-01-12 18:12:10 (186 MB/s) - `puppetlabs-release-precise.deb' saved [3430/3430]
Selecting previously unselected package puppetlabs-release.
(Reading database ... 21188 files and directories currently installed.)
Unpacking puppetlabs-release (from puppetlabs-release-precise.deb) ...
Setting up puppetlabs-release (1.0-7) ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 91 not upgraded.
(Reading database ... 21194 files and directories currently installed.)
Preparing to replace puppetlabs-release 1.0-7 (using puppetlabs-release-precise.deb) ...
Unpacking replacement puppetlabs-release ...
Setting up puppetlabs-release (1.0-7) ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
augeas-lenses debconf-utils dmidecode facter libaugeas-ruby1.8 libaugeas0 libreadline5 libruby libruby1.8
libshadow-ruby1.8 puppet-common ruby ruby1.8
Suggested packages:
augeas-doc ruby-json augeas-tools puppet-el vim-puppet etckeeper ruby-selinux libselinux-ruby1.8 librrd-ruby1.8 ri
ruby-dev ruby1.8-examples ri1.8
Recommended packages:
rdoc
The following NEW packages will be installed:
augeas-lenses debconf-utils dmidecode facter libaugeas-ruby1.8 libaugeas0 libreadline5 libruby libruby1.8
libshadow-ruby1.8 puppet puppet-common ruby ruby1.8
0 upgraded, 14 newly installed, 0 to remove and 91 not upgraded.
Need to get 3,256 kB of archives.
After this operation, 12.6 MB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu/ precise/main libreadline5 i386 5.2-11 [123 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main libruby1.8 i386 1.8.7.352-2ubuntu1.4 [1,787 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main ruby1.8 i386 1.8.7.352-2ubuntu1.4 [34.2 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu/ precise/main libruby all 4.8 [4,766 B]
Get:5 http://us.archive.ubuntu.com/ubuntu/ precise/main libshadow-ruby1.8 i386 1.4.1-8build1 [8,828 B]
Get:6 http://us.archive.ubuntu.com/ubuntu/ precise/main augeas-lenses all 0.10.0-0ubuntu4 [175 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu/ precise/main libaugeas0 i386 0.10.0-0ubuntu4 [169 kB]
Get:8 http://us.archive.ubuntu.com/ubuntu/ precise/main libaugeas-ruby1.8 i386 0.3.0-1.1ubuntu4 [9,490 B]
Get:9 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main facter all 1.6.5-1ubuntu1.2 [45.3 kB]
Get:10 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main puppet-common all 2.7.11-1ubuntu2.7 [768 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main puppet all 2.7.11-1ubuntu2.7 [20.2 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu/ precise/main dmidecode i386 2.11-4 [51.7 kB]
Get:13 http://us.archive.ubuntu.com/ubuntu/ precise/main debconf-utils all 1.5.42ubuntu1 [54.9 kB]
Get:14 http://us.archive.ubuntu.com/ubuntu/ precise/main ruby all 4.8 [5,054 B]
Fetched 3,256 kB in 0s (7,260 kB/s)
Selecting previously unselected package libreadline5.
(Reading database ... 21194 files and directories currently installed.)
Unpacking libreadline5 (from .../libreadline5_5.2-11_i386.deb) ...
Selecting previously unselected package libruby1.8.
Unpacking libruby1.8 (from .../libruby1.8_1.8.7.352-2ubuntu1.4_i386.deb) ...
Selecting previously unselected package ruby1.8.
Unpacking ruby1.8 (from .../ruby1.8_1.8.7.352-2ubuntu1.4_i386.deb) ...
Selecting previously unselected package libruby.
Unpacking libruby (from .../archives/libruby_4.8_all.deb) ...
Selecting previously unselected package libshadow-ruby1.8.
Unpacking libshadow-ruby1.8 (from .../libshadow-ruby1.8_1.4.1-8build1_i386.deb) ...
Selecting previously unselected package augeas-lenses.
Unpacking augeas-lenses (from .../augeas-lenses_0.10.0-0ubuntu4_all.deb) ...
Selecting previously unselected package libaugeas0.
Unpacking libaugeas0 (from .../libaugeas0_0.10.0-0ubuntu4_i386.deb) ...
Selecting previously unselected package libaugeas-ruby1.8.
Unpacking libaugeas-ruby1.8 (from .../libaugeas-ruby1.8_0.3.0-1.1ubuntu4_i386.deb) ...
Selecting previously unselected package facter.
Unpacking facter (from .../facter_1.6.5-1ubuntu1.2_all.deb) ...
Selecting previously unselected package puppet-common.
Unpacking puppet-common (from .../puppet-common_2.7.11-1ubuntu2.7_all.deb) ...
Selecting previously unselected package puppet.
Unpacking puppet (from .../puppet_2.7.11-1ubuntu2.7_all.deb) ...
Selecting previously unselected package dmidecode.
Unpacking dmidecode (from .../dmidecode_2.11-4_i386.deb) ...
Selecting previously unselected package debconf-utils.
Unpacking debconf-utils (from .../debconf-utils_1.5.42ubuntu1_all.deb) ...
Selecting previously unselected package ruby.
Unpacking ruby (from .../apt/archives/ruby_4.8_all.deb) ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Setting up libreadline5 (5.2-11) ...
Setting up libruby1.8 (1.8.7.352-2ubuntu1.4) ...
Setting up ruby1.8 (1.8.7.352-2ubuntu1.4) ...
update-alternatives: using /usr/bin/ruby1.8 to provide /usr/bin/ruby (ruby) in auto mode.
Setting up libruby (4.8) ...
Setting up libshadow-ruby1.8 (1.4.1-8build1) ...
Setting up augeas-lenses (0.10.0-0ubuntu4) ...
Setting up libaugeas0 (0.10.0-0ubuntu4) ...
Setting up libaugeas-ruby1.8 (0.3.0-1.1ubuntu4) ...
Setting up facter (1.6.5-1ubuntu1.2) ...
Setting up puppet-common (2.7.11-1ubuntu2.7) ...
Setting up puppet (2.7.11-1ubuntu2.7) ...
* Starting puppet agent
puppet not configured to start, please edit /etc/default/puppet to enable
[ OK ]
Setting up dmidecode (2.11-4) ...
Setting up debconf-utils (1.5.42ubuntu1) ...
Setting up ruby (4.8) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
--2014-01-12 18:12:22-- http://puppet.spreecommerce.com:5000/certs?fqdn=xxx.mysite.com&digest=9c84e8370316f24b7189bb9abb02b6af&cert=ca
Resolving puppet.spreecommerce.com (puppet.spreecommerce.com)... 50.57.232.196
Connecting to puppet.spreecommerce.com (puppet.spreecommerce.com)|50.57.232.196|:5000... connected.
HTTP request sent, awaiting response... 200 OK
Length: 830 [text/html]
Saving to: `/var/lib/puppet/ssl/certs/ca.pem'
100%[=============================================================================>] 830 --.-K/s in 0s
2014-01-12 18:12:22 (55.8 MB/s) - `/var/lib/puppet/ssl/certs/ca.pem' saved [830/830]
--2014-01-12 18:12:22-- http://puppet.spreecommerce.com:5000/certs?fqdn=xxx.mysite.com&digest=9c84e8370316f24b7189bb9abb02b6af&cert=public
Resolving puppet.spreecommerce.com (puppet.spreecommerce.com)... 50.57.232.196
Connecting to puppet.spreecommerce.com (puppet.spreecommerce.com)|50.57.232.196|:5000... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1395 (1.4K) [text/html]
Saving to: `/var/lib/puppet/ssl/certs/xxx.mysite.com.pem'
100%[=============================================================================>] 1,395 --.-K/s in 0s
2014-01-12 18:12:22 (126 MB/s) - `/var/lib/puppet/ssl/certs/xxx.mysite.com.pem' saved [1395/1395]
--2014-01-12 18:12:22-- http://puppet.spreecommerce.com:5000/certs?fqdn=xxx.mysite.com&digest=9c84e8370316f24b7189bb9abb02b6af&cert=private
Resolving puppet.spreecommerce.com (puppet.spreecommerce.com)... 50.57.232.196
Connecting to puppet.spreecommerce.com (puppet.spreecommerce.com)|50.57.232.196|:5000... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3247 (3.2K) [text/html]
Saving to: `/var/lib/puppet/ssl/private_keys/xxx.mysite.com.pem'
100%[=============================================================================>] 3,247 --.-K/s in 0s
2014-01-12 18:12:22 (210 MB/s) - `/var/lib/puppet/ssl/private_keys/xxx.mysite.com.pem' saved [3247/3247]
info: Retrieving plugin
info: Caching certificate_revocation_list for ca
notice: /File[/var/lib/puppet/lib/puppet]/ensure: created
notice: /File[/var/lib/puppet/lib/puppet/provider]/ensure: created
notice: /File[/var/lib/puppet/lib/puppet/provider/database_user]/ensure: created
notice: /File[/var/lib/puppet/lib/puppet/provider/database_user/mysql.rb]/ensure: defined content as '{md5}a1de13720084641bcdce82a499b36650'
notice: /File[/var/lib/puppet/lib/puppet/provider/file_line]/ensure: created
notice: /File[/var/lib/puppet/lib/puppet/parser]/ensure: created
notice: /File[/var/lib/puppet/lib/puppet/parser/functions]/ensure: created
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_hash.rb]/ensure: defined content as '{md5}e9cfaca68751524efe16ecf2f958a9a0'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_bool.rb]/ensure: defined content as '{md5}4ddffdf5954b15863d18f392950b88f4'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/get_module_path.rb]/ensure: defined content as '{md5}d4bf50da25c0b98d26b75354fa1bcc45'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_ip_address.rb]/ensure: defined content as '{md5}a53f6e3a5855954148230846ccb3e04d'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_numeric.rb]/ensure: defined content as '{md5}6283dd52935fb1aba41958e50c85b1ed'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/delete.rb]/ensure: defined content as '{md5}4a3c82d0ed8ea4c953658efdd06fe7c9'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_domain_name.rb]/ensure: defined content as '{md5}fba9f855df3bbf90d72dfd5201f65d2b'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_absolute_path.rb]/ensure: defined content as '{md5}385137ac24a2dec6cecc4e6ea75be442'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/has_key.rb]/ensure: defined content as '{md5}7cd9728c38f0b0065f832dabd62b0e7e'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/flatten.rb]/ensure: defined content as '{md5}251d63696564254d41742ecbfbfcb9fd'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_mac_address.rb]/ensure: defined content as '{md5}288bd4b38d4df42a83681f13e7eaaee0'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_array.rb]/ensure: defined content as '{md5}72b29289b8af1cfc3662ef9be78911b8'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/loadyaml.rb]/ensure: defined content as '{md5}2b912f257aa078e376d3b3f6a86c2a00'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/empty.rb]/ensure: defined content as '{md5}ae92905c9d94ddca30bf56b7b1dabedf'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/defined_with_params.rb]/ensure: defined content as '{md5}ffab4433d03f32b551f2ea024a2948fc'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/bool2num.rb]/ensure: defined content as '{md5}8e627eee990e811e35e7e838c586bd77'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/hash.rb]/ensure: defined content as '{md5}75fd86c01d5b1e50be1bc8b22d3d0a61'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/prefix.rb]/ensure: defined content as '{md5}6a2d86233c9435afc1738f60a0c34576'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_integer.rb]/ensure: defined content as '{md5}6520458000b349f1c7ba7c9ed382ae0b'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/swapcase.rb]/ensure: defined content as '{md5}4902f38f0b9292afec66d40fee4b02ec'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/to_bytes.rb]/ensure: defined content as '{md5}83f23c33adbfa42b2a9d9fc2db3daeb4'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/lstrip.rb]/ensure: defined content as '{md5}210b103f78622e099f91cc2956b6f741'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_array.rb]/ensure: defined content as '{md5}875ca4356cb0d7a10606fb146b4a3d11'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/sort.rb]/ensure: defined content as '{md5}504b033b438461ca4f9764feeb017833'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/merge.rb]/ensure: defined content as '{md5}52281fe881b762e2adfef20f58dc4180'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/mysql_password.rb]/ensure: defined content as '{md5}3c375e08f7372795ad25d51d43995f96'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/member.rb]/ensure: defined content as '{md5}541e67d06bc4155e79b00843a125e9bc'
notice: /File[/var/lib/puppet/lib/puppet/provider/database]/ensure: created
notice: /File[/var/lib/puppet/lib/puppet/provider/database/mysql.rb]/ensure: defined content as '{md5}a337e681a7de594df6240a252aff0f66'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/capitalize.rb]/ensure: defined content as '{md5}14481fc8c7c83fe002066ebcf6722f17'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/values.rb]/ensure: defined content as '{md5}066a6e4170e5034edb9a80463dff2bb5'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/chomp.rb]/ensure: defined content as '{md5}7040b3348d2f770f265cf4c8c25c51c5'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/unique.rb]/ensure: defined content as '{md5}217ccce6d23235af92923f50f8556963'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/shuffle.rb]/ensure: defined content as '{md5}6445e6b4dc62c37b184a60eeaf34414b'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/num2bool.rb]/ensure: defined content as '{md5}dbdc81982468ebb8ac24ab78d7097ad3'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/rstrip.rb]/ensure: defined content as '{md5}8a0d69876bdbc88a2054ba41c9c38961'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/str2bool.rb]/ensure: defined content as '{md5}846b49d623cb847c1870d7ac4a6bedf3'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/abs.rb]/ensure: defined content as '{md5}c2f2c4a62a56e7adbf5cf0b292e081fc'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/parseyaml.rb]/ensure: defined content as '{md5}6cfee471d287c8d110a3629a9ac31b69'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/grep.rb]/ensure: defined content as '{md5}5682995af458b05f3b53dd794c4bf896'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/squeeze.rb]/ensure: defined content as '{md5}ae5aafb7478cced0ba0c23856e45cec5'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/downcase.rb]/ensure: defined content as '{md5}9204a04c2a168375a38d502db8811bbe'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_string.rb]/ensure: defined content as '{md5}2bd9a652bbb2668323eee6c57729ff64'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/delete_at.rb]/ensure: defined content as '{md5}6bc24b79390d463d8be95396c963381a'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/size.rb]/ensure: defined content as '{md5}8972d48c0f9e487d659bd7326b40b642'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_hash.rb]/ensure: defined content as '{md5}8c7d9a05084dab0389d1b779c8a05b1a'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/keys.rb]/ensure: defined content as '{md5}eb6ac815ea14fbf423580ed903ef7bad'
notice: /File[/var/lib/puppet/lib/puppet/provider/database_grant]/ensure: created
notice: /File[/var/lib/puppet/lib/puppet/provider/file_line/ruby.rb]/ensure: defined content as '{md5}f0f61ee3076d6b8f5883872abe844f37'
notice: /File[/var/lib/puppet/lib/puppet/type]/ensure: created
notice: /File[/var/lib/puppet/lib/puppet/type/database.rb]/ensure: defined content as '{md5}a5e9e5edb5aa67bbddd17fb9096c9eae'
notice: /File[/var/lib/puppet/lib/puppet/type/database_user.rb]/ensure: defined content as '{md5}3c1569f97f0b2c76437503e3d47d520b'
notice: /File[/var/lib/puppet/lib/puppet/type/anchor.rb]/ensure: defined content as '{md5}cc1da7acfe1259d5b86a64e2dea42c34'
notice: /File[/var/lib/puppet/lib/puppet/type/database_grant.rb]/ensure: defined content as '{md5}8a9d41da37ab8450f656b0e50c0f3c1e'
notice: /File[/var/lib/puppet/lib/facter]/ensure: created
notice: /File[/var/lib/puppet/lib/facter/util]/ensure: created
notice: /File[/var/lib/puppet/lib/facter/util/puppet_settings.rb]/ensure: defined content as '{md5}9f1d2593d0ae56bfca89d4b9266aeee1'
notice: /File[/var/lib/puppet/lib/facter/facter_dot_d.rb]/ensure: defined content as '{md5}926b2c2e886a43c615d7663029d43595'
notice: /File[/var/lib/puppet/lib/facter/root_home.rb]/ensure: defined content as '{md5}f559294cceafcf70799339627d94871d'
notice: /File[/var/lib/puppet/lib/facter/puppet_vardir.rb]/ensure: defined content as '{md5}c7ddc97e8a84ded3dd93baa5b9b3283d'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/range.rb]/ensure: defined content as '{md5}033048bba333fe429e77e0f2e91db25f'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_slength.rb]/ensure: defined content as '{md5}0ca530d1d3b45c3fe2d604c69acfc22f'
notice: /File[/var/lib/puppet/lib/facter/pe_version.rb]/ensure: defined content as '{md5}4a9353952963b011759f3e6652a10da5'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/join.rb]/ensure: defined content as '{md5}b28087823456ca5cf943de4a233ac77f'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/strip.rb]/ensure: defined content as '{md5}273d547c7b05c0598556464dfd12f5fd'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/upcase.rb]/ensure: defined content as '{md5}a5744a74577cfa136fca2835e75888d3'
notice: /File[/var/lib/puppet/lib/puppet/type/file_line.rb]/ensure: defined content as '{md5}09381c3e04c684f4ba702381c727acbd'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/time.rb]/ensure: defined content as '{md5}08d88d52abd1e230e3a2f82107545d48'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_string.rb]/ensure: defined content as '{md5}6afcbc51f83f0714348b8d61e06ea7eb'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/reverse.rb]/ensure: defined content as '{md5}1386371c0f5301055fdf99079e862b3e'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/type.rb]/ensure: defined content as '{md5}62f914d6c90662aaae40c5539701be60'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/zip.rb]/ensure: defined content as '{md5}a80782461ed9465f0cd0c010936f1855'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/ensure_resource.rb]/ensure: defined content as '{md5}5c2e7990e22e5a532931627b4aaf545b'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_re.rb]/ensure: defined content as '{md5}c6664b3943bc820415a43f16372dc2a9'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/str2saltedsha512.rb]/ensure: defined content as '{md5}49afad7b386be38ce53deaefef326e85'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/fqdn_rotate.rb]/ensure: defined content as '{md5}20743a138c56fc806a35cb7b60137dbc'
notice: /File[/var/lib/puppet/lib/puppet/provider/database_grant/mysql.rb]/ensure: defined content as '{md5}51f8b6b793ede0983da32f0c89baa259'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/values_at.rb]/ensure: defined content as '{md5}094ac110ce9f7a5b16d0c80a0cf2243c'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/getvar.rb]/ensure: defined content as '{md5}10bf744212947bc6a7bfd2c9836dbd23'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/strftime.rb]/ensure: defined content as '{md5}e02e01a598ca5d7d6eee0ba22440304a'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/chop.rb]/ensure: defined content as '{md5}4cc840d63ec172d8533a613676391d39'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_float.rb]/ensure: defined content as '{md5}491937483b14fbe2594a6e0e9af6acf9'
notice: /File[/var/lib/puppet/lib/puppet/parser/functions/parsejson.rb]/ensure: defined content as '{md5}e7f968c34928107b84cd0860daf50ab1'
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/validate_string.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/lstrip.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/is_hash.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/validate_bool.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/type/database_user.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/is_mac_address.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/shuffle.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/is_integer.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/sort.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/abs.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/getvar.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/range.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/parseyaml.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/fqdn_rotate.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/downcase.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/to_bytes.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/values.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/provider/database_grant/mysql.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/chomp.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/type/database_grant.rb
info: Redefining database_grant in Puppet::Type
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/delete_at.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/num2bool.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/is_float.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/validate_slength.rb
info: Loading downloaded plugin /var/lib/puppet/lib/facter/util/puppet_settings.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/is_ip_address.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/member.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/capitalize.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/ensure_resource.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/keys.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/loadyaml.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/values_at.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/str2bool.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/strip.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/provider/database/mysql.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/size.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/type/database.rb
info: Redefining database in Puppet::Type
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/validate_array.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/strftime.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/type/anchor.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/zip.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/validate_hash.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/validate_absolute_path.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/unique.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/merge.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/time.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/prefix.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/grep.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/is_array.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/get_module_path.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/is_domain_name.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/is_string.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/join.rb
info: Loading downloaded plugin /var/lib/puppet/lib/facter/pe_version.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/mysql_password.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/hash.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/rstrip.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/empty.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/swapcase.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/type/file_line.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/delete.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/provider/database_user/mysql.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/flatten.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/is_numeric.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/parsejson.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/str2saltedsha512.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/validate_re.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/type.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/upcase.rb
info: Loading downloaded plugin /var/lib/puppet/lib/facter/puppet_vardir.rb
info: Loading downloaded plugin /var/lib/puppet/lib/facter/facter_dot_d.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/defined_with_params.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/chop.rb
info: Loading downloaded plugin /var/lib/puppet/lib/facter/root_home.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/has_key.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/provider/file_line/ruby.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/reverse.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/bool2num.rb
info: Loading downloaded plugin /var/lib/puppet/lib/puppet/parser/functions/squeeze.rb
info: Loading facts in /var/lib/puppet/lib/facter/root_home.rb
info: Loading facts in /var/lib/puppet/lib/facter/pe_version.rb
info: Loading facts in /var/lib/puppet/lib/facter/puppet_vardir.rb
info: Loading facts in /var/lib/puppet/lib/facter/facter_dot_d.rb
pcilib: Cannot open /proc/bus/pci
lspci: Cannot find any working access method.
info: Caching catalog for xxx.mysite.com
info: /Service[mysqld]: Provider upstart does not support features enableable; not managing attribute enable
info: Applying configuration version '1384865699'
notice: Augeas[set puppet report](provider=augeas):
--- /etc/puppet/puppet.conf 2012-03-16 16:41:22.000000000 +0000
+++ /etc/puppet/puppet.conf.augnew 2014-01-12 18:12:48.000000000 +0000
@@ -14,3 +14,5 @@
ssl_client_header = SSL_CLIENT_S_DN
ssl_client_verify_header = SSL_CLIENT_VERIFY
+[agent]
+report=true
notice: /Stage[main]/Puppetclient/Augeas[set puppet report]/returns: executed successfully
notice: Augeas[set puppet pluginsync](provider=augeas):
--- /etc/puppet/puppet.conf 2014-01-12 18:12:48.000000000 +0000
+++ /etc/puppet/puppet.conf.augnew 2014-01-12 18:12:49.000000000 +0000
@@ -8,6 +8,7 @@
prerun_command=/etc/puppet/etckeeper-commit-pre
postrun_command=/etc/puppet/etckeeper-commit-post
+pluginsync=true
[master]
# These are needed when the puppetmaster is run by passenger
# and can safely be removed if webrick is used.
notice: /Stage[main]/Puppetclient/Augeas[set puppet pluginsync]/returns: executed successfully
notice: /Stage[main]/Mysql::Server/Package[mysql-server]/ensure: ensure changed 'purged' to 'present'
notice: /Stage[main]/Ruby/Package[build-essential]/ensure: ensure changed 'purged' to 'present'
notice: /Stage[main]/Ruby/Package[libxslt1-dev]/ensure: ensure changed 'purged' to 'present'
notice: /Stage[main]/Ruby/Package[imagemagick]/ensure: ensure changed 'purged' to 'present'
notice: /Stage[main]/Ruby/Package[htop]/ensure: ensure changed 'purged' to 'present'
notice: /Stage[main]/Ruby/Package[libsqlite3-dev]/ensure: ensure changed 'purged' to 'present'
notice: /Stage[main]/Ruby/User[spree]/ensure: created
notice: /Stage[main]/Ruby/File[/etc/init]/group: group changed 'root' to 'spree'
notice: /Stage[main]/Ruby/File[/etc/init]/mode: mode changed '0755' to '0775'
notice: /Stage[main]/Ruby/Package[sqlite3]/ensure: ensure changed 'purged' to 'present'
notice: /Stage[main]/Ruby/File[/etc/gemrc]/ensure: defined content as '{md5}4f27af3d749b806593ab60c2ccefde1e'
notice: /Stage[main]/Ruby/Package[libmysqlclient-dev]/ensure: ensure changed 'purged' to 'present'
notice: /Stage[main]/Ruby/Package[libssl-dev]/ensure: ensure changed 'purged' to 'present'
notice: /Stage[main]/Ruby/File[/home/spree/ruby_version]/ensure: created
info: /Stage[main]/Ruby/File[/home/spree/ruby_version]: Scheduling refresh of Exec[install ruby]
notice: /Stage[main]/Ruby/Package[git-core]/ensure: ensure changed 'purged' to 'present'
notice: /Stage[main]/Ruby/Package[libreadline]/ensure: ensure changed 'purged' to 'present'
notice: /Stage[main]/Common/File[/data]/ensure: created
notice: /Stage[main]/Common/File[/etc/profile.d/set_env_vars.sh]/ensure: created
notice: /Stage[main]/Mysql/Package[mysql_client]/ensure: ensure changed 'purged' to 'present'
notice: /Stage[main]/Common/File[/data/config]/ensure: created
notice: /Stage[main]/Mysql::Ruby/Package[ruby_mysql]/ensure: ensure changed 'purged' to 'present'
notice: /Stage[main]/Common/File[/etc/sudoers]/content:
--- /etc/sudoers 2012-01-31 15:44:33.000000000 +0000
+++ /tmp/puppet-file20140112-5059-1jeh4sz-0 2014-01-12 18:14:12.000000000 +0000
@@ -1,29 +1,16 @@
-#
-# This file MUST be edited with the 'visudo' command as root.
-#
-# Please consider adding local content in /etc/sudoers.d/ instead of
-# directly modifying this file.
-#
-# See the man page for details on how to write a sudoers file.
-#
-Defaults env_reset
-Defaults secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
-
-# Host alias specification
-
-# User alias specification
+# /etc/sudoers
-# Cmnd alias specification
+Defaults env_reset
# User privilege specification
-root ALL=(ALL:ALL) ALL
-
-# Members of the admin group may gain root privileges
-%admin ALL=(ALL) ALL
+root ALL=(ALL) ALL
-# Allow members of group sudo to execute any command
-%sudo ALL=(ALL:ALL) ALL
+# Allow members of group sudo to execute any command after they have
+# provided their password
+# (Note that later entries override this, so you might need to move
+# it further down)
+%sudo ALL=(ALL) ALL
-# See sudoers(5) for more information on "#include" directives:
+# Allow spree control upstart without providing password (capistrano)
+spree ALL=NOPASSWD: /usr/local/bin/bluepill
-#includedir /etc/sudoers.d
info: FileBucket adding {md5}1b00ee0a97a1bcf9961e476140e2c5c1
info: /Stage[main]/Common/File[/etc/sudoers]: Filebucketed /etc/sudoers to puppet with sum 1b00ee0a97a1bcf9961e476140e2c5c1
notice: /Stage[main]/Common/File[/etc/sudoers]/content: content changed '{md5}1b00ee0a97a1bcf9961e476140e2c5c1' to '{md5}c793d933a3ba690eb78ebf4d031c3801'
err: /Stage[main]/Dbserver/Dbserver::Create_db[spree]/Database[spree]/ensure: change from absent to present failed: Execution of '/usr/bin/mysql --defaults-file=/root/.my.cnf -NBe create database `spree` character set utf8' returned 1: Could not open required defaults file: /root/.my.cnf
Fatal error in defaults handling. Program aborted
notice: /Stage[main]/Dbserver/Dbserver::Create_db[spree]/Database_user[spree@localhost]: Dependency Database[spree] has failures: true
warning: /Stage[main]/Dbserver/Dbserver::Create_db[spree]/Database_user[spree@localhost]: Skipping because of failed dependencies
err: Could not prefetch database_grant provider 'mysql': Execution of '/usr/bin/mysql --defaults-file=/root/.my.cnf mysql -Be describe user' returned 1: Could not open required defaults file: /root/.my.cnf
Fatal error in defaults handling. Program aborted
notice: /Stage[main]/Dbserver/Dbserver::Create_db[spree]/Database_grant[spree@localhost/spree]: Dependency Database[spree] has failures: true
warning: /Stage[main]/Dbserver/Dbserver::Create_db[spree]/Database_grant[spree@localhost/spree]: Skipping because of failed dependencies
notice: /Stage[main]/App/Spree::App[spree]/File[/data/spree]/ensure: created
notice: /Stage[main]/App/Spree::App[spree]/File[/data/spree/releases]/ensure: created
notice: /Stage[main]/App/Spree::App[spree]/File[/data/spree/shared]/ensure: created
notice: /Stage[main]/App/Spree::App[spree]/File[/data/spree/shared/sockets]/ensure: created
notice: /Stage[main]/App/Spree::App[spree]/File[/data/spree/shared/config]/ensure: created
notice: /Stage[main]/App/Spree::App[spree]/File[/data/spree/shared/config/spree.pill]/ensure: defined content as '{md5}16b819fa22574ec0997f67f592abf054'
notice: /Stage[main]/App/Spree::App[spree]/File[/data/spree/shared/config/Procfile]/ensure: defined content as '{md5}f7aea9b818dc08852cd4365863282845'
notice: /Stage[main]/App/Spree::App[spree]/File[/data/spree/shared/system]/ensure: created
notice: /Stage[main]/App/Spree::App[spree]/File[/data/spree/shared/log]/ensure: created
notice: /Stage[main]/App/Spree::App[spree]/File[/data/spree/shared/config/database.yml]/ensure: defined content as '{md5}6fb005418b702d4ca9f24239dff6614f'
notice: /Stage[main]/App/Spree::App[spree]/File[/data/spree/shared/tmp]/ensure: created
notice: /Stage[main]/App/Spree::App[spree]/File[/data/spree/shared/config/master.pill.erb]/ensure: defined content as '{md5}18c86c7e5c2848d593b2fd4d5e6c7f1a'
notice: /Stage[main]/Common/File[/etc/init/bluepill.conf]/ensure: defined content as '{md5}41b3dff62fd421abafb5dc363f799f33'
notice: /Stage[main]/Common/Cron[ntpdate_set]/ensure: created
notice: /Stage[main]/Nginx/Package[python-software-properties]/ensure: ensure changed 'purged' to 'present'
info: /Stage[main]/Nginx/Package[python-software-properties]: Scheduling refresh of Exec[add-apt-repository nginx]
notice: /Stage[main]/Nginx/Exec[add-apt-repository nginx]: Triggered 'refresh' from 1 events
notice: /Stage[main]/Nginx/Package[nginx]/ensure: ensure changed 'purged' to 'latest'
info: /Stage[main]/Nginx/Package[nginx]: Scheduling refresh of Service[nginx]
notice: /Stage[main]/Nginx/File[/etc/nginx/nginx.conf]/content:
--- /etc/nginx/nginx.conf 2014-01-10 21:34:40.000000000 +0000
+++ /tmp/puppet-file20140112-5059-9gd22a-0 2014-01-12 18:14:28.000000000 +0000
@@ -1,95 +1,56 @@
user www-data;
-worker_processes 4;
-pid /run/nginx.pid;
+worker_processes 2;
+pid /var/run/nginx.pid;
events {
- worker_connections 768;
- # multi_accept on;
+ worker_connections 768;
+ # multi_accept on;
}
http {
+ ##
+ # Basic Settings
+ ##
+
+ sendfile on;
+ tcp_nopush on;
+ tcp_nodelay off;
+ keepalive_timeout 5 5;
+ types_hash_max_size 2048;
+ # server_tokens off;
+
+ # server_names_hash_bucket_size 64;
+ # server_name_in_redirect off;
+
+ include /etc/nginx/mime.types;
+ default_type application/octet-stream;
+
+ ##
+ # Logging Settings
+ ##
+
+ access_log /var/log/nginx/access.log;
+ error_log /var/log/nginx/error.log;
+
+ ##
+ # Gzip Settings
+ ##
+
+ gzip on;
+ gzip_static on;
+ gzip_http_version 1.1;
+ gzip_disable "msie6";
+ gzip_vary on;
+ gzip_min_length 1100;
+ gzip_buffers 64 8k;
+ gzip_comp_level 3;
+ gzip_proxied any;
+ gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;
+
+ ##
+ # Virtual Host Configs
+ ##
- ##
- # Basic Settings
- ##
-
- sendfile on;
- tcp_nopush on;
- tcp_nodelay on;
- keepalive_timeout 65;
- types_hash_max_size 2048;
- # server_tokens off;
-
- # server_names_hash_bucket_size 64;
- # server_name_in_redirect off;
-
- include /etc/nginx/mime.types;
- default_type application/octet-stream;
-
- ##
- # Logging Settings
- ##
-
- access_log /var/log/nginx/access.log;
- error_log /var/log/nginx/error.log;
-
- ##
- # Gzip Settings
- ##
-
- gzip on;
- gzip_disable "msie6";
-
- # gzip_vary on;
- # gzip_proxied any;
- # gzip_comp_level 6;
- # gzip_buffers 16 8k;
- # gzip_http_version 1.1;
- # gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;
-
- ##
- # nginx-naxsi config
- ##
- # Uncomment it if you installed nginx-naxsi
- ##
-
- #include /etc/nginx/naxsi_core.rules;
-
- ##
- # nginx-passenger config
- ##
- # Uncomment it if you installed nginx-passenger
- ##
-
- #passenger_root /usr;
- #passenger_ruby /usr/bin/ruby;
-
- ##
- # Virtual Host Configs
- ##
-
- include /etc/nginx/conf.d/*.conf;
- include /etc/nginx/sites-enabled/*;
+ include /etc/nginx/conf.d/*.conf;
+ include /etc/nginx/sites-enabled/*;
}
-
-
-#mail {
-# # See sample authentication script at:
-# # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
-#
-# # auth_http localhost/auth.php;
-# # pop3_capabilities "TOP" "USER";
-# # imap_capabilities "IMAP4rev1" "UIDPLUS";
-#
-# server {
-# listen localhost:110;
-# protocol pop3;
-# proxy on;
-# }
-#
-# server {
-# listen localhost:143;
-# protocol imap;
-# proxy on;
-# }
-#}
info: FileBucket adding {md5}a85dcbc5367783f3d42d0b7eab22ea50
info: /Stage[main]/Nginx/File[/etc/nginx/nginx.conf]: Filebucketed /etc/nginx/nginx.conf to puppet with sum a85dcbc5367783f3d42d0b7eab22ea50
notice: /Stage[main]/Nginx/File[/etc/nginx/nginx.conf]/content: content changed '{md5}a85dcbc5367783f3d42d0b7eab22ea50' to '{md5}0847117d53d9a57606dfc8dbec86f327'
info: /Stage[main]/Nginx/File[/etc/nginx/nginx.conf]: Scheduling refresh of Service[nginx]
notice: /Stage[main]/Appserver/Nginx::Site[spree]/File[/etc/nginx/sites-available/spree]/ensure: defined content as '{md5}9aa4cb852c6641fd5e0f53ac525ae78e'
info: /Stage[main]/Appserver/Nginx::Site[spree]/File[/etc/nginx/sites-available/spree]: Scheduling refresh of Service[nginx]
info: FileBucket adding {md5}f2a429b4ab6b011006350c8646d38f4c
info: /Stage[main]/Nginx/File[/etc/nginx/sites-enabled/default]: Filebucketed /etc/nginx/sites-enabled/default to puppet with sum f2a429b4ab6b011006350c8646d38f4c
notice: /Stage[main]/Nginx/File[/etc/nginx/sites-enabled/default]/ensure: removed
info: /Stage[main]/Nginx/File[/etc/nginx/sites-enabled/default]: Scheduling refresh of Service[nginx]
notice: /Stage[main]/Appserver/Nginx::Site[spree]/File[/etc/nginx/sites-enabled/spree]/ensure: created
info: /Stage[main]/Appserver/Nginx::Site[spree]/File[/etc/nginx/sites-enabled/spree]: Scheduling refresh of Service[nginx]
notice: /Stage[main]/Appserver/Nginx::Site[spree]/File[/etc/nginx/sites-available/spree-secure]/ensure: defined content as '{md5}8e36e057c5b237dbc7f503e5bd0eb584'
info: /Stage[main]/Appserver/Nginx::Site[spree]/File[/etc/nginx/sites-available/spree-secure]: Scheduling refresh of Service[nginx]
notice: /Stage[main]/Ruby/Exec[checkout ruby-build]/returns: executed successfully
notice: /Stage[main]/Puppetclient/Service[puppet]/enable: enable changed 'true' to 'false'
notice: /Stage[main]/Appserver/Appserver::Unicorn[spree]/File[/data/spree/shared/config/unicorn.rb]/ensure: defined content as '{md5}d837c3ce98eee5c4cf57c13a05d96752'
notice: /Stage[main]/Nginx/Service[nginx]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Nginx/Service[nginx]: Triggered 'refresh' from 6 events
notice: /Stage[main]/Ruby/Package[graphicsmagick-libmagick-dev-compat]/ensure: ensure changed 'purged' to 'present'
notice: /Stage[main]/Mysql::Config/File[/root/.my.cnf]/ensure: created
info: /Stage[main]/Mysql::Config/File[/root/.my.cnf]: Scheduling refresh of Exec[mysqld-restart]
notice: /Stage[main]/Mysql::Config/File[/etc/mysql/my.cnf]/content:
--- /etc/mysql/my.cnf 2013-10-22 20:09:48.000000000 +0000
+++ /tmp/puppet-file20140112-5059-1nciaas-0 2014-01-12 18:14:43.000000000 +0000
@@ -1,127 +1,41 @@
-#
-# The MySQL database server configuration file.
-#
-# You can copy this to one of:
-# - "/etc/mysql/my.cnf" to set global options,
-# - "~/.my.cnf" to set user-specific options.
-#
-# One can use all long options that the program supports.
-# Run program with --help to get a list of available options and with
-# --print-defaults to see which it would actually understand and use.
-#
-# For explanations see
-# http://dev.mysql.com/doc/mysql/en/server-system-variables.html
-
-# This will be passed to all mysql clients
-# It has been reported that passwords should be enclosed with ticks/quotes
-# escpecially if they contain "#" chars...
-# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
-port = 3306
-socket = /var/run/mysqld/mysqld.sock
-
-# Here is entries for some specific programs
-# The following values assume you have at least 32M ram
-
-# This was formally known as [safe_mysqld]. Both versions are currently parsed.
+port = 3306
+socket = /var/run/mysqld/mysqld.sock
[mysqld_safe]
-socket = /var/run/mysqld/mysqld.sock
-nice = 0
-
+socket = /var/run/mysqld/mysqld.sock
+nice = 0
[mysqld]
-#
-# * Basic Settings
-#
-user = mysql
-pid-file = /var/run/mysqld/mysqld.pid
-socket = /var/run/mysqld/mysqld.sock
-port = 3306
-basedir = /usr
-datadir = /var/lib/mysql
-tmpdir = /tmp
-lc-messages-dir = /usr/share/mysql
+user = mysql
+pid-file = /var/run/mysqld/mysqld.pid
+socket = /var/run/mysqld/mysqld.sock
+port = 3306
+basedir = /usr
+datadir = /var/lib/mysql
+tmpdir = /tmp
skip-external-locking
-#
-# Instead of skip-networking the default is now to listen only on
-# localhost which is more compatible and is not less secure.
-bind-address = 127.0.0.1
-#
-# * Fine Tuning
-#
-key_buffer = 16M
-max_allowed_packet = 16M
-thread_stack = 192K
-thread_cache_size = 8
-# This replaces the startup script and checks MyISAM tables if needed
-# the first time they are touched
-myisam-recover = BACKUP
-#max_connections = 100
-#table_cache = 64
-#thread_concurrency = 10
-#
-# * Query Cache Configuration
-#
-query_cache_limit = 1M
-query_cache_size = 16M
-#
-# * Logging and Replication
-#
-# Both location gets rotated by the cronjob.
-# Be aware that this log type is a performance killer.
-# As of 5.1 you can enable the log at runtime!
-#general_log_file = /var/log/mysql/mysql.log
-#general_log = 1
-#
-# Error log - should be very few entries.
-#
-log_error = /var/log/mysql/error.log
-#
-# Here you can see queries with especially long duration
-#log_slow_queries = /var/log/mysql/mysql-slow.log
-#long_query_time = 2
-#log-queries-not-using-indexes
-#
-# The following can be used as easy to replay backup logs or for replication.
-# note: if you are setting up a replication slave, see README.Debian about
-# other settings you may need to change.
-#server-id = 1
-#log_bin = /var/log/mysql/mysql-bin.log
-expire_logs_days = 10
-max_binlog_size = 100M
-#binlog_do_db = include_database_name
-#binlog_ignore_db = include_database_name
-#
-# * InnoDB
-#
-# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
-# Read the manual for more InnoDB related options. There are many!
-#
-# * Security Features
-#
-# Read the manual, too, if you want chroot!
-# chroot = /var/lib/mysql/
-#
-# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
-#
-# ssl-ca=/etc/mysql/cacert.pem
-# ssl-cert=/etc/mysql/server-cert.pem
-# ssl-key=/etc/mysql/server-key.pem
+
+
+bind-address = 127.0.0.1
+
+
+key_buffer = 16M
+max_allowed_packet = 16M
+thread_stack = 192K
+thread_cache_size = 8
+myisam-recover = BACKUP
+query_cache_limit = 1M
+query_cache_size = 16M
+log_error = /var/log/mysql/error.log
+expire_logs_days = 10
+max_binlog_size = 100M
[mysqldump]
quick
quote-names
-max_allowed_packet = 16M
-
+max_allowed_packet = 16M
[mysql]
-#no-auto-rehash # faster start of mysql but no tab completition
-
[isamchk]
-key_buffer = 16M
-
-#
-# * IMPORTANT: Additional settings that can override those from this file!
-# The files must end with '.cnf', otherwise they'll be ignored.
-#
+key_buffer = 16M
!includedir /etc/mysql/conf.d/
info: FileBucket adding {md5}77f15d6c87f9c136c4efcda072017f71
info: /Stage[main]/Mysql::Config/File[/etc/mysql/my.cnf]: Filebucketed /etc/mysql/my.cnf to puppet with sum 77f15d6c87f9c136c4efcda072017f71
notice: /Stage[main]/Mysql::Config/File[/etc/mysql/my.cnf]/content: content changed '{md5}77f15d6c87f9c136c4efcda072017f71' to '{md5}d9e035104d0794fd82604e6c0ae8d715'
info: /Stage[main]/Mysql::Config/File[/etc/mysql/my.cnf]: Scheduling refresh of Exec[mysqld-restart]
notice: /Stage[main]/Mysql::Config/Exec[mysqld-restart]: Triggered 'refresh' from 2 events
notice: /Stage[main]/Ruby/Exec[install ruby-build]/returns: executed successfully
notice: /Stage[main]/Ruby/Exec[install ruby]/returns: Downloading ruby-2.0.0-p195.tar.gz...
notice: /Stage[main]/Ruby/Exec[install ruby]/returns: -> http://dqw8nmjcqpjn7.cloudfront.net/0672e5af309ae99d1703d0e96eff8ea5
notice: /Stage[main]/Ruby/Exec[install ruby]/returns: Installing ruby-2.0.0-p195...
notice: /Stage[main]/Ruby/Exec[install ruby]/returns: Installed ruby-2.0.0-p195 to /usr/local
notice: /Stage[main]/Ruby/Exec[install ruby]: Triggered 'refresh' from 1 events
notice: /Stage[main]/Ruby/File[/usr/bin/gem]/ensure: created
notice: /Stage[main]/Ruby/Package[rubygems]/ensure: ensure changed 'purged' to 'latest'
err: /Stage[main]/Ruby/Package[bundler]/ensure: change from absent to present failed: Execution of '/usr/local/bin/gem install --include-dependencies --no-rdoc --no-ri bundler' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
err: /Stage[main]/Ruby/Package[backup]/ensure: change from absent to present failed: Execution of '/usr/local/bin/gem install --include-dependencies --no-rdoc --no-ri backup' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
err: /Stage[main]/Ruby/Package[bluepill]/ensure: change from absent to present failed: Execution of '/usr/local/bin/gem install --include-dependencies --no-rdoc --no-ri bluepill' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
err: /Stage[main]/Ruby/Package[foreman]/ensure: change from absent to present failed: Execution of '/usr/local/bin/gem install --include-dependencies --no-rdoc --no-ri foreman' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
err: /Stage[main]/Ruby/Package[net-ssh]/ensure: change from absent to 2.1.4 failed: Could not update: Execution of '/usr/local/bin/gem install -v 2.1.4 --include-dependencies --no-rdoc --no-ri net-ssh' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
at /etc/puppet/modules/ruby/manifests/init.pp:115
err: /Stage[main]/Ruby/Package[net-scp]/ensure: change from absent to 1.0.4 failed: Could not update: Execution of '/usr/local/bin/gem install -v 1.0.4 --include-dependencies --no-rdoc --no-ri net-scp' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
at /etc/puppet/modules/ruby/manifests/init.pp:121
notice: /Stage[main]/App/Spree::App[spree]/File[/data/spree/shared/pids]/ensure: created
notice: /Stage[main]/Dbserver/Dbserver::Create_db[spree]/Database_user[spree@xxx.xxx.xx.xxx]: Dependency Database[spree] has failures: true
warning: /Stage[main]/Dbserver/Dbserver::Create_db[spree]/Database_user[spree@xxx.xxx.xx.xxx]: Skipping because of failed dependencies
notice: /Stage[main]/Dbserver/Dbserver::Create_db[spree]/Database_grant[spree@xxx.xxx.xx.xxx/spree]: Dependency Database[spree] has failures: true
warning: /Stage[main]/Dbserver/Dbserver::Create_db[spree]/Database_grant[spree@xxx.xxx.xx.xxx/spree]: Skipping because of failed dependencies
notice: /Stage[main]/App/Spree::App[spree]/File[/data/spree/shared/config/.foreman]/ensure: defined content as '{md5}2447b6353fce57c41e04abf90ec08c90'
notice: /Stage[main]/Common/Service[bluepill]: Dependency Package[bluepill] has failures: true
warning: /Stage[main]/Common/Service[bluepill]: Skipping because of failed dependencies
info: Creating state file /var/lib/puppet/state/state.yaml
notice: Finished catalog run in 667.26 seconds
info: Retrieving plugin
info: Loading facts in /var/lib/puppet/lib/facter/root_home.rb
info: Loading facts in /var/lib/puppet/lib/facter/pe_version.rb
info: Loading facts in /var/lib/puppet/lib/facter/puppet_vardir.rb
info: Loading facts in /var/lib/puppet/lib/facter/facter_dot_d.rb
pcilib: Cannot open /proc/bus/pci
lspci: Cannot find any working access method.
info: Caching catalog for xxx.mysite.com
info: /Service[mysqld]: Provider upstart does not support features enableable; not managing attribute enable
info: Applying configuration version '1384865699'
notice: /Stage[main]/Dbserver/Dbserver::Create_db[spree]/Database[spree]/ensure: created
notice: /Stage[main]/Dbserver/Dbserver::Create_db[spree]/Database_user[spree@localhost]/ensure: created
notice: /Stage[main]/Dbserver/Dbserver::Create_db[spree]/Database_grant[spree@localhost/spree]/privileges: privileges changed '' to 'all'
info: FileBucket adding {md5}1cca49734659d6d27dd067c74b26e58c
info: /Stage[main]/Ruby/File[/usr/bin/gem]: Filebucketed /usr/bin/gem to puppet with sum 1cca49734659d6d27dd067c74b26e58c
notice: /Stage[main]/Ruby/File[/usr/bin/gem]/target: target changed '/etc/alternatives/gem' to '/usr/local/bin/gem'
err: /Stage[main]/Ruby/Package[bundler]/ensure: change from absent to present failed: Execution of '/usr/local/bin/gem install --include-dependencies --no-rdoc --no-ri bundler' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
err: /Stage[main]/Ruby/Package[backup]/ensure: change from absent to present failed: Execution of '/usr/local/bin/gem install --include-dependencies --no-rdoc --no-ri backup' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
err: /Stage[main]/Ruby/Package[bluepill]/ensure: change from absent to present failed: Execution of '/usr/local/bin/gem install --include-dependencies --no-rdoc --no-ri bluepill' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
err: /Stage[main]/Ruby/Package[foreman]/ensure: change from absent to present failed: Execution of '/usr/local/bin/gem install --include-dependencies --no-rdoc --no-ri foreman' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
err: /Stage[main]/Ruby/Package[net-ssh]/ensure: change from absent to 2.1.4 failed: Could not update: Execution of '/usr/local/bin/gem install -v 2.1.4 --include-dependencies --no-rdoc --no-ri net-ssh' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
at /etc/puppet/modules/ruby/manifests/init.pp:115
err: /Stage[main]/Ruby/Package[net-scp]/ensure: change from absent to 1.0.4 failed: Could not update: Execution of '/usr/local/bin/gem install -v 1.0.4 --include-dependencies --no-rdoc --no-ri net-scp' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
at /etc/puppet/modules/ruby/manifests/init.pp:121
notice: /Stage[main]/Dbserver/Dbserver::Create_db[spree]/Database_user[spree@xxx.xxx.xx.xxx]/ensure: created
notice: /Stage[main]/Dbserver/Dbserver::Create_db[spree]/Database_grant[spree@xxx.xxx.xx.xxx/spree]/privileges: privileges changed '' to 'all'
notice: /Stage[main]/Common/Service[bluepill]: Dependency Package[bluepill] has failures: true
warning: /Stage[main]/Common/Service[bluepill]: Skipping because of failed dependencies
notice: Finished catalog run in 23.77 seconds
info: Retrieving plugin
info: Loading facts in /var/lib/puppet/lib/facter/root_home.rb
info: Loading facts in /var/lib/puppet/lib/facter/pe_version.rb
info: Loading facts in /var/lib/puppet/lib/facter/puppet_vardir.rb
info: Loading facts in /var/lib/puppet/lib/facter/facter_dot_d.rb
pcilib: Cannot open /proc/bus/pci
lspci: Cannot find any working access method.
info: Caching catalog for xxx.mysite.com
info: /Service[mysqld]: Provider upstart does not support features enableable; not managing attribute enable
info: Applying configuration version '1384865699'
err: /Stage[main]/Ruby/Package[bundler]/ensure: change from absent to present failed: Execution of '/usr/local/bin/gem install --include-dependencies --no-rdoc --no-ri bundler' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
err: /Stage[main]/Ruby/Package[backup]/ensure: change from absent to present failed: Execution of '/usr/local/bin/gem install --include-dependencies --no-rdoc --no-ri backup' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
err: /Stage[main]/Ruby/Package[bluepill]/ensure: change from absent to present failed: Execution of '/usr/local/bin/gem install --include-dependencies --no-rdoc --no-ri bluepill' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
err: /Stage[main]/Ruby/Package[foreman]/ensure: change from absent to present failed: Execution of '/usr/local/bin/gem install --include-dependencies --no-rdoc --no-ri foreman' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
err: /Stage[main]/Ruby/Package[net-ssh]/ensure: change from absent to 2.1.4 failed: Could not update: Execution of '/usr/local/bin/gem install -v 2.1.4 --include-dependencies --no-rdoc --no-ri net-ssh' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
at /etc/puppet/modules/ruby/manifests/init.pp:115
err: /Stage[main]/Ruby/Package[net-scp]/ensure: change from absent to 1.0.4 failed: Could not update: Execution of '/usr/local/bin/gem install -v 1.0.4 --include-dependencies --no-rdoc --no-ri net-scp' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
invalid option: --include-dependencies
at /etc/puppet/modules/ruby/manifests/init.pp:121
notice: /Stage[main]/Common/Service[bluepill]: Dependency Package[bluepill] has failures: true
warning: /Stage[main]/Common/Service[bluepill]: Skipping because of failed dependencies
notice: Finished catalog run in 12.64 seconds
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment