Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
ebextension to enable rails 6
commands:
01_install_yarn:
command: "sudo wget https://dl.yarnpkg.com/rpm/yarn.repo -O /etc/yum.repos.d/yarn.repo && curl --silent --location https://rpm.nodesource.com/setup_6.x | sudo bash - && sudo yum install yarn -y"
02_download_nodejs:
command: "curl --silent --location https://rpm.nodesource.com/setup_8.x | sudo bash -"
03_install_nodejs:
command: "yum -y install nodejs"
04_mkdir_webapp_dir:
command: "mkdir /home/webapp"
ignoreErrors: true
05_chown_webapp_dir:
command: "chown webapp:webapp /home/webapp"
ignoreErrors: true
06_chmod_webapp_dir:
command: "chmod 0744 /home/webapp"
ignoreErrors: true
07_chmod_logs:
command: "chown webapp:webapp -R /var/app/current/log/"
ignoreErrors: true
08_create_log_file:
command: "touch /var/app/current/log/production.log"
ignoreErrors: true
09_chown_log_production:
command: "chown webapp:webapp /var/app/current/log/production.log"
ignoreErrors: true
10_chmod_log_dir:
command: "chmod 0664 -R /var/app/current/log/"
ignoreErrors: true
11_update_bundler:
command: "gem update bundler"
ignoreErrors: true
12_config_for_update_nokogiri:
command: "bundle config build.nokogiri --use-system-libraries"
13_chown_current:
command: "chown webapp:webapp -R /var/app/current/"
ignoreErrors: true
14_chmod_current:
command: "chmod 0755 -R /var/app/current/"
ignoreErrors: true
15_chown_current:
command: "chown webapp:webapp -R /var/app/ondeck/"
ignoreErrors: true
16_chown_current:
command: "chmod 0644 -R /var/app/ondeck/"
ignoreErrors: true
container_commands:
17_install_webpack:
command: "npm install --save-dev webpack"
18_config_for_update_nokogiri:
command: "bundle config build.nokogiri --use-system-libraries"
19_precompile:
command: "bundle exec rake assets:precompile"
@hrdwdmrbl

This comment has been minimized.

Copy link

hrdwdmrbl commented Apr 21, 2020

With Rails 6.0.2 and rails/webpack 4.2.2, I get the error Webpacker requires Node.js >= 8.16.0 and you are using 6.17.1

@x9prototype

This comment has been minimized.

Copy link

x9prototype commented May 3, 2020

With Rails 6.0.2 and rails/webpack 4.2.2, I get the error Webpacker requires Node.js >= 8.16.0 and you are using 6.17.1

I am getting the same error, have you resolved this?

@hrdwdmrbl

This comment has been minimized.

Copy link

hrdwdmrbl commented May 3, 2020

@ x9prototype I removed the last section, the container_commands section and thing seems to work. But I'm super not confident in my "fix". Things still seem really flaky and I think I will probably discontinue my trial of Beanstalk because of the added complexity. I really thought that Beanstalk would be less complexity.

@hrdwdmrbl

This comment has been minimized.

Copy link

hrdwdmrbl commented May 3, 2020

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.