public
Created

  • Download Gist
gistfile1.txt
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
luis@Feather ~[ruby-1.9.2-p180]$ gem env
RubyGems Environment:
- RUBYGEMS VERSION: 1.8.5
- RUBY VERSION: 1.9.2 (2011-02-18 patchlevel 180) [x86_64-darwin10.7.0]
- INSTALLATION DIRECTORY: /Users/luis/.rvm/gems/ruby-1.9.2-p180
- RUBY EXECUTABLE: /Users/luis/.rvm/rubies/ruby-1.9.2-p180/bin/ruby
- EXECUTABLE DIRECTORY: /Users/luis/.rvm/gems/ruby-1.9.2-p180/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86_64-darwin-10
- GEM PATHS:
- /Users/luis/.rvm/gems/ruby-1.9.2-p180
- /Users/luis/.rvm/gems/ruby-1.9.2-p180@global
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- "gem" => "--no-ri --no-rdoc"
- REMOTE SOURCES:
- http://rubygems.org/
luis@Feather ~[ruby-1.9.2-p180]$ gem update --system 1.3.7
Updating rubygems-update
Fetching: rubygems-update-1.3.7.gem (100%)
Successfully installed rubygems-update-1.3.7
Installing RubyGems 1.3.7
/Users/luis/.rvm/gems/ruby-1.9.2-p180/gems/rubygems-update-1.3.7/lib/rubygems/source_index.rb:68:in `installed_spec_directories': undefined method `path' for Gem:Module (NoMethodError)
from /Users/luis/.rvm/gems/ruby-1.9.2-p180/gems/rubygems-update-1.3.7/lib/rubygems/source_index.rb:58:in `from_installed_gems'
from /Users/luis/.rvm/gems/ruby-1.9.2-p180/gems/rubygems-update-1.3.7/lib/rubygems.rb:883:in `source_index'
from /Users/luis/.rvm/gems/ruby-1.9.2-p180/gems/rubygems-update-1.3.7/lib/rubygems/gem_path_searcher.rb:81:in `init_gemspecs'
from /Users/luis/.rvm/gems/ruby-1.9.2-p180/gems/rubygems-update-1.3.7/lib/rubygems/gem_path_searcher.rb:13:in `initialize'
from /Users/luis/.rvm/gems/ruby-1.9.2-p180/gems/rubygems-update-1.3.7/lib/rubygems.rb:841:in `new'
from /Users/luis/.rvm/gems/ruby-1.9.2-p180/gems/rubygems-update-1.3.7/lib/rubygems.rb:841:in `block in searcher'
from <internal:prelude>:10:in `synchronize'
from /Users/luis/.rvm/gems/ruby-1.9.2-p180/gems/rubygems-update-1.3.7/lib/rubygems.rb:840:in `searcher'
from /Users/luis/.rvm/gems/ruby-1.9.2-p180/gems/rubygems-update-1.3.7/lib/rubygems.rb:479:in `find_files'
from /Users/luis/.rvm/gems/ruby-1.9.2-p180/gems/rubygems-update-1.3.7/lib/rubygems.rb:983:in `load_plugins'
from /Users/luis/.rvm/gems/ruby-1.9.2-p180/gems/rubygems-update-1.3.7/lib/rubygems.rb:1139:in `<top (required)>'
from <internal:lib/rubygems/custom_require>:29:in `require'
from <internal:lib/rubygems/custom_require>:29:in `require'
from setup.rb:24:in `<main>'

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.