Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
$ which ruby
/Users/luis/.portile/apps/x86_64-apple-darwin10.4.0/ruby/1.9.3-trunk/bin/ruby
$ ruby -v
ruby 1.9.3dev (2010-09-09 trunk 29199) [x86_64-darwin10.4.0]
$ gem env
RubyGems Environment:
- RUBYGEMS VERSION: 1.3.7
- RUBY VERSION: 1.9.3 (2010-09-09 patchlevel -1) [x86_64-darwin10.4.0]
- INSTALLATION DIRECTORY: /Users/luis/.portile/apps/x86_64-apple-darwin10.4.0/ruby/1.9.3-trunk/lib/ruby/gems/1.9.1
- RUBY EXECUTABLE: /Users/luis/.portile/apps/x86_64-apple-darwin10.4.0/ruby/1.9.3-trunk/bin/ruby
- EXECUTABLE DIRECTORY: /Users/luis/.portile/apps/x86_64-apple-darwin10.4.0/ruby/1.9.3-trunk/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86_64-darwin-10
- GEM PATHS:
- /Users/luis/.portile/apps/x86_64-apple-darwin10.4.0/ruby/1.9.3-trunk/lib/ruby/gems/1.9.1
- /Users/luis/.gem/ruby/1.9.1
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- "install" => "--no-ri --no-rdoc --env-shebang"
- "update" => "--no-ri --no-rdoc --env-shebang"
- REMOTE SOURCES:
- http://rubygems.org/
$ gem list
*** LOCAL GEMS ***
minitest (1.7.1)
rake (0.8.7)
rdoc (2.5.8)
$ gem list rake -d
*** LOCAL GEMS ***
rake (0.8.7)
Author:
Installed at: /Users/luis/.portile/apps/x86_64-apple-darwin10.4.0/ruby/1.9.3-trunk/lib/ruby/gems/1.9.1
This rake is bundled with Ruby
$ which rake
/Users/luis/.portile/apps/x86_64-apple-darwin10.4.0/ruby/1.9.3-trunk/bin/rake
$ rake --version
rake, version 0.8.7
$ gem install rake
Successfully installed rake-0.8.7
1 gem installed
$ rake --version
/Users/luis/.portile/apps/x86_64-apple-darwin10.4.0/ruby/1.9.3-trunk/lib/ruby/1.9.1/rubygems.rb:340:in `bin_path': can't find executable rake for rake-0.8.7 (Gem::Exception)
from /Users/luis/.portile/apps/x86_64-apple-darwin10.4.0/ruby/1.9.3-trunk/bin/rake:19:in `<main>'
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.