Skip to content

Instantly share code, notes, and snippets.

Avatar

Maran maran

  • Amsterdam
View GitHub Profile
@maran
maran / gist:dc50de67832ad390013f30943a065fac
Created Nov 22, 2017
0x00f080E5cC01327c7e7F7688471f5Bcff76a9Fd1
View gist:dc50de67832ad390013f30943a065fac
0x00f080E5cC01327c7e7F7688471f5Bcff76a9Fd1
View development_genesis.json
{
"nonce": "0x0000000000000042",
"difficulty": "0x40000",
"alloc": {
"bbbbbaaaaa82db86a35502193b4c6ee9a76ebe8f": {
"balance": "10015200000000000000000"
}
},
"mixhash": "0x0000000000000000000000000000000000000000000000000000000000000000",
"coinbase": "0x0000000000000000000000000000000000000000",
View gist:53703efd76430f023eeb
Verifying that +maran is my Bitcoin username. You can send me #bitcoin here: https://onename.io/maran
View install
#!/bin/bash -i
# This script will install Ethereum-Go and all dependencies.
# Please download and make it executable and run it as such to make sure the script reloads bashrc
# wget https://gist.github.com/maran/2d69089ed5ea3f83fde8 -O install
# chmod +x install
# ./install
if ! lsb_release -sr | grep 14.04 > /dev/null; then
echo "This script is made for Ubuntu 14.04, this probably won't work."
echo -p "Do you want to try it anyway? (y/n) " -n 1 -r
@maran
maran / install
Last active Aug 29, 2015
Ubuntu 14.04 Ethereum Go install
View install
#!/bin/bash -i
# This script will install Go & QML
# Please download and make it executable and run it as such to make sure the script reloads bashrc
# wget https://gist.githubusercontent.com/maran/8dc397ed79331f16e284/raw -O install
# chmod +x install
# ./install
VERSION="1.2.2"
function fromPkg(){
sudo apt-get install -y golang
View XenWalletInstall
#!/bin/bash
# @date: 2014-01-10
# @author: Xendarboh Sensorii <xen@shastafareye.net>
#
# This script will:
# 1) install system dependencies based on the Linux flavor (~Debian or Fedora)
# 2) install a custom-compiled openssl into $MYUSR_PREFIX (see config below)
# 3) install rvm and ruby
# 4) install mastercoin-wallet
#
View install.sh
#!/bin/bash
if grep 'Ubuntu\|Debian' /etc/issue; then
echo "Debian based distro detected; installing RVM"
sudo apt-get install -y libqt4-gui libqt4-dev cmake libssl-dev libgdbm-dev libncurses5-dev automake libtool bison libffi-dev
curl -L https://get.rvm.io | bash -s stable --autolibs=enabled --ruby
source ~/.rvm/scripts/rvm
echo "source ~/.rvm/scripts/rvm" >> ~/.bashrc
elif grep 'Fedora' /etc/issue; then
echo "Fedora detected, not installing RVM"
sudo yum install -y gcc-c++ qt-devel cmake ruby-devel rubygems qtwebkit-devel qtwebkit
View gist:3005828
#!/usr/bin/env bash
# echo "65536 * 3 + 256 * 2 + 25" | bc
if [[ -n "${BASH_VERSION:-}" ]] &&
(( 65536 * ${BASH_VERSINFO[0]} + 256 * ${BASH_VERSINFO[1]} + ${BASH_VERSINFO[2]} < 197145 ))
then
echo "BASH 3.2.25 required (you have $BASH_VERSION)"
exit 1
fi
@maran
maran / rollback.sh
Created Sep 1, 2011
Rollback to 1.3.2
View rollback.sh
#!/bin/bash
wget http://git.deluge-torrent.org/deluge/snapshot/deluge-1.3.2.tar.gz
tar -zxvf deluge-1.3.2.tar.gz
virtualenv ~/deluge
source ~/deluge/bin/activate
cd ~/deluge-1.3.2
sed -ibackup s/-dev// setup.cfg
python setup.py clean -a
python setup.py build
python setup.py install
@maran
maran / _rounded.sass
Created Jul 23, 2011
rounded corners
View _rounded.sass
@mixin rounded-corner($radius: 5px)
-moz-border-radius: $radius
-webkit-border-radius: $radius
border-radius: $radius
@mixin rounded-top-left-corner($radius: 5px)
-moz-border-radius-topleft: $radius
-webkit-border-top-left-radius: $radius
border-top-left-radius: $radius
You can’t perform that action at this time.