Create a gist now

Instantly share code, notes, and snippets.

What would you like to do?
Rails 3 installation fails on Linux with "File not found: lib" before making rdocs
marko@harman:~$ sudo gem install rails
[sudo] password for marko:
Successfully installed activesupport-3.0.0
Successfully installed i18n-0.4.1
Successfully installed activemodel-3.0.0
Successfully installed rack-1.2.1
Successfully installed rack-mount-0.6.13
Successfully installed tzinfo-0.3.23
Successfully installed erubis-2.6.6
Successfully installed actionpack-3.0.0
Successfully installed arel-1.0.1
Successfully installed activerecord-3.0.0
Successfully installed activeresource-3.0.0
Successfully installed polyglot-0.3.1
Successfully installed treetop-1.4.8
Successfully installed mail-2.2.5
Successfully installed actionmailer-3.0.0
Successfully installed thor-0.14.0
Successfully installed railties-3.0.0
Successfully installed bundler-1.0.0
Successfully installed rails-3.0.0
19 gems installed
Installing ri documentation for activesupport-3.0.0...
Installing ri documentation for i18n-0.4.1...
Installing ri documentation for activemodel-3.0.0...
Installing ri documentation for rack-1.2.1...
Installing ri documentation for rack-mount-0.6.13...
Installing ri documentation for tzinfo-0.3.23...
Installing ri documentation for erubis-2.6.6...
Installing ri documentation for actionpack-3.0.0...
Installing ri documentation for arel-1.0.1...
Installing ri documentation for activerecord-3.0.0...
Installing ri documentation for activeresource-3.0.0...
Installing ri documentation for polyglot-0.3.1...
Installing ri documentation for treetop-1.4.8...
Installing ri documentation for mail-2.2.5...
Installing ri documentation for actionmailer-3.0.0...
Installing ri documentation for thor-0.14.0...
Installing ri documentation for railties-3.0.0...
Installing ri documentation for bundler-1.0.0...
Installing ri documentation for rails-3.0.0...
File not found: lib
marko@harman:~$ gem env
RubyGems Environment:
- RUBYGEMS VERSION: 1.3.6
- RUBY VERSION: 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux]
- INSTALLATION DIRECTORY: /usr/lib/ruby/gems/1.8
- RUBY EXECUTABLE: /usr/bin/ruby1.8
- EXECUTABLE DIRECTORY: /usr/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86_64-linux
- GEM PATHS:
- /usr/lib/ruby/gems/1.8
- /home/marko/.gem/ruby/1.8
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- :sources => ["http://rubygems.org/", "http://gemcutter.org", "http://gems.github.com"]
- REMOTE SOURCES:
- http://rubygems.org/
- http://gemcutter.org
- http://gems.github.com

amuino commented Sep 5, 2010

Same here using rvm with ruby 1.8.7 p302.
Any clues?

amuino commented Sep 6, 2010

Upgrading rdoc seems to solve this for me: gem install rdoc

Owner

markoa commented Sep 9, 2010

You're right, that works for me too. Thanks!

lvnilesh commented Aug 4, 2012

gem install rdoc
gem install rails

That worked. Thanks.

megha24 commented Feb 8, 2013

worked for me too

thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment