Skip to content

Instantly share code, notes, and snippets.

@mastertheknife

mastertheknife/zm_centos64

Last active Dec 21, 2015
Embed
What would you like to do?
Steps to install ZoneMinder on CentOS 6.4. For more information, refer to this thread: http://www.zoneminder.com/forums/viewtopic.php?f=9&t=19119
Testing the RPM on a virgin CentOS 6.4 x86-64 installation (Minimal installation) with just nfs server, samba, httpd, ntpd installed so far.
Documenting the steps as i go.
Installing wget:
[root@atom ~]# yum install wget
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.syn.co.il
* extras: centos.syn.co.il
* updates: centos.syn.co.il
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package wget.x86_64 0:1.12-1.8.el6 will be installed
--> Finished Dependency Resolution
Dependencies Resolved
================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
wget x86_64 1.12-1.8.el6 base 482 k
Transaction Summary
================================================================================
Install 1 Package(s)
Total download size: 482 k
Installed size: 1.8 M
Is this ok [y/N]: y
Downloading Packages:
wget-1.12-1.8.el6.x86_64.rpm | 482 kB 00:00
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : wget-1.12-1.8.el6.x86_64 1/1
Verifying : wget-1.12-1.8.el6.x86_64 1/1
Installed:
wget.x86_64 0:1.12-1.8.el6
Complete!
Downloading and installing the epel and rpmforge repository files:
[root@atom ~]# cd /root
[root@atom ~]# wget http://ftp.linux.cz/pub/linux/fedora/epel/6/i386/epel-release-6-8.noarch.rpm
--2013-08-28 07:55:08-- http://ftp.linux.cz/pub/linux/fedora/epel/6/i386/epel-release-6-8.noarch.rpm
Resolving ftp.linux.cz... 147.251.48.205, 2001:718:801:230::cd
Connecting to ftp.linux.cz|147.251.48.205|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 14540 (14K) [application/x-rpm]
Saving to: “epel-release-6-8.noarch.rpm”
100%[======================================>] 14,540 --.-K/s in 0.1s
2013-08-28 07:55:09 (133 KB/s) - “epel-release-6-8.noarch.rpm” saved [14540/14540]
[root@atom ~]# yum localinstall epel-release-6-8.noarch.rpm
Loaded plugins: fastestmirror
Setting up Local Package Process
Examining epel-release-6-8.noarch.rpm: epel-release-6-8.noarch
Marking epel-release-6-8.noarch.rpm to be installed
Loading mirror speeds from cached hostfile
* base: centos.syn.co.il
* extras: centos.syn.co.il
* updates: centos.syn.co.il
Resolving Dependencies
--> Running transaction check
---> Package epel-release.noarch 0:6-8 will be installed
--> Finished Dependency Resolution
Dependencies Resolved
================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
epel-release noarch 6-8 /epel-release-6-8.noarch 22 k
Transaction Summary
================================================================================
Install 1 Package(s)
Total size: 22 k
Installed size: 22 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : epel-release-6-8.noarch 1/1
Verifying : epel-release-6-8.noarch 1/1
Installed:
epel-release.noarch 0:6-8
Complete!
[root@atom ~]# wget http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm
--2013-08-28 07:55:35-- http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm
Resolving pkgs.repoforge.org... 78.46.17.228
Connecting to pkgs.repoforge.org|78.46.17.228|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://rpmforge.sw.be/redhat/el6/en/x86_64/rpmforge/RPMS/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm [following]
--2013-08-28 07:55:36-- http://rpmforge.sw.be/redhat/el6/en/x86_64/rpmforge/RPMS/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm
Resolving rpmforge.sw.be... 78.46.17.228
Connecting to rpmforge.sw.be|78.46.17.228|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://tree.repoforge.org/redhat/el6/en/x86_64/rpmforge/RPMS/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm [following]
--2013-08-28 07:55:36-- http://tree.repoforge.org/redhat/el6/en/x86_64/rpmforge/RPMS/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm
Resolving tree.repoforge.org... 78.46.17.228
Connecting to tree.repoforge.org|78.46.17.228|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://apt.sw.be/redhat/el6/en/x86_64/rpmforge/RPMS/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm [following]
--2013-08-28 07:55:36-- http://apt.sw.be/redhat/el6/en/x86_64/rpmforge/RPMS/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm
Resolving apt.sw.be... 193.1.193.67
Connecting to apt.sw.be|193.1.193.67|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 12640 (12K) [application/x-redhat-package-manager]
Saving to: “rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm”
100%[======================================>] 12,640 55.5K/s in 0.2s
2013-08-28 07:55:37 (55.5 KB/s) - “rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm” saved [12640/12640]
[root@atom ~]# yum localinstall rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm
Loaded plugins: fastestmirror
Setting up Local Package Process
Examining rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm: rpmforge-release-0.5.3-1.el6.rf.x86_64
Marking rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm to be installed
Loading mirror speeds from cached hostfile
epel/metalink | 22 kB 00:00
* base: centos.syn.co.il
* epel: mirrors.n-ix.net
* extras: centos.syn.co.il
* updates: centos.syn.co.il
epel | 4.2 kB 00:00
epel/primary_db | 5.4 MB 00:02
Resolving Dependencies
--> Running transaction check
---> Package rpmforge-release.x86_64 0:0.5.3-1.el6.rf will be installed
--> Finished Dependency Resolution
Dependencies Resolved
================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
rpmforge-release
x86_64 0.5.3-1.el6.rf /rpmforge-release-0.5.3-1.el6.rf.x86_64 13 k
Transaction Summary
================================================================================
Install 1 Package(s)
Total size: 13 k
Installed size: 13 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : rpmforge-release-0.5.3-1.el6.rf.x86_64 1/1
Verifying : rpmforge-release-0.5.3-1.el6.rf.x86_64 1/1
Installed:
rpmforge-release.x86_64 0:0.5.3-1.el6.rf
Complete!
Installing the manual dependencies:
[root@atom kfir]# yum localinstall perl-Astro-SunTime-0.01-1.noarch.rpm perl-X10-0.03-1.noarch.rpm cambozola-0.92-6.el6.noarch.rpm
Loaded plugins: fastestmirror
Setting up Local Package Process
Examining perl-Astro-SunTime-0.01-1.noarch.rpm: perl-Astro-SunTime-0.01-1.noarch
Marking perl-Astro-SunTime-0.01-1.noarch.rpm to be installed
Loading mirror speeds from cached hostfile
* base: centos.syn.co.il
* epel: be.mirror.eurid.eu
* extras: centos.syn.co.il
* rpmforge: be.mirror.eurid.eu
* updates: centos.syn.co.il
Examining perl-X10-0.03-1.noarch.rpm: perl-X10-0.03-1.noarch
Marking perl-X10-0.03-1.noarch.rpm to be installed
Examining cambozola-0.92-6.el6.noarch.rpm: cambozola-0.92-6.el6.noarch
Marking cambozola-0.92-6.el6.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package cambozola.noarch 0:0.92-6.el6 will be installed
--> Processing Dependency: java for package: cambozola-0.92-6.el6.noarch
--> Processing Dependency: jpackage-utils for package: cambozola-0.92-6.el6.noarch
---> Package perl-Astro-SunTime.noarch 0:0.01-1 will be installed
--> Processing Dependency: perl(Time::ParseDate) for package: perl-Astro-SunTime-0.01-1.noarch
---> Package perl-X10.noarch 0:0.03-1 will be installed
--> Processing Dependency: perl(Device::SerialPort) for package: perl-X10-0.03-1.noarch
--> Running transaction check
---> Package java-1.5.0-gcj.x86_64 0:1.5.0.0-29.1.el6 will be installed
--> Processing Dependency: libgcj >= 4.1.2-5 for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: sinjdoc for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/lib64/security/classpath.security for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/gij for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/gij for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/gcj-dbtool for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/gcj-dbtool for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
---> Package jpackage-utils.noarch 0:1.7.5-3.12.el6 will be installed
---> Package perl-Device-SerialPort.x86_64 0:1.04-5.el6 will be installed
---> Package perl-Time-modules.noarch 0:2006.0814-5.el6 will be installed
--> Running transaction check
---> Package libgcj.x86_64 0:4.4.7-3.el6 will be installed
--> Processing Dependency: zip >= 2.1 for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libart_lgpl >= 2.1.0 for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: gtk2 >= 2.4.0 for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libasound.so.2(ALSA_0.9)(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libpangoft2-1.0.so.0()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libpangocairo-1.0.so.0()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libpango-1.0.so.0()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libgtk-x11-2.0.so.0()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libgdk-x11-2.0.so.0()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libfreetype.so.6()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libfontconfig.so.1()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libcairo.so.2()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libatk-1.0.so.0()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libasound.so.2()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libXtst.so.6()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libXrender.so.1()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libXrandr.so.2()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libSM.so.6()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
--> Processing Dependency: libICE.so.6()(64bit) for package: libgcj-4.4.7-3.el6.x86_64
---> Package sinjdoc.x86_64 0:0.5-9.1.el6 will be installed
--> Processing Dependency: java_cup >= 0.10 for package: sinjdoc-0.5-9.1.el6.x86_64
--> Running transaction check
---> Package alsa-lib.x86_64 0:1.0.22-3.el6 will be installed
---> Package atk.x86_64 0:1.28.0-2.el6 will be installed
---> Package cairo.x86_64 0:1.8.8-3.1.el6 will be installed
--> Processing Dependency: libpixman-1.so.0()(64bit) for package: cairo-1.8.8-3.1.el6.x86_64
--> Processing Dependency: libX11.so.6()(64bit) for package: cairo-1.8.8-3.1.el6.x86_64
---> Package fontconfig.x86_64 0:2.8.0-3.el6 will be installed
---> Package freetype.x86_64 0:2.3.11-14.el6_3.1 will be installed
---> Package gtk2.x86_64 0:2.18.9-12.el6 will be installed
--> Processing Dependency: hicolor-icon-theme for package: gtk2-2.18.9-12.el6.x86_64
--> Processing Dependency: libjasper.so.1()(64bit) for package: gtk2-2.18.9-12.el6.x86_64
--> Processing Dependency: libXinerama.so.1()(64bit) for package: gtk2-2.18.9-12.el6.x86_64
--> Processing Dependency: libXi.so.6()(64bit) for package: gtk2-2.18.9-12.el6.x86_64
--> Processing Dependency: libXfixes.so.3()(64bit) for package: gtk2-2.18.9-12.el6.x86_64
--> Processing Dependency: libXext.so.6()(64bit) for package: gtk2-2.18.9-12.el6.x86_64
--> Processing Dependency: libXdamage.so.1()(64bit) for package: gtk2-2.18.9-12.el6.x86_64
--> Processing Dependency: libXcursor.so.1()(64bit) for package: gtk2-2.18.9-12.el6.x86_64
--> Processing Dependency: libXcomposite.so.1()(64bit) for package: gtk2-2.18.9-12.el6.x86_64
---> Package java_cup.x86_64 1:0.10k-5.el6 will be installed
---> Package libICE.x86_64 0:1.0.6-1.el6 will be installed
---> Package libSM.x86_64 0:1.2.1-2.el6 will be installed
---> Package libXrandr.x86_64 0:1.4.0-1.el6 will be installed
---> Package libXrender.x86_64 0:0.9.7-2.el6 will be installed
---> Package libXtst.x86_64 0:1.2.1-2.el6 will be installed
---> Package libart_lgpl.x86_64 0:2.3.20-5.1.el6 will be installed
---> Package pango.x86_64 0:1.28.1-7.el6_3 will be installed
--> Processing Dependency: libthai >= 0.1.9 for package: pango-1.28.1-7.el6_3.x86_64
--> Processing Dependency: libthai.so.0(LIBTHAI_0.1)(64bit) for package: pango-1.28.1-7.el6_3.x86_64
--> Processing Dependency: libthai.so.0()(64bit) for package: pango-1.28.1-7.el6_3.x86_64
--> Processing Dependency: libXft.so.2()(64bit) for package: pango-1.28.1-7.el6_3.x86_64
---> Package zip.x86_64 0:3.0-1.el6 will be installed
--> Running transaction check
---> Package hicolor-icon-theme.noarch 0:0.11-1.1.el6 will be installed
---> Package jasper-libs.x86_64 0:1.900.1-15.el6_1.1 will be installed
---> Package libX11.x86_64 0:1.5.0-4.el6 will be installed
--> Processing Dependency: libX11-common = 1.5.0-4.el6 for package: libX11-1.5.0-4.el6.x86_64
--> Processing Dependency: libxcb.so.1()(64bit) for package: libX11-1.5.0-4.el6.x86_64
---> Package libXcomposite.x86_64 0:0.4.3-4.el6 will be installed
---> Package libXcursor.x86_64 0:1.1.13-2.el6 will be installed
---> Package libXdamage.x86_64 0:1.1.3-4.el6 will be installed
---> Package libXext.x86_64 0:1.3.1-2.el6 will be installed
---> Package libXfixes.x86_64 0:5.0-3.el6 will be installed
---> Package libXft.x86_64 0:2.3.1-2.el6 will be installed
---> Package libXi.x86_64 0:1.6.1-3.el6 will be installed
---> Package libXinerama.x86_64 0:1.1.2-2.el6 will be installed
---> Package libthai.x86_64 0:0.1.12-3.el6 will be installed
---> Package pixman.x86_64 0:0.26.2-5.el6_4 will be installed
--> Running transaction check
---> Package libX11-common.noarch 0:1.5.0-4.el6 will be installed
---> Package libxcb.x86_64 0:1.8.1-1.el6 will be installed
--> Processing Dependency: libXau.so.6()(64bit) for package: libxcb-1.8.1-1.el6.x86_64
--> Running transaction check
---> Package libXau.x86_64 0:1.0.6-4.el6 will be installed
--> Finished Dependency Resolution
Dependencies Resolved
================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
cambozola noarch 0.92-6.el6 /cambozola-0.92-6.el6.noarch 159 k
perl-Astro-SunTime noarch 0.01-1 /perl-Astro-SunTime-0.01-1.noarch
3.0 k
perl-X10 noarch 0.03-1 /perl-X10-0.03-1.noarch 103 k
Installing for dependencies:
alsa-lib x86_64 1.0.22-3.el6 base 370 k
atk x86_64 1.28.0-2.el6 base 191 k
cairo x86_64 1.8.8-3.1.el6 base 309 k
fontconfig x86_64 2.8.0-3.el6 base 186 k
freetype x86_64 2.3.11-14.el6_3.1 updates 359 k
gtk2 x86_64 2.18.9-12.el6 base 3.3 M
hicolor-icon-theme noarch 0.11-1.1.el6 base 40 k
jasper-libs x86_64 1.900.1-15.el6_1.1
base 136 k
java-1.5.0-gcj x86_64 1.5.0.0-29.1.el6 base 139 k
java_cup x86_64 1:0.10k-5.el6 base 197 k
jpackage-utils noarch 1.7.5-3.12.el6 base 59 k
libICE x86_64 1.0.6-1.el6 base 53 k
libSM x86_64 1.2.1-2.el6 base 37 k
libX11 x86_64 1.5.0-4.el6 base 584 k
libX11-common noarch 1.5.0-4.el6 base 192 k
libXau x86_64 1.0.6-4.el6 base 24 k
libXcomposite x86_64 0.4.3-4.el6 base 20 k
libXcursor x86_64 1.1.13-2.el6 base 37 k
libXdamage x86_64 1.1.3-4.el6 base 18 k
libXext x86_64 1.3.1-2.el6 base 35 k
libXfixes x86_64 5.0-3.el6 base 23 k
libXft x86_64 2.3.1-2.el6 base 55 k
libXi x86_64 1.6.1-3.el6 base 35 k
libXinerama x86_64 1.1.2-2.el6 base 20 k
libXrandr x86_64 1.4.0-1.el6 base 36 k
libXrender x86_64 0.9.7-2.el6 base 30 k
libXtst x86_64 1.2.1-2.el6 base 29 k
libart_lgpl x86_64 2.3.20-5.1.el6 base 65 k
libgcj x86_64 4.4.7-3.el6 base 19 M
libthai x86_64 0.1.12-3.el6 base 183 k
libxcb x86_64 1.8.1-1.el6 base 110 k
pango x86_64 1.28.1-7.el6_3 base 350 k
perl-Device-SerialPort
x86_64 1.04-5.el6 epel 64 k
perl-Time-modules noarch 2006.0814-5.el6 base 38 k
pixman x86_64 0.26.2-5.el6_4 updates 200 k
sinjdoc x86_64 0.5-9.1.el6 base 705 k
zip x86_64 3.0-1.el6 base 260 k
Transaction Summary
================================================================================
Install 40 Package(s)
Total size: 27 M
Total download size: 27 M
Installed size: 90 M
Is this ok [y/N]: y
Downloading Packages:
(1/37): alsa-lib-1.0.22-3.el6.x86_64.rpm | 370 kB 00:00
(2/37): atk-1.28.0-2.el6.x86_64.rpm | 191 kB 00:00
(3/37): cairo-1.8.8-3.1.el6.x86_64.rpm | 309 kB 00:00
(4/37): fontconfig-2.8.0-3.el6.x86_64.rpm | 186 kB 00:00
(5/37): freetype-2.3.11-14.el6_3.1.x86_64.rpm | 359 kB 00:00
(6/37): gtk2-2.18.9-12.el6.x86_64.rpm | 3.3 MB 00:01
(7/37): hicolor-icon-theme-0.11-1.1.el6.noarch.rpm | 40 kB 00:00
(8/37): jasper-libs-1.900.1-15.el6_1.1.x86_64.rpm | 136 kB 00:00
(9/37): java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64.rpm | 139 kB 00:00
(10/37): java_cup-0.10k-5.el6.x86_64.rpm | 197 kB 00:00
(11/37): jpackage-utils-1.7.5-3.12.el6.noarch.rpm | 59 kB 00:00
(12/37): libICE-1.0.6-1.el6.x86_64.rpm | 53 kB 00:00
(13/37): libSM-1.2.1-2.el6.x86_64.rpm | 37 kB 00:00
(14/37): libX11-1.5.0-4.el6.x86_64.rpm | 584 kB 00:00
(15/37): libX11-common-1.5.0-4.el6.noarch.rpm | 192 kB 00:00
(16/37): libXau-1.0.6-4.el6.x86_64.rpm | 24 kB 00:00
(17/37): libXcomposite-0.4.3-4.el6.x86_64.rpm | 20 kB 00:00
(18/37): libXcursor-1.1.13-2.el6.x86_64.rpm | 37 kB 00:00
(19/37): libXdamage-1.1.3-4.el6.x86_64.rpm | 18 kB 00:00
(20/37): libXext-1.3.1-2.el6.x86_64.rpm | 35 kB 00:00
(21/37): libXfixes-5.0-3.el6.x86_64.rpm | 23 kB 00:00
(22/37): libXft-2.3.1-2.el6.x86_64.rpm | 55 kB 00:00
(23/37): libXi-1.6.1-3.el6.x86_64.rpm | 35 kB 00:00
(24/37): libXinerama-1.1.2-2.el6.x86_64.rpm | 20 kB 00:00
(25/37): libXrandr-1.4.0-1.el6.x86_64.rpm | 36 kB 00:00
(26/37): libXrender-0.9.7-2.el6.x86_64.rpm | 30 kB 00:00
(27/37): libXtst-1.2.1-2.el6.x86_64.rpm | 29 kB 00:00
(28/37): libart_lgpl-2.3.20-5.1.el6.x86_64.rpm | 65 kB 00:00
(29/37): libgcj-4.4.7-3.el6.x86_64.rpm | 19 MB 00:05
(30/37): libthai-0.1.12-3.el6.x86_64.rpm | 183 kB 00:00
(31/37): libxcb-1.8.1-1.el6.x86_64.rpm | 110 kB 00:00
(32/37): pango-1.28.1-7.el6_3.x86_64.rpm | 350 kB 00:00
(33/37): perl-Device-SerialPort-1.04-5.el6.x86_64.rpm | 64 kB 00:00
(34/37): perl-Time-modules-2006.0814-5.el6.noarch.rpm | 38 kB 00:00
(35/37): pixman-0.26.2-5.el6_4.x86_64.rpm | 200 kB 00:00
(36/37): sinjdoc-0.5-9.1.el6.x86_64.rpm | 705 kB 00:00
(37/37): zip-3.0-1.el6.x86_64.rpm | 260 kB 00:00
--------------------------------------------------------------------------------
Total 2.4 MB/s | 27 MB 00:11
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID 0608b895: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
Importing GPG key 0x0608B895:
Userid : EPEL (6) <epel@fedoraproject.org>
Package: epel-release-6-8.noarch (@/epel-release-6-8.noarch)
From : /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : freetype-2.3.11-14.el6_3.1.x86_64 1/40
Installing : fontconfig-2.8.0-3.el6.x86_64 2/40
Installing : libICE-1.0.6-1.el6.x86_64 3/40
Installing : perl-Time-modules-2006.0814-5.el6.noarch 4/40
Installing : jpackage-utils-1.7.5-3.12.el6.noarch 5/40
Installing : atk-1.28.0-2.el6.x86_64 6/40
Installing : perl-Astro-SunTime-0.01-1.noarch 7/40
Installing : libSM-1.2.1-2.el6.x86_64 8/40
Installing : jasper-libs-1.900.1-15.el6_1.1.x86_64 9/40
Installing : pixman-0.26.2-5.el6_4.x86_64 10/40
Installing : libXau-1.0.6-4.el6.x86_64 11/40
Installing : libxcb-1.8.1-1.el6.x86_64 12/40
Installing : perl-Device-SerialPort-1.04-5.el6.x86_64 13/40
Installing : libX11-common-1.5.0-4.el6.noarch 14/40
Installing : libX11-1.5.0-4.el6.x86_64 15/40
Installing : libXrender-0.9.7-2.el6.x86_64 16/40
Installing : libXext-1.3.1-2.el6.x86_64 17/40
Installing : cairo-1.8.8-3.1.el6.x86_64 18/40
Installing : libXfixes-5.0-3.el6.x86_64 19/40
Installing : libXi-1.6.1-3.el6.x86_64 20/40
Installing : libXrandr-1.4.0-1.el6.x86_64 21/40
Installing : libXtst-1.2.1-2.el6.x86_64 22/40
Installing : libXdamage-1.1.3-4.el6.x86_64 23/40
Installing : libXcursor-1.1.13-2.el6.x86_64 24/40
Installing : libXinerama-1.1.2-2.el6.x86_64 25/40
Installing : libXft-2.3.1-2.el6.x86_64 26/40
Installing : libXcomposite-0.4.3-4.el6.x86_64 27/40
Installing : alsa-lib-1.0.22-3.el6.x86_64 28/40
Installing : hicolor-icon-theme-0.11-1.1.el6.noarch 29/40
Installing : zip-3.0-1.el6.x86_64 30/40
Installing : libthai-0.1.12-3.el6.x86_64 31/40
Installing : pango-1.28.1-7.el6_3.x86_64 32/40
Installing : gtk2-2.18.9-12.el6.x86_64 33/40
Installing : libart_lgpl-2.3.20-5.1.el6.x86_64 34/40
Installing : libgcj-4.4.7-3.el6.x86_64 35/40
Installing : java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64 36/40
Installing : 1:java_cup-0.10k-5.el6.x86_64 37/40
Installing : sinjdoc-0.5-9.1.el6.x86_64 38/40
Installing : cambozola-0.92-6.el6.noarch 39/40
Installing : perl-X10-0.03-1.noarch 40/40
Verifying : sinjdoc-0.5-9.1.el6.x86_64 1/40
Verifying : gtk2-2.18.9-12.el6.x86_64 2/40
Verifying : libXdamage-1.1.3-4.el6.x86_64 3/40
Verifying : libxcb-1.8.1-1.el6.x86_64 4/40
Verifying : atk-1.28.0-2.el6.x86_64 5/40
Verifying : perl-Astro-SunTime-0.01-1.noarch 6/40
Verifying : libSM-1.2.1-2.el6.x86_64 7/40
Verifying : libart_lgpl-2.3.20-5.1.el6.x86_64 8/40
Verifying : fontconfig-2.8.0-3.el6.x86_64 9/40
Verifying : libthai-0.1.12-3.el6.x86_64 10/40
Verifying : zip-3.0-1.el6.x86_64 11/40
Verifying : hicolor-icon-theme-0.11-1.1.el6.noarch 12/40
Verifying : cairo-1.8.8-3.1.el6.x86_64 13/40
Verifying : freetype-2.3.11-14.el6_3.1.x86_64 14/40
Verifying : cambozola-0.92-6.el6.noarch 15/40
Verifying : libXinerama-1.1.2-2.el6.x86_64 16/40
Verifying : jpackage-utils-1.7.5-3.12.el6.noarch 17/40
Verifying : java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64 18/40
Verifying : libXrender-0.9.7-2.el6.x86_64 19/40
Verifying : libXcomposite-0.4.3-4.el6.x86_64 20/40
Verifying : perl-Time-modules-2006.0814-5.el6.noarch 21/40
Verifying : alsa-lib-1.0.22-3.el6.x86_64 22/40
Verifying : libXi-1.6.1-3.el6.x86_64 23/40
Verifying : libgcj-4.4.7-3.el6.x86_64 24/40
Verifying : libX11-common-1.5.0-4.el6.noarch 25/40
Verifying : perl-X10-0.03-1.noarch 26/40
Verifying : libXft-2.3.1-2.el6.x86_64 27/40
Verifying : libXrandr-1.4.0-1.el6.x86_64 28/40
Verifying : libXcursor-1.1.13-2.el6.x86_64 29/40
Verifying : perl-Device-SerialPort-1.04-5.el6.x86_64 30/40
Verifying : libXtst-1.2.1-2.el6.x86_64 31/40
Verifying : libXfixes-5.0-3.el6.x86_64 32/40
Verifying : libXau-1.0.6-4.el6.x86_64 33/40
Verifying : 1:java_cup-0.10k-5.el6.x86_64 34/40
Verifying : pango-1.28.1-7.el6_3.x86_64 35/40
Verifying : libICE-1.0.6-1.el6.x86_64 36/40
Verifying : pixman-0.26.2-5.el6_4.x86_64 37/40
Verifying : libX11-1.5.0-4.el6.x86_64 38/40
Verifying : libXext-1.3.1-2.el6.x86_64 39/40
Verifying : jasper-libs-1.900.1-15.el6_1.1.x86_64 40/40
Installed:
cambozola.noarch 0:0.92-6.el6 perl-Astro-SunTime.noarch 0:0.01-1
perl-X10.noarch 0:0.03-1
Dependency Installed:
alsa-lib.x86_64 0:1.0.22-3.el6
atk.x86_64 0:1.28.0-2.el6
cairo.x86_64 0:1.8.8-3.1.el6
fontconfig.x86_64 0:2.8.0-3.el6
freetype.x86_64 0:2.3.11-14.el6_3.1
gtk2.x86_64 0:2.18.9-12.el6
hicolor-icon-theme.noarch 0:0.11-1.1.el6
jasper-libs.x86_64 0:1.900.1-15.el6_1.1
java-1.5.0-gcj.x86_64 0:1.5.0.0-29.1.el6
java_cup.x86_64 1:0.10k-5.el6
jpackage-utils.noarch 0:1.7.5-3.12.el6
libICE.x86_64 0:1.0.6-1.el6
libSM.x86_64 0:1.2.1-2.el6
libX11.x86_64 0:1.5.0-4.el6
libX11-common.noarch 0:1.5.0-4.el6
libXau.x86_64 0:1.0.6-4.el6
libXcomposite.x86_64 0:0.4.3-4.el6
libXcursor.x86_64 0:1.1.13-2.el6
libXdamage.x86_64 0:1.1.3-4.el6
libXext.x86_64 0:1.3.1-2.el6
libXfixes.x86_64 0:5.0-3.el6
libXft.x86_64 0:2.3.1-2.el6
libXi.x86_64 0:1.6.1-3.el6
libXinerama.x86_64 0:1.1.2-2.el6
libXrandr.x86_64 0:1.4.0-1.el6
libXrender.x86_64 0:0.9.7-2.el6
libXtst.x86_64 0:1.2.1-2.el6
libart_lgpl.x86_64 0:2.3.20-5.1.el6
libgcj.x86_64 0:4.4.7-3.el6
libthai.x86_64 0:0.1.12-3.el6
libxcb.x86_64 0:1.8.1-1.el6
pango.x86_64 0:1.28.1-7.el6_3
perl-Device-SerialPort.x86_64 0:1.04-5.el6
perl-Time-modules.noarch 0:2006.0814-5.el6
pixman.x86_64 0:0.26.2-5.el6_4
sinjdoc.x86_64 0:0.5-9.1.el6
zip.x86_64 0:3.0-1.el6
Complete!
Installing zoneminder:
[root@atom kfir]# yum localinstall zoneminder-1.26.0beta-2.el6.x86_64.rpm
Loaded plugins: fastestmirror
Setting up Local Package Process
Examining zoneminder-1.26.0beta-2.el6.x86_64.rpm: zoneminder-1.26.0beta-2.el6.x86_64
Marking zoneminder-1.26.0beta-2.el6.x86_64.rpm to be installed
Loading mirror speeds from cached hostfile
* base: centos.syn.co.il
* epel: nl.mirror.eurid.eu
* extras: centos.syn.co.il
* rpmforge: nl.mirror.eurid.eu
* updates: centos.syn.co.il
Resolving Dependencies
--> Running transaction check
---> Package zoneminder.x86_64 0:1.26.0beta-2.el6 will be installed
--> Processing Dependency: ffmpeg <= 0.6.5 for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: ffmpeg >= 0.4.9 for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: httpd for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: libavcodec.so.52(LIBAVCODEC_52)(64bit) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: libavformat.so.52(LIBAVFORMAT_52)(64bit) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: libavutil.so.50(LIBAVUTIL_50)(64bit) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: libswscale.so.0(LIBSWSCALE_0)(64bit) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: mysql-server for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: perl(Archive::Tar) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: perl(Archive::Zip) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: perl(DBD::mysql) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: perl(DBI) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: perl(Date::Manip) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: perl(LWP::UserAgent) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: perl(MIME::Entity) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: perl(MIME::Lite) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: perl(Module::Load) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: perl(Sys::Mmap) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: perl(Time::HiRes) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: php for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: php-mysql for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: libavcodec.so.52()(64bit) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: libavdevice.so.52()(64bit) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: libavformat.so.52()(64bit) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: libavutil.so.50()(64bit) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: libswscale.so.0()(64bit) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Processing Dependency: libx264.so.107()(64bit) for package: zoneminder-1.26.0beta-2.el6.x86_64
--> Running transaction check
---> Package ffmpeg.x86_64 0:0.6.5-1.el6.rf will be installed
--> Processing Dependency: libtheoradec.so.1(libtheoradec_1.0)(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libpostproc.so.51(LIBPOSTPROC_51)(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: a52dec for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libtheoraenc.so.1(libtheoraenc_1.0)(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libspeex.so.1()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libdc1394.so.22()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libSDL-1.2.so.0()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libva.so.1()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libtheoraenc.so.1()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libmp3lame.so.0()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libpostproc.so.51()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libdirac_encoder.so.0()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: librtmp.so.0()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libtheoradec.so.1()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libopencore-amrnb.so.0()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libschroedinger-1.0.so.0()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libopencore-amrwb.so.0()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libfaac.so.0()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
--> Processing Dependency: libgsm.so.1()(64bit) for package: ffmpeg-0.6.5-1.el6.rf.x86_64
---> Package httpd.x86_64 0:2.2.15-29.el6.centos will be installed
---> Package mysql-server.x86_64 0:5.1.69-1.el6_4 will be installed
--> Processing Dependency: mysql = 5.1.69-1.el6_4 for package: mysql-server-5.1.69-1.el6_4.x86_64
---> Package perl-Archive-Tar.x86_64 0:1.58-131.el6_4 will be installed
--> Processing Dependency: perl(Package::Constants) for package: perl-Archive-Tar-1.58-131.el6_4.x86_64
--> Processing Dependency: perl(IO::Zlib) for package: perl-Archive-Tar-1.58-131.el6_4.x86_64
--> Processing Dependency: perl(Compress::Zlib) for package: perl-Archive-Tar-1.58-131.el6_4.x86_64
---> Package perl-Archive-Zip.noarch 0:1.30-2.el6 will be installed
--> Processing Dependency: perl(Compress::Raw::Zlib) for package: perl-Archive-Zip-1.30-2.el6.noarch
---> Package perl-DBD-MySQL.x86_64 0:4.013-3.el6 will be installed
---> Package perl-DBI.x86_64 0:1.609-4.el6 will be installed
---> Package perl-Date-Manip.noarch 0:6.24-1.el6 will be installed
--> Processing Dependency: perl(YAML::Syck) for package: perl-Date-Manip-6.24-1.el6.noarch
---> Package perl-MIME-Lite.noarch 0:3.027-2.el6 will be installed
--> Processing Dependency: perl(MIME::Types) >= 1.28 for package: perl-MIME-Lite-3.027-2.el6.noarch
--> Processing Dependency: perl(Mail::Address) for package: perl-MIME-Lite-3.027-2.el6.noarch
--> Processing Dependency: perl(Email::Date::Format) for package: perl-MIME-Lite-3.027-2.el6.noarch
---> Package perl-MIME-tools.noarch 0:5.427-4.el6 will be installed
--> Processing Dependency: perl(IO::ScalarArray) >= 1.114 for package: perl-MIME-tools-5.427-4.el6.noarch
--> Processing Dependency: perl(IO::ScalarArray) for package: perl-MIME-tools-5.427-4.el6.noarch
--> Processing Dependency: perl(IO::Lines) for package: perl-MIME-tools-5.427-4.el6.noarch
--> Processing Dependency: perl(IO::InnerFile) for package: perl-MIME-tools-5.427-4.el6.noarch
--> Processing Dependency: perl(Convert::BinHex) for package: perl-MIME-tools-5.427-4.el6.noarch
---> Package perl-Module-Load.x86_64 1:0.16-131.el6_4 will be installed
---> Package perl-Sys-Mmap.x86_64 0:0.14-1.el6.rf will be installed
--> Processing Dependency: perl(Test::More) for package: perl-Sys-Mmap-0.14-1.el6.rf.x86_64
---> Package perl-Time-HiRes.x86_64 4:1.9721-131.el6_4 will be installed
---> Package perl-libwww-perl.noarch 0:5.833-2.el6 will be installed
--> Processing Dependency: perl-HTML-Parser >= 3.33 for package: perl-libwww-perl-5.833-2.el6.noarch
--> Processing Dependency: perl(URI::URL) for package: perl-libwww-perl-5.833-2.el6.noarch
--> Processing Dependency: perl(URI::Heuristic) for package: perl-libwww-perl-5.833-2.el6.noarch
--> Processing Dependency: perl(URI) for package: perl-libwww-perl-5.833-2.el6.noarch
--> Processing Dependency: perl(HTML::Entities) for package: perl-libwww-perl-5.833-2.el6.noarch
---> Package php.x86_64 0:5.3.3-23.el6_4 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-5.3.3-23.el6_4.x86_64
--> Processing Dependency: php-cli(x86-64) = 5.3.3-23.el6_4 for package: php-5.3.3-23.el6_4.x86_64
---> Package php-mysql.x86_64 0:5.3.3-23.el6_4 will be installed
--> Processing Dependency: php-pdo(x86-64) for package: php-mysql-5.3.3-23.el6_4.x86_64
---> Package x264.x86_64 0:0.0.0-0.4.20101111.el6.rf will be installed
--> Running transaction check
---> Package SDL.x86_64 0:1.2.14-3.el6 will be installed
---> Package a52dec.x86_64 0:0.7.4-8.el6.rf will be installed
---> Package dirac-libs.x86_64 0:1.0.2-4.el6 will be installed
---> Package faac.x86_64 0:1.26-1.el6.rf will be installed
---> Package ffmpeg-libpostproc.x86_64 0:0.6.5-1.el6.rf will be installed
---> Package gsm.x86_64 0:1.0.13-4.el6 will be installed
---> Package lame.x86_64 0:3.99.5-1.el6.rf will be installed
---> Package libdc1394.x86_64 0:2.1.2-3.4.el6 will be installed
--> Processing Dependency: libusb-1.0.so.0()(64bit) for package: libdc1394-2.1.2-3.4.el6.x86_64
--> Processing Dependency: libraw1394.so.11()(64bit) for package: libdc1394-2.1.2-3.4.el6.x86_64
---> Package librtmp.x86_64 0:2.3-1.el6.rf will be installed
---> Package libtheora.x86_64 1:1.1.0-2.el6 will be installed
--> Processing Dependency: libogg.so.0()(64bit) for package: 1:libtheora-1.1.0-2.el6.x86_64
---> Package libva.x86_64 0:1.0.15-1.el6 will be installed
--> Processing Dependency: mesa-dri-drivers for package: libva-1.0.15-1.el6.x86_64
--> Processing Dependency: libGL.so.1()(64bit) for package: libva-1.0.15-1.el6.x86_64
---> Package mysql.x86_64 0:5.1.69-1.el6_4 will be installed
---> Package opencore-amr.x86_64 0:0.1.2-1.el6.rf will be installed
---> Package perl-Compress-Raw-Zlib.x86_64 1:2.020-131.el6_4 will be installed
---> Package perl-Compress-Zlib.x86_64 0:2.020-131.el6_4 will be installed
--> Processing Dependency: perl(IO::Uncompress::Gunzip) >= 2.020 for package: perl-Compress-Zlib-2.020-131.el6_4.x86_64
--> Processing Dependency: perl(IO::Compress::Gzip::Constants) >= 2.020 for package: perl-Compress-Zlib-2.020-131.el6_4.x86_64
--> Processing Dependency: perl(IO::Compress::Gzip) >= 2.020 for package: perl-Compress-Zlib-2.020-131.el6_4.x86_64
--> Processing Dependency: perl(IO::Compress::Base::Common) >= 2.020 for package: perl-Compress-Zlib-2.020-131.el6_4.x86_64
---> Package perl-Convert-BinHex.noarch 0:1.119-10.1.el6 will be installed
---> Package perl-Email-Date-Format.noarch 0:1.002-5.el6 will be installed
---> Package perl-HTML-Parser.x86_64 0:3.64-2.el6 will be installed
--> Processing Dependency: perl(HTML::Tagset) >= 3.03 for package: perl-HTML-Parser-3.64-2.el6.x86_64
--> Processing Dependency: perl(HTML::Tagset) for package: perl-HTML-Parser-3.64-2.el6.x86_64
---> Package perl-IO-Zlib.x86_64 1:1.09-131.el6_4 will be installed
---> Package perl-IO-stringy.noarch 0:2.110-10.1.el6 will be installed
---> Package perl-MIME-Types.noarch 0:1.28-2.el6 will be installed
---> Package perl-MailTools.noarch 0:2.04-4.el6 will be installed
--> Processing Dependency: perl(Date::Parse) for package: perl-MailTools-2.04-4.el6.noarch
--> Processing Dependency: perl(Date::Format) for package: perl-MailTools-2.04-4.el6.noarch
---> Package perl-Package-Constants.x86_64 1:0.02-131.el6_4 will be installed
---> Package perl-Test-Simple.x86_64 0:0.92-131.el6_4 will be installed
--> Processing Dependency: perl-devel for package: perl-Test-Simple-0.92-131.el6_4.x86_64
---> Package perl-URI.noarch 0:1.40-2.el6 will be installed
---> Package perl-YAML-Syck.x86_64 0:1.07-4.el6 will be installed
---> Package php-cli.x86_64 0:5.3.3-23.el6_4 will be installed
---> Package php-common.x86_64 0:5.3.3-23.el6_4 will be installed
---> Package php-pdo.x86_64 0:5.3.3-23.el6_4 will be installed
---> Package schroedinger.x86_64 0:1.0.10-1.el6.rf will be installed
--> Processing Dependency: liborc-0.4.so.0()(64bit) for package: schroedinger-1.0.10-1.el6.rf.x86_64
---> Package speex.x86_64 0:1.2-0.12.rc1.1.el6 will be installed
--> Running transaction check
---> Package libogg.x86_64 2:1.1.4-2.1.el6 will be installed
---> Package libraw1394.x86_64 0:2.0.4-1.el6 will be installed
---> Package libusb1.x86_64 0:1.0.9-0.6.rc1.el6 will be installed
---> Package mesa-dri-drivers.x86_64 0:9.0-0.8.el6_4.3 will be installed
--> Processing Dependency: mesa-dri1-drivers >= 7.11-6 for package: mesa-dri-drivers-9.0-0.8.el6_4.3.x86_64
--> Processing Dependency: mesa-dri-filesystem(x86-64) for package: mesa-dri-drivers-9.0-0.8.el6_4.3.x86_64
---> Package mesa-libGL.x86_64 0:9.0-0.8.el6_4.3 will be installed
--> Processing Dependency: libXxf86vm.so.1()(64bit) for package: mesa-libGL-9.0-0.8.el6_4.3.x86_64
---> Package orc.x86_64 0:0.4.16-6.el6 will be installed
---> Package perl-HTML-Tagset.noarch 0:3.20-4.el6 will be installed
---> Package perl-IO-Compress-Base.x86_64 0:2.020-131.el6_4 will be installed
---> Package perl-IO-Compress-Zlib.x86_64 0:2.020-131.el6_4 will be installed
---> Package perl-TimeDate.noarch 1:1.16-11.1.el6 will be installed
---> Package perl-devel.x86_64 4:5.10.1-131.el6_4 will be installed
--> Processing Dependency: perl(ExtUtils::ParseXS) for package: 4:perl-devel-5.10.1-131.el6_4.x86_64
--> Processing Dependency: perl(ExtUtils::MakeMaker) for package: 4:perl-devel-5.10.1-131.el6_4.x86_64
--> Processing Dependency: perl(ExtUtils::Installed) for package: 4:perl-devel-5.10.1-131.el6_4.x86_64
--> Running transaction check
---> Package libXxf86vm.x86_64 0:1.1.2-2.el6 will be installed
---> Package mesa-dri-filesystem.x86_64 0:9.0-0.8.el6_4.3 will be installed
---> Package mesa-dri1-drivers.x86_64 0:7.11-8.el6 will be installed
---> Package perl-ExtUtils-MakeMaker.x86_64 0:6.55-131.el6_4 will be installed
--> Processing Dependency: perl(Test::Harness) for package: perl-ExtUtils-MakeMaker-6.55-131.el6_4.x86_64
---> Package perl-ExtUtils-ParseXS.x86_64 1:2.2003.0-131.el6_4 will be installed
--> Running transaction check
---> Package perl-Test-Harness.x86_64 0:3.17-131.el6_4 will be installed
--> Finished Dependency Resolution
Dependencies Resolved
================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
zoneminder x86_64 1.26.0beta-2.el6 /zoneminder-1.26.0beta-2.el6.x86_64
8.3 M
Installing for dependencies:
SDL x86_64 1.2.14-3.el6 base 193 k
a52dec x86_64 0.7.4-8.el6.rf rpmforge 89 k
dirac-libs x86_64 1.0.2-4.el6 epel 335 k
faac x86_64 1.26-1.el6.rf rpmforge 140 k
ffmpeg x86_64 0.6.5-1.el6.rf rpmforge 2.7 M
ffmpeg-libpostproc x86_64 0.6.5-1.el6.rf rpmforge 24 k
gsm x86_64 1.0.13-4.el6 base 27 k
httpd x86_64 2.2.15-29.el6.centos updates 821 k
lame x86_64 3.99.5-1.el6.rf rpmforge 647 k
libXxf86vm x86_64 1.1.2-2.el6 base 22 k
libdc1394 x86_64 2.1.2-3.4.el6 base 117 k
libogg x86_64 2:1.1.4-2.1.el6 base 21 k
libraw1394 x86_64 2.0.4-1.el6 base 53 k
librtmp x86_64 2.3-1.el6.rf rpmforge 106 k
libtheora x86_64 1:1.1.0-2.el6 base 129 k
libusb1 x86_64 1.0.9-0.6.rc1.el6 base 80 k
libva x86_64 1.0.15-1.el6 epel 53 k
mesa-dri-drivers x86_64 9.0-0.8.el6_4.3 updates 4.1 M
mesa-dri-filesystem x86_64 9.0-0.8.el6_4.3 updates 45 k
mesa-dri1-drivers x86_64 7.11-8.el6 base 3.8 M
mesa-libGL x86_64 9.0-0.8.el6_4.3 updates 162 k
mysql x86_64 5.1.69-1.el6_4 updates 907 k
mysql-server x86_64 5.1.69-1.el6_4 updates 8.7 M
opencore-amr x86_64 0.1.2-1.el6.rf rpmforge 417 k
orc x86_64 0.4.16-6.el6 epel 146 k
perl-Archive-Tar x86_64 1.58-131.el6_4 updates 72 k
perl-Archive-Zip noarch 1.30-2.el6 base 107 k
perl-Compress-Raw-Zlib x86_64 1:2.020-131.el6_4 updates 68 k
perl-Compress-Zlib x86_64 2.020-131.el6_4 updates 44 k
perl-Convert-BinHex noarch 1.119-10.1.el6 base 43 k
perl-DBD-MySQL x86_64 4.013-3.el6 base 134 k
perl-DBI x86_64 1.609-4.el6 base 705 k
perl-Date-Manip noarch 6.24-1.el6 base 1.4 M
perl-Email-Date-Format noarch 1.002-5.el6 base 16 k
perl-ExtUtils-MakeMaker x86_64 6.55-131.el6_4 updates 292 k
perl-ExtUtils-ParseXS x86_64 1:2.2003.0-131.el6_4 updates 44 k
perl-HTML-Parser x86_64 3.64-2.el6 base 109 k
perl-HTML-Tagset noarch 3.20-4.el6 base 17 k
perl-IO-Compress-Base x86_64 2.020-131.el6_4 updates 68 k
perl-IO-Compress-Zlib x86_64 2.020-131.el6_4 updates 134 k
perl-IO-Zlib x86_64 1:1.09-131.el6_4 updates 32 k
perl-IO-stringy noarch 2.110-10.1.el6 base 68 k
perl-MIME-Lite noarch 3.027-2.el6 base 82 k
perl-MIME-Types noarch 1.28-2.el6 base 32 k
perl-MIME-tools noarch 5.427-4.el6 base 247 k
perl-MailTools noarch 2.04-4.el6 base 101 k
perl-Module-Load x86_64 1:0.16-131.el6_4 updates 27 k
perl-Package-Constants x86_64 1:0.02-131.el6_4 updates 25 k
perl-Sys-Mmap x86_64 0.14-1.el6.rf rpmforge 47 k
perl-Test-Harness x86_64 3.17-131.el6_4 updates 230 k
perl-Test-Simple x86_64 0.92-131.el6_4 updates 111 k
perl-Time-HiRes x86_64 4:1.9721-131.el6_4 updates 47 k
perl-TimeDate noarch 1:1.16-11.1.el6 base 34 k
perl-URI noarch 1.40-2.el6 base 117 k
perl-YAML-Syck x86_64 1.07-4.el6 base 75 k
perl-devel x86_64 4:5.10.1-131.el6_4 updates 421 k
perl-libwww-perl noarch 5.833-2.el6 base 387 k
php x86_64 5.3.3-23.el6_4 updates 1.1 M
php-cli x86_64 5.3.3-23.el6_4 updates 2.2 M
php-common x86_64 5.3.3-23.el6_4 updates 524 k
php-mysql x86_64 5.3.3-23.el6_4 updates 81 k
php-pdo x86_64 5.3.3-23.el6_4 updates 75 k
schroedinger x86_64 1.0.10-1.el6.rf rpmforge 591 k
speex x86_64 1.2-0.12.rc1.1.el6 base 96 k
x264 x86_64 0.0.0-0.4.20101111.el6.rf rpmforge 1.0 M
Transaction Summary
================================================================================
Install 66 Package(s)
Total size: 43 M
Total download size: 34 M
Installed size: 120 M
Is this ok [y/N]: y
Downloading Packages:
(1/65): SDL-1.2.14-3.el6.x86_64.rpm | 193 kB 00:00
(2/65): a52dec-0.7.4-8.el6.rf.x86_64.rpm | 89 kB 00:00
(3/65): dirac-libs-1.0.2-4.el6.x86_64.rpm | 335 kB 00:00
(4/65): faac-1.26-1.el6.rf.x86_64.rpm | 140 kB 00:00
(5/65): ffmpeg-0.6.5-1.el6.rf.x86_64.rpm | 2.7 MB 00:00
(6/65): ffmpeg-libpostproc-0.6.5-1.el6.rf.x86_64.rpm | 24 kB 00:00
(7/65): gsm-1.0.13-4.el6.x86_64.rpm | 27 kB 00:00
(8/65): httpd-2.2.15-29.el6.centos.x86_64.rpm | 821 kB 00:00
(9/65): lame-3.99.5-1.el6.rf.x86_64.rpm | 647 kB 00:00
(10/65): libXxf86vm-1.1.2-2.el6.x86_64.rpm | 22 kB 00:00
(11/65): libdc1394-2.1.2-3.4.el6.x86_64.rpm | 117 kB 00:00
(12/65): libogg-1.1.4-2.1.el6.x86_64.rpm | 21 kB 00:00
(13/65): libraw1394-2.0.4-1.el6.x86_64.rpm | 53 kB 00:00
(14/65): librtmp-2.3-1.el6.rf.x86_64.rpm | 106 kB 00:00
(15/65): libtheora-1.1.0-2.el6.x86_64.rpm | 129 kB 00:00
(16/65): libusb1-1.0.9-0.6.rc1.el6.x86_64.rpm | 80 kB 00:00
(17/65): libva-1.0.15-1.el6.x86_64.rpm | 53 kB 00:00
(18/65): mesa-dri-drivers-9.0-0.8.el6_4.3.x86_64.rpm | 4.1 MB 00:01
(19/65): mesa-dri-filesystem-9.0-0.8.el6_4.3.x86_64.rpm | 45 kB 00:00
(20/65): mesa-dri1-drivers-7.11-8.el6.x86_64.rpm | 3.8 MB 00:01
(21/65): mesa-libGL-9.0-0.8.el6_4.3.x86_64.rpm | 162 kB 00:00
(22/65): mysql-5.1.69-1.el6_4.x86_64.rpm | 907 kB 00:00
(23/65): mysql-server-5.1.69-1.el6_4.x86_64.rpm | 8.7 MB 00:02
(24/65): opencore-amr-0.1.2-1.el6.rf.x86_64.rpm | 417 kB 00:00
(25/65): orc-0.4.16-6.el6.x86_64.rpm | 146 kB 00:00
(26/65): perl-Archive-Tar-1.58-131.el6_4.x86_64.rpm | 72 kB 00:00
(27/65): perl-Archive-Zip-1.30-2.el6.noarch.rpm | 107 kB 00:00
(28/65): perl-Compress-Raw-Zlib-2.020-131.el6_4.x86_64.r | 68 kB 00:00
(29/65): perl-Compress-Zlib-2.020-131.el6_4.x86_64.rpm | 44 kB 00:00
(30/65): perl-Convert-BinHex-1.119-10.1.el6.noarch.rpm | 43 kB 00:00
(31/65): perl-DBD-MySQL-4.013-3.el6.x86_64.rpm | 134 kB 00:00
(32/65): perl-DBI-1.609-4.el6.x86_64.rpm | 705 kB 00:00
(33/65): perl-Date-Manip-6.24-1.el6.noarch.rpm | 1.4 MB 00:00
(34/65): perl-Email-Date-Format-1.002-5.el6.noarch.rpm | 16 kB 00:00
(35/65): perl-ExtUtils-MakeMaker-6.55-131.el6_4.x86_64.r | 292 kB 00:00
(36/65): perl-ExtUtils-ParseXS-2.2003.0-131.el6_4.x86_64 | 44 kB 00:00
(37/65): perl-HTML-Parser-3.64-2.el6.x86_64.rpm | 109 kB 00:00
(38/65): perl-HTML-Tagset-3.20-4.el6.noarch.rpm | 17 kB 00:00
(39/65): perl-IO-Compress-Base-2.020-131.el6_4.x86_64.rp | 68 kB 00:00
(40/65): perl-IO-Compress-Zlib-2.020-131.el6_4.x86_64.rp | 134 kB 00:00
(41/65): perl-IO-Zlib-1.09-131.el6_4.x86_64.rpm | 32 kB 00:00
(42/65): perl-IO-stringy-2.110-10.1.el6.noarch.rpm | 68 kB 00:00
(43/65): perl-MIME-Lite-3.027-2.el6.noarch.rpm | 82 kB 00:00
(44/65): perl-MIME-Types-1.28-2.el6.noarch.rpm | 32 kB 00:00
(45/65): perl-MIME-tools-5.427-4.el6.noarch.rpm | 247 kB 00:00
(46/65): perl-MailTools-2.04-4.el6.noarch.rpm | 101 kB 00:00
(47/65): perl-Module-Load-0.16-131.el6_4.x86_64.rpm | 27 kB 00:00
(48/65): perl-Package-Constants-0.02-131.el6_4.x86_64.rp | 25 kB 00:00
(49/65): perl-Sys-Mmap-0.14-1.el6.rf.x86_64.rpm | 47 kB 00:00
(50/65): perl-Test-Harness-3.17-131.el6_4.x86_64.rpm | 230 kB 00:00
(51/65): perl-Test-Simple-0.92-131.el6_4.x86_64.rpm | 111 kB 00:00
(52/65): perl-Time-HiRes-1.9721-131.el6_4.x86_64.rpm | 47 kB 00:00
(53/65): perl-TimeDate-1.16-11.1.el6.noarch.rpm | 34 kB 00:00
(54/65): perl-URI-1.40-2.el6.noarch.rpm | 117 kB 00:00
(55/65): perl-YAML-Syck-1.07-4.el6.x86_64.rpm | 75 kB 00:00
(56/65): perl-devel-5.10.1-131.el6_4.x86_64.rpm | 421 kB 00:00
(57/65): perl-libwww-perl-5.833-2.el6.noarch.rpm | 387 kB 00:00
(58/65): php-5.3.3-23.el6_4.x86_64.rpm | 1.1 MB 00:00
(59/65): php-cli-5.3.3-23.el6_4.x86_64.rpm | 2.2 MB 00:00
(60/65): php-common-5.3.3-23.el6_4.x86_64.rpm | 524 kB 00:00
(61/65): php-mysql-5.3.3-23.el6_4.x86_64.rpm | 81 kB 00:00
(62/65): php-pdo-5.3.3-23.el6_4.x86_64.rpm | 75 kB 00:00
(63/65): schroedinger-1.0.10-1.el6.rf.x86_64.rpm | 591 kB 00:01
(64/65): speex-1.2-0.12.rc1.1.el6.x86_64.rpm | 96 kB 00:00
(65/65): x264-0.0.0-0.4.20101111.el6.rf.x86_64.rpm | 1.0 MB 00:00
--------------------------------------------------------------------------------
Total 1.9 MB/s | 34 MB 00:18
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : php-common-5.3.3-23.el6_4.x86_64 1/66
Installing : perl-DBI-1.609-4.el6.x86_64 2/66
Installing : 1:perl-Compress-Raw-Zlib-2.020-131.el6_4.x86_64 3/66
Installing : perl-DBD-MySQL-4.013-3.el6.x86_64 4/66
Installing : mesa-dri-filesystem-9.0-0.8.el6_4.3.x86_64 5/66
Installing : perl-IO-Compress-Base-2.020-131.el6_4.x86_64 6/66
Installing : x264-0.0.0-0.4.20101111.el6.rf.x86_64 7/66
Installing : httpd-2.2.15-29.el6.centos.x86_64 8/66
Installing : perl-IO-Compress-Zlib-2.020-131.el6_4.x86_64 9/66
Installing : perl-Compress-Zlib-2.020-131.el6_4.x86_64 10/66
Installing : 1:perl-IO-Zlib-1.09-131.el6_4.x86_64 11/66
Installing : perl-Archive-Zip-1.30-2.el6.noarch 12/66
Installing : php-pdo-5.3.3-23.el6_4.x86_64 13/66
Installing : php-mysql-5.3.3-23.el6_4.x86_64 14/66
Installing : php-cli-5.3.3-23.el6_4.x86_64 15/66
Installing : php-5.3.3-23.el6_4.x86_64 16/66
Installing : perl-Test-Harness-3.17-131.el6_4.x86_64 17/66
Installing : perl-ExtUtils-MakeMaker-6.55-131.el6_4.x86_64 18/66
Installing : 4:perl-devel-5.10.1-131.el6_4.x86_64 19/66
Installing : 1:perl-ExtUtils-ParseXS-2.2003.0-131.el6_4.x86_64 20/66
Installing : perl-Test-Simple-0.92-131.el6_4.x86_64 21/66
Installing : perl-Sys-Mmap-0.14-1.el6.rf.x86_64 22/66
Installing : SDL-1.2.14-3.el6.x86_64 23/66
Installing : 1:perl-TimeDate-1.16-11.1.el6.noarch 24/66
Installing : perl-MailTools-2.04-4.el6.noarch 25/66
Installing : perl-Convert-BinHex-1.119-10.1.el6.noarch 26/66
Installing : gsm-1.0.13-4.el6.x86_64 27/66
Installing : perl-IO-stringy-2.110-10.1.el6.noarch 28/66
Installing : perl-MIME-tools-5.427-4.el6.noarch 29/66
Installing : perl-HTML-Tagset-3.20-4.el6.noarch 30/66
Installing : perl-HTML-Parser-3.64-2.el6.x86_64 31/66
Installing : speex-1.2-0.12.rc1.1.el6.x86_64 32/66
Installing : orc-0.4.16-6.el6.x86_64 33/66
Installing : schroedinger-1.0.10-1.el6.rf.x86_64 34/66
Installing : perl-URI-1.40-2.el6.noarch 35/66
Installing : perl-libwww-perl-5.833-2.el6.noarch 36/66
Installing : 1:perl-Package-Constants-0.02-131.el6_4.x86_64 37/66
Installing : perl-Archive-Tar-1.58-131.el6_4.x86_64 38/66
Installing : opencore-amr-0.1.2-1.el6.rf.x86_64 39/66
Installing : perl-MIME-Types-1.28-2.el6.noarch 40/66
Installing : libusb1-1.0.9-0.6.rc1.el6.x86_64 41/66
Installing : librtmp-2.3-1.el6.rf.x86_64 42/66
Installing : perl-YAML-Syck-1.07-4.el6.x86_64 43/66
Installing : perl-Date-Manip-6.24-1.el6.noarch 44/66
Installing : faac-1.26-1.el6.rf.x86_64 45/66
Installing : perl-Email-Date-Format-1.002-5.el6.noarch 46/66
Installing : perl-MIME-Lite-3.027-2.el6.noarch 47/66
Installing : 2:libogg-1.1.4-2.1.el6.x86_64 48/66
Installing : 1:libtheora-1.1.0-2.el6.x86_64 49/66
Installing : lame-3.99.5-1.el6.rf.x86_64 50/66
Installing : dirac-libs-1.0.2-4.el6.x86_64 51/66
Installing : libXxf86vm-1.1.2-2.el6.x86_64 52/66
Installing : mesa-dri1-drivers-7.11-8.el6.x86_64 53/66
Installing : mesa-dri-drivers-9.0-0.8.el6_4.3.x86_64 54/66
Installing : mesa-libGL-9.0-0.8.el6_4.3.x86_64 55/66
Installing : libva-1.0.15-1.el6.x86_64 56/66
Installing : libraw1394-2.0.4-1.el6.x86_64 57/66
Installing : libdc1394-2.1.2-3.4.el6.x86_64 58/66
Installing : 4:perl-Time-HiRes-1.9721-131.el6_4.x86_64 59/66
Installing : mysql-5.1.69-1.el6_4.x86_64 60/66
Installing : mysql-server-5.1.69-1.el6_4.x86_64 61/66
Installing : 1:perl-Module-Load-0.16-131.el6_4.x86_64 62/66
Installing : a52dec-0.7.4-8.el6.rf.x86_64 63/66
Installing : ffmpeg-libpostproc-0.6.5-1.el6.rf.x86_64 64/66
Installing : ffmpeg-0.6.5-1.el6.rf.x86_64 65/66
Installing : zoneminder-1.26.0beta-2.el6.x86_64 66/66
Creating and installing a ZoneMinder SELinux policy module. Please wait.
/usr/bin/checkmodule: loading policy configuration from /usr/share/doc/zoneminder-1.26.0beta/local_zoneminder.te
/usr/bin/checkmodule: policy configuration loaded
/usr/bin/checkmodule: writing binary representation (version 10) to /usr/share/doc/zoneminder-1.26.0beta/local_zoneminder.mod
New installs
============
1. Unless you are already using MySQL server, you need to ensure that
the server is confired to start during boot and properly secured
by running:
sudo service mysqld start
/usr/bin/mysql_secure_installation
sudo chkconfig mysqld on
2. Using the password for the root account set during the previous step, you
will need to create the ZoneMinder database:
mysql -uroot -p
mysql> create database zm;
mysql> grant select,insert,update,delete on zm.* to
'zmuser'@localhost identified by 'zmpass';
mysql> exit;
mysql -uroot -p < /usr/share/zoneminder/db/zm_create.sql
mysqladmin -uroot -p reload
3. IMPORTANT: Edit /etc/php.ini and put in the appropriate timezone for
date.timezone!
4. The ZoneMinder web interface is disabled by default, you will need
to edit this file to enable it:
/etc/httpd/conf.d/zoneminder.conf
HINT: Most users will want to simply delete the line that says
"Deny from all".
5. Configure the web server to start automatically:
sudo chkconfig httpd on
sudo service httpd start
6. This package has automatically configured and installed the SELinux policy
module found from the ZoneMinder Wiki:
http://www.zoneminder.com/wiki/index.php/Documentation#Configuring_SELinux_Policy
7. Finally, you may start the ZoneMinder service:
sudo service zoneminder start
Then point your web browser to http://<machine name or ip>/zm
Upgrades
========
1. You will need to upgrade the ZoneMinder database as described in the
manual. This command should be sufficient:
sudo zmupdate.pl --user=root --pass=<mysql root pwd> --version=<from version>
It is recommended to backup your database and then upgrade your tables
to InnoDB when prompted.
Verifying : httpd-2.2.15-29.el6.centos.x86_64 1/66
Verifying : a52dec-0.7.4-8.el6.rf.x86_64 2/66
Verifying : x264-0.0.0-0.4.20101111.el6.rf.x86_64 3/66
Verifying : perl-Date-Manip-6.24-1.el6.noarch 4/66
Verifying : perl-DBD-MySQL-4.013-3.el6.x86_64 5/66
Verifying : schroedinger-1.0.10-1.el6.rf.x86_64 6/66
Verifying : php-pdo-5.3.3-23.el6_4.x86_64 7/66
Verifying : php-mysql-5.3.3-23.el6_4.x86_64 8/66
Verifying : perl-IO-Compress-Zlib-2.020-131.el6_4.x86_64 9/66
Verifying : php-5.3.3-23.el6_4.x86_64 10/66
Verifying : 1:perl-Module-Load-0.16-131.el6_4.x86_64 11/66
Verifying : 1:perl-ExtUtils-ParseXS-2.2003.0-131.el6_4.x86_64 12/66
Verifying : mysql-5.1.69-1.el6_4.x86_64 13/66
Verifying : 4:perl-Time-HiRes-1.9721-131.el6_4.x86_64 14/66
Verifying : 1:libtheora-1.1.0-2.el6.x86_64 15/66
Verifying : perl-Archive-Zip-1.30-2.el6.noarch 16/66
Verifying : libraw1394-2.0.4-1.el6.x86_64 17/66
Verifying : mesa-dri-drivers-9.0-0.8.el6_4.3.x86_64 18/66
Verifying : 4:perl-devel-5.10.1-131.el6_4.x86_64 19/66
Verifying : mesa-dri1-drivers-7.11-8.el6.x86_64 20/66
Verifying : perl-libwww-perl-5.833-2.el6.noarch 21/66
Verifying : libXxf86vm-1.1.2-2.el6.x86_64 22/66
Verifying : php-common-5.3.3-23.el6_4.x86_64 23/66
Verifying : dirac-libs-1.0.2-4.el6.x86_64 24/66
Verifying : lame-3.99.5-1.el6.rf.x86_64 25/66
Verifying : perl-IO-Compress-Base-2.020-131.el6_4.x86_64 26/66
Verifying : mysql-server-5.1.69-1.el6_4.x86_64 27/66
Verifying : perl-MIME-Lite-3.027-2.el6.noarch 28/66
Verifying : libva-1.0.15-1.el6.x86_64 29/66
Verifying : 2:libogg-1.1.4-2.1.el6.x86_64 30/66
Verifying : libdc1394-2.1.2-3.4.el6.x86_64 31/66
Verifying : perl-Email-Date-Format-1.002-5.el6.noarch 32/66
Verifying : mesa-dri-filesystem-9.0-0.8.el6_4.3.x86_64 33/66
Verifying : faac-1.26-1.el6.rf.x86_64 34/66
Verifying : perl-YAML-Syck-1.07-4.el6.x86_64 35/66
Verifying : librtmp-2.3-1.el6.rf.x86_64 36/66
Verifying : php-cli-5.3.3-23.el6_4.x86_64 37/66
Verifying : libusb1-1.0.9-0.6.rc1.el6.x86_64 38/66
Verifying : perl-Test-Harness-3.17-131.el6_4.x86_64 39/66
Verifying : perl-MIME-Types-1.28-2.el6.noarch 40/66
Verifying : opencore-amr-0.1.2-1.el6.rf.x86_64 41/66
Verifying : 1:perl-Compress-Raw-Zlib-2.020-131.el6_4.x86_64 42/66
Verifying : 1:perl-Package-Constants-0.02-131.el6_4.x86_64 43/66
Verifying : perl-ExtUtils-MakeMaker-6.55-131.el6_4.x86_64 44/66
Verifying : perl-URI-1.40-2.el6.noarch 45/66
Verifying : perl-MailTools-2.04-4.el6.noarch 46/66
Verifying : orc-0.4.16-6.el6.x86_64 47/66
Verifying : speex-1.2-0.12.rc1.1.el6.x86_64 48/66
Verifying : perl-HTML-Tagset-3.20-4.el6.noarch 49/66
Verifying : perl-DBI-1.609-4.el6.x86_64 50/66
Verifying : perl-MIME-tools-5.427-4.el6.noarch 51/66
Verifying : perl-IO-stringy-2.110-10.1.el6.noarch 52/66
Verifying : ffmpeg-libpostproc-0.6.5-1.el6.rf.x86_64 53/66
Verifying : zoneminder-1.26.0beta-2.el6.x86_64 54/66
Verifying : mesa-libGL-9.0-0.8.el6_4.3.x86_64 55/66
Verifying : gsm-1.0.13-4.el6.x86_64 56/66
Verifying : perl-Sys-Mmap-0.14-1.el6.rf.x86_64 57/66
Verifying : perl-Convert-BinHex-1.119-10.1.el6.noarch 58/66
Verifying : perl-Archive-Tar-1.58-131.el6_4.x86_64 59/66
Verifying : 1:perl-TimeDate-1.16-11.1.el6.noarch 60/66
Verifying : perl-Compress-Zlib-2.020-131.el6_4.x86_64 61/66
Verifying : perl-Test-Simple-0.92-131.el6_4.x86_64 62/66
Verifying : perl-HTML-Parser-3.64-2.el6.x86_64 63/66
Verifying : ffmpeg-0.6.5-1.el6.rf.x86_64 64/66
Verifying : SDL-1.2.14-3.el6.x86_64 65/66
Verifying : 1:perl-IO-Zlib-1.09-131.el6_4.x86_64 66/66
Installed:
zoneminder.x86_64 0:1.26.0beta-2.el6
Dependency Installed:
SDL.x86_64 0:1.2.14-3.el6
a52dec.x86_64 0:0.7.4-8.el6.rf
dirac-libs.x86_64 0:1.0.2-4.el6
faac.x86_64 0:1.26-1.el6.rf
ffmpeg.x86_64 0:0.6.5-1.el6.rf
ffmpeg-libpostproc.x86_64 0:0.6.5-1.el6.rf
gsm.x86_64 0:1.0.13-4.el6
httpd.x86_64 0:2.2.15-29.el6.centos
lame.x86_64 0:3.99.5-1.el6.rf
libXxf86vm.x86_64 0:1.1.2-2.el6
libdc1394.x86_64 0:2.1.2-3.4.el6
libogg.x86_64 2:1.1.4-2.1.el6
libraw1394.x86_64 0:2.0.4-1.el6
librtmp.x86_64 0:2.3-1.el6.rf
libtheora.x86_64 1:1.1.0-2.el6
libusb1.x86_64 0:1.0.9-0.6.rc1.el6
libva.x86_64 0:1.0.15-1.el6
mesa-dri-drivers.x86_64 0:9.0-0.8.el6_4.3
mesa-dri-filesystem.x86_64 0:9.0-0.8.el6_4.3
mesa-dri1-drivers.x86_64 0:7.11-8.el6
mesa-libGL.x86_64 0:9.0-0.8.el6_4.3
mysql.x86_64 0:5.1.69-1.el6_4
mysql-server.x86_64 0:5.1.69-1.el6_4
opencore-amr.x86_64 0:0.1.2-1.el6.rf
orc.x86_64 0:0.4.16-6.el6
perl-Archive-Tar.x86_64 0:1.58-131.el6_4
perl-Archive-Zip.noarch 0:1.30-2.el6
perl-Compress-Raw-Zlib.x86_64 1:2.020-131.el6_4
perl-Compress-Zlib.x86_64 0:2.020-131.el6_4
perl-Convert-BinHex.noarch 0:1.119-10.1.el6
perl-DBD-MySQL.x86_64 0:4.013-3.el6
perl-DBI.x86_64 0:1.609-4.el6
perl-Date-Manip.noarch 0:6.24-1.el6
perl-Email-Date-Format.noarch 0:1.002-5.el6
perl-ExtUtils-MakeMaker.x86_64 0:6.55-131.el6_4
perl-ExtUtils-ParseXS.x86_64 1:2.2003.0-131.el6_4
perl-HTML-Parser.x86_64 0:3.64-2.el6
perl-HTML-Tagset.noarch 0:3.20-4.el6
perl-IO-Compress-Base.x86_64 0:2.020-131.el6_4
perl-IO-Compress-Zlib.x86_64 0:2.020-131.el6_4
perl-IO-Zlib.x86_64 1:1.09-131.el6_4
perl-IO-stringy.noarch 0:2.110-10.1.el6
perl-MIME-Lite.noarch 0:3.027-2.el6
perl-MIME-Types.noarch 0:1.28-2.el6
perl-MIME-tools.noarch 0:5.427-4.el6
perl-MailTools.noarch 0:2.04-4.el6
perl-Module-Load.x86_64 1:0.16-131.el6_4
perl-Package-Constants.x86_64 1:0.02-131.el6_4
perl-Sys-Mmap.x86_64 0:0.14-1.el6.rf
perl-Test-Harness.x86_64 0:3.17-131.el6_4
perl-Test-Simple.x86_64 0:0.92-131.el6_4
perl-Time-HiRes.x86_64 4:1.9721-131.el6_4
perl-TimeDate.noarch 1:1.16-11.1.el6
perl-URI.noarch 0:1.40-2.el6
perl-YAML-Syck.x86_64 0:1.07-4.el6
perl-devel.x86_64 4:5.10.1-131.el6_4
perl-libwww-perl.noarch 0:5.833-2.el6
php.x86_64 0:5.3.3-23.el6_4
php-cli.x86_64 0:5.3.3-23.el6_4
php-common.x86_64 0:5.3.3-23.el6_4
php-mysql.x86_64 0:5.3.3-23.el6_4
php-pdo.x86_64 0:5.3.3-23.el6_4
schroedinger.x86_64 0:1.0.10-1.el6.rf
speex.x86_64 0:1.2-0.12.rc1.1.el6
x264.x86_64 0:0.0.0-0.4.20101111.el6.rf
Complete!
[root@atom kfir]# service mysqld start
Initializing MySQL database: WARNING: The host 'atom.localdomain' could not be looked up with resolveip.
This probably means that your libc libraries are not 100 % compatible
with this binary MySQL version. The MySQL daemon, mysqld, should work
normally with the exception that host name resolving will not work.
This means that you should use IP addresses instead of hostnames
when specifying MySQL privileges !
Installing MySQL system tables...
OK
Filling help tables...
OK
To start mysqld at boot time you have to copy
support-files/mysql.server to the right place for your system
PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !
To do so, start the server, then issue the following commands:
/usr/bin/mysqladmin -u root password 'new-password'
/usr/bin/mysqladmin -u root -h atom.localdomain password 'new-password'
Alternatively you can run:
/usr/bin/mysql_secure_installation
which will also give you the option of removing the test
databases and anonymous user created by default. This is
strongly recommended for production servers.
See the manual for more instructions.
You can start the MySQL daemon with:
cd /usr ; /usr/bin/mysqld_safe &
You can test the MySQL daemon with mysql-test-run.pl
cd /usr/mysql-test ; perl mysql-test-run.pl
Please report any problems with the /usr/bin/mysqlbug script!
[ OK ]
Starting mysqld: [ OK ]
[root@atom kfir]# /usr/bin/mysql_secure_installation
NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MySQL
SERVERS IN PRODUCTION USE! PLEASE READ EACH STEP CAREFULLY!
In order to log into MySQL to secure it, we'll need the current
password for the root user. If you've just installed MySQL, and
you haven't set the root password yet, the password will be blank,
so you should just press enter here.
Enter current password for root (enter for none): <PRESS ENTER>
OK, successfully used password, moving on...
Setting the root password ensures that nobody can log into the MySQL
root user without the proper authorisation.
Set root password? [Y/n] Y
New password:
Re-enter new password:
Password updated successfully!
Reloading privilege tables..
... Success!
By default, a MySQL installation has an anonymous user, allowing anyone
to log into MySQL without having to have a user account created for
them. This is intended only for testing, and to make the installation
go a bit smoother. You should remove them before moving into a
production environment.
Remove anonymous users? [Y/n] Y
... Success!
Normally, root should only be allowed to connect from 'localhost'. This
ensures that someone cannot guess at the root password from the network.
Disallow root login remotely? [Y/n] Y
... Success!
By default, MySQL comes with a database named 'test' that anyone can
access. This is also intended only for testing, and should be removed
before moving into a production environment.
Remove test database and access to it? [Y/n] Y
- Dropping test database...
... Success!
- Removing privileges on test database...
... Success!
Reloading the privilege tables will ensure that all changes made so far
will take effect immediately.
Reload privilege tables now? [Y/n] Y
... Success!
Cleaning up...
All done! If you've completed all of the above steps, your MySQL
installation should now be secure.
Thanks for using MySQL!
[root@atom kfir]# chkconfig mysqld on
[root@atom kfir]# mysql -uroot -pPASSWORD
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 12
Server version: 5.1.69 Source distribution
Copyright (c) 2000, 2013, Oracle and/or its affiliates. All rights reserved.
Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.
Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
mysql> CREATE DATABASE zm;
Query OK, 1 row affected (0.00 sec)
mysql> GRANT SELECT,INSERT,UPDATE,DELETE on zm.* to 'zmuser'@localhost identified by 'PASSWORD_FOR_ZM_USER';
Query OK, 0 rows affected (0.00 sec)
mysql> exit;
Bye
[root@atom kfir]# mysql -uroot -pPASSWORD < /usr/share/zoneminder/db/zm_create.sql
[root@atom kfir]# mysqladmin -uroot -p reload
Enter password:
[root@atom kfir]# vim /etc/php.ini # Uncomment and change timezone: ;date.timezone = to: date.timezone = "Asia/Jerusalem" for example
[root@atom kfir]# vim /etc/httpd/conf.d/zoneminder.conf # Remove Deny from all line
[root@atom kfir]# chkconfig httpd on # Enable apache to start on startup
[root@atom kfir]# service httpd start # Start apache
Starting httpd: httpd: apr_sockaddr_info_get() failed for atom.localdomain
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
[root@atom kfir]# getenforce
Enforcing
[root@atom kfir]# chkconfig zoneminder on # Enable zoneminder to start on startup
[root@atom kfir]# service zoneminder start # Start ZoneMinder
ERROR 1045 (28000): Access denied for user 'zmuser'@'localhost' (using password: YES)
Starting ZoneMinder: DBI connect('database=zm;host=localhost','zmuser',...) failed: Access denied for user 'zmuser'@'localhost' (using password: YES) at /usr/share/perl5/vendor_perl/ZoneMinder/Config.pm line 89
Can't call method "prepare_cached" on an undefined value at /usr/share/perl5/vendor_perl/ZoneMinder/Config.pm line 91.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/ZoneMinder/Config.pm line 100.
Compilation failed in require at /usr/share/perl5/vendor_perl/ZoneMinder.pm line 33.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/ZoneMinder.pm line 33.
Compilation failed in require at /usr/bin/zmpkg.pl line 37.
BEGIN failed--compilation aborted at /usr/bin/zmpkg.pl line 37.
[FAILED]
[root@atom kfir]# vim /etc/zm.conf # Edit password in zm.conf to match the password for mysql's zmuser
[root@atom kfir]# service zoneminder start
Starting ZoneMinder: [ OK ]
[root@atom kfir]#
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.