Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
bundler unicode
-----> Heroku receiving push
-----> Ruby/Rails app detected
-----> Detected Rails is not set to serve static_assets
Installing rails3_serve_static_assets... done
-----> Configure Rails 3 to disable x-sendfile
Installing rails3_disable_x_sendfile... done
-----> Configure Rails to log to stdout
Installing rails_log_stdout... done
-----> Gemfile detected, running Bundler version 1.0.7
Unresolved dependencies detected; Installing...
Using --without development:test
Fetching source index for http://rubygems.org/
Fetching git://github.com/myfreecomm/hirefire.git
Fetching https://github.com/tapajos/kumade.git
Installing rake (0.8.7)
Installing multi_json (1.0.3)
Installing activesupport (3.1.0.rc6)
Installing bcrypt-ruby (2.1.4) with native extensions
Installing builder (3.0.0)
Installing i18n (0.6.0)
Installing activemodel (3.1.0.rc6)
Installing erubis (2.7.0)
Installing rack (1.3.2)
Installing rack-cache (1.0.2)
Installing rack-mount (0.8.2)
Installing rack-test (0.6.1)
Installing hike (1.2.1)
Installing tilt (1.3.2)
Installing sprockets (2.0.0.beta.13)
Installing actionpack (3.1.0.rc6)
Installing mime-types (1.16)
Installing polyglot (0.3.2)
Installing treetop (1.4.10)
Installing mail (2.3.0)
Installing actionmailer (3.1.0.rc6)
Installing arel (2.2.1)
Installing tzinfo (0.3.29)
Installing activerecord (3.1.0.rc6)
Installing activeresource (3.1.0.rc6)
Installing addressable (2.2.6)
Installing aes (0.4.0)
Installing gyoku (0.4.4)
Installing akami (1.0.0)
Installing xml-simple (1.1.0)
Installing aws-s3 (0.6.2)
Installing brcpfcnpj (3.0.4)
Installing cocaine (0.2.0)
Installing crack (0.1.8)
Installing daemons (1.1.4)
Installing delayed_job (2.1.4)
Installing orm_adapter (0.0.5)
Installing warden (1.0.5)
Installing devise (1.3.4)
Installing multipart-post (1.1.3)
Installing faraday (0.6.1)
Installing fattr (2.2.0)
Installing haml (3.1.2)
Installing launchy (2.0.5)
Installing rest-client (1.6.3)
Installing term-ansicolor (1.0.6)
Installing heroku (2.4.2)
Installing session (3.1.0)
Installing rush (0.6.7)
Using hirefire (0.1.4) from git://github.com/myfreecomm/hirefire.git (at develop)
Installing hoptoad_notifier (2.4.11)
Installing httparty (0.7.8)
Installing httpi (0.9.5)
Installing rack-ssl (1.3.2)
Installing rdoc (3.9.2)
Installing thor (0.14.6)
Installing railties (3.1.0.rc6)
Installing jquery-rails (1.0.13)
Using kumade (0.2.2) from https://github.com/tapajos/kumade.git (at callbacks)
Installing multi_xml (0.2.2)
Installing nokogiri (1.5.0) with native extensions
Installing nori (1.0.2)
Installing oa-core (0.2.6)
Installing oauth (0.4.5)
Installing oauth2 (0.4.1)
Installing oa-oauth (0.2.6)
/usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/specification.rb:519:in `normalize_yaml_input': invalid byte sequence in US-ASCII (ArgumentError)
from /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/specification.rb:479:in `from_yaml'
from /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/package/tar_input.rb:183:in `load_gemspec'
from /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/package/tar_input.rb:51:in `block in initialize'
from /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/package/tar_reader.rb:64:in `block in each'
from /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/package/tar_reader.rb:55:in `loop'
from /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/package/tar_reader.rb:55:in `each'
from /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/package/tar_input.rb:32:in `initialize'
from /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/package/tar_input.rb:17:in `new'
from /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/package/tar_input.rb:17:in `open'
from /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/package.rb:58:in `open'
from /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/format.rb:63:in `from_io'
from /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/format.rb:51:in `block in from_file_by_path'
from /usr/ruby1.9.2/lib/ruby/1.9.1/open-uri.rb:35:in `open'
from /usr/ruby1.9.2/lib/ruby/1.9.1/open-uri.rb:35:in `open'
from /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/format.rb:50:in `from_file_by_path'
from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/source.rb:72:in `fetch'
from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/installer.rb:45:in `block in run'
from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/spec_set.rb:12:in `block in each'
from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/spec_set.rb:12:in `each'
from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/spec_set.rb:12:in `each'
from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/installer.rb:44:in `run'
from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/installer.rb:8:in `install'
from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/cli.rb:225:in `install'
from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/vendor/thor/task.rb:22:in `run'
from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/vendor/thor/invocation.rb:118:in `invoke_task'
from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/vendor/thor.rb:246:in `dispatch'
from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/vendor/thor/base.rb:389:in `start'
from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/bin/bundle:13:in `<top (required)>'
from /usr/ruby1.9.2/bin/bundle:19:in `load'
from /usr/ruby1.9.2/bin/bundle:19:in `<main>'
FAILED: http://devcenter.heroku.com/articles/bundler
! Heroku push rejected, failed to install gems via Bundler
To git@heroku.com:fundos-production.git
! [remote rejected] deploy -> master (pre-receive hook declined)
error: failed to push some refs to 'git@heroku.com:fundos-production.git'
==> ! Failed to force push deploy -> production/master
For some reason bundler is choking on the unicode character in the author's name in this gemspec:
[~] cat omni_auth_myfc_id.gemspec
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = %q{omni_auth_myfc_id}
s.version = "1.0.9.pre"
s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = [%q{Marcos Tapajós}]
s.date = %q{2011-08-18}
s.description = %q{description}
s.email = [%q{marcos@tapajos.me}]
s.files = [
"Rakefile",
"VERSION.yml",
"lib/omni_auth_myfc_id.rb",
"lib/omni_auth_myfc_id/myfcid.rb",
"omni_auth_myfc_id.gemspec",
"spec/omni_auth_myfc_id/myfc_id_spec.rb",
"spec/spec.opts",
"spec/spec_helper.rb"
]
s.homepage = %q{http://myfreecomm.com.br}
s.require_paths = [%q{lib}]
s.rubygems_version = %q{1.8.8}
s.summary = %q{summary}
if s.respond_to? :specification_version then
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<oa-oauth>, ["~> 0.2.6"])
else
s.add_dependency(%q<oa-oauth>, ["~> 0.2.6"])
end
else
s.add_dependency(%q<oa-oauth>, ["~> 0.2.6"])
end
end
@rnaud

This comment has been minimized.

Copy link

@rnaud rnaud commented Sep 30, 2011

Did you get rid of this error ?

@alanho

This comment has been minimized.

Copy link

@alanho alanho commented Nov 23, 2011

workaround: adding this top of Gemfile

if RUBY_VERSION =~ /1.9/
Encoding.default_external = Encoding::UTF_8
Encoding.default_internal = Encoding::UTF_8
end

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment