Skip to content

Instantly share code, notes, and snippets.

@mdesantis
Last active Apr 2, 2017
Embed
What would you like to do?
begin
require "bundler/inline"
rescue LoadError => e
$stderr.puts "Bundler version 1.10 or later is required. Please update your Bundler"
raise e
end
gemfile(true) do
source "https://rubygems.org"
# Activate the gem you are reporting the issue against.
gem "activerecord", "5.1.0.rc1"
gem "sqlite3"
end
require "active_record"
require "minitest/autorun"
require "logger"
# Ensure backward compatibility with Minitest 4
Minitest::Test = MiniTest::Unit::TestCase unless defined?(Minitest::Test)
# This connection will do for database-independent bug reports.
ActiveRecord::Base.establish_connection(adapter: "sqlite3", database: ":memory:")
ActiveRecord::Base.logger = Logger.new(STDOUT)
ActiveRecord::Schema.define do
create_table :contents, force: true do |t|
end
create_table :tags, force: true do |t|
end
create_table :taggings, force: true do |t|
t.references :taggable, polymorphic: true
t.references :tag
end
end
class Content < ActiveRecord::Base
end
class Tagging < ActiveRecord::Base
belongs_to :taggable, polymorphic: true
belongs_to :tag
end
class Tag < ActiveRecord::Base
end
class BugTest < Minitest::Test
def test_association_stuff
Tagging.create! taggable: Content.create!, tag: Tag.create!
end
end
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment