Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?

Install Huginn

  1. Clone the repo

     $ git clone git@github.com:cantino/huginn.git
     $ cd huginn
    
  2. Install Ruby and Ruby Gems (if necessary)

  3. Install rake and bundle (if necesssary):

     $ gem install rake bundle
    
  4. Install Huginn's dependencies

     $ bundle install
    
  5. Install MySQL

  6. Start the MySQL server:

     $ mysql.server start
    
  7. Copy .env.example to .env:

     $ cp .env.example .env
    
  8. Create the APP_SECRET_TOKEN:

     $ rake secret
    
  9. Edit .env, at least updating the APP_SECRET_TOKEN variable we just created.

  10. Create a development MySQL database with some example seed data:

     $ rake db:create
     $ rake db:migrate
     $ rake db:seed
    
  11. All done. Fire up the local server:

     $ foreman start  
    

    Navigate to http://localhost:3000/ and login with the username and the password of "admin" and "password", respectively.

@hopsoft
Copy link

hopsoft commented Jun 2, 2022

Note that HEAD (as of 2022-06-02) will not work with Ruby 3+. I had to downgrade Ruby to version 2.7 to get things working.

@FrostyFraz
Copy link

FrostyFraz commented Aug 26, 2022

I am having issues at step 4.

The install is running in my command prompt (i.e. specifically "Start Command Prompt with Ruby").

I am getting the following output in my cmd:

ruby 3.1.2p20 (2022-04-12 revision 4491bb740a) [x64-mingw-ucrt]
C:\Users\Alex>cd C:\Users\Alex\Documents\Programs\Github\huginn
C:\Users\Alex\Documents\Programs\Github\huginn>bundle install
'grep' is not recognized as an internal or external command,
operable program or batch file.
'grep' is not recognized as an internal or external command,
operable program or batch file.
Fetching gem metadata from https://rubygems.org/.......
Using rake 13.0.6
Using racc 1.6.0
Using ace-rails-ap 2.0.1
Using concurrent-ruby 1.1.10
Using minitest 5.16.3
Using thread_safe 0.3.6
Using zeitwerk 2.6.0
Using builder 3.2.4
Using erubi 1.11.0
Using mini_portile2 2.8.0
Using crass 1.0.6
Using rack 2.2.4
Using nio4r 2.5.8
Using websocket-extensions 0.1.5
Using marcel 1.0.2
Using bundler 2.3.10
Using mini_mime 1.1.2
Using public_suffix 4.0.7
Using net-ssh 6.1.0
Using aws-eventstream 1.2.0
Using capybara-select-2 0.3.2 from https://github.com/Hirurg103/capybara_select2.git (at fbf22fb@fbf22fb)
Using aws-partitions 1.547.0
Using jmespath 1.6.1
Using bcrypt 3.1.16
Using coderay 1.1.3
Using debug_inspector 1.1.0
Using json 2.6.1
Using msgpack 1.4.2
Using kaminari-core 1.2.2
Using method_source 1.0.0
Using thor 0.20.3
Using buftok 0.2.0
Using byebug 11.1.3
Using cliver 0.3.2
Using coffee-script-source 1.12.2
Using execjs 2.8.1
Using dotenv 2.0.1 from source at vendor/gems/dotenv-2.0.1
Using cookiejar 0.3.3
Using docile 1.4.0
Using simplecov-html 0.10.2
Using sync 0.5.0
Using safe_yaml 1.0.4
Using daemons 1.1.9
Using declarative 0.0.20
Using orm_adapter 0.5.0
Using diff-lcs 1.5.0
Using unf_ext 0.0.7.4
Using hashie 3.5.7
Using multi_json 1.15.0
Using multipart-post 2.1.1
Using jwt 2.3.0
Using multi_xml 0.6.0
Using eventmachine 1.2.7
Using http_parser.rb 0.6.0
Using equalizer 0.0.11
Using polyglot 0.3.5
Using ffi 1.15.5
Using evernote-thrift 1.25.1
Using oauth 0.5.8
Using sax-machine 1.3.2
Using rb-fsevent 0.11.0
Using formatador 0.3.0
Using raabro 1.4.0
Using gems 1.2.0
Using geokit 1.13.1
Using memoist 0.16.2
Using os 1.1.4
Using httpclient 2.8.3
Using trailblazer-option 0.1.2
Using uber 0.1.0
Using retriable 3.1.2
Using rexml 3.2.5
Using webrick 1.7.0
Using google-cloud-errors 1.2.0
Using google-protobuf 3.21.5
Using rly 0.2.3
Using lumberjack 1.2.8
Using nenv 0.3.0
Using shellany 0.0.1
Using guard-compat 1.2.1
Using rspec-support 3.8.3
Using hashdiff 0.3.8
Using haversine 0.3.0
Using http-form_data 1.0.1
Using liquid 5.3.0
Using systemu 2.6.4
Using mime-types-data 3.2021.1115
Using mini_magick 4.11.0
Using mqtt 0.3.1
Using naught 1.1.0
Using net-ftp-list 3.2.8
Fetching libv8-node 16.10.0.0
Fetching kgio 2.11.4
Using netrc 0.11.0
Using rr 3.0.9
Using tilt 2.0.10
Fetching mysql2 0.5.3
Using simple_oauth 0.3.1
Using slack-notifier 1.0.0
Using vcr 3.0.3
Using xmpp4r 0.5.6
Fetching raindrops 0.20.0
Using i18n 1.12.0
Using tzinfo 1.2.10
Using nokogiri 1.13.8
Using memoizable 0.4.2
Using rack-test 2.0.2
Using websocket-driver 0.7.5
Using net-scp 3.0.0
Using mail 2.7.1
Using addressable 2.8.0
Using aws-sigv4 1.4.0
Using sprockets 3.7.2
Using warden 1.2.9
Using rack-livereload 0.3.17
Using better_errors 2.9.1
Using binding_of_caller 1.0.0
Using bootsnap 1.9.3
Using coffee-script 2.4.1
Using pry 0.13.1
Using huginn_agent 0.6.1
Using select2-rails 3.5.9.3
Using uglifier 2.7.2
Using simplecov 0.16.1
Using tins 1.31.0
Using crack 0.4.3
Using unf 0.1.4
Using faraday 0.17.4
Using em-socksify 0.3.2
Using em-websocket 0.5.3
Using treetop 1.6.10
Using ethon 0.12.0
Using rb-inotify 0.10.1
Using httparty 0.14.0
Using jsonpath 1.1.0
Using omniauth 1.9.1
Using rb-kqueue 0.2.4
Using sassc 2.3.0
Using evernote_oauth 0.2.3
Using gmail_xoauth 0.4.2
Using representable 3.1.1
Using googleapis-common-protos-types 1.3.0
Using kramdown 2.3.1
Using notiffany 0.1.3
Using twitter-stream 0.1.15 from https://github.com/cantino/twitter-stream.git (at huginn@a80822d)
Using rspec-core 3.8.2
Using rspec-expectations 3.8.6
Using rspec-mocks 3.8.2
Using macaddr 1.7.1
Using mime-types 3.4.1
Using activesupport 6.0.5.1
Using loofah 2.18.0
Using xpath 3.0.0
Using et-orbi 1.2.6
Using sshkit 1.21.2
Using aws-sdk-core 3.125.2
Using launchy 2.5.0
Using pry-byebug 3.9.0
Fetching mimemagic 0.4.3
Using pry-rails 0.3.9
Using term-ansicolor 1.7.1
Using webmock 3.5.1
Using erector 0.10.0 from https://github.com/dsander/erector.git (at rails6@821c2fa)
Using domain_name 0.5.20170404
Using oauth2 1.4.7
Using em-http-request 1.1.7
Using faraday_middleware 0.12.2
Using forecast_io 2.0.1
Using signet 0.16.0
Using google-cloud-env 1.5.0
Using twilio-ruby 5.62.0
Using typhoeus 1.3.1
Using sass-listen 4.0.0
Using listen 3.0.8
Using hipchat 1.2.0
Using omniauth-oauth 1.1.0
Using rails-dom-testing 2.0.3
Using globalid 1.0.0
Fetching grpc 1.42.0
Using activemodel 6.0.5.1
Using delayed_job 4.1.9
Using rspec 3.8.0
Using rspec-collection_matchers 1.2.0
Using uuid 2.3.7
Using shoulda-matchers 4.0.1
Using rails-html-sanitizer 1.4.3
Using airbrussh 1.4.0
Using capybara 2.18.0
Using feedjira 3.2.0
Using fugit 1.5.2
Using aws-sdk-kms 1.53.0
Using letter_opener 1.7.0
Using dropbox-api 0.5.0 from https://github.com/dsander/dropbox-api.git (at 86cb7b5@86cb7b5)
Using coveralls 0.8.23
Using http-cookie 1.0.3
Using omniauth-oauth2 1.7.2
Using tumblr_client 0.8.5 from https://github.com/albertsun/tumblr_client.git (at e046fe6@e046fe6)
Installing libv8-node 16.10.0.0 with native extensions
Installing mimemagic 0.4.3 with native extensions
Installing kgio 2.11.4 with native extensions
Installing raindrops 0.20.0 with native extensions
Installing mysql2 0.5.3 with native extensions
Using googleauth 0.17.1
Using google-cloud-core 1.6.0
Using sass 3.7.4
Using guard 2.18.0
Using omniauth-evernote 1.2.1
Using omniauth-tumblr 1.2
Using omniauth-twitter 1.3.0
Using activejob 6.0.5.1
Using activerecord 6.0.5.1
Using rspec-html-matchers 0.9.4
Using ruby-growl 4.1
Using actionview 6.0.5.1
Using capistrano 3.16.0
Using capybara-screenshot 1.0.17
Using poltergeist 1.8.1
Using aws-sdk-s3 1.111.1
Using rufus-scheduler 3.8.1
Using http 2.1.0
Using dotenv-rails 2.0.1 from source at vendor/gems/dotenv-2.0.1
Using rest-client 2.0.2
Using omniauth-google-oauth2 0.8.2
Using foreman 0.63.0
Using google-apis-core 0.4.1
Using font-awesome-sass 4.7.0
Using guard-livereload 2.5.2
Using guard-rspec 4.7.3
Using delayed_job_active_record 4.1.4 from https://github.com/dsander/delayed_job_active_record.git (at rails6-zeitwerk@ac2dfef)
Using kaminari-activerecord 1.2.2
Using actionpack 6.0.5.1
Using kaminari-actionview 1.2.2
Using capistrano-bundler 2.0.1
Using weibo_2 0.1.7 from https://github.com/albertsun/weibo_2.git (at master@ac38d04)
Using google-apis-discovery_v1 0.7.0
Using actioncable 6.0.5.1
Using activestorage 6.0.5.1
Using actionmailer 6.0.5.1
Using railties 6.0.5.1
Using sprockets-rails 3.4.2
Using rails-controller-testing 1.0.4
Using kaminari 1.2.2
Using capistrano-rails 1.6.1
Using google-apis-generator 0.4.0
Using actionmailbox 6.0.5.1
Using actiontext 6.0.5.1
Using coffee-rails 5.0.0
Using responders 3.0.1
Using jquery-rails 4.2.2
Using letter_opener_web 1.4.1
Using rspec-rails 3.8.2
Using spectrum-rails 1.3.4
Using web-console 3.3.1
Using sassc-rails 2.1.2
Using google-api-client 0.53.0
Using rails 6.0.5.1
Using devise 4.8.1
Using sass-rails 6.0.0
Using bootstrap-kaminari-views 0.0.5
Using geokit-rails 2.3.2
Using rturk 2.12.1
Using omniauth-dropbox-oauth2 0.3.0 from https://github.com/huginn/omniauth-dropbox-oauth2.git (at master@9468fb3)
Using twitter 5.15.0 from https://github.com/sferik/twitter.git (at master@d11707e)
Installing grpc 1.42.0 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
current directory:
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/grpc-1.42.0/src/ruby/ext/grpc
C:/Ruby31-x64/bin/ruby.exe -I C:/Ruby31-x64/lib/ruby/3.1.0 -r
./siteconf20220826-9660-w38par.rb extconf.rb
Generating Makefile for grpc/grpc_c
creating Makefile
current directory:
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/grpc-1.42.0/src/ruby/ext/grpc
make DESTDIR= clean
current directory:
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/grpc-1.42.0/src/ruby/ext/grpc
make DESTDIR=
generating grpc_c-x64-mingw-ucrt.def
compiling rb_byte_buffer.c
In file included from C:/Ruby31-x64/include/ruby-3.1.0/ruby/ruby.h:15,
from rb_byte_buffer.c:19:
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/config.h:137:50: warning:
VA_OPT is not available until C++20
137 | # define RBIMPL_TEST2(...) RBIMPL_TEST3(VA_OPT(,),1,0,0)
| ^
In file included from
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/xmalloc.h:34,
from C:/Ruby31-x64/include/ruby-3.1.0/ruby/defines.h:71,
from C:/Ruby31-x64/include/ruby-3.1.0/ruby/ruby.h:25,
from rb_byte_buffer.c:19:
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/nodiscard.h:35:34: warning:
ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
35 | # define RBIMPL_ATTR_NODISCARD() [[nodiscard]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/xmalloc.h:62:1: note: in
expansion of macro 'RBIMPL_ATTR_NODISCARD'
62 | RBIMPL_ATTR_NODISCARD()
| ^~~~~~~~~~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/nodiscard.h:35:34: warning:
ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
35 | # define RBIMPL_ATTR_NODISCARD() [[nodiscard]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/xmalloc.h:90:1: note: in
expansion of macro 'RBIMPL_ATTR_NODISCARD'
90 | RBIMPL_ATTR_NODISCARD()
| ^~~~~~~~~~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/nodiscard.h:35:34: warning:
ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
35 | # define RBIMPL_ATTR_NODISCARD() [[nodiscard]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/xmalloc.h:121:1: note: in
expansion of macro 'RBIMPL_ATTR_NODISCARD'
121 | RBIMPL_ATTR_NODISCARD()
| ^~~~~~~~~~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/nodiscard.h:35:34: warning:
ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
35 | # define RBIMPL_ATTR_NODISCARD() [[nodiscard]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/xmalloc.h:151:1: note: in
expansion of macro 'RBIMPL_ATTR_NODISCARD'
151 | RBIMPL_ATTR_NODISCARD()
| ^~~~~~~~~~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/nodiscard.h:35:34: warning:
ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
35 | # define RBIMPL_ATTR_NODISCARD() [[nodiscard]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/xmalloc.h:197:1: note: in
expansion of macro 'RBIMPL_ATTR_NODISCARD'
197 | RBIMPL_ATTR_NODISCARD()
| ^~~~~~~~~~~~~~~~~~~~~
In file included from
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/core/rstring.h:30,
from
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/arithmetic/char.h:29,
from
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/arithmetic.h:23,
from C:/Ruby31-x64/include/ruby-3.1.0/ruby/ruby.h:27,
from rb_byte_buffer.c:19:
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h: In function
'RB_OBJ_TAINTABLE':
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h:794:24: warning: unused
parameter 'obj' [-Wunused-parameter]
794 | RB_OBJ_TAINTABLE(VALUE obj)
| ~~~~~~^~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h: In function
'RB_OBJ_TAINTED_RAW':
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h:811:26: warning: unused
parameter 'obj' [-Wunused-parameter]
811 | RB_OBJ_TAINTED_RAW(VALUE obj)
| ~~~~~~^~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h: In function
'RB_OBJ_TAINTED':
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h:828:22: warning: unused
parameter 'obj' [-Wunused-parameter]
828 | RB_OBJ_TAINTED(VALUE obj)
| ~~~~~~^~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h: In function
'RB_OBJ_TAINT_RAW':
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h:843:24: warning: unused
parameter 'obj' [-Wunused-parameter]
843 | RB_OBJ_TAINT_RAW(VALUE obj)
| ~~~~~~^~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h: In function
'RB_OBJ_TAINT':
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h:858:20: warning: unused
parameter 'obj' [-Wunused-parameter]
858 | RB_OBJ_TAINT(VALUE obj)
| ~~~~~~^~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h: In function
'RB_OBJ_INFECT_RAW':
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h:874:25: warning: unused
parameter 'dst' [-Wunused-parameter]
874 | RB_OBJ_INFECT_RAW(VALUE dst, VALUE src)
| ~~~~~~^~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h:874:36: warning: unused
parameter 'src' [-Wunused-parameter]
874 | RB_OBJ_INFECT_RAW(VALUE dst, VALUE src)
| ~~~~~~^~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h: In function
'RB_OBJ_INFECT':
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h:890:21: warning: unused
parameter 'dst' [-Wunused-parameter]
890 | RB_OBJ_INFECT(VALUE dst, VALUE src)
| ~~~~~~^~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/fl_type.h:890:32: warning: unused
parameter 'src' [-Wunused-parameter]
890 | RB_OBJ_INFECT(VALUE dst, VALUE src)
| ~~~~~~^~~
In file included from
C:/Ruby31-x64/include/ruby-3.1.0/ruby/backward/2/attributes.h:38,
from C:/Ruby31-x64/include/ruby-3.1.0/ruby/defines.h:73,
from C:/Ruby31-x64/include/ruby-3.1.0/ruby/ruby.h:25,
from rb_byte_buffer.c:19:
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/rgengc.h: At top level:
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/maybe_unused.h:31:37:
warning: ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
31 | # define RBIMPL_ATTR_MAYBE_UNUSED() [[maybe_unused]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/rgengc.h:365:5: note: in
expansion of macro 'RBIMPL_ATTR_MAYBE_UNUSED'
365 | RBIMPL_ATTR_MAYBE_UNUSED()
| ^~~~~~~~~~~~~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/maybe_unused.h:31:37:
warning: ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
31 | # define RBIMPL_ATTR_MAYBE_UNUSED() [[maybe_unused]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/rgengc.h:367:5: note: in
expansion of macro 'RBIMPL_ATTR_MAYBE_UNUSED'
367 | RBIMPL_ATTR_MAYBE_UNUSED()
| ^~~~~~~~~~~~~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/maybe_unused.h:31:37:
warning: ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
31 | # define RBIMPL_ATTR_MAYBE_UNUSED() [[maybe_unused]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/rgengc.h:393:5: note: in
expansion of macro 'RBIMPL_ATTR_MAYBE_UNUSED'
393 | RBIMPL_ATTR_MAYBE_UNUSED()
| ^~~~~~~~~~~~~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/maybe_unused.h:31:37:
warning: ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
31 | # define RBIMPL_ATTR_MAYBE_UNUSED() [[maybe_unused]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/rgengc.h:396:5: note: in
expansion of macro 'RBIMPL_ATTR_MAYBE_UNUSED'
396 | RBIMPL_ATTR_MAYBE_UNUSED()
| ^~~~~~~~~~~~~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/maybe_unused.h:31:37:
warning: ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
31 | # define RBIMPL_ATTR_MAYBE_UNUSED() [[maybe_unused]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/rgengc.h:398:5: note: in
expansion of macro 'RBIMPL_ATTR_MAYBE_UNUSED'
398 | RBIMPL_ATTR_MAYBE_UNUSED()
| ^~~~~~~~~~~~~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/maybe_unused.h:31:37:
warning: ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
31 | # define RBIMPL_ATTR_MAYBE_UNUSED() [[maybe_unused]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/rgengc.h:428:5: note: in
expansion of macro 'RBIMPL_ATTR_MAYBE_UNUSED'
428 | RBIMPL_ATTR_MAYBE_UNUSED()
| ^~~~~~~~~~~~~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/maybe_unused.h:31:37:
warning: ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
31 | # define RBIMPL_ATTR_MAYBE_UNUSED() [[maybe_unused]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/rgengc.h:430:5: note: in
expansion of macro 'RBIMPL_ATTR_MAYBE_UNUSED'
430 | RBIMPL_ATTR_MAYBE_UNUSED()
| ^~~~~~~~~~~~~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/maybe_unused.h:31:37:
warning: ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
31 | # define RBIMPL_ATTR_MAYBE_UNUSED() [[maybe_unused]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/core/rarray.h:418:24: note: in
expansion of macro 'RBIMPL_ATTR_MAYBE_UNUSED'
418 | RBIMPL_ATTR_MAYBE_UNUSED()
| ^~~~~~~~~~~~~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/maybe_unused.h:31:37:
warning: ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
31 | # define RBIMPL_ATTR_MAYBE_UNUSED() [[maybe_unused]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/core/rarray.h:445:22: note: in
expansion of macro 'RBIMPL_ATTR_MAYBE_UNUSED'
445 | RBIMPL_ATTR_MAYBE_UNUSED()
| ^~~~~~~~~~~~~~~~~~~~~~~~
In file included from C:/Ruby31-x64/include/ruby-3.1.0/ruby/ruby.h:44,
from rb_byte_buffer.c:19:
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/newobj.h: In function
'rb_clone_setup':
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/newobj.h:173:22: warning: unused
parameter 'clone' [-Wunused-parameter]
173 | rb_clone_setup(VALUE clone, VALUE obj)
| ~~~~~~^~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/newobj.h:173:35: warning: unused
parameter 'obj' [-Wunused-parameter]
173 | rb_clone_setup(VALUE clone, VALUE obj)
| ~~~~~~^~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/newobj.h: In function
'rb_dup_setup':
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/newobj.h:190:20: warning: unused
parameter 'dup' [-Wunused-parameter]
190 | rb_dup_setup(VALUE dup, VALUE obj)
| ~~~~~~^~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/newobj.h:190:31: warning: unused
parameter 'obj' [-Wunused-parameter]
190 | rb_dup_setup(VALUE dup, VALUE obj)
| ~~~~~~^~~
In file included from
C:/Ruby31-x64/include/ruby-3.1.0/ruby/backward/2/attributes.h:38,
from C:/Ruby31-x64/include/ruby-3.1.0/ruby/defines.h:73,
from C:/Ruby31-x64/include/ruby-3.1.0/ruby/ruby.h:25,
from rb_byte_buffer.c:19:
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/scan_args.h: At top level:
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/maybe_unused.h:31:37:
warning: ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
31 | # define RBIMPL_ATTR_MAYBE_UNUSED() [[maybe_unused]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/backward/2/attributes.h:163:28: note: in
expansion of macro 'RBIMPL_ATTR_MAYBE_UNUSED'
163 | #define RB_UNUSED_VAR(x) x RBIMPL_ATTR_MAYBE_UNUSED()
| ^~~~~~~~~~~~~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/scan_args.h:391:33: note: in
expansion of macro 'RB_UNUSED_VAR'
391 | VALUE *vars[], RB_UNUSED_VAR(const char *fmt),
RB_UNUSED_VAR(int varc))
| ^~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/attr/maybe_unused.h:31:37:
warning: ISO C does not support '[[]]' attributes before C2X [-Wpedantic]
31 | # define RBIMPL_ATTR_MAYBE_UNUSED() [[maybe_unused]]
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/backward/2/attributes.h:163:28: note: in
expansion of macro 'RBIMPL_ATTR_MAYBE_UNUSED'
163 | #define RB_UNUSED_VAR(x) x RBIMPL_ATTR_MAYBE_UNUSED()
| ^~~~~~~~~~~~~~~~~~~~~~~~
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/scan_args.h:391:65: note: in
expansion of macro 'RB_UNUSED_VAR'
391 | VALUE *vars[], RB_UNUSED_VAR(const char *fmt),
RB_UNUSED_VAR(int varc))
|
^~~~~~~~~~~~~
In file included from C:/Ruby31-x64/include/ruby-3.1.0/ruby/ruby.h:46,
from rb_byte_buffer.c:19:
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/scan_args.h:502:41: warning:
VA_OPT is not available until C++20
502 | (rb_scan_args)(argc, argvp, fmt VA_OPT(, VA_ARGS)))
| ^
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/scan_args.h:510:53: warning:
VA_OPT is not available until C++20
510 | (rb_scan_args_kw)(kw_flag, argc, argvp, fmt VA_OPT(,
VA_ARGS)))
| ^
In file included from rb_grpc.h:24,
from rb_byte_buffer.c:23:
C:/Ruby31-x64/msys64/ucrt64/include/sys/time.h:42:13: error: conflicting types
for 'gettimeofday'; have 'int(struct timeval * restrict, void * restrict)'
42 | int __cdecl gettimeofday(struct timeval *restrict,
| ^~~~~~~~~~~~
In file included from
C:/Ruby31-x64/include/ruby-3.1.0/ruby/internal/dosish.h:38,
from C:/Ruby31-x64/include/ruby-3.1.0/ruby/defines.h:78,
from C:/Ruby31-x64/include/ruby-3.1.0/ruby/ruby.h:25,
from rb_byte_buffer.c:19:
C:/Ruby31-x64/include/ruby-3.1.0/ruby/win32.h:304:12: note: previous declaration
of 'gettimeofday' with type 'int(struct timeval *, struct timezone *)'
304 | extern int gettimeofday(struct timeval *, struct timezone *);
| ^~~~~~~~~~~~
make: *** [Makefile:248: rb_byte_buffer.o] Error 1
make failed, exit code 2
Gem files will remain installed in
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/grpc-1.42.0 for inspection.
Results logged to
C:/Ruby31-x64/lib/ruby/gems/3.1.0/extensions/x64-mingw-ucrt/3.1.0/grpc-1.42.0/gem_make.out
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:95:in run' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:44:in block in make'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:36:in each' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:36:in make'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/ext_conf_builder.rb:63:in block in build' C:/Ruby31-x64/lib/ruby/3.1.0/tempfile.rb:317:in open'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/ext_conf_builder.rb:26:in build' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:161:in build_extension'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:195:in block in build_extensions' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:192:in each'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:192:in build_extensions' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/installer.rb:853:in build_extensions'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/rubygems_gem_installer.rb:71:in
build_extensions' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/rubygems_gem_installer.rb:28:in install'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/source/rubygems.rb:204:in
install' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/gem_installer.rb:54:in install'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/gem_installer.rb:16:in
install_from_spec' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/parallel_installer.rb:186:in do_install'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/parallel_installer.rb:177:in
block in worker_pool' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:62:in apply_func'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:57:in
block in process_queue' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:54:in loop'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:54:in
process_queue' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:91:in block (2 levels) in create_threads'
An error occurred while installing grpc (1.42.0), and Bundler cannot continue.
In Gemfile:
google-cloud-translate was resolved to 2.3.0, which depends on
google-gax was resolved to 1.8.2, which depends on
googleapis-common-protos was resolved to 1.3.12, which depends on
grpc
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
current directory:
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/mimemagic-0.4.3/ext/mimemagic
C:/Ruby31-x64/bin/ruby.exe -IC:/Ruby31-x64/lib/ruby/3.1.0 -rrubygems
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/rake-13.0.6/exe/rake
RUBYARCHDIR=C:/Ruby31-x64/lib/ruby/gems/3.1.0/extensions/x64-mingw-ucrt/3.1.0/mimemagic-0.4.3
RUBYLIBDIR=C:/Ruby31-x64/lib/ruby/gems/3.1.0/extensions/x64-mingw-ucrt/3.1.0/mimemagic-0.4.3
rake aborted!
Could not find MIME type database in the following locations:
["/usr/local/share/mime/packages/freedesktop.org.xml",
/opt/homebrew/share/mime/packages/freedesktop.org.xml,
/opt/local/share/mime/packages/freedesktop.org.xml,
/usr/share/mime/packages/freedesktop.org.xml]
Ensure you have either installed the shared-mime-info package for your
distribution, or
obtain a version of freedesktop.org.xml and set FREEDESKTOP_MIME_TYPES_PATH to
the location
of that file.
Tasks: TOP => default
(See full trace by running task with --trace)
rake failed, exit code 1
Gem files will remain installed in
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/mimemagic-0.4.3 for inspection.
Results logged to
C:/Ruby31-x64/lib/ruby/gems/3.1.0/extensions/x64-mingw-ucrt/3.1.0/mimemagic-0.4.3/gem_make.out
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:95:in run' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/rake_builder.rb:28:in build'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:161:in build_extension' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:195:in block in
build_extensions'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:192:in each' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:192:in build_extensions'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/installer.rb:853:in build_extensions' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/rubygems_gem_installer.rb:71:in build_extensions'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/rubygems_gem_installer.rb:28:in
install' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/source/rubygems.rb:204:in install'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/gem_installer.rb:54:in
install' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/gem_installer.rb:16:in install_from_spec'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/parallel_installer.rb:186:in
do_install' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/parallel_installer.rb:177:in block in worker_pool'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:62:in
apply_func' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:57:in block in process_queue'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:54:in
loop' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:54:in process_queue'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:91:in
block (2 levels) in create_threads' An error occurred while installing mimemagic (0.4.3), and Bundler cannot continue. In Gemfile: hypdf was resolved to 1.0.10, which depends on httmultiparty was resolved to 0.3.16, which depends on mimemagic Gem::Ext::BuildError: ERROR: Failed to build gem native extension. current directory: C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/libv8-node-16.10.0.0/ext/libv8-node C:/Ruby31-x64/bin/ruby.exe -I C:/Ruby31-x64/lib/ruby/3.1.0 -r ./siteconf20220826-9660-n57b8c.rb extconf.rb creating Makefile C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/libv8-node-16.10.0.0/ext/libv8-node/builder.rb:12:in build_libv8!': failed to download node 16.10.0 (Libv8::Node::BuilderError)
from
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/libv8-node-16.10.0.0/ext/libv8-node/location.rb:30:in
install!' from extconf.rb:9:in

'
==== in
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/libv8-node-16.10.0.0/ext/libv8-node
==== running
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/libv8-node-16.10.0.0/libexec/download-node
extconf failed, exit code 1
Gem files will remain installed in
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/libv8-node-16.10.0.0 for inspection.
Results logged to
C:/Ruby31-x64/lib/ruby/gems/3.1.0/extensions/x64-mingw-ucrt/3.1.0/libv8-node-16.10.0.0/gem_make.out
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:95:in run' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/ext_conf_builder.rb:47:in block in
build'
C:/Ruby31-x64/lib/ruby/3.1.0/tempfile.rb:317:in open' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/ext_conf_builder.rb:26:in build'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:161:in build_extension' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:195:in block in
build_extensions'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:192:in each' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:192:in build_extensions'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/installer.rb:853:in build_extensions' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/rubygems_gem_installer.rb:71:in build_extensions'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/rubygems_gem_installer.rb:28:in
install' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/source/rubygems.rb:204:in install'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/gem_installer.rb:54:in
install' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/gem_installer.rb:16:in install_from_spec'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/parallel_installer.rb:186:in
do_install' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/parallel_installer.rb:177:in block in worker_pool'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:62:in
apply_func' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:57:in block in process_queue'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:54:in
loop' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:54:in process_queue'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:91:in
block (2 levels) in create_threads' An error occurred while installing libv8-node (16.10.0.0), and Bundler cannot continue. In Gemfile: mini_racer was resolved to 0.6.2, which depends on libv8-node Gem::Ext::BuildError: ERROR: Failed to build gem native extension. current directory: C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/raindrops-0.20.0/ext/raindrops C:/Ruby31-x64/bin/ruby.exe -I C:/Ruby31-x64/lib/ruby/3.1.0 -r ./siteconf20220826-9660-81o5qm.rb extconf.rb checking for mmap() in sys/mman.h... no mmap() not found *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. Check the mkmf.log file for more details. You may need configuration options. Provided configuration options: --with-opt-dir --without-opt-dir --with-opt-include --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=C:/Ruby31-x64/bin/$(RUBY_BASE_NAME) --with-atomic_ops-dir --without-atomic_ops-dir --with-atomic_ops-include --without-atomic_ops-include=${atomic_ops-dir}/include --with-atomic_ops-lib --without-atomic_ops-lib=${atomic_ops-dir}/lib To see why this extension failed to compile, please check the mkmf.log which can be found here: C:/Ruby31-x64/lib/ruby/gems/3.1.0/extensions/x64-mingw-ucrt/3.1.0/raindrops-0.20.0/mkmf.log extconf failed, exit code 1 Gem files will remain installed in C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/raindrops-0.20.0 for inspection. Results logged to C:/Ruby31-x64/lib/ruby/gems/3.1.0/extensions/x64-mingw-ucrt/3.1.0/raindrops-0.20.0/gem_make.out C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:95:in run'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/ext_conf_builder.rb:47:in block in build' C:/Ruby31-x64/lib/ruby/3.1.0/tempfile.rb:317:in open'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/ext_conf_builder.rb:26:in build' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:161:in build_extension'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:195:in block in build_extensions' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:192:in each'
C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:192:in build_extensions' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/installer.rb:853:in build_extensions'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/rubygems_gem_installer.rb:71:in
build_extensions' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/rubygems_gem_installer.rb:28:in install'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/source/rubygems.rb:204:in
install' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/gem_installer.rb:54:in install'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/gem_installer.rb:16:in
install_from_spec' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/parallel_installer.rb:186:in do_install'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/installer/parallel_installer.rb:177:in
block in worker_pool' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:62:in apply_func'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:57:in
block in process_queue' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:54:in loop'
C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:54:in
process_queue' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.10/lib/bundler/worker.rb:91:in block (2 levels) in create_threads'
An error occurred while installing raindrops (0.20.0), and Bundler cannot
continue.
In Gemfile:
unicorn was resolved to 6.1.0, which depends on
raindrops
C:\Users\Alex\Documents\Programs\Github\huginn>
An error occurred while installing raindrops (0.20.0), and Bundler cannot
continue.
In Gemfile:
unicorn was resolved to 6.1.0, which depends on
raindrops

So, that is the result of my cmd. Here is the result of the mkmf.log file that it told me to check out:

tinywow_Huggin Step 4 Issue 1_4849141_1
tinywow_Huggin Step 4 Issue 1_4849141_2
tinywow_Huggin Step 4 Issue 1_4849141_3

I know the picture is not in the best format, but any and all help would be appreciated!
Thank you!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment