Skip to content

Instantly share code, notes, and snippets.

@mrcodedev
Last active December 31, 2023 00:56
Show Gist options
  • Star 10 You must be signed in to star a gist
  • Fork 1 You must be signed in to fork a gist
  • Save mrcodedev/37b463ae63c0c1d762e6efaf4c26af4f to your computer and use it in GitHub Desktop.
Save mrcodedev/37b463ae63c0c1d762e6efaf4c26af4f to your computer and use it in GitHub Desktop.
Como instalar Expo (React Native)

Instalación Expo para React Native

Instalando Expo

Primero instalamos con npm explo-cli y exp (debemos de tener Node.js y npm instalados)

npm install -g expo-cli exp

Después creamos nuestra zona de trabajo, le decimos como se quiere llamar la carpeta:

expo init nombreApp

Una vez que tengamos la carpeta nos metemos dentro:

cd nombreApp

Una vez dentro ya arrancamos Expo:

expo start

Ya podremos utilizar un emulador de Android o iOS o con la app de Expo ver la app en el móvil

@matiassrusso
Copy link

Me tira el siguiente error al intentar iniciar. Osea, instala bien, pero a su vez no. No me deja iniciar, ni chequear la version ni hacer nada:

expo : El término 'expo' no se reconoce como nombre de un cmdlet, función, archivo de script o programa ejecutable. Compruebe si escribió correctamente el nombre o, si incluyó una ruta de acceso, compruebe que dicha ruta es correcta e inténtelo de nuevo.
En línea: 1 Carácter: 1

  • expo start
  •   + CategoryInfo          : ObjectNotFound: (expo:String) [], CommandNotFoundException
      + FullyQualifiedErrorId : CommandNotFoundException
    

@ignacioborraz
Copy link

Tuve el mismo error ### ruxxit0
instale expo, limpié caché vaaarias veces y sigue sin reconocerlo... no me funciona ni siquiera expo -v

@cadmojose
Copy link

PS C:\Users\Cadmo Antunes> expo init MEON
expo : O arquivo C:\Users\Cadmo Antunes\AppData\Roaming\npm\expo.ps1 não pode ser carregado porque a execução de scripts foi desabilitada neste sistema. Para obter mais
informações, consulte about_Execution_Policies em https://go.microsoft.com/fwlink/?LinkID=135170.
No linha:1 caractere:1

  • expo init MEON
  •   + CategoryInfo          : ErrodeSegurança: (:) [], PSSecurityException
    

PS C:\Users\Cadmo Antunes> node --version
v18.12.1
PS C:\Users\Cadmo Antunes> expo init my-projeto
expo : O arquivo C:\Users\Cadmo Antunes\AppData\Roaming\npm\expo.ps1 não pode ser carregado porque a execução de scripts foi desabilitada neste sistema. Para obter mais
informações, consulte about_Execution_Policies em https://go.microsoft.com/fwlink/?LinkID=135170.
No linha:1 caractere:1

  • expo init my-projeto
    • CategoryInfo : ErrodeSegurança: (:) [], PSSecurityException
    • FullyQualifiedErrorId : UnauthorizedAccess
      PS C:\Users\Cadmo Antunes> expo --version
      expo : O arquivo C:\Users\Cadmo Antunes\AppData\Roaming\npm\expo.ps1 não pode ser carregado porque a execução de scripts foi desabilitada neste sistema. Para obter mais ra obter mais
      informações, consulte about_Execution_Policies em https://go.microsoft.com/fwlink/?LinkID=135170.
      No linha:1 caractere:1
  • expo --version
  •   + CategoryInfo          : ErrodeSegurança: (:) [], PSSecurityException
      + FullyQualifiedErrorId : UnauthorizedAccess
    
    
    
    

alguem sab q erro e este. instalei o expo mais parece q não deu certo

@IgnacioBarocchi
Copy link

IgnacioBarocchi commented Feb 20, 2023

**Edit:
Lo solucioné instalando la última versión de node con nvm, después actualicé npm. Eliminé reinstalé node modules en el proyecto.

nvm install 19.6.1 && nvm use 19.6.1 && npm install -g npm@latest

en el proyecto

rm -r node_modules && npm install**

Hola! tengo un problema que solo me ocurre en Ubuntu (20.04.5 LTS). Al hacer npm start el linter encuentra un error de sintaxis en módulo de expo, algo que no me ocurre cuando trabajo el repo en windows.
Este es el error:

<APP_NAME>@1.0.0 start /home/<USER_NAME>/Documents/projects/<APP_NAME>
expo start

(node:10592) UnhandledPromiseRejectionWarning: /home/<USER_NAME>/Documents/projects/<APP_NAME>/node_modules/@expo/cli/build/src/api/rest/client.js:26
    name = "ApiV2Error";
         ^

SyntaxError: Unexpected token =
    at Module._compile (internal/modules/cjs/loader.js:723:23)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
    at Module.load (internal/modules/cjs/loader.js:653:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
    at Function.Module._load (internal/modules/cjs/loader.js:585:3)
    at Module.require (internal/modules/cjs/loader.js:692:17)
    at require (internal/modules/cjs/helpers.js:25:18)
    at Object.<anonymous> (/home/<USER_NAME>/Documents/projects/<APP_NAME>/node_modules/@expo/cli/build/src/api/getExpoGoIntermediateCertificate.js:7:15)
    at Module._compile (internal/modules/cjs/loader.js:778:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
(node:10592) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:10592) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
(node:10592) UnhandledPromiseRejectionWarning: /home/<USER_NAME>/Documents/projects/<APP_NAME>/node_modules/@expo/cli/build/src/api/rest/client.js:26
    name = "ApiV2Error";
         ^

SyntaxError: Unexpected token =
    at Module._compile (internal/modules/cjs/loader.js:723:23)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
    at Module.load (internal/modules/cjs/loader.js:653:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
    at Function.Module._load (internal/modules/cjs/loader.js:585:3)
    at Module.require (internal/modules/cjs/loader.js:692:17)
    at require (internal/modules/cjs/helpers.js:25:18)
    at Object.<anonymous> (/home/<USER_NAME>/Documents/projects/<APP_NAME>/node_modules/@expo/cli/build/src/api/getExpoGoIntermediateCertificate.js:7:15)
    at Module._compile (internal/modules/cjs/loader.js:778:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
(node:10592) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 3)

esta es la parte del módulo /home/<USER_NAME>/Documents/projects/<APP_NAME>/node_modules/@expo/cli/build/src/api/rest/client.js

class ApiV2Error extends Error {
    name = "ApiV2Error";
    constructor(response){
        super(response.message);
        this.code = response.code;
        this.expoApiV2ErrorCode = response.code;
        this.expoApiV2ErrorDetails = response.details;
        this.expoApiV2ErrorServerStack = response.stack;
        this.expoApiV2ErrorMetadata = response.metadata;
    }
}

Alguna idea?

@amari21
Copy link

amari21 commented May 9, 2023

¡Hola! A mí me sucede lo siguiente después de intentar instalar:

npm WARN deprecated @npmcli/move-file@1.1.2: This functionality has been moved to @npmcli/fs
npm WARN deprecated stable@0.1.8: Modern JS already guarantees Array#sort() is a stable sort, so this library is deprecated. See the compatibility table on MDN: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/sort#browser_compatibility
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.

added 1173 packages in 28s

104 packages are looking for funding
  run `npm fund` for details

Busqué en varios foros, pero nada me funciona :')

@fer060890
Copy link

a mi tambien me sale lo mismo

@Isa-josep
Copy link

tengo un problema hace como unos 5 meses ya usaba react native y funcionaba bien, lo quise usar y me decia que intalara expo-cli lo hice con
npm install -g expo-cli y lo deje instalando por casi 12 horas y nunca termino, mi conexión de internet es buena no se si me puedan ayudar

@ayrtoncu
Copy link

Tengo una problema para trabajar React Native, no puedo hacer la creacion del proyecto.
Este es el Error que me sale:
´´´
× Something went wrong in downloading and extracting the project files: Could not parse JSON returned from "npm.cmd pack expo-template-blank@latest --dry-run".

expo-template-blank-49.0.22.tgz

Error: Unexpected token 'e', "expo-templ"... is not valid JSON
Error: Could not parse JSON returned from "npm.cmd pack expo-template-blank@latest --dry-run".

expo-template-blank-49.0.22.tgz

Error: Unexpected token 'e', "expo-templ"... is not valid JSON
´´´
Ya reintente de todo, actualice el Node, el npm, desinstale el node y todo. Pero sigo teniendo el mismo error. Alguien puede ayudarme?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment