Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Install Vowpal Wabbit on Mac OS X Lion

The INSTALL instructions that come with Vowpal Wabbit appear not to work on Mac OS X Lion. Here's what I did to get it to compile. You will need the developer tools that come with the XCode installation.

The only dependency VW has is the boost C++ library. So first, download and install Boost

To install Boost, do the following:

$ cp ~/Downloads/boost_1_48_0.tar.bz2 ./
$ tar xfj boost_1_48_0.tar.bz2
$ cd boost_1_48_0
$ ./bootstrap.sh					# Install defaults to /usr/local
$ sudo ./b2 install

To install VW, do the following:

$  git clone https://github.com/JohnLangford/vowpal_wabbit.git
$ autoreconf --force --install		# Options copy any needed autoconf files to local
$ ./configure
$ make
$ make install
$ vw --help
@davidrosenberg
Copy link

davidrosenberg commented Mar 21, 2012

I had to install some stuff to get autoreconf to run. I used brew:
brew install automake
brew install libtool
I also used brew to install boost:
brew install boost
brew install boost-build
Then worked great -- thanks!

@chintan09
Copy link

chintan09 commented Nov 29, 2013

Thanks for the tip! I had to install automake, libtool, boost via macports and it worked well.

@CindiThompsonUSF
Copy link

CindiThompsonUSF commented Feb 22, 2015

This was the magic post I needed! Thanks so much.

@asimjalis
Copy link

asimjalis commented Sep 7, 2016

Thanks. That worked.

Here is the full script (adding David Rosenberg’s brew steps):

# Install prereqs
brew install automake
brew install libtool
brew install boost
brew install boost-build

# Install VW
git clone https://github.com/JohnLangford/vowpal_wabbit.git
cd vowpal_wabbit
autoreconf --force --install
./configure
make
make install

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment