Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Error setting up kubernetes with vagrant.
➜ kubernetes ./cluster/kube-up.sh
Starting cluster using provider: vagrant
... calling verify-prereqs
... calling kube-up
Using credentials: vagrant:vagrant
Bringing machine 'master' up with 'virtualbox' provider...
Bringing machine 'minion-1' up with 'virtualbox' provider...
==> master: Importing base box 'kube-fedora21'...
==> master: Matching MAC address for NAT networking...
==> master: Setting the name of the VM: kubernetes_master_1438188958419_38582
==> master: Clearing any previously set network interfaces...
==> master: Preparing network interfaces based on configuration...
master: Adapter 1: nat
master: Adapter 2: hostonly
==> master: Forwarding ports...
master: 22 => 2222 (adapter 1)
==> master: Running 'pre-boot' VM customizations...
==> master: Booting VM...
==> master: Waiting for machine to boot. This may take a few minutes...
master: SSH address: 127.0.0.1:2222
master: SSH username: vagrant
master: SSH auth method: private key
master: Warning: Connection timeout. Retrying...
master:
master: Vagrant insecure key detected. Vagrant will automatically replace
master: this with a newly generated keypair for better security.
master:
master: Inserting generated public key within guest...
master: Removing insecure key from the guest if it's present...
master: Key inserted! Disconnecting and reconnecting using new SSH key...
==> master: Machine booted and ready!
==> master: Checking for guest additions in VM...
==> master: Configuring and enabling network interfaces...
==> master: Mounting shared folders...
master: /vagrant => /Users/smithm/kubernetes
==> master: Running provisioner: shell...
master: Running: /var/folders/rt/phr89yfj2fl206jtk0l86724th0_1v/T/vagrant-shell20150729-37703-109wswb.sh
==> master: Adding kubernetes-minion-1 to hosts file
==> master: Verifying network configuration
==> master: It looks like the required network bridge has not yet been created
==> master: Installing, enabling prerequisites
==> master:
==> master:
==> master: One of the configured repositories failed (Fedora 21 - x86_64),
==> master: and yum doesn't have enough cached data to continue. At this point the only
==> master: safe thing yum can do is fail. There are a few ways to work "fix" this:
==> master:
==> master: 1. Contact the upstream for the repository and get them to fix the problem.
==> master:
==> master: 2. Reconfigure the baseurl/etc. for the repository, to point to a working
==> master: upstream. This is most often useful if you are using a newer
==> master: distribution release than is supported by the repository (and the
==> master: packages for the previous distribution release still work).
==> master:
==> master: 3. Disable the repository, so yum won't use it by default. Yum will then
==> master: just ignore the repository until you permanently enable it again or use
==> master: --enablerepo for temporary usage:
==> master:
==> master: yum-config-manager --disable fedora
==> master:
==> master: 4. Configure the failing repository to be skipped, if it is unavailable.
==> master: Note that yum will try to contact the repo. when it runs most commands,
==> master: so will have to try and fail each time (and thus. yum will be be much
==> master: slower). If it is a very temporary problem though, this is often a nice
==> master: compromise:
==> master:
==> master: yum-config-manager --save --setopt=fedora.skip_if_unavailable=true
==> master:
==> master: Cannot retrieve metalink for repository: fedora/21/x86_64. Please verify its path and try again
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.
➜ kubernetes ./cluster/kube-up.sh
Starting cluster using provider: vagrant
... calling verify-prereqs
... calling kube-up
Using credentials: vagrant:vagrant
Bringing machine 'master' up with 'virtualbox' provider...
Bringing machine 'minion-1' up with 'virtualbox' provider...
==> master: Importing base box 'kube-fedora21'...
==> master: Matching MAC address for NAT networking...
==> master: Setting the name of the VM: kubernetes_master_1438260105420_49732
==> master: Clearing any previously set network interfaces...
==> master: Preparing network interfaces based on configuration...
master: Adapter 1: nat
master: Adapter 2: hostonly
==> master: Forwarding ports...
master: 22 => 2222 (adapter 1)
==> master: Running 'pre-boot' VM customizations...
==> master: Booting VM...
==> master: Waiting for machine to boot. This may take a few minutes...
master: SSH address: 127.0.0.1:2222
master: SSH username: vagrant
master: SSH auth method: private key
master: Warning: Connection timeout. Retrying...
master:
master: Vagrant insecure key detected. Vagrant will automatically replace
master: this with a newly generated keypair for better security.
master:
master: Inserting generated public key within guest...
master: Removing insecure key from the guest if it's present...
master: Key inserted! Disconnecting and reconnecting using new SSH key...
==> master: Machine booted and ready!
==> master: Checking for guest additions in VM...
==> master: Configuring and enabling network interfaces...
==> master: Mounting shared folders...
master: /vagrant => /Users/smithm/kubernetes
==> master: Running provisioner: shell...
master: Running: /var/folders/rt/phr89yfj2fl206jtk0l86724th0_1v/T/vagrant-shell20150730-38892-134nvff.sh
==> master: Adding kubernetes-minion-1 to hosts file
==> master: Verifying network configuration
==> master: It looks like the required network bridge has not yet been created
==> master: Installing, enabling prerequisites
==> master: ftp://mirror.lstn.net/fedora/releases/21/Everything/x86_64/os/repodata/4c0ea0d0ca8fd81fd3a96cacabfbcf9e02c33125670505fcf20aacefab48df02-primary.sqlite.xz: [Errno 14] curl#7 - "Failed to connect to mirror.lstn.net port 21: Connection refused"
==> master: Trying other mirror.
==> master: http://mirror.pnl.gov/fedora/linux/updates/21/x86_64/repodata/1c3e34384485b31aee427d93795aba90f1b5e82c63f37ed1fc0eed9cb480402d-updateinfo.xml.gz: [Errno 14] HTTP Error 404 - Not Found
==> master: Trying other mirror.
==> master: Resolving Dependencies
==> master: --> Running transaction check
==> master: ---> Package bridge-utils.x86_64 0:1.5-10.fc21 will be installed
==> master: ---> Package openvswitch.x86_64 0:2.3.2-1.fc21 will be installed
==> master: --> Finished Dependency Resolution
==> master:
==> master: Dependencies Resolved
==> master:
==> master: ================================================================================
==> master: Package Arch Version Repository Size
==> master: ================================================================================
==> master: Installing:
==> master: bridge-utils x86_64 1.5-10.fc21 fedora 36 k
==> master: openvswitch x86_64 2.3.2-1.fc21 updates 1.8 M
==> master:
==> master: Transaction Summary
==> master: ================================================================================
==> master: Install 2 Packages
==> master: Total download size: 1.9 M
==> master: Installed size: 7.7 M
==> master: Downloading packages:
==> master: http://mirror.pnl.gov/fedora/linux/updates/21/x86_64/o/openvswitch-2.3.2-1.fc21.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
==> master: Trying other mirror.
==> master: warning: /var/cache/yum/x86_64/21/fedora/packages/bridge-utils-1.5-10.fc21.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 95a43f54: NOKEY
==> master: Public key for bridge-utils-1.5-10.fc21.x86_64.rpm is not installed
==> master: Public key for openvswitch-2.3.2-1.fc21.x86_64.rpm is not installed
==> master: --------------------------------------------------------------------------------
==> master: Total 537 kB/s | 1.9 MB 00:03
==> master: Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-21-x86_64
==> master: Importing GPG key 0x95A43F54:
==> master: Userid : "Fedora (21) <fedora@fedoraproject.org>"
==> master: Fingerprint: 6596 b8fb abda 5227 a9c5 b59e 89ad 4e87 95a4 3f54
==> master: Package : fedora-repos-21-2.noarch (@anaconda)
==> master: From : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-21-x86_64
==> master: Running transaction check
==> master: Running transaction test
==> master: Transaction test succeeded
==> master: Running transaction (shutdown inhibited)
==> master: Installing : openvswitch-2.3.2-1.fc21.x86_64 1/2
==> master:
==> master: Installing : bridge-utils-1.5-10.fc21.x86_64 2/2
==> master:
==> master: Verifying : bridge-utils-1.5-10.fc21.x86_64 1/2
==> master:
==> master: Verifying : openvswitch-2.3.2-1.fc21.x86_64 2/2
==> master:
==> master:
==> master: Installed:
==> master: bridge-utils.x86_64 0:1.5-10.fc21 openvswitch.x86_64 0:2.3.2-1.fc21
==> master: Complete!
==> master: Created symlink from /etc/systemd/system/multi-user.target.wants/openvswitch.service to /usr/lib/systemd/system/openvswitch.service.
==> master: Create a new docker bridge
==> master: Cannot find device "cbr0"
==> master: bridge cbr0 doesn't exist; can't delete it
==> master: Add ovs bridge
==> master: ovs-vsctl: no bridge named obr0
==> master: ovs-vsctl: no port named gre0
==> master: Add tun device
==> master: ovs-vsctl: no port named tun0
==> master: Add oflow rules
==> master: Creating persistent gre tunnels
==> master: Created persistent gre tunnels
==> master: Add ip route rules such that all pod traffic flows through docker bridge
==> master: Network configuration verified
==> master: Running release install script
==> master: /kube-install /home/vagrant
==> master: +++ Installing salt files into new trees
==> master: ‘./kubernetes/saltbase/salt’ -> ‘/srv/salt-new/salt’
==> master: ‘./kubernetes/saltbase/salt/fluentd-gcp’ -> ‘/srv/salt-new/salt/fluentd-gcp’
==> master: ‘./kubernetes/saltbase/salt/fluentd-gcp/init.sls’ -> ‘/srv/salt-new/salt/fluentd-gcp/init.sls’
==> master: ‘./kubernetes/saltbase/salt/fluentd-gcp/fluentd-gcp.yaml’ -> ‘/srv/salt-new/salt/fluentd-gcp/fluentd-gcp.yaml’
==> master: ‘./kubernetes/saltbase/salt/docker’ -> ‘/srv/salt-new/salt/docker’
==> master: ‘./kubernetes/saltbase/salt/docker/init.sls’ -> ‘/srv/salt-new/salt/docker/init.sls’
==> master: ‘./kubernetes/saltbase/salt/docker/docker.service’ -> ‘/srv/salt-new/salt/docker/docker.service’
==> master: ‘./kubernetes/saltbase/salt/docker/default’ -> ‘/srv/salt-new/salt/docker/default’
==> master: ‘./kubernetes/saltbase/salt/docker/docker-defaults’ -> ‘/srv/salt-new/salt/docker/docker-defaults’
==> master: ‘./kubernetes/saltbase/salt/helpers’ -> ‘/srv/salt-new/salt/helpers’
==> master: ‘./kubernetes/saltbase/salt/helpers/safe_format_and_mount’ -> ‘/srv/salt-new/salt/helpers/safe_format_and_mount’
==> master: ‘./kubernetes/saltbase/salt/helpers/init.sls’ -> ‘/srv/salt-new/salt/helpers/init.sls’
==> master: ‘./kubernetes/saltbase/salt/kube-addons’ -> ‘/srv/salt-new/salt/kube-addons’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/kube-addon-update.sh’ -> ‘/srv/salt-new/salt/kube-addons/kube-addon-update.sh’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/init.sls’ -> ‘/srv/salt-new/salt/kube-addons/init.sls’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/kube-addons.sh’ -> ‘/srv/salt-new/salt/kube-addons/kube-addons.sh’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/namespace.yaml’ -> ‘/srv/salt-new/salt/kube-addons/namespace.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/kube-ui’ -> ‘/srv/salt-new/salt/kube-addons/kube-ui’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/kube-ui/kube-ui-svc.yaml’ -> ‘/srv/salt-new/salt/kube-addons/kube-ui/kube-ui-svc.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/kube-ui/kube-ui-rc.yaml’ -> ‘/srv/salt-new/salt/kube-addons/kube-ui/kube-ui-rc.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/kube-addons.service’ -> ‘/srv/salt-new/salt/kube-addons/kube-addons.service’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/initd’ -> ‘/srv/salt-new/salt/kube-addons/initd’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/dns’ -> ‘/srv/salt-new/salt/kube-addons/dns’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/dns/skydns-rc.yaml.in’ -> ‘/srv/salt-new/salt/kube-addons/dns/skydns-rc.yaml.in’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/dns/skydns-svc.yaml.in’ -> ‘/srv/salt-new/salt/kube-addons/dns/skydns-svc.yaml.in’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring’ -> ‘/srv/salt-new/salt/kube-addons/cluster-monitoring’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring/influxdb’ -> ‘/srv/salt-new/salt/kube-addons/cluster-monitoring/influxdb’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring/influxdb/heapster-controller.yaml’ -> ‘/srv/salt-new/salt/kube-addons/cluster-monitoring/influxdb/heapster-controller.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring/influxdb/influxdb-service.yaml’ -> ‘/srv/salt-new/salt/kube-addons/cluster-monitoring/influxdb/influxdb-service.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring/influxdb/heapster-service.yaml’ -> ‘/srv/salt-new/salt/kube-addons/cluster-monitoring/influxdb/heapster-service.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring/influxdb/influxdb-grafana-controller.yaml’ -> ‘/srv/salt-new/salt/kube-addons/cluster-monitoring/influxdb/influxdb-grafana-controller.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring/influxdb/grafana-service.yaml’ -> ‘/srv/salt-new/salt/kube-addons/cluster-monitoring/influxdb/grafana-service.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring/standalone’ -> ‘/srv/salt-new/salt/kube-addons/cluster-monitoring/standalone’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring/standalone/heapster-controller.yaml’ -> ‘/srv/salt
==> master: -new/salt/kube-addons/cluster-monitoring/standalone/heapster-controller.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring/standalone/heapster-service.yaml’ -> ‘/srv/salt-new/salt/kube-addons/cluster-monitoring/standalone/heapster-service.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring/googleinfluxdb’ -> ‘/srv/salt-new/salt/kube-addons/cluster-monitoring/googleinfluxdb’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring/googleinfluxdb/heapster-controller-combined.yaml’ -> ‘/srv/salt-new/salt/kube-addons/cluster-monitoring/googleinfluxdb/heapster-controller-combined.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring/google’ -> ‘/srv/salt-new/salt/kube-addons/cluster-monitoring/google’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring/google/heapster-controller.yaml’ -> ‘/srv/salt-new/salt/kube-addons/cluster-monitoring/google/heapster-controller.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/cluster-monitoring/google/heapster-service.yaml’ -> ‘/srv/salt-new/salt/kube-addons/cluster-monitoring/google/heapster-service.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/fluentd-elasticsearch’ -> ‘/srv/salt-new/salt/kube-addons/fluentd-elasticsearch’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/fluentd-elasticsearch/es-service.yaml’ -> ‘/srv/salt-new/salt/kube-addons/fluentd-elasticsearch/es-service.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/fluentd-elasticsearch/es-controller.yaml’ -> ‘/srv/salt-new/salt/kube-addons/fluentd-elasticsearch/es-controller.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/fluentd-elasticsearch/kibana-service.yaml’ -> ‘/srv/salt-new/salt/kube-addons/fluentd-elasticsearch/kibana-service.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-addons/fluentd-elasticsearch/kibana-controller.yaml’ -> ‘/srv/salt-new/salt/kube-addons/fluentd-elasticsearch/kibana-controller.yaml’
==> master: ‘./kubernetes/saltbase/salt/kube-master-addons’ -> ‘/srv/salt-new/salt/kube-master-addons’
==> master: ‘./kubernetes/saltbase/salt/kube-master-addons/init.sls’ -> ‘/srv/salt-new/salt/kube-master-addons/init.sls’
==> master: ‘./kubernetes/saltbase/salt/kube-master-addons/kube-master-addons.service’ -> ‘/srv/salt-new/salt/kube-master-addons/kube-master-addons.service’
==> master: ‘./kubernetes/saltbase/salt/kube-master-addons/kube-master-addons.sh’ -> ‘/srv/salt-new/salt/kube-master-addons/kube-master-addons.sh’
==> master: ‘./kubernetes/saltbase/salt/kube-master-addons/initd’ -> ‘/srv/salt-new/salt/kube-master-addons/initd’
==> master: ‘./kubernetes/saltbase/salt/kube-scheduler’ -> ‘/srv/salt-new/salt/kube-scheduler’
==> master: ‘./kubernetes/saltbase/salt/kube-scheduler/init.sls’ -> ‘/srv/salt-new/salt/kube-scheduler/init.sls’
==> master: ‘./kubernetes/saltbase/salt/kube-scheduler/kube-scheduler.manifest’ -> ‘/srv/salt-new/salt/kube-scheduler/kube-scheduler.manifest’
==> master: ‘./kubernetes/saltbase/salt/openvpn’ -> ‘/srv/salt-new/salt/openvpn’
==> master: ‘./kubernetes/saltbase/salt/openvpn/init.sls’ -> ‘/srv/salt-new/salt/openvpn/init.sls’
==> master: ‘./kubernetes/saltbase/salt/openvpn/server.conf’ -> ‘/srv/salt-new/salt/openvpn/server.conf’
==> master: ‘./kubernetes/saltbase/salt/monit’ -> ‘/srv/salt-new/salt/monit’
==> master: ‘./kubernetes/saltbase/salt/monit/docker’ -> ‘/srv/salt-new/salt/monit/docker’
==> master: ‘./kubernetes/saltbase/salt/monit/kube-addons’ -> ‘/srv/salt-new/salt/monit/kube-addons’
==> master: ‘./kubernetes/saltbase/salt/monit/init.sls’ -> ‘/srv/salt-new/salt/monit/init.sls’
==> master: ‘./kubernetes/saltbase/salt/monit/kube-proxy’ -> ‘/srv/salt-new/salt/monit/kube-proxy’
==> master: ‘./kubernetes/saltbase/salt/monit/kubelet’ -> ‘/srv/salt-new/salt/monit/kubelet’
==> master: ‘./kubernetes/saltbase/salt/monit/monit_watcher.sh’ -> ‘/srv/salt-new/salt/monit/monit_watcher.sh’
==> master: ‘./kubernetes/saltbase/salt/debian-auto-upgrades’ -> ‘/srv/salt-new/salt/debian-auto-upgrades’
==> master: ‘./kubernetes/saltbase/salt/debian-auto-upgrades/20auto-upgrades’ -> ‘/srv/salt-new/salt/debian-auto-upgrades/20auto-upgrades’
==> master: ‘./kubernetes/saltbase/salt/debia
==> master: n-auto-upgrades/init.sls’ -> ‘/srv/salt-new/salt/debian-auto-upgrades/init.sls’
==> master: ‘./kubernetes/saltbase/salt/logrotate’ -> ‘/srv/salt-new/salt/logrotate’
==> master: ‘./kubernetes/saltbase/salt/logrotate/conf’ -> ‘/srv/salt-new/salt/logrotate/conf’
==> master: ‘./kubernetes/saltbase/salt/logrotate/init.sls’ -> ‘/srv/salt-new/salt/logrotate/init.sls’
==> master: ‘./kubernetes/saltbase/salt/logrotate/docker-containers’ -> ‘/srv/salt-new/salt/logrotate/docker-containers’
==> master: ‘./kubernetes/saltbase/salt/logrotate/cron’ -> ‘/srv/salt-new/salt/logrotate/cron’
==> master: ‘./kubernetes/saltbase/salt/nginx’ -> ‘/srv/salt-new/salt/nginx’
==> master: ‘./kubernetes/saltbase/salt/nginx/kubernetes-site’ -> ‘/srv/salt-new/salt/nginx/kubernetes-site’
==> master: ‘./kubernetes/saltbase/salt/nginx/init.sls’ -> ‘/srv/salt-new/salt/nginx/init.sls’
==> master: ‘./kubernetes/saltbase/salt/nginx/nginx.json’ -> ‘/srv/salt-new/salt/nginx/nginx.json’
==> master: ‘./kubernetes/saltbase/salt/nginx/nginx.conf’ -> ‘/srv/salt-new/salt/nginx/nginx.conf’
==> master: ‘./kubernetes/saltbase/salt/kube-proxy’ -> ‘/srv/salt-new/salt/kube-proxy’
==> master: ‘./kubernetes/saltbase/salt/kube-proxy/init.sls’ -> ‘/srv/salt-new/salt/kube-proxy/init.sls’
==> master: ‘./kubernetes/saltbase/salt/kube-proxy/default’ -> ‘/srv/salt-new/salt/kube-proxy/default’
==> master: ‘./kubernetes/saltbase/salt/kube-proxy/kubeconfig’ -> ‘/srv/salt-new/salt/kube-proxy/kubeconfig’
==> master: ‘./kubernetes/saltbase/salt/kube-proxy/kube-proxy.service’ -> ‘/srv/salt-new/salt/kube-proxy/kube-proxy.service’
==> master: ‘./kubernetes/saltbase/salt/kube-proxy/initd’ -> ‘/srv/salt-new/salt/kube-proxy/initd’
==> master: ‘./kubernetes/saltbase/salt/salt-helpers’ -> ‘/srv/salt-new/salt/salt-helpers’
==> master: ‘./kubernetes/saltbase/salt/salt-helpers/init.sls’ -> ‘/srv/salt-new/salt/salt-helpers/init.sls’
==> master: ‘./kubernetes/saltbase/salt/salt-helpers/services’ -> ‘/srv/salt-new/salt/salt-helpers/services’
==> master: ‘./kubernetes/saltbase/salt/kubelet’ -> ‘/srv/salt-new/salt/kubelet’
==> master: ‘./kubernetes/saltbase/salt/kubelet/kubelet.service’ -> ‘/srv/salt-new/salt/kubelet/kubelet.service’
==> master: ‘./kubernetes/saltbase/salt/kubelet/init.sls’ -> ‘/srv/salt-new/salt/kubelet/init.sls’
==> master: ‘./kubernetes/saltbase/salt/kubelet/kubernetes_auth’ -> ‘/srv/salt-new/salt/kubelet/kubernetes_auth’
==> master: ‘./kubernetes/saltbase/salt/kubelet/default’ -> ‘/srv/salt-new/salt/kubelet/default’
==> master: ‘./kubernetes/saltbase/salt/kubelet/initd’ -> ‘/srv/salt-new/salt/kubelet/initd’
==> master: ‘./kubernetes/saltbase/salt/fluentd-es’ -> ‘/srv/salt-new/salt/fluentd-es’
==> master: ‘./kubernetes/saltbase/salt/fluentd-es/fluentd-es.yaml’ -> ‘/srv/salt-new/salt/fluentd-es/fluentd-es.yaml’
==> master: ‘./kubernetes/saltbase/salt/fluentd-es/init.sls’ -> ‘/srv/salt-new/salt/fluentd-es/init.sls’
==> master: ‘./kubernetes/saltbase/salt/kube-admission-controls’ -> ‘/srv/salt-new/salt/kube-admission-controls’
==> master: ‘./kubernetes/saltbase/salt/kube-admission-controls/init.sls’ -> ‘/srv/salt-new/salt/kube-admission-controls/init.sls’
==> master: ‘./kubernetes/saltbase/salt/kube-admission-controls/limit-range’ -> ‘/srv/salt-new/salt/kube-admission-controls/limit-range’
==> master: ‘./kubernetes/saltbase/salt/kube-admission-controls/limit-range/limit-range.yaml’ -> ‘/srv/salt-new/salt/kube-admission-controls/limit-range/limit-range.yaml’
==> master: ‘./kubernetes/saltbase/salt/openvpn-client’ -> ‘/srv/salt-new/salt/openvpn-client’
==> master: ‘./kubernetes/saltbase/salt/openvpn-client/init.sls’ -> ‘/srv/salt-new/salt/openvpn-client/init.sls’
==> master: ‘./kubernetes/saltbase/salt/openvpn-client/client.conf’ -> ‘/srv/salt-new/salt/openvpn-client/client.conf’
==> master: ‘./kubernetes/saltbase/salt/README.md’ -> ‘/srv/salt-new/salt/README.md’
==> master: ‘./kubernetes/saltbase/salt/generate-cert’ -> ‘/srv/salt-new/salt/generate-cert’
==> master: ‘./kubernetes/saltbase/salt/generate-cert/init.sls’ -> ‘/srv/salt-new/salt/generate-cert/init.sls’
==> master: ‘./kubernetes/saltbase/salt/generate-cert/make-ca-cert.sh’ -> ‘/srv/salt-new/salt/generate-cert/make-ca-cert.sh’
==> master: ‘./kubernetes/saltbase/salt/generate-cert/make-ce
==> master: rt.sh’ -> ‘/srv/salt-new/salt/generate-cert/make-cert.sh’
==> master: ‘./kubernetes/saltbase/salt/top.sls’ -> ‘/srv/salt-new/salt/top.sls’
==> master: ‘./kubernetes/saltbase/salt/etcd’ -> ‘/srv/salt-new/salt/etcd’
==> master: ‘./kubernetes/saltbase/salt/etcd/init.sls’ -> ‘/srv/salt-new/salt/etcd/init.sls’
==> master: ‘./kubernetes/saltbase/salt/etcd/etcd.manifest’ -> ‘/srv/salt-new/salt/etcd/etcd.manifest’
==> master: ‘./kubernetes/saltbase/salt/kube-client-tools.sls’ -> ‘/srv/salt-new/salt/kube-client-tools.sls’
==> master: ‘./kubernetes/saltbase/salt/cadvisor’ -> ‘/srv/salt-new/salt/cadvisor’
==> master: ‘./kubernetes/saltbase/salt/cadvisor/init.sls’ -> ‘/srv/salt-new/salt/cadvisor/init.sls’
==> master: ‘./kubernetes/saltbase/salt/base.sls’ -> ‘/srv/salt-new/salt/base.sls’
==> master: ‘./kubernetes/saltbase/salt/kube-apiserver’ -> ‘/srv/salt-new/salt/kube-apiserver’
==> master: ‘./kubernetes/saltbase/salt/kube-apiserver/init.sls’ -> ‘/srv/salt-new/salt/kube-apiserver/init.sls’
==> master: ‘./kubernetes/saltbase/salt/kube-apiserver/kube-apiserver.manifest’ -> ‘/srv/salt-new/salt/kube-apiserver/kube-apiserver.manifest’
==> master: ‘./kubernetes/saltbase/salt/static-routes’ -> ‘/srv/salt-new/salt/static-routes’
==> master: ‘./kubernetes/saltbase/salt/static-routes/if-down’ -> ‘/srv/salt-new/salt/static-routes/if-down’
==> master: ‘./kubernetes/saltbase/salt/static-routes/init.sls’ -> ‘/srv/salt-new/salt/static-routes/init.sls’
==> master: ‘./kubernetes/saltbase/salt/static-routes/refresh’ -> ‘/srv/salt-new/salt/static-routes/refresh’
==> master: ‘./kubernetes/saltbase/salt/static-routes/if-up’ -> ‘/srv/salt-new/salt/static-routes/if-up’
==> master: ‘./kubernetes/saltbase/salt/kube-controller-manager’ -> ‘/srv/salt-new/salt/kube-controller-manager’
==> master: ‘./kubernetes/saltbase/salt/kube-controller-manager/init.sls’ -> ‘/srv/salt-new/salt/kube-controller-manager/init.sls’
==> master: ‘./kubernetes/saltbase/salt/kube-controller-manager/kube-controller-manager.manifest’ -> ‘/srv/salt-new/salt/kube-controller-manager/kube-controller-manager.manifest’
==> master: ‘./kubernetes/saltbase/pillar’ -> ‘/srv/salt-new/pillar’
==> master: ‘./kubernetes/saltbase/pillar/cluster-params.sls’ -> ‘/srv/salt-new/pillar/cluster-params.sls’
==> master: ‘./kubernetes/saltbase/pillar/logging.sls’ -> ‘/srv/salt-new/pillar/logging.sls’
==> master: ‘./kubernetes/saltbase/pillar/docker-images.sls’ -> ‘/srv/salt-new/pillar/docker-images.sls’
==> master: ‘./kubernetes/saltbase/pillar/mine.sls’ -> ‘/srv/salt-new/pillar/mine.sls’
==> master: ‘./kubernetes/saltbase/pillar/README.md’ -> ‘/srv/salt-new/pillar/README.md’
==> master: ‘./kubernetes/saltbase/pillar/top.sls’ -> ‘/srv/salt-new/pillar/top.sls’
==> master: ‘./kubernetes/saltbase/pillar/systemd.sls’ -> ‘/srv/salt-new/pillar/systemd.sls’
==> master: ‘./kubernetes/saltbase/pillar/privilege.sls’ -> ‘/srv/salt-new/pillar/privilege.sls’
==> master: ‘./kubernetes/saltbase/reactor’ -> ‘/srv/salt-new/reactor’
==> master: ‘./kubernetes/saltbase/reactor/highstate-new.sls’ -> ‘/srv/salt-new/reactor/highstate-new.sls’
==> master: ‘./kubernetes/saltbase/reactor/highstate-minions.sls’ -> ‘/srv/salt-new/reactor/highstate-minions.sls’
==> master: ‘./kubernetes/saltbase/reactor/README.md’ -> ‘/srv/salt-new/reactor/README.md’
==> master: ‘./kubernetes/saltbase/reactor/highstate-masters.sls’ -> ‘/srv/salt-new/reactor/highstate-masters.sls’
==> master: +++ Installing salt overlay files
==> master: ‘/srv/salt-overlay/salt/kube-proxy/kubeconfig’ -> ‘/srv/salt-new/salt/kube-proxy/kubeconfig’
==> master: ‘/srv/salt-overlay/salt/kubelet/kubernetes_auth’ -> ‘/srv/salt-new/salt/kubelet/kubernetes_auth’
==> master: ‘/srv/salt-overlay/salt/kubelet/kubeconfig’ -> ‘/srv/salt-new/salt/kubelet/kubeconfig’
==> master: ‘/srv/salt-overlay/salt/kube-apiserver/basic_auth.csv’ -> ‘/srv/salt-new/salt/kube-apiserver/basic_auth.csv’
==> master: ‘/srv/salt-overlay/salt/kube-apiserver/known_tokens.csv’ -> ‘/srv/salt-new/salt/kube-apiserver/known_tokens.csv’
==> master: ‘/srv/salt-overlay/pillar/cluster-params.sls’ -> ‘/srv/salt-new/pillar/cluster-params.sls’
==> master: +++ Install binaries from tar: kubernetes-server-linux-amd64.tar.gz
==> master: ‘/tmp/kubernetes.68QHQ9/kubernetes/server/bin/hyperkube’ -> ‘/srv/salt-new/salt/kube-bins/hyperkube’
==> master: ‘/tmp/kubernetes.68QHQ9/kubernetes/server/bin/kube-apiserver’ -> ‘/srv/salt-new/salt/kube-bins/kube-apiserver’
==> master: ‘/tmp/kubernetes.68QHQ9/kubernetes/server/bin/kube-apiserver.docker_tag’ -> ‘/srv/salt-new/salt/kube-bins/kube-apiserver.docker_tag’
==> master: ‘/tmp/kubernetes.68QHQ9/kubernetes/server/bin/kube-apiserver.tar’ -> ‘/srv/salt-new/salt/kube-bins/kube-apiserver.tar’
==> master: ‘/tmp/kubernetes.68QHQ9/kubernetes/server/bin/kube-controller-manager’ -> ‘/srv/salt-new/salt/kube-bins/kube-controller-manager’
==> master: ‘/tmp/kubernetes.68QHQ9/kubernetes/server/bin/kube-controller-manager.docker_tag’ -> ‘/srv/salt-new/salt/kube-bins/kube-controller-manager.docker_tag’
==> master: ‘/tmp/kubernetes.68QHQ9/kubernetes/server/bin/kube-controller-manager.tar’ -> ‘/srv/salt-new/salt/kube-bins/kube-controller-manager.tar’
==> master: ‘/tmp/kubernetes.68QHQ9/kubernetes/server/bin/kubectl’ -> ‘/srv/salt-new/salt/kube-bins/kubectl’
==> master: ‘/tmp/kubernetes.68QHQ9/kubernetes/server/bin/kubelet’ -> ‘/srv/salt-new/salt/kube-bins/kubelet’
==> master: ‘/tmp/kubernetes.68QHQ9/kubernetes/server/bin/kube-proxy’ -> ‘/srv/salt-new/salt/kube-bins/kube-proxy’
==> master: ‘/tmp/kubernetes.68QHQ9/kubernetes/server/bin/kubernetes’ -> ‘/srv/salt-new/salt/kube-bins/kubernetes’
==> master: ‘/tmp/kubernetes.68QHQ9/kubernetes/server/bin/kube-scheduler’ -> ‘/srv/salt-new/salt/kube-bins/kube-scheduler’
==> master: ‘/tmp/kubernetes.68QHQ9/kubernetes/server/bin/kube-scheduler.docker_tag’ -> ‘/srv/salt-new/salt/kube-bins/kube-scheduler.docker_tag’
==> master: ‘/tmp/kubernetes.68QHQ9/kubernetes/server/bin/kube-scheduler.tar’ -> ‘/srv/salt-new/salt/kube-bins/kube-scheduler.tar’
==> master: +++ Swapping in new configs
==> master: ‘/srv/salt-new/salt’ -> ‘/srv/salt’
==> master: ‘/srv/salt-new/pillar’ -> ‘/srv/pillar’
==> master: ‘/srv/salt-new/reactor’ -> ‘/srv/reactor’
==> master: /home/vagrant
==> master: * INFO: sh -- Version 2015.07.22
==> master:
==> master: * INFO: System Information:
==> master: * INFO: CPU: GenuineIntel
==> master: * INFO: CPU Arch: x86_64
==> master: * INFO: OS Name: Linux
==> master: * INFO: OS Version: 3.17.4-301.fc21.x86_64
==> master: * INFO: Distribution: Fedora 21
==> master: * INFO: Installing master
==> master: * INFO: Found function install_fedora_deps
==> master: * INFO: Found function install_fedora_stable
==> master: * INFO: Found function install_fedora_stable_post
==> master: * INFO: Found function install_fedora_restart_daemons
==> master: * INFO: Found function daemons_running
==> master: * INFO: Found function install_fedora_check_services
==> master: * INFO: Running install_fedora_deps()
==> master: * INFO: Adding SaltStack's COPR repository
==> master: Resolving Dependencies
==> master: --> Running transaction check
==> master: ---> Package PyYAML.x86_64 0:3.11-7.fc21 will be installed
==> master: ---> Package libyaml.x86_64 0:0.1.6-6.fc21 will be installed
==> master: ---> Package m2crypto.x86_64 0:0.21.1-18.fc21 will be installed
==> master: ---> Package python-crypto.x86_64 0:2.6.1-6.fc21 will be installed
==> master: --> Processing Dependency: libtomcrypt.so.0()(64bit) for package: python-crypto-2.6.1-6.fc21.x86_64
==> master: ---> Package python-jinja2.noarch 0:2.7.3-2.fc21 will be installed
==> master: --> Processing Dependency: python-babel >= 0.8 for package: python-jinja2-2.7.3-2.fc21.noarch
==> master: --> Processing Dependency: python-setuptools for package: python-jinja2-2.7.3-2.fc21.noarch
==> master: --> Processing Dependency: python-markupsafe for package: python-jinja2-2.7.3-2.fc21.noarch
==> master: ---> Package python-msgpack.x86_64 0:0.4.6-1.fc21 will be installed
==> master: ---> Package python-requests.noarch 0:2.7.0-1.fc21 will be installed
==> master: --> Processing Dependency: python-urllib3 >= 1.10 for package: python-requests-2.7.0-1.fc21.noarch
==> master: --> Processing Dependency: python-chardet for package: python-requests-2.7.0-1.fc21.noarch
==> master: ---> Package python-zmq.x86_64 0:14.3.1-1.fc21 will be installed
==> master: --> Processing Dependency: libzmq.so.3()(64bit) for package: python-zmq-14.3.1-1.fc21.x86_64
==> master: ---> Package yum-utils.noarch 0:1.1.31-27.fc21 will be installed
==> master: --> Processing Dependency: python-kitchen for package: yum-utils-1.1.31-27.fc21.noarch
==> master: --> Running transaction check
==> master: ---> Package libtomcrypt.x86_64 0:1.17-24.fc21 will be installed
==> master: --> Processing Dependency: libtommath >= 0.42.0 for package: libtomcrypt-1.17-24.fc21.x86_64
==> master: --> Processing Dependency: libtommath.so.0()(64bit) for package: libtomcrypt-1.17-24.fc21.x86_64
==> master: ---> Package python-babel.noarch 0:1.3-7.fc21 will be installed
==> master: --> Processing Dependency: pytz for package: python-babel-1.3-7.fc21.noarch
==> master: ---> Package python-chardet.noarch 0:2.2.1-2.fc21 will be installed
==> master: ---> Package python-kitchen.noarch 0:1.2.1-2.fc21 will be installed
==> master: ---> Package python-markupsafe.x86_64 0:0.23-6.fc21 will be installed
==> master: ---> Package python-setuptools.noarch 0:2.0-8.fc21 will be installed
==> master: --> Processing Dependency: python-backports-ssl_match_hostname for package: python-setuptools-2.0-8.fc21.noarch
==> master: ---> Package python-urllib3.noarch 0:1.10.4-3.20150503gita91975b.fc21 will be installed
==> master: --> Processing Dependency: python-pyasn1 for package: python-urllib3-1.10.4-3.20150503gita91975b.fc21.noarch
==> master: --> Processing Dependency: python-ndg_httpsclient for package: python-urllib3-1.10.4-3.20150503gita91975b.fc21.noarch
==> master: --> Processing Dependency: pyOpenSSL for package: python-urllib3-1.10.4-3.20150503gita91975b.fc21.noarch
==> master: ---> Package zeromq3.x86_64 0:3.2.5-1.fc21 will be installed
==> master: --> Processing Dependency: libpgm-5.2.so.0()(64bit) for package: zeromq3-3.2.5-1.fc21.x86_64
==> master: --> Running transaction check
==> master: ---> Package libtommath.x86_64 0:0.42.0-5.fc21 will be installed
==> master: ---> Package openpgm.x86_64 0:5.2.122-4.fc21 will be installed
==> master: ---> Package pyOpenSSL.x86_64 0:0.13.1-4.fc21 will be installed
==> master: ---> Package python-backports-ssl_match_hostname.noarch 0:3.4.0.2-4.fc21 will be installed
==> master: --> Processing Dependency: python-backports for package: python-backports-ssl_match_hostname-3.4.0.2-4.fc21.noarch
==> master: ---> Package python-ndg_httpsclient.noarch 0:0.3.2-1.fc21 will be installed
==> master: ---> Package python-pyasn1.noarch 0:0.1.7-4.fc21 will be installed
==> master: ---> Package pytz.noarch 0:2012d-7.fc21 will be installed
==> master: --> Running transaction check
==> master: ---> Package python-backports.x86_64 0:1.0-5.fc21 will be installed
==> master: --> Finished Dependency Resolution
==> master:
==> master: Dependencies Resolved
==> master:
==> master: ================================================================================
==> master: Package Arch Version Repository
==> master: Size
==> master: ================================================================================
==> master: Installing:
==> master: PyYAML x86_64 3.11-7.fc21 updates 172 k
==> master: libyaml x86_64 0.1.6-6.fc21 updates 58 k
==> master: m2crypto x86_64 0.21.1-18.fc21 fedora 431 k
==> master: python-crypto x86_64 2.6.1-6.fc21 fedora 467 k
==> master: python-jinja2 noarch 2.7.3-2.fc21 updates 531 k
==> master: python-msgpack x86_64 0.4.6-1.fc21 updates 81 k
==> master: python-requests noarch 2.7.0-1.fc21 updates 99 k
==> master: python-zmq x86_64 14.3.1-1.fc21 fedora 480 k
==> master: yum-utils noarch 1.1.31-27.fc21 updates 118 k
==> master: Installing for dependencies:
==> master: libtomcrypt x86_64 1.17-24.fc21 fedora 227 k
==> master: libtommath x86_64 0.42.0-5.fc21 fedora 39 k
==> master: openpgm x86_64 5.2.122-4.fc21 fedora 176 k
==> master: pyOpenSSL x86_64 0.13.1-4.fc21 fedora 137 k
==> master: python-babel noarch 1.3-7.fc21 updates 2.5 M
==> master: python-backports x86_64 1.0-5.fc21 fedora 9.7 k
==> master: python-backports-ssl_match_hostname
==> master: noarch 3.4.0.2-4.fc21 fedora 17 k
==> master: python-chardet noarch 2.2.1-2.fc21 fedora 231 k
==> master: python-kitchen noarch 1.2.1-2.fc21 updates 120 k
==> master: python-markupsafe x86_64 0.23-6.fc21 fedora 35 k
==> master: python-ndg_httpsclient noarch 0.3.2-1.fc21 fedora 47 k
==> master: python-pyasn1 noarch 0.1.7-4.fc21 fedora 92 k
==> master: python-setuptools noarch 2.0-8.fc21 fedora 393 k
==> master: python-urllib3 noarch 1.10.4-3.20150503gita91975b.fc21 updates 109 k
==> master: pytz noarch 2012d-7.fc21 fedora 39 k
==> master: zeromq3 x86_64 3.2.5-1.fc21 updates 349 k
==> master:
==> master: Transaction Summary
==> master: ================================================================================
==> master: Install 9 Packages (+16 Dependent packages)
==> master: Total download size: 6.8 M
==> master: Installed size: 26 M
==> master: Downloading packages:
==> master: --------------------------------------------------------------------------------
==> master: Total 1.2 MB/s | 6.8 MB 00:05
==> master: Running transaction check
==> master: Running transaction test
==> master: Transaction test succeeded
==> master: Running transaction (shutdown inhibited)
==> master: Installing : python-chardet-2.2.1-2.fc21.noarch 1/25
==> master:
==> master: Installing : python-pyasn1-0.1.7-4.fc21.noarch 2/25
==> master:
==> master: Installing : pyOpenSSL-0.13.1-4.fc21.x86_64 3/25
==> master:
==> master: Installing : python-kitchen-1.2.1-2.fc21.noarch 4/25
==> master:
==> master: Installing : libtommath-0.42.0-5.fc21.x86_64 5/25
==> master:
==> master: Installing : libtomcrypt-1.17-24.fc21.x86_64 6/25
==> master:
==> master: Installing : python-backports-1.0-5.fc21.x86_64 7/25
==> master:
==> master: Installing : python-backports-ssl_match_hostname-3.4.0.2-4.fc21.noarc 8/25
==> master:
==> master: Installing : python-setuptools-2.0-8.fc21.noarch 9/25
==> master:
==> master: Installing : python-ndg_httpsclient-0.3.2-1.fc21.noarch 10/25
==> master:
==> master: Installing : python-urllib3-1.10.4-3.20150503gita91975b.fc21.noarch 11/25
==> master:
==> master: Installing : pytz-2012d-7.fc21.noarch 12/25
==> master:
==> master: Installing : python-babel-1.3-7.fc21.noarch 13/25
==> master:
==> master: Installing : openpgm-5.2.122-4.fc21.x86_64 14/25
==> master:
==> master: Installing : zeromq3-3.2.5-1.fc21.x86_64 15/25
==> master:
==> master: Installing : libyaml-0.1.6-6.fc21.x86_64 16/25
==> master:
==> master: Installing : python-markupsafe-0.23-6.fc21.x86_64 17/25
==> master:
==> master: Installing : python-jinja2-2.7.3-2.fc21.noarch 18/25
==> master:
==> master: Installing : PyYAML-3.11-7.fc21.x86_64 19/25
==> master:
==> master: Installing : python-zmq-14.3.1-1.fc21.x86_64 20/25
==> master:
==> master: Installing : python-requests-2.7.0-1.fc21.noarch 21/25
==> master:
==> master: Installing : python-crypto-2.6.1-6.fc21.x86_64 22/25
==> master:
==> master: Installing : yum-utils-1.1.31-27.fc21.noarch 23/25
==> master:
==> master: Installing : python-msgpack-0.4.6-1.fc21.x86_64 24/25
==> master:
==> master: Installing : m2crypto-0.21.1-18.fc21.x86_64 25/25
==> master:
==> master: Verifying : python-urllib3-1.10.4-3.20150503gita91975b.fc21.noarch 1/25
==> master:
==> master: Verifying : python-markupsafe-0.23-6.fc21.x86_64 2/25
==> master:
==> master: Verifying : python-crypto-2.6.1-6.fc21.x86_64 3/25
==> master:
==> master: Verifying : python-jinja2-2.7.3-2.fc21.noarch 4/25
==> master:
==> master: Verifying : pyOpenSSL-0.13.1-4.fc21.x86_64 5/25
==> master:
==> master: Verifying : PyYAML-3.11-7.fc21.x86_64 6/25
==> master:
==> master: Verifying : m2crypto-0.21.1-18.fc21.x86_64 7/25
==> master:
==> master: Verifying : python-kitchen-1.2.1-2.fc21.noarch 8/25
==> master:
==> master: Verifying : libyaml-0.1.6-6.fc21.x86_64 9/25
==> master:
==> master: Verifying : openpgm-5.2.122-4.fc21.x86_64 10/25
==> master:
==> master: Verifying : python-requests-2.7.0-1.fc21.noarch 11/25
==> master:
==> master: Verifying : python-zmq-14.3.1-1.fc21.x86_64 12/25
==> master:
==> master: Verifying : python-babel-1.3-7.fc21.noarch 13/25
==> master:
==> master: Verifying : zeromq3-3.2.5-1.fc21.x86_64 14/25
==> master:
==> master: Verifying : libtomcrypt-1.17-24.fc21.x86_64 15/25
==> master:
==> master: Verifying : python-pyasn1-0.1.7-4.fc21.noarch 16/25
==> master:
==> master: Verifying : yum-utils-1.1.31-27.fc21.noarch 17/25
==> master:
==> master: Verifying : pytz-2012d-7.fc21.noarch 18/25
==> master:
==> master: Verifying : python-setuptools-2.0-8.fc21.noarch 19/25
==> master:
==> master: Verifying : python-backports-1.0-5.fc21.x86_64 20/25
==> master:
==> master: Verifying : python-msgpack-0.4.6-1.fc21.x86_64 21/25
==> master:
==> master: Verifying : python-backports-ssl_match_hostname-3.4.0.2-4.fc21.noarc 22/25
==> master:
==> master: Verifying : python-ndg_httpsclient-0.3.2-1.fc21.noarch 23/25
==> master:
==> master: Verifying : libtommath-0.42.0-5.fc21.x86_64 24/25
==> master:
==> master: Verifying : python-chardet-2.2.1-2.fc21.noarch 25/25
==> master:
==> master:
==> master: Installed:
==> master: PyYAML.x86_64 0:3.11-7.fc21 libyaml.x86_64 0:0.1.6-6.fc21
==> master: m2crypto.x86_64 0:0.21.1-18.fc21 python-crypto.x86_64 0:2.6.1-6.fc21
==> master: python-jinja2.noarch 0:2.7.3-2.fc21 python-msgpack.x86_64 0:0.4.6-1.fc21
==> master: python-requests.noarch 0:2.7.0-1.fc21 python-zmq.x86_64 0:14.3.1-1.fc21
==> master: yum-utils.noarch 0:1.1.31-27.fc21
==> master:
==> master: Dependency Installed:
==> master: libtomcrypt.x86_64 0:1.17-24.fc21
==> master: libtommath.x86_64 0:0.42.0-5.fc21
==> master: openpgm.x86_64 0:5.2.122-4.fc21
==> master: pyOpenSSL.x86_64 0:0.13.1-4.fc21
==> master: python-babel.noarch 0:1.3-7.fc21
==> master: python-backports.x86_64 0:1.0-5.fc21
==> master: python-backports-ssl_match_hostname.noarch 0:3.4.0.2-4.fc21
==> master: python-chardet.noarch 0:2.2.1-2.fc21
==> master: python-kitchen.noarch 0:1.2.1-2.fc21
==> master: python-markupsafe.x86_64 0:0.23-6.fc21
==> master: python-ndg_httpsclient.noarch 0:0.3.2-1.fc21
==> master: python-pyasn1.noarch 0:0.1.7-4.fc21
==> master: python-setuptools.noarch 0:2.0-8.fc21
==> master: python-urllib3.noarch 0:1.10.4-3.20150503gita91975b.fc21
==> master: pytz.noarch 0:2012d-7.fc21
==> master: zeromq3.x86_64 0:3.2.5-1.fc21
==> master: Complete!
==> master: * INFO: Running install_fedora_stable()
==> master: Resolving Dependencies
==> master: --> Running transaction check
==> master: ---> Package salt-master.noarch 0:2015.5.3-4.fc21 will be installed
==> master: --> Processing Dependency: salt = 2015.5.3-4.fc21 for package: salt-master-2015.5.3-4.fc21.noarch
==> master: --> Processing Dependency: systemd-python for package: salt-master-2015.5.3-4.fc21.noarch
==> master: --> Running transaction check
==> master: ---> Package salt.noarch 0:2015.5.3-4.fc21 will be installed
==> master: --> Processing Dependency: pciutils for package: salt-2015.5.3-4.fc21.noarch
==> master: ---> Package systemd-python.x86_64 0:216-25.fc21 will be installed
==> master: --> Processing Dependency: systemd = 216-25.fc21 for package: systemd-python-216-25.fc21.x86_64
==> master: --> Running transaction check
==> master: ---> Package pciutils.x86_64 0:3.3.0-1.fc21 will be installed
==> master: --> Processing Dependency: pciutils-libs = 3.3.0-1.fc21 for package: pciutils-3.3.0-1.fc21.x86_64
==> master: --> Processing Dependency: libpci.so.3(LIBPCI_3.3)(64bit) for package: pciutils-3.3.0-1.fc21.x86_64
==> master: --> Processing Dependency: libpci.so.3(LIBPCI_3.1)(64bit) for package: pciutils-3.3.0-1.fc21.x86_64
==> master: --> Processing Dependency: libpci.so.3(LIBPCI_3.0)(64bit) for package: pciutils-3.3.0-1.fc21.x86_64
==> master: --> Processing Dependency: hwdata for package: pciutils-3.3.0-1.fc21.x86_64
==> master: --> Processing Dependency: libpci.so.3()(64bit) for package: pciutils-3.3.0-1.fc21.x86_64
==> master: ---> Package systemd.x86_64 0:216-12.fc21 will be updated
==> master: --> Processing Dependency: systemd = 216-12.fc21 for package: libgudev1-216-12.fc21.x86_64
==> master: ---> Package systemd.x86_64 0:216-25.fc21 will be an update
==> master: --> Processing Dependency: systemd-libs = 216-25.fc21 for package: systemd-216-25.fc21.x86_64
==> master: --> Running transaction check
==> master: ---> Package hwdata.noarch 0:0.280-1.fc21 will be installed
==> master: ---> Package libgudev1.x86_64 0:216-12.fc21 will be updated
==> master: ---> Package libgudev1.x86_64 0:216-25.fc21 will be an update
==> master: ---> Package pciutils-libs.x86_64 0:3.3.0-1.fc21 will be installed
==> master: ---> Package systemd-libs.x86_64 0:216-12.fc21 will be updated
==> master: ---> Package systemd-libs.x86_64 0:216-25.fc21 will be an update
==> master: --> Finished Dependency Resolution
==> master:
==> master: Dependencies Resolved
==> master:
==> master: ================================================================================
==> master: Package Arch Version Repository Size
==> master: ================================================================================
==> master: Installing:
==> master: salt-master noarch 2015.5.3-4.fc21 updates 968 k
==> master: Installing for dependencies:
==> master: hwdata noarch 0.280-1.fc21 updates 1.4 M
==> master: pciutils x86_64 3.3.0-1.fc21 fedora 96 k
==> master: pciutils-libs x86_64 3.3.0-1.fc21 fedora 50 k
==> master: salt noarch 2015.5.3-4.fc21 updates 3.9 M
==> master: systemd-python x86_64 216-25.fc21 updates 95 k
==> master: Updating for dependencies:
==> master: libgudev1 x86_64 216-25.fc21 updates 62 k
==> master: systemd x86_64 216-25.fc21 updates 5.1 M
==> master: systemd-libs x86_64 216-25.fc21 updates 323 k
==> master:
==> master: Transaction Summary
==> master: ================================================================================
==> master: Install 1 Package (+5 Dependent packages)
==> master: Upgrade ( 3 Dependent packages)
==> master: Total download size: 12 M
==> master: Downloading packages:
==> master: Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
==> master: http://mirror.pnl.gov/fedora/linux/updates/21/x86_64/h/hwdata-0.280-1.fc21.noarch.rpm: [Errno 14] HTTP Error 404 - Not Found
==> master: Trying other mirror.
==> master: http://mirror.pnl.gov/fedora/linux/updates/21/x86_64/s/salt-2015.5.3-4.fc21.noarch.rpm: [Errno 14] HTTP Error 404 - Not Found
==> master: Trying other mirror.
==> master: http://mirror.pnl.gov/fedora/linux/updates/21/x86_64/s/salt-master-2015.5.3-4.fc21.noarch.rpm: [Errno 14] HTTP Error 404 - Not Found
==> master: Trying other mirror.
==> master: --------------------------------------------------------------------------------
==> master: Total 2.3 MB/s | 12 MB 00:05
==> master: Running transaction check
==> master: Running transaction test
==> master: Transaction test succeeded
==> master: Running transaction (shutdown inhibited)
==> master: Updating : systemd-libs-216-25.fc21.x86_64 1/12
==> master:
==> master: Updating : systemd-216-25.fc21.x86_64 2/12
==> master:
==> master: Installing : systemd-python-216-25.fc21.x86_64 3/12
==> master:
==> master: Installing : hwdata-0.280-1.fc21.noarch 4/12
==> master:
==> master: Installing : pciutils-libs-3.3.0-1.fc21.x86_64 5/12
==> master:
==> master: Installing : pciutils-3.3.0-1.fc21.x86_64 6/12
==> master:
==> master: Installing : salt-2015.5.3-4.fc21.noarch 7/12
==> master:
==> master: Installing : salt-master-2015.5.3-4.fc21.noarch 8/12
==> master:
==> master: Updating : libgudev1-216-25.fc21.x86_64 9/12
==> master:
==> master: Cleanup : libgudev1-216-12.fc21.x86_64 10/12
==> master:
==> master: Cleanup : systemd-216-12.fc21.x86_64 11/12
==> master:
==> master: Cleanup : systemd-libs-216-12.fc21.x86_64 12/12
==> master:
==> master: Verifying : salt-2015.5.3-4.fc21.noarch 1/12
==> master:
==> master: Verifying : systemd-libs-216-25.fc21.x86_64 2/12
==> master:
==> master: Verifying : libgudev1-216-25.fc21.x86_64 3/12
==> master:
==> master: Verifying : salt-master-2015.5.3-4.fc21.noarch 4/12
==> master:
==> master: Verifying : pciutils-libs-3.3.0-1.fc21.x86_64 5/12
==> master:
==> master: Verifying : pciutils-3.3.0-1.fc21.x86_64 6/12
==> master:
==> master: Verifying : systemd-python-216-25.fc21.x86_64 7/12
==> master:
==> master: Verifying : hwdata-0.280-1.fc21.noarch 8/12
==> master:
==> master: Verifying : systemd-216-25.fc21.x86_64 9/12
==> master:
==> master: Verifying : systemd-216-12.fc21.x86_64 10/12
==> master:
==> master: Verifying : libgudev1-216-12.fc21.x86_64 11/12
==> master:
==> master: Verifying : systemd-libs-216-12.fc21.x86_64 12/12
==> master:
==> master:
==> master: Installed:
==> master: salt-master.noarch 0:2015.5.3-4.fc21
==> master:
==> master: Dependency Installed:
==> master: hwdata.noarch 0:0.280-1.fc21 pciutils.x86_64 0:3.3.0-1.fc21
==> master: pciutils-libs.x86_64 0:3.3.0-1.fc21 salt.noarch 0:2015.5.3-4.fc21
==> master: systemd-python.x86_64 0:216-25.fc21
==> master:
==> master: Dependency Updated:
==> master: libgudev1.x86_64 0:216-25.fc21 systemd.x86_64 0:216-25.fc21
==> master: systemd-libs.x86_64 0:216-25.fc21
==> master: Complete!
==> master: * INFO: Running install_fedora_stable_post()
==> master: disabled
==> master: Created symlink from /etc/systemd/system/multi-user.target.wants/salt-master.service to /usr/lib/systemd/system/salt-master.service.
==> master: * INFO: Running install_fedora_check_services()
==> master: * INFO: Running install_fedora_restart_daemons()
==> master: * INFO: Running daemons_running()
==> master: * INFO: Salt installed!
==> master: Resolving Dependencies
==> master: --> Running transaction check
==> master: ---> Package python-cherrypy.noarch 0:3.2.2-6.fc21 will be installed
==> master: --> Finished Dependency Resolution
==> master:
==> master: Dependencies Resolved
==> master:
==> master: ================================================================================
==> master: Package Arch Version Repository Size
==> master: ================================================================================
==> master: Installing:
==> master: python-cherrypy noarch 3.2.2-6.fc21 fedora 423 k
==> master:
==> master: Transaction Summary
==> master: ================================================================================
==> master: Install 1 Package
==> master: Total download size: 423 k
==> master: Installed size: 1.4 M
==> master: Downloading packages:
==> master: Running transaction check
==> master: Running transaction test
==> master: Transaction test succeeded
==> master: Running transaction (shutdown inhibited)
==> master: Installing : python-cherrypy-3.2.2-6.fc21.noarch 1/1
==> master:
==> master: Verifying : python-cherrypy-3.2.2-6.fc21.noarch 1/1
==> master:
==> master:
==> master: Installed:
==> master: python-cherrypy.noarch 0:3.2.2-6.fc21
==> master: Complete!
==> master: Resolving Dependencies
==> master: --> Running transaction check
==> master: ---> Package salt-api.noarch 0:2015.5.3-4.fc21 will be installed
==> master: --> Finished Dependency Resolution
==> master:
==> master: Dependencies Resolved
==> master:
==> master: ================================================================================
==> master: Package Arch Version Repository Size
==> master: ================================================================================
==> master: Installing:
==> master: salt-api noarch 2015.5.3-4.fc21 updates 16 k
==> master:
==> master: Transaction Summary
==> master: ================================================================================
==> master: Install 1 Package
==> master: Total download size: 16 k
==> master: Installed size: 1.3 k
==> master: Downloading packages:
==> master: http://mirror.pnl.gov/fedora/linux/updates/21/x86_64/s/salt-api-2015.5.3-4.fc21.noarch.rpm: [Errno 14] HTTP Error 404 - Not Found
==> master: Trying other mirror.
==> master: Running transaction check
==> master: Running transaction test
==> master: Transaction test succeeded
==> master: Running transaction (shutdown inhibited)
==> master: Installing : salt-api-2015.5.3-4.fc21.noarch 1/1
==> master:
==> master: Verifying : salt-api-2015.5.3-4.fc21.noarch 1/1
==> master:
==> master:
==> master: Installed:
==> master: salt-api.noarch 0:2015.5.3-4.fc21
==> master: Complete!
==> master: * INFO: sh -- Version 2015.07.22
==> master:
==> master: * INFO: System Information:
==> master: * INFO: CPU: GenuineIntel
==> master: * INFO: CPU Arch: x86_64
==> master: * INFO: OS Name: Linux
==> master: * INFO: OS Version: 3.17.4-301.fc21.x86_64
==> master: * INFO: Distribution: Fedora 21
==> master: * INFO: Installing minion
==> master: * INFO: Found function install_fedora_deps
==> master: * INFO: Found function install_fedora_stable
==> master: * INFO: Found function install_fedora_stable_post
==> master: * INFO: Found function install_fedora_restart_daemons
==> master: * INFO: Found function daemons_running
==> master: * INFO: Found function install_fedora_check_services
==> master: * INFO: Running install_fedora_deps()
==> master: * INFO: Adding SaltStack's COPR repository
==> master: Package yum-utils-1.1.31-27.fc21.noarch already installed and latest version
==> master: Package PyYAML-3.11-7.fc21.x86_64 already installed and latest version
==> master: Package libyaml-0.1.6-6.fc21.x86_64 already installed and latest version
==> master: Package m2crypto-0.21.1-18.fc21.x86_64 already installed and latest version
==> master: Package python-crypto-2.6.1-6.fc21.x86_64 already installed and latest version
==> master: Package python-jinja2-2.7.3-2.fc21.noarch already installed and latest version
==> master: Package python-msgpack-0.4.6-1.fc21.x86_64 already installed and latest version
==> master: Package python-zmq-14.3.1-1.fc21.x86_64 already installed and latest version
==> master: Package python-requests-2.7.0-1.fc21.noarch already installed and latest version
==> master: Nothing to do
==> master: * INFO: Running install_fedora_stable()
==> master: Resolving Dependencies
==> master: --> Running transaction check
==> master: ---> Package salt-minion.noarch 0:2015.5.3-4.fc21 will be installed
==> master: --> Finished Dependency Resolution
==> master:
==> master: Dependencies Resolved
==> master:
==> master: ================================================================================
==> master: Package Arch Version Repository Size
==> master: ================================================================================
==> master: Installing:
==> master: salt-minion noarch 2015.5.3-4.fc21 updates 29 k
==> master:
==> master: Transaction Summary
==> master: ================================================================================
==> master: Install 1 Package
==> master: Total download size: 29 k
==> master: Installed size: 29 k
==> master: Downloading packages:
==> master: http://mirror.pnl.gov/fedora/linux/updates/21/x86_64/s/salt-minion-2015.5.3-4.fc21.noarch.rpm: [Errno 14] HTTP Error 404 - Not Found
==> master: Trying other mirror.
==> master: Running transaction check
==> master: Running transaction test
==> master: Transaction test succeeded
==> master: Running transaction (shutdown inhibited)
==> master: Installing : salt-minion-2015.5.3-4.fc21.noarch 1/1
==> master:
==> master: Verifying : salt-minion-2015.5.3-4.fc21.noarch 1/1
==> master:
==> master:
==> master: Installed:
==> master: salt-minion.noarch 0:2015.5.3-4.fc21
==> master: Complete!
==> master: * INFO: Running install_fedora_stable_post()
==> master: disabled
==> master: Created symlink from /etc/systemd/system/multi-user.target.wants/salt-minion.service to /usr/lib/systemd/system/salt-minion.service.
==> master: * INFO: Running install_fedora_check_services()
==> master: * INFO: Running install_fedora_restart_daemons()
==> master: * INFO: Running daemons_running()
==> master: * INFO: Salt installed!
==> minion-1: Importing base box 'kube-fedora21'...
==> minion-1: Matching MAC address for NAT networking...
==> minion-1: Setting the name of the VM: kubernetes_minion-1_1438260204131_64097
==> minion-1: Fixed port collision for 22 => 2222. Now on port 2200.
==> minion-1: Clearing any previously set network interfaces...
==> minion-1: Preparing network interfaces based on configuration...
minion-1: Adapter 1: nat
minion-1: Adapter 2: hostonly
==> minion-1: Forwarding ports...
minion-1: 22 => 2200 (adapter 1)
==> minion-1: Running 'pre-boot' VM customizations...
==> minion-1: Booting VM...
==> minion-1: Waiting for machine to boot. This may take a few minutes...
minion-1: SSH address: 127.0.0.1:2200
minion-1: SSH username: vagrant
minion-1: SSH auth method: private key
minion-1: Warning: Connection timeout. Retrying...
minion-1:
minion-1: Vagrant insecure key detected. Vagrant will automatically replace
minion-1: this with a newly generated keypair for better security.
minion-1:
minion-1: Inserting generated public key within guest...
minion-1: Removing insecure key from the guest if it's present...
minion-1: Key inserted! Disconnecting and reconnecting using new SSH key...
==> minion-1: Machine booted and ready!
==> minion-1: Checking for guest additions in VM...
==> minion-1: Configuring and enabling network interfaces...
==> minion-1: Mounting shared folders...
minion-1: /vagrant => /Users/smithm/kubernetes
==> minion-1: Running provisioner: shell...
minion-1: Running: /var/folders/rt/phr89yfj2fl206jtk0l86724th0_1v/T/vagrant-shell20150730-38892-1qc12vs.sh
==> minion-1: Adding kubernetes-master to hosts file
==> minion-1: Verifying network configuration
==> minion-1: It looks like the required network bridge has not yet been created
==> minion-1: Installing, enabling prerequisites
==> minion-1: http://repo.atlantic.net/fedora/linux/updates/21/x86_64/repodata/repomd.xml: [Errno -1] repomd.xml does not match metalink for updates
==> minion-1: Trying other mirror.
==> minion-1: http://mirror.pnl.gov/fedora/linux/updates/21/x86_64/repodata/0fce48b9091094de006cd77253a8f35b321a9498d5376ac71097460e82edf3ce-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> minion-1: Trying other mirror.
==> minion-1: Resolving Dependencies
==> minion-1: --> Running transaction check
==> minion-1: ---> Package bridge-utils.x86_64 0:1.5-10.fc21 will be installed
==> minion-1: ---> Package openvswitch.x86_64 0:2.3.2-1.fc21 will be installed
==> minion-1: --> Finished Dependency Resolution
==> minion-1:
==> minion-1: Dependencies Resolved
==> minion-1:
==> minion-1: ================================================================================
==> minion-1: Package Arch Version Repository Size
==> minion-1: ================================================================================
==> minion-1: Installing:
==> minion-1: bridge-utils x86_64 1.5-10.fc21 fedora 36 k
==> minion-1: openvswitch x86_64 2.3.2-1.fc21 updates 1.8 M
==> minion-1:
==> minion-1: Transaction Summary
==> minion-1: ================================================================================
==> minion-1: Install 2 Packages
==> minion-1: Total download size: 1.9 M
==> minion-1: Installed size: 7.7 M
==> minion-1: Downloading packages:
==> minion-1: warning: /var/cache/yum/x86_64/21/fedora/packages/bridge-utils-1.5-10.fc21.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 95a43f54: NOKEY
==> minion-1: Public key for bridge-utils-1.5-10.fc21.x86_64.rpm is not installed
==> minion-1: Public key for openvswitch-2.3.2-1.fc21.x86_64.rpm is not installed
==> minion-1: --------------------------------------------------------------------------------
==> minion-1: Total 824 kB/s | 1.9 MB 00:02
==> minion-1: Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-21-x86_64
==> minion-1: Importing GPG key 0x95A43F54:
==> minion-1: Userid : "Fedora (21) <fedora@fedoraproject.org>"
==> minion-1: Fingerprint: 6596 b8fb abda 5227 a9c5 b59e 89ad 4e87 95a4 3f54
==> minion-1: Package : fedora-repos-21-2.noarch (@anaconda)
==> minion-1: From : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-21-x86_64
==> minion-1: Running transaction check
==> minion-1: Running transaction test
==> minion-1: Transaction test succeeded
==> minion-1: Running transaction (shutdown inhibited)
==> minion-1: Installing : openvswitch-2.3.2-1.fc21.x86_64 1/2
==> minion-1:
==> minion-1: Installing : bridge-utils-1.5-10.fc21.x86_64 2/2
==> minion-1:
==> minion-1: Verifying : bridge-utils-1.5-10.fc21.x86_64 1/2
==> minion-1:
==> minion-1: Verifying : openvswitch-2.3.2-1.fc21.x86_64 2/2
==> minion-1:
==> minion-1:
==> minion-1: Installed:
==> minion-1: bridge-utils.x86_64 0:1.5-10.fc21 openvswitch.x86_64 0:2.3.2-1.fc21
==> minion-1: Complete!
==> minion-1: Created symlink from /etc/systemd/system/multi-user.target.wants/openvswitch.service to /usr/lib/systemd/system/openvswitch.service.
==> minion-1: Create a new docker bridge
==> minion-1: Cannot find device "cbr0"
==> minion-1: bridge cbr0 doesn't exist; can't delete it
==> minion-1: Add ovs bridge
==> minion-1: ovs-vsctl: no bridge named obr0
==> minion-1: ovs-vsctl: no port named gre0
==> minion-1: Add tun device
==> minion-1: ovs-vsctl: no port named tun0
==> minion-1: Add oflow rules
==> minion-1: Creating persistent gre tunnels
==> minion-1: Created persistent gre tunnels
==> minion-1: Add ip route rules such that all pod traffic flows through docker bridge
==> minion-1: Network configuration verified
==> minion-1: * INFO: sh -- Version 2015.07.22
==> minion-1:
==> minion-1: * INFO: System Information:
==> minion-1: * INFO: CPU: GenuineIntel
==> minion-1: * INFO: CPU Arch: x86_64
==> minion-1: * INFO: OS Name: Linux
==> minion-1: * INFO: OS Version: 3.17.4-301.fc21.x86_64
==> minion-1: * INFO: Distribution: Fedora 21
==> minion-1: * INFO: Installing minion
==> minion-1: * INFO: Found function install_fedora_deps
==> minion-1: * INFO: Found function install_fedora_stable
==> minion-1: * INFO: Found function install_fedora_stable_post
==> minion-1: * INFO: Found function install_fedora_restart_daemons
==> minion-1: * INFO: Found function daemons_running
==> minion-1: * INFO: Found function install_fedora_check_services
==> minion-1: * INFO: Running install_fedora_deps()
==> minion-1: * INFO: Adding SaltStack's COPR repository
==> minion-1: Resolving Dependencies
==> minion-1: --> Running transaction check
==> minion-1: ---> Package PyYAML.x86_64 0:3.11-7.fc21 will be installed
==> minion-1: ---> Package libyaml.x86_64 0:0.1.6-6.fc21 will be installed
==> minion-1: ---> Package m2crypto.x86_64 0:0.21.1-18.fc21 will be installed
==> minion-1: ---> Package python-crypto.x86_64 0:2.6.1-6.fc21 will be installed
==> minion-1: --> Processing Dependency: libtomcrypt.so.0()(64bit) for package: python-crypto-2.6.1-6.fc21.x86_64
==> minion-1: ---> Package python-jinja2.noarch 0:2.7.3-2.fc21 will be installed
==> minion-1: --> Processing Dependency: python-babel >= 0.8 for package: python-jinja2-2.7.3-2.fc21.noarch
==> minion-1: --> Processing Dependency: python-setuptools for package: python-jinja2-2.7.3-2.fc21.noarch
==> minion-1: --> Processing Dependency: python-markupsafe for package: python-jinja2-2.7.3-2.fc21.noarch
==> minion-1: ---> Package python-msgpack.x86_64 0:0.4.6-1.fc21 will be installed
==> minion-1: ---> Package python-requests.noarch 0:2.7.0-1.fc21 will be installed
==> minion-1: --> Processing Dependency: python-urllib3 >= 1.10 for package: python-requests-2.7.0-1.fc21.noarch
==> minion-1: --> Processing Dependency: python-chardet for package: python-requests-2.7.0-1.fc21.noarch
==> minion-1: ---> Package python-zmq.x86_64 0:14.3.1-1.fc21 will be installed
==> minion-1: --> Processing Dependency: libzmq.so.3()(64bit) for package: python-zmq-14.3.1-1.fc21.x86_64
==> minion-1: ---> Package yum-utils.noarch 0:1.1.31-27.fc21 will be installed
==> minion-1: --> Processing Dependency: python-kitchen for package: yum-utils-1.1.31-27.fc21.noarch
==> minion-1: --> Running transaction check
==> minion-1: ---> Package libtomcrypt.x86_64 0:1.17-24.fc21 will be installed
==> minion-1: --> Processing Dependency: libtommath >= 0.42.0 for package: libtomcrypt-1.17-24.fc21.x86_64
==> minion-1: --> Processing Dependency: libtommath.so.0()(64bit) for package: libtomcrypt-1.17-24.fc21.x86_64
==> minion-1: ---> Package python-babel.noarch 0:1.3-7.fc21 will be installed
==> minion-1: --> Processing Dependency: pytz for package: python-babel-1.3-7.fc21.noarch
==> minion-1: ---> Package python-chardet.noarch 0:2.2.1-2.fc21 will be installed
==> minion-1: ---> Package python-kitchen.noarch 0:1.2.1-2.fc21 will be installed
==> minion-1: ---> Package python-markupsafe.x86_64 0:0.23-6.fc21 will be installed
==> minion-1: ---> Package python-setuptools.noarch 0:2.0-8.fc21 will be installed
==> minion-1: --> Processing Dependency: python-backports-ssl_match_hostname for package: python-setuptools-2.0-8.fc21.noarch
==> minion-1: ---> Package python-urllib3.noarch 0:1.10.4-3.20150503gita91975b.fc21 will be installed
==> minion-1: --> Processing Dependency: python-pyasn1 for package: python-urllib3-1.10.4-3.20150503gita91975b.fc21.noarch
==> minion-1: --> Processing Dependency: python-ndg_httpsclient for package: python-urllib3-1.10.4-3.20150503gita91975b.fc21.noarch
==> minion-1: --> Processing Dependency: pyOpenSSL for package: python-urllib3-1.10.4-3.20150503gita91975b.fc21.noarch
==> minion-1: ---> Package zeromq3.x86_64 0:3.2.5-1.fc21 will be installed
==> minion-1: --> Processing Dependency: libpgm-5.2.so.0()(64bit) for package: zeromq3-3.2.5-1.fc21.x86_64
==> minion-1: --> Running transaction check
==> minion-1: ---> Package libtommath.x86_64 0:0.42.0-5.fc21 will be installed
==> minion-1: ---> Package openpgm.x86_64 0:5.2.122-4.fc21 will be installed
==> minion-1: ---> Package pyOpenSSL.x86_64 0:0.13.1-4.fc21 will be installed
==> minion-1: ---> Package python-backports-ssl_match_hostname.noarch 0:3.4.0.2-4.fc21 will be installed
==> minion-1: --> Processing Dependency: python-backports for package: python-backports-ssl_match_hostname-3.4.0.2-4.fc21.noarch
==> minion-1: ---> Package python-ndg_httpsclient.noarch 0:0.3.2-1.fc21 will be installed
==> minion-1: ---> Package python-pyasn1.noarch 0:0.1.7-4.fc21 will be installed
==> minion-1: ---> Package pytz.noarch 0:2012d-7.fc21 will be installed
==> minion-1: --> Running transaction check
==> minion-1: ---> Package python-backports.x86_64 0:1.0-5.fc21 will be installed
==> minion-1: --> Finished Dependency Resolution
==> minion-1:
==> minion-1: Dependencies Resolved
==> minion-1:
==> minion-1: ================================================================================
==> minion-1: Package Arch Version Repository
==> minion-1: Size
==> minion-1: ================================================================================
==> minion-1: Installing:
==> minion-1: PyYAML x86_64 3.11-7.fc21 updates 172 k
==> minion-1: libyaml x86_64 0.1.6-6.fc21 updates 58 k
==> minion-1: m2crypto x86_64 0.21.1-18.fc21 fedora 431 k
==> minion-1: python-crypto x86_64 2.6.1-6.fc21 fedora 467 k
==> minion-1: python-jinja2 noarch 2.7.3-2.fc21 updates 531 k
==> minion-1: python-msgpack x86_64 0.4.6-1.fc21 updates 81 k
==> minion-1: python-requests noarch 2.7.0-1.fc21 updates 99 k
==> minion-1: python-zmq x86_64 14.3.1-1.fc21 fedora 480 k
==> minion-1: yum-utils noarch 1.1.31-27.fc21 updates 118 k
==> minion-1: Installing for dependencies:
==> minion-1: libtomcrypt x86_64 1.17-24.fc21 fedora 227 k
==> minion-1: libtommath x86_64 0.42.0-5.fc21 fedora 39 k
==> minion-1: openpgm x86_64 5.2.122-4.fc21 fedora 176 k
==> minion-1: pyOpenSSL x86_64 0.13.1-4.fc21 fedora 137 k
==> minion-1: python-babel noarch 1.3-7.fc21 updates 2.5 M
==> minion-1: python-backports x86_64 1.0-5.fc21 fedora 9.7 k
==> minion-1: python-backports-ssl_match_hostname
==> minion-1: noarch 3.4.0.2-4.fc21 fedora 17 k
==> minion-1: python-chardet noarch 2.2.1-2.fc21 fedora 231 k
==> minion-1: python-kitchen noarch 1.2.1-2.fc21 updates 120 k
==> minion-1: python-markupsafe x86_64 0.23-6.fc21 fedora 35 k
==> minion-1: python-ndg_httpsclient noarch 0.3.2-1.fc21 fedora 47 k
==> minion-1: python-pyasn1 noarch 0.1.7-4.fc21 fedora 92 k
==> minion-1: python-setuptools noarch 2.0-8.fc21 fedora 393 k
==> minion-1: python-urllib3 noarch 1.10.4-3.20150503gita91975b.fc21 updates 109 k
==> minion-1: pytz noarch 2012d-7.fc21 fedora 39 k
==> minion-1: zeromq3 x86_64 3.2.5-1.fc21 updates 349 k
==> minion-1:
==> minion-1: Transaction Summary
==> minion-1: ================================================================================
==> minion-1: Install 9 Packages (+16 Dependent packages)
==> minion-1: Total download size: 6.8 M
==> minion-1: Installed size: 26 M
==> minion-1: Downloading packages:
==> minion-1: --------------------------------------------------------------------------------
==> minion-1: Total 669 kB/s | 6.8 MB 00:10
==> minion-1: Running transaction check
==> minion-1: Running transaction test
==> minion-1: Transaction test succeeded
==> minion-1: Running transaction (shutdown inhibited)
==> minion-1: Installing : python-chardet-2.2.1-2.fc21.noarch 1/25
==> minion-1:
==> minion-1: Installing : python-pyasn1-0.1.7-4.fc21.noarch 2/25
==> minion-1:
==> minion-1: Installing : pyOpenSSL-0.13.1-4.fc21.x86_64 3/25
==> minion-1:
==> minion-1: Installing : python-kitchen-1.2.1-2.fc21.noarch 4/25
==> minion-1:
==> minion-1: Installing : libtommath-0.42.0-5.fc21.x86_64 5/25
==> minion-1:
==> minion-1: Installing : libtomcrypt-1.17-24.fc21.x86_64 6/25
==> minion-1:
==> minion-1: Installing : python-backports-1.0-5.fc21.x86_64 7/25
==> minion-1:
==> minion-1: Installing : python-backports-ssl_match_hostname-3.4.0.2-4.fc21.noarc 8/25
==> minion-1:
==> minion-1: Installing : python-setuptools-2.0-8.fc21.noarch 9/25
==> minion-1:
==> minion-1: Installing : python-ndg_httpsclient-0.3.2-1.fc21.noarch 10/25
==> minion-1:
==> minion-1: Installing : python-urllib3-1.10.4-3.20150503gita91975b.fc21.noarch 11/25
==> minion-1:
==> minion-1: Installing : pytz-2012d-7.fc21.noarch 12/25
==> minion-1:
==> minion-1: Installing : python-babel-1.3-7.fc21.noarch 13/25
==> minion-1:
==> minion-1: Installing : openpgm-5.2.122-4.fc21.x86_64 14/25
==> minion-1:
==> minion-1: Installing : zeromq3-3.2.5-1.fc21.x86_64 15/25
==> minion-1:
==> minion-1: Installing : libyaml-0.1.6-6.fc21.x86_64 16/25
==> minion-1:
==> minion-1: Installing : python-markupsafe-0.23-6.fc21.x86_64 17/25
==> minion-1:
==> minion-1: Installing : python-jinja2-2.7.3-2.fc21.noarch 18/25
==> minion-1:
==> minion-1: Installing : PyYAML-3.11-7.fc21.x86_64 19/25
==> minion-1:
==> minion-1: Installing : python-zmq-14.3.1-1.fc21.x86_64 20/25
==> minion-1:
==> minion-1: Installing : python-requests-2.7.0-1.fc21.noarch 21/25
==> minion-1:
==> minion-1: Installing : python-crypto-2.6.1-6.fc21.x86_64 22/25
==> minion-1:
==> minion-1: Installing : yum-utils-1.1.31-27.fc21.noarch 23/25
==> minion-1:
==> minion-1: Installing : python-msgpack-0.4.6-1.fc21.x86_64 24/25
==> minion-1:
==> minion-1: Installing : m2crypto-0.21.1-18.fc21.x86_64 25/25
==> minion-1:
==> minion-1: Verifying : python-urllib3-1.10.4-3.20150503gita91975b.fc21.noarch 1/25
==> minion-1:
==> minion-1: Verifying : python-markupsafe-0.23-6.fc21.x86_64 2/25
==> minion-1:
==> minion-1: Verifying : python-crypto-2.6.1-6.fc21.x86_64 3/25
==> minion-1:
==> minion-1: Verifying : python-jinja2-2.7.3-2.fc21.noarch 4/25
==> minion-1:
==> minion-1: Verifying : pyOpenSSL-0.13.1-4.fc21.x86_64 5/25
==> minion-1:
==> minion-1: Verifying : PyYAML-3.11-7.fc21.x86_64 6/25
==> minion-1:
==> minion-1: Verifying : m2crypto-0.21.1-18.fc21.x86_64 7/25
==> minion-1:
==> minion-1: Verifying : python-kitchen-1.2.1-2.fc21.noarch 8/25
==> minion-1:
==> minion-1: Verifying : libyaml-0.1.6-6.fc21.x86_64 9/25
==> minion-1:
==> minion-1: Verifying : openpgm-5.2.122-4.fc21.x86_64 10/25
==> minion-1:
==> minion-1: Verifying : python-requests-2.7.0-1.fc21.noarch 11/25
==> minion-1:
==> minion-1: Verifying : python-zmq-14.3.1-1.fc21.x86_64 12/25
==> minion-1:
==> minion-1: Verifying : python-babel-1.3-7.fc21.noarch 13/25
==> minion-1:
==> minion-1: Verifying : zeromq3-3.2.5-1.fc21.x86_64 14/25
==> minion-1:
==> minion-1: Verifying : libtomcrypt-1.17-24.fc21.x86_64 15/25
==> minion-1:
==> minion-1: Verifying : python-pyasn1-0.1.7-4.fc21.noarch 16/25
==> minion-1:
==> minion-1: Verifying : yum-utils-1.1.31-27.fc21.noarch 17/25
==> minion-1:
==> minion-1: Verifying : pytz-2012d-7.fc21.noarch 18/25
==> minion-1:
==> minion-1: Verifying : python-setuptools-2.0-8.fc21.noarch 19/25
==> minion-1:
==> minion-1: Verifying : python-backports-1.0-5.fc21.x86_64 20/25
==> minion-1:
==> minion-1: Verifying : python-msgpack-0.4.6-1.fc21.x86_64 21/25
==> minion-1:
==> minion-1: Verifying : python-backports-ssl_match_hostname-3.4.0.2-4.fc21.noarc 22/25
==> minion-1:
==> minion-1: Verifying : python-ndg_httpsclient-0.3.2-1.fc21.noarch 23/25
==> minion-1:
==> minion-1: Verifying : libtommath-0.42.0-5.fc21.x86_64 24/25
==> minion-1:
==> minion-1: Verifying : python-chardet-2.2.1-2.fc21.noarch 25/25
==> minion-1:
==> minion-1:
==> minion-1: Installed:
==> minion-1: PyYAML.x86_64 0:3.11-7.fc21 libyaml.x86_64 0:0.1.6-6.fc21
==> minion-1: m2crypto.x86_64 0:0.21.1-18.fc21 python-crypto.x86_64 0:2.6.1-6.fc21
==> minion-1: python-jinja2.noarch 0:2.7.3-2.fc21 python-msgpack.x86_64 0:0.4.6-1.fc21
==> minion-1: python-requests.noarch 0:2.7.0-1.fc21 python-zmq.x86_64 0:14.3.1-1.fc21
==> minion-1: yum-utils.noarch 0:1.1.31-27.fc21
==> minion-1:
==> minion-1: Dependency Installed:
==> minion-1: libtomcrypt.x86_64 0:1.17-24.fc21
==> minion-1: libtommath.x86_64 0:0.42.0-5.fc21
==> minion-1: openpgm.x86_64 0:5.2.122-4.fc21
==> minion-1: pyOpenSSL.x86_64 0:0.13.1-4.fc21
==> minion-1: python-babel.noarch 0:1.3-7.fc21
==> minion-1: python-backports.x86_64 0:1.0-5.fc21
==> minion-1: python-backports-ssl_match_hostname.noarch 0:3.4.0.2-4.fc21
==> minion-1: python-chardet.noarch 0:2.2.1-2.fc21
==> minion-1: python-kitchen.noarch 0:1.2.1-2.fc21
==> minion-1: python-markupsafe.x86_64 0:0.23-6.fc21
==> minion-1: python-ndg_httpsclient.noarch 0:0.3.2-1.fc21
==> minion-1: python-pyasn1.noarch 0:0.1.7-4.fc21
==> minion-1: python-setuptools.noarch 0:2.0-8.fc21
==> minion-1: python-urllib3.noarch 0:1.10.4-3.20150503gita91975b.fc21
==> minion-1: pytz.noarch 0:2012d-7.fc21
==> minion-1: zeromq3.x86_64 0:3.2.5-1.fc21
==> minion-1: Complete!
==> minion-1: * INFO: Running install_fedora_stable()
==> minion-1: Resolving Dependencies
==> minion-1: --> Running transaction check
==> minion-1: ---> Package salt-minion.noarch 0:2015.5.3-4.fc21 will be installed
==> minion-1: --> Processing Dependency: salt = 2015.5.3-4.fc21 for package: salt-minion-2015.5.3-4.fc21.noarch
==> minion-1: --> Running transaction check
==> minion-1: ---> Package salt.noarch 0:2015.5.3-4.fc21 will be installed
==> minion-1: --> Processing Dependency: systemd-python for package: salt-2015.5.3-4.fc21.noarch
==> minion-1: --> Processing Dependency: pciutils for package: salt-2015.5.3-4.fc21.noarch
==> minion-1: --> Running transaction check
==> minion-1: ---> Package pciutils.x86_64 0:3.3.0-1.fc21 will be installed
==> minion-1: --> Processing Dependency: pciutils-libs = 3.3.0-1.fc21 for package: pciutils-3.3.0-1.fc21.x86_64
==> minion-1: --> Processing Dependency: libpci.so.3(LIBPCI_3.3)(64bit) for package: pciutils-3.3.0-1.fc21.x86_64
==> minion-1: --> Processing Dependency: libpci.so.3(LIBPCI_3.1)(64bit) for package: pciutils-3.3.0-1.fc21.x86_64
==> minion-1: --> Processing Dependency: libpci.so.3(LIBPCI_3.0)(64bit) for package: pciutils-3.3.0-1.fc21.x86_64
==> minion-1: --> Processing Dependency: hwdata for package: pciutils-3.3.0-1.fc21.x86_64
==> minion-1: --> Processing Dependency: libpci.so.3()(64bit) for package: pciutils-3.3.0-1.fc21.x86_64
==> minion-1: ---> Package systemd-python.x86_64 0:216-25.fc21 will be installed
==> minion-1: --> Processing Dependency: systemd = 216-25.fc21 for package: systemd-python-216-25.fc21.x86_64
==> minion-1: --> Running transaction check
==> minion-1: ---> Package hwdata.noarch 0:0.280-1.fc21 will be installed
==> minion-1: ---> Package pciutils-libs.x86_64 0:3.3.0-1.fc21 will be installed
==> minion-1: ---> Package systemd.x86_64 0:216-12.fc21 will be updated
==> minion-1: --> Processing Dependency: systemd = 216-12.fc21 for package: libgudev1-216-12.fc21.x86_64
==> minion-1: ---> Package systemd.x86_64 0:216-25.fc21 will be an update
==> minion-1: --> Processing Dependency: systemd-libs = 216-25.fc21 for package: systemd-216-25.fc21.x86_64
==> minion-1: --> Running transaction check
==> minion-1: ---> Package libgudev1.x86_64 0:216-12.fc21 will be updated
==> minion-1: ---> Package libgudev1.x86_64 0:216-25.fc21 will be an update
==> minion-1: ---> Package systemd-libs.x86_64 0:216-12.fc21 will be updated
==> minion-1: ---> Package systemd-libs.x86_64 0:216-25.fc21 will be an update
==> minion-1: --> Finished Dependency Resolution
==> minion-1:
==> minion-1: Dependencies Resolved
==> minion-1:
==> minion-1: ================================================================================
==> minion-1: Package Arch Version Repository Size
==> minion-1: ================================================================================
==> minion-1: Installing:
==> minion-1: salt-minion noarch 2015.5.3-4.fc21 updates 29 k
==> minion-1: Installing for dependencies:
==> minion-1: hwdata noarch 0.280-1.fc21 updates 1.4 M
==> minion-1: pciutils x86_64 3.3.0-1.fc21 fedora 96 k
==> minion-1: pciutils-libs x86_64 3.3.0-1.fc21 fedora 50 k
==> minion-1: salt noarch 2015.5.3-4.fc21 updates 3.9 M
==> minion-1: systemd-python x86_64 216-25.fc21 updates 95 k
==> minion-1: Updating for dependencies:
==> minion-1: libgudev1 x86_64 216-25.fc21 updates 62 k
==> minion-1: systemd x86_64 216-25.fc21 updates 5.1 M
==> minion-1: systemd-libs x86_64 216-25.fc21 updates 323 k
==> minion-1:
==> minion-1: Transaction Summary
==> minion-1: ================================================================================
==> minion-1: Install 1 Package (+5 Dependent packages)
==> minion-1: Upgrade ( 3 Dependent packages)
==> minion-1: Total download size: 11 M
==> minion-1: Downloading packages:
==> minion-1: Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
==> minion-1: --------------------------------------------------------------------------------
==> minion-1: Total 1.4 MB/s | 11 MB 00:08
==> minion-1: Running transaction check
==> minion-1: Running transaction test
==> minion-1: Transaction test succeeded
==> minion-1: Running transaction (shutdown inhibited)
==> minion-1: Updating : systemd-libs-216-25.fc21.x86_64 1/12
==> minion-1:
==> minion-1: Updating : systemd-216-25.fc21.x86_64 2/12
==> minion-1:
==> minion-1: Installing : systemd-python-216-25.fc21.x86_64 3/12
==> minion-1:
==> minion-1: Installing : hwdata-0.280-1.fc21.noarch 4/12
==> minion-1:
==> minion-1: Installing : pciutils-libs-3.3.0-1.fc21.x86_64 5/12
==> minion-1:
==> minion-1: Installing : pciutils-3.3.0-1.fc21.x86_64 6/12
==> minion-1:
==> minion-1: Installing : salt-2015.5.3-4.fc21.noarch 7/12
==> minion-1:
==> minion-1: Installing : salt-minion-2015.5.3-4.fc21.noarch 8/12
==> minion-1:
==> minion-1: Updating : libgudev1-216-25.fc21.x86_64 9/12
==> minion-1:
==> minion-1: Cleanup : libgudev1-216-12.fc21.x86_64 10/12
==> minion-1:
==> minion-1: Cleanup : systemd-216-12.fc21.x86_64 11/12
==> minion-1:
==> minion-1: Cleanup : systemd-libs-216-12.fc21.x86_64 12/12
==> minion-1:
==> minion-1: Verifying : systemd-libs-216-25.fc21.x86_64 1/12
==> minion-1:
==> minion-1: Verifying : salt-minion-2015.5.3-4.fc21.noarch 2/12
==> minion-1:
==> minion-1: Verifying : salt-2015.5.3-4.fc21.noarch 3/12
==> minion-1:
==> minion-1: Verifying : pciutils-libs-3.3.0-1.fc21.x86_64 4/12
==> minion-1:
==> minion-1: Verifying : pciutils-3.3.0-1.fc21.x86_64 5/12
==> minion-1:
==> minion-1: Verifying : systemd-python-216-25.fc21.x86_64 6/12
==> minion-1:
==> minion-1: Verifying : hwdata-0.280-1.fc21.noarch 7/12
==> minion-1:
==> minion-1: Verifying : libgudev1-216-25.fc21.x86_64 8/12
==> minion-1:
==> minion-1: Verifying : systemd-216-25.fc21.x86_64 9/12
==> minion-1:
==> minion-1: Verifying : libgudev1-216-12.fc21.x86_64 10/12
==> minion-1:
==> minion-1: Verifying : systemd-216-12.fc21.x86_64 11/12
==> minion-1:
==> minion-1: Verifying : systemd-libs-216-12.fc21.x86_64 12/12
==> minion-1:
==> minion-1:
==> minion-1: Installed:
==> minion-1: salt-minion.noarch 0:2015.5.3-4.fc21
==> minion-1:
==> minion-1: Dependency Installed:
==> minion-1: hwdata.noarch 0:0.280-1.fc21 pciutils.x86_64 0:3.3.0-1.fc21
==> minion-1: pciutils-libs.x86_64 0:3.3.0-1.fc21 salt.noarch 0:2015.5.3-4.fc21
==> minion-1: systemd-python.x86_64 0:216-25.fc21
==> minion-1:
==> minion-1: Dependency Updated:
==> minion-1: libgudev1.x86_64 0:216-25.fc21 systemd.x86_64 0:216-25.fc21
==> minion-1: systemd-libs.x86_64 0:216-25.fc21
==> minion-1: Complete!
==> minion-1: * INFO: Running install_fedora_stable_post()
==> minion-1: disabled
==> minion-1: Created symlink from /etc/systemd/system/multi-user.target.wants/salt-minion.service to /usr/lib/systemd/system/salt-minion.service.
==> minion-1: * INFO: Running install_fedora_check_services()
==> minion-1: * INFO: Running install_fedora_restart_daemons()
==> minion-1: * INFO: Running daemons_running()
==> minion-1: * INFO: Salt installed!
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment