Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
install -g grunt-div
npm ERR! 404 404 Not Found: grunt-div
npm ERR! 404
npm ERR! 404 'grunt-div' is not in the npm registry.
npm ERR! 404 You should bug the author to publish it
npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, or http url, or git url.
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "grunt-div"
npm ERR! cwd /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.21
npm ERR! code E404
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile/npm-debug.log
npm ERR! not ok code 0
Martins-Air:asokoinsight-profile mwawrusch$ npm install -g grunt-divshot
> chokidar@0.7.1 postinstall /usr/local/lib/node_modules/grunt-divshot/node_modules/superstatic/node_modules/chokidar
> node setup.js postinstall
> chokidar@0.7.1 postinstall /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/superstatic/node_modules/chokidar
> node setup.js postinstall
npm WARN engine tar@0.1.16: wanted: {"node":"~0.5.9 || 0.6 || 0.7 || 0.8"} (current: {"node":"0.10.30","npm":"1.4.21"})
> zlib@1.0.5 preinstall /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/tarzan/node_modules/zlib
> node-waf clean || true; node-waf configure build
sh: node-waf: command not found
sh: node-waf: command not found
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/tarzan/node_modules/tar/tar.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR! <http://github.com/npm/npm/issues>
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "grunt-divshot"
npm ERR! cwd /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.21
npm ERR! path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/tarzan/node_modules/tar/tar.js
npm ERR! fstream_path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/tarzan/node_modules/tar/tar.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (evalmachine.<anonymous>:107:15)
npm ERR! Error: ENOENT, utime '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/superstatic/node_modules/connect/lib/public/icons/page_find.png'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR! <http://github.com/npm/npm/issues>
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "grunt-divshot"
npm ERR! cwd /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.21
npm ERR! path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/superstatic/node_modules/connect/lib/public/icons/page_find.png
npm ERR! fstream_path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/superstatic/node_modules/connect/lib/public/icons/page_find.png
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! fstream_finish_call utimes
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:305:19
npm ERR! fstream_stack Object.oncomplete (evalmachine.<anonymous>:107:15)
npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/request/node_modules/hawk/node_modules/hoek'
npm ERR! error rolling back divshot-cli@0.9.14 { [Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/request/node_modules/hawk/node_modules/hoek']
npm ERR! error rolling back errno: 53,
npm ERR! error rolling back code: 'ENOTEMPTY',
npm ERR! error rolling back path: '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/request/node_modules/hawk/node_modules/hoek' }
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/moment/test/lang/en-ca.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR! <http://github.com/npm/npm/issues>
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "grunt-divshot"
npm ERR! cwd /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.21
npm ERR! path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/moment/test/lang/en-ca.js
npm ERR! fstream_path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/moment/test/lang/en-ca.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (evalmachine.<anonymous>:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/superstatic/node_modules/deliver/node_modules/request/node_modules/hawk/lib/server.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR! <http://github.com/npm/npm/issues>
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "grunt-divshot"
npm ERR! cwd /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.21
npm ERR! path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/superstatic/node_modules/deliver/node_modules/request/node_modules/hawk/lib/server.js
npm ERR! fstream_path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/superstatic/node_modules/deliver/node_modules/request/node_modules/hawk/lib/server.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (evalmachine.<anonymous>:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/superstatic/node_modules/deliver/node_modules/request/node_modules/tough-cookie/test.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR! <http://github.com/npm/npm/issues>
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "grunt-divshot"
npm ERR! cwd /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.21
npm ERR! path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/superstatic/node_modules/deliver/node_modules/request/node_modules/tough-cookie/test.js
npm ERR! fstream_path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/superstatic/node_modules/deliver/node_modules/request/node_modules/tough-cookie/test.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (evalmachine.<anonymous>:107:15)
npm ERR! EEXIST, mkdir '/usr/local/lib/node_modules/grunt-divshot/node_modules/superstatic/node_modules/lodash/dist'
File exists: /usr/local/lib/node_modules/grunt-divshot/node_modules/superstatic/node_modules/lodash/dist
Move it away, and try again.
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "grunt-divshot"
npm ERR! cwd /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.21
npm ERR! path /usr/local/lib/node_modules/grunt-divshot/node_modules/superstatic/node_modules/lodash/dist
npm ERR! fstream_path /usr/local/lib/node_modules/grunt-divshot/node_modules/superstatic/node_modules/lodash/dist/lodash.underscore.min.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code EEXIST
npm ERR! errno 47
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:171:23
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/mkdirp/index.js:37:53
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/superstatic/node_modules/deliver/node_modules/request/node_modules/http-signature/node_modules/ctype/ctio.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR! <http://github.com/npm/npm/issues>
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "grunt-divshot"
npm ERR! cwd /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.21
npm ERR! path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/superstatic/node_modules/deliver/node_modules/request/node_modules/http-signature/node_modules/ctype/ctio.js
npm ERR! fstream_path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/superstatic/node_modules/deliver/node_modules/request/node_modules/http-signature/node_modules/ctype/ctio.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (evalmachine.<anonymous>:107:15)
npm ERR! Error: ENOENT, utime '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/tarzan/node_modules/fstream-ignore/node_modules/fstream/README.md'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR! <http://github.com/npm/npm/issues>
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "grunt-divshot"
npm ERR! cwd /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.21
npm ERR! path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/tarzan/node_modules/fstream-ignore/node_modules/fstream/README.md
npm ERR! fstream_path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/tarzan/node_modules/fstream-ignore/node_modules/fstream/README.md
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! fstream_finish_call utimes
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:305:19
npm ERR! fstream_stack Object.oncomplete (evalmachine.<anonymous>:107:15)
npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/tarzan/node_modules/fstream-ignore/node_modules'
npm ERR! error rolling back grunt-divshot@0.3.3 { [Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/tarzan/node_modules/fstream-ignore/node_modules']
npm ERR! error rolling back errno: 53,
npm ERR! error rolling back code: 'ENOTEMPTY',
npm ERR! error rolling back path: '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/tarzan/node_modules/fstream-ignore/node_modules' }
npm ERR! zlib@1.0.5 preinstall: `node-waf clean || true; node-waf configure build`
npm ERR! Exit status 127
npm ERR!
npm ERR! Failed at the zlib@1.0.5 preinstall script.
npm ERR! This is most likely a problem with the zlib package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-waf clean || true; node-waf configure build
npm ERR! You can get their info via:
npm ERR! npm owner ls zlib
npm ERR! There is likely additional logging output above.
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "grunt-divshot"
npm ERR! cwd /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.21
npm ERR! code ELIFECYCLE
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/tarzan/node_modules/fstream-ignore/node_modules/minimatch/README.md'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR! <http://github.com/npm/npm/issues>
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "grunt-divshot"
npm ERR! cwd /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.21
npm ERR! path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/tarzan/node_modules/fstream-ignore/node_modules/minimatch/README.md
npm ERR! fstream_path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/tarzan/node_modules/fstream-ignore/node_modules/minimatch/README.md
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (evalmachine.<anonymous>:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/grunt-divshot/node_modules/superstatic/node_modules/deliver/node_modules/request/node_modules/tough-cookie/node_modules/punycode/punycode.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR! <http://github.com/npm/npm/issues>
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "grunt-divshot"
npm ERR! cwd /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.21
npm ERR! path /usr/local/lib/node_modules/grunt-divshot/node_modules/superstatic/node_modules/deliver/node_modules/request/node_modules/tough-cookie/node_modules/punycode/punycode.js
npm ERR! fstream_path /usr/local/lib/node_modules/grunt-divshot/node_modules/superstatic/node_modules/deliver/node_modules/request/node_modules/tough-cookie/node_modules/punycode/punycode.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (evalmachine.<anonymous>:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/request/node_modules/hawk/node_modules/hoek/test/index.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR! <http://github.com/npm/npm/issues>
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "grunt-divshot"
npm ERR! cwd /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.21
npm ERR! path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/request/node_modules/hawk/node_modules/hoek/test/index.js
npm ERR! fstream_path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/request/node_modules/hawk/node_modules/hoek/test/index.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (evalmachine.<anonymous>:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/nash/node_modules/pretty-print/node_modules/lodash/lodash.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR! <http://github.com/npm/npm/issues>
npm ERR! System Darwin 14.0.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "grunt-divshot"
npm ERR! cwd /Users/mwawrusch/Documents/asokoinsight/asokoinsight-profile
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.21
npm ERR! path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/nash/node_modules/pretty-print/node_modules/lodash/lodash.js
npm ERR! fstream_path /usr/local/lib/node_modules/grunt-divshot/node_modules/divshot-cli/node_modules/nash/node_modules/pretty-print/node_modules/lodash/lodash.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (evalmachine.<anonymous>:107:15)
\
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.