Skip to content

Instantly share code, notes, and snippets.

@myabc
Created Jul 31, 2009
Embed
What would you like to do?
* Install JRuby (tested with v.1.2.0 and 1.3.1)
* Install Addresable, Extlib, DataObjects (edge):
jruby -S gem install addressable
git clone git://github.com/datamapper/extlib && cd extlib
git checkout -b next --track origin/next
jruby -S rake install & cd ..
git clone git://github.com/datamapper/do && cd do
git checkout -b next --track origin/next
cd data_objects && jruby -S rake install & cd ..
cd do_jdbc && jruby -S rake install & cd ..
* Pick the DO Driver you wish to use:
cd do/do_DRIVERNAME && jruby -S rake install && cd ..
cd ..
* Then proceed to install DataMapper (edge):
git clone datamapper/dm-core && git checkout -b next --track origin/next
cd dm-core && jruby -S rake install & cd ..
git clone datamapper/dm-more && git checkout -b next --track origin/next
cd dm-more && jruby -S rake install & cd ..
* Finally, depending on the DO Driver you picked above, install the its corresponding JDBC Driver:
jruby -S gem install jdbc-derby
jruby -S gem install jdbc-h2
jruby -S gem install jdbc-hsqldb
jruby -S gem install jdbc-mysql
jruby -S gem install jdbc-postgres
jruby -S gem install jdbc-sqlite3
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment