Skip to content

Instantly share code, notes, and snippets.

What would you like to do?
UnsatisfiableError: The following specifications were found to be incompatible with each other:
Package mkl conflicts for:
pytorch -> mkl[version='>=2018']
Package libstdcxx-ng conflicts for:
python=3.7 -> libstdcxx-ng[version='>=7.2.0|>=7.3.0']
Package python conflicts for:
pytorch -> python[version='>=2.7,<2.8.0a0|>=3.5,<3.6.0a0|>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0']
torchvision -> python[version='>=3.5,<3.6.0a0|>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0']
Package ninja conflicts for:
pytorch -> ninja
Package readline conflicts for:
python=3.7 -> readline[version='>=7.0,<8.0a0']
Package openssl conflicts for:
python=3.7 -> openssl[version='>=1.0.2o,<1.0.3a|>=1.0.2p,<1.0.3a|>=1.1.1a,<1.1.2a|>=1.1.1b,<1.1.2a|>=1.1.1c,<1.1.2a|>=1.1.1d,<1.1.2a']
Package libgcc-ng conflicts for:
python=3.7 -> libgcc-ng[version='>=7.2.0|>=7.3.0']
Package numpy conflicts for:
pytorch -> numpy[version='>=1.11']
torchvision -> numpy[version='>=1.11']
Package ncurses conflicts for:
python=3.7 -> ncurses[version='>=6.1,<7.0a0']
Package six conflicts for:
torchvision -> six
Package zlib conflicts for:
python=3.7 -> zlib[version='>=1.2.11,<1.3.0a0']
Package cudatoolkit conflicts for:
pytorch -> cudatoolkit[version='>=10.0,<10.1|>=10.1,<10.2|>=9.2,<9.3']
torchvision -> cudatoolkit[version='>=10.0,<10.1|>=10.1,<10.2|>=9.2,<9.3']
Package * conflicts for:
pytorch -> *[track_features=cpuonly]
torchvision -> *[track_features=cpuonly]
Package tk conflicts for:
python=3.7 -> tk[version='>=8.6.7,<8.7.0a0|>=8.6.8,<8.7.0a0']
Package typing conflicts for:
pytorch -> typing
Package pip conflicts for:
python=3.7 -> pip
Package libffi conflicts for:
python=3.7 -> libffi[version='>=3.2.1,<4.0a0']
Package sqlite conflicts for:
python=3.7 -> sqlite[version='>=3.24.0,<4.0a0|>=3.25.2,<4.0a0|>=3.25.3,<4.0a0|>=3.26.0,<4.0a0|>=3.27.2,<4.0a0|>=3.29.0,<4.0a0|>=3.30.1,<4.0a0']
Package cffi conflicts for:
pytorch -> cffi
Package xz conflicts for:
python=3.7 -> xz[version='>=5.2.4,<6.0a0']
Package ld_impl_linux-64 conflicts for:
python=3.7 -> ld_impl_linux-64
Package pillow conflicts for:
torchvision -> pillow[version='>=4.1.1']
Package pytorch conflicts for:
torchvision -> pytorch==1.5.0.dev20200218
Package future conflicts for:
pytorch -> future
Note that strict channel priority may have removed packages required for satisfiability.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment