Skip to content

Instantly share code, notes, and snippets.

@nicksieger
Created Jul 28, 2010
Embed
What would you like to do?
$ rvm use jruby-head
Using jruby head
[11:35:29][~/Projects/ruby/rails (master) {jruby-head-}]
$ rvm gemset create rails-clean
Gemset 'rails-clean' created.
[11:35:46][~/Projects/ruby/rails (master) {jruby-head-}]
$ rvm use jruby-head@rails-clean
Using jruby head with gemset rails clean
[11:35:53][~/Projects/ruby/rails (master) {jruby-head-@rails-clean}]
$ gem list
*** LOCAL GEMS ***
[11:35:55][~/Projects/ruby/rails (master) {jruby-head-@rails-clean}]
$ gem install bundler --pre
JRuby limited openssl loaded. http://jruby.org/openssl
gem install jruby-openssl for full support.
Successfully installed bundler-1.0.0.rc.1
1 gem installed
[11:36:10][~/Projects/ruby/rails (master) {jruby-head-@rails-clean}]
$ bundle install
JRuby limited openssl loaded. http://jruby.org/openssl
gem install jruby-openssl for full support.
Updating git://github.com/rails/arel.git
Fetching source index for http://rubygems.org/
Installing rake (0.8.7)
Installing abstract (1.0.0)
Using activesupport (3.0.0.rc) from source at /Users/nicksieger/Projects/ruby/rails
Installing builder (2.1.2)
Installing i18n (0.4.1)
Using activemodel (3.0.0.rc) from source at /Users/nicksieger/Projects/ruby/rails
Installing erubis (2.6.6)
Installing rack (1.2.1)
Installing rack-mount (0.6.9)
Installing rack-test (0.5.4)
Installing tzinfo (0.3.22)
Using actionpack (3.0.0.rc) from source at /Users/nicksieger/Projects/ruby/rails
Installing mime-types (1.16)
Installing polyglot (0.3.1)
Installing treetop (1.4.8)
Installing mail (2.2.5)
Using actionmailer (3.0.0.rc) from source at /Users/nicksieger/Projects/ruby/rails
Using arel (0.4.0) from git://github.com/rails/arel.git (at master)
Using activerecord (3.0.0.rc) from source at /Users/nicksieger/Projects/ruby/rails
Installing activerecord-jdbc-adapter (0.9.7)
Installing jdbc-mysql (5.0.4)
Installing activerecord-jdbcmysql-adapter (0.9.7)
Installing jdbc-postgres (8.4.701)
Installing activerecord-jdbcpostgresql-adapter (0.9.7)
Installing jdbc-sqlite3 (3.6.3.054)
Installing activerecord-jdbcsqlite3-adapter (0.9.7)
Using activeresource (3.0.0.rc) from source at /Users/nicksieger/Projects/ruby/rails
Using bundler (1.0.0.rc.1)
Installing columnize (0.3.1)
Installing rdoc (2.5.9)
Installing horo (1.0.0)
Installing linecache (0.43) with native extensions /Users/nicksieger/Projects/ruby/jruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:483:in `build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)
/Users/nicksieger/Projects/ruby/jruby/bin/jruby extconf.rb
WARNING: JRuby does not support native extensions or the `mkmf' library.
Check http://kenai.com/projects/jruby/pages/Home for alternatives.
extconf.rb:16: undefined method `create_makefile' for main:Object (NoMethodError)
Gem files will remain installed in /Users/nicksieger/.rvm/gems/jruby-head@rails-clean/gems/linecache-0.43 for inspection.
Results logged to /Users/nicksieger/.rvm/gems/jruby-head@rails-clean/gems/linecache-0.43/ext/gem_make.out
from /Users/nicksieger/Projects/ruby/jruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:446:in `each'
from /Users/nicksieger/Projects/ruby/jruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:446:in `build_extensions'
from /Users/nicksieger/Projects/ruby/jruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:198:in `install'
from /Users/nicksieger/.rvm/gems/jruby-head@rails-clean/gems/bundler-1.0.0.rc.1/lib/bundler/source.rb:96:in `install'
from /Users/nicksieger/.rvm/gems/jruby-head@rails-clean/gems/bundler-1.0.0.rc.1/lib/bundler/installer.rb:51:in `run'
from /Users/nicksieger/.rvm/gems/jruby-head@rails-clean/gems/bundler-1.0.0.rc.1/lib/bundler/spec_set.rb:12:in `each'
from /Users/nicksieger/.rvm/gems/jruby-head@rails-clean/gems/bundler-1.0.0.rc.1/lib/bundler/spec_set.rb:12:in `each'
from /Users/nicksieger/.rvm/gems/jruby-head@rails-clean/gems/bundler-1.0.0.rc.1/lib/bundler/installer.rb:40:in `run'
... 9 levels...
from /Users/nicksieger/.rvm/gems/jruby-head@rails-clean/gems/bundler-1.0.0.rc.1/bin/bundle:13
from /Users/nicksieger/.rvm/gems/jruby-head@rails-clean/gems/bundler-1.0.0.rc.1/bin/bundle:19:in `load'
from /Users/nicksieger/.rvm/gems/jruby-head@rails-clean/bin/bundle:19
[exited with 1]
[11:37:08][~/Projects/ruby/rails (master) {jruby-head-@rails-clean}]
$ gem install ~/Projects/ruby/jruby/build_lib/ruby-debug-base-0.10.3.2-java.gem
JRuby limited openssl loaded. http://jruby.org/openssl
gem install jruby-openssl for full support.
Successfully installed ruby-debug-base-0.10.3.2-java
1 gem installed
[11:37:22][~/Projects/ruby/rails (master) {jruby-head-@rails-clean}]
$ gem install ruby-debug --ignore-dependencies
JRuby limited openssl loaded. http://jruby.org/openssl
gem install jruby-openssl for full support.
Successfully installed ruby-debug-0.10.3
1 gem installed
[11:37:33][~/Projects/ruby/rails (master) {jruby-head-@rails-clean}]
$ bundle install
JRuby limited openssl loaded. http://jruby.org/openssl
gem install jruby-openssl for full support.
Updating git://github.com/rails/arel.git
Fetching source index for http://rubygems.org/
Using rake (0.8.7)
Using abstract (1.0.0)
Using activesupport (3.0.0.rc) from source at /Users/nicksieger/Projects/ruby/rails
Using builder (2.1.2)
Using i18n (0.4.1)
Using activemodel (3.0.0.rc) from source at /Users/nicksieger/Projects/ruby/rails
Using erubis (2.6.6)
Using rack (1.2.1)
Using rack-mount (0.6.9)
Using rack-test (0.5.4)
Using tzinfo (0.3.22)
Using actionpack (3.0.0.rc) from source at /Users/nicksieger/Projects/ruby/rails
Using mime-types (1.16)
Using polyglot (0.3.1)
Using treetop (1.4.8)
Using mail (2.2.5)
Using actionmailer (3.0.0.rc) from source at /Users/nicksieger/Projects/ruby/rails
Using arel (0.4.0) from git://github.com/rails/arel.git (at master)
Using activerecord (3.0.0.rc) from source at /Users/nicksieger/Projects/ruby/rails
Using activerecord-jdbc-adapter (0.9.7)
Using jdbc-mysql (5.0.4)
Using activerecord-jdbcmysql-adapter (0.9.7)
Using jdbc-postgres (8.4.701)
Using activerecord-jdbcpostgresql-adapter (0.9.7)
Using jdbc-sqlite3 (3.6.3.054)
Using activerecord-jdbcsqlite3-adapter (0.9.7)
Using activeresource (3.0.0.rc) from source at /Users/nicksieger/Projects/ruby/rails
Using bundler (1.0.0.rc.1)
Using columnize (0.3.1)
Using rdoc (2.5.9)
Using horo (1.0.0)
Installing memcache-client (1.8.5)
Installing mocha (0.9.8)
Installing thor (0.14.0)
Using railties (3.0.0.rc) from source at /Users/nicksieger/Projects/ruby/rails
Using rails (3.0.0.rc) from source at /Users/nicksieger/Projects/ruby/rails
Using ruby-debug-base (0.10.3.2)
Using ruby-debug (0.10.3)
Installing text-hyphen (1.0.0)
Installing text-format (1.0.0)
Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment