Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
#######################################
$ cat composer.json
{
"require": {
"npm-asset/grunt-modernizr": "0.5.2"
}
}
$ composer install
Loading composer repositories with package information
Installing dependencies (including require-dev)
Your GitHub credentials are required to fetch private repository metadata (git://github.com/doctyper/grunt-modernizr.git)
The credentials will be swapped for an OAuth token stored in /home/niko/.composer/auth.json, your password will not be stored
To revoke access to this token you can visit https://github.com/settings/applications
Username: nsams
Password:
An existing OAuth token for Composer is present and will be reused
Your requirements could not be resolved to an installable set of packages.
Problem 1
- The requested package npm-asset/grunt-modernizr could not be found in any version, there may be a typo in the package name.
Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> for more details.
Read <http://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
#######################################
$ cat composer.json
{
"require": {
"npm-asset/uglify-js": "2.4.13"
}
}
$ composer install
Loading composer repositories with package information
Installing dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.
Problem 1
- npm-asset/uglify-js v2.4.13 requires npm-asset/optimist >=0.3.5,<0.4 -> satisfiable by npm-asset/optimist[0.3.7, 0.3.6, 0.3.5].
- npm-asset/uglify-js v2.4.13 requires npm-asset/optimist >=0.3.5,<0.4 -> satisfiable by npm-asset/optimist[0.3.7, 0.3.6, 0.3.5].
- npm-asset/optimist 0.3.5 requires npm-asset/wordwrap >=0.0.2,<0.1 -> no matching package found.
- npm-asset/optimist 0.3.5 requires npm-asset/wordwrap >=0.0.2,<0.1 -> no matching package found.
- npm-asset/optimist 0.3.6 requires npm-asset/wordwrap >=0.0.2,<0.1 -> no matching package found.
- npm-asset/optimist 0.3.6 requires npm-asset/wordwrap >=0.0.2,<0.1 -> no matching package found.
- npm-asset/optimist 0.3.7 requires npm-asset/wordwrap >=0.0.2,<0.1 -> no matching package found.
- npm-asset/optimist 0.3.7 requires npm-asset/wordwrap >=0.0.2,<0.1 -> no matching package found.
- Installation request for npm-asset/uglify-js 2.4.13 -> satisfiable by npm-asset/uglify-js[v2.4.13].
Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> for more details.
Read <http://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
@francoispluchino

This comment has been minimized.

Copy link

commented Sep 16, 2014

The bug is caused by Composer that it no manages the redirects for the VCS Repositories:
git://github.com/doctyper/grunt-modernizr.git to git://github.com/Modernizr/grunt-modernizr.git

I search an solution directly in Composer.

@francoispluchino

This comment has been minimized.

Copy link

commented Sep 18, 2014

The second case is solved (see francoispluchino/composer-asset-plugin@a94c862).

Because 'wordwrap' has no tag version, we must indicate the stability (native system of Composer).

$ cat composer.json
{
    "require": {
        "npm-asset/uglify-js": "2.4.13",
        "npm-asset/wordwrap": "0.0.2@dev"
    }
}

$ composer install
Loading composer repositories with package information
Installing dependencies (including require-dev)
  - Installing npm-asset/uglify-to-browserify (1.0.2)
    Downloading: 100%

  - Installing npm-asset/wordwrap (dev-master b026541)
    Cloning b0265414e9fbce0413d5bf26179685786b759d8a

  - Installing npm-asset/optimist (0.3.7)
    Downloading: 100%

  - Installing npm-asset/amdefine (default)
    Downloading: 100%

  - Installing npm-asset/source-map (0.1.39)
    Downloading: 100%

  - Installing npm-asset/async (0.2.10)
    Downloading: 100%

  - Installing npm-asset/uglify-js (v2.4.13)
    Downloading: 100%

Writing lock file
Generating autoload files
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.