Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Install libmemcached with brew in preview (build 13A558) version of OSX Mavericks with XCode 5 Developer Preview 6
require 'formula'
class Libmemcached < Formula
homepage 'http://libmemcached.org'
url 'https://launchpad.net/libmemcached/1.0/1.0.17/+download/libmemcached-1.0.17.tar.gz'
sha1 '1023bc8c738b1f5b8ea2cd16d709ec6b47c3efa8'
depends_on 'memcached'
def install
ENV.append_to_cflags "-undefined dynamic_lookup" if MacOS.version <= :leopard
if MacOS.version > :mountain_lion
ENV.append 'CXXFLAGS', "-I#{MacOS.sdk_path}/usr/include/c++/4.2.1"
ENV.append 'LIBS', "#{MacOS.sdk_path}/usr/lib/libstdc++.dylib"
end
system "./configure", "--prefix=#{prefix}"
system "make install"
end
end
@potiuk
Copy link
Author

potiuk commented Aug 25, 2013

Until the problem is fixed permanently (by whatever party - I reported to all of them), you can manually modify libmemcached brew formula by running

brew edit libmemcached

@potiuk
Copy link
Author

potiuk commented Aug 25, 2013

More details about the problem and issues opened are in Homebrew: Homebrew/legacy-homebrew#20635 and Libmemcached: https://bugs.launchpad.net/libmemcached/+bug/1216521

@dasilvacontin
Copy link

dasilvacontin commented Dec 27, 2013

Thanks so much for this! I can't believe you still get the "<tr1/cinttypes>" error on Mavericks when installing libmemcached via brew.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment