Skip to content

Instantly share code, notes, and snippets.

@powerwlsl

powerwlsl/error

Created May 21, 2019
Embed
What would you like to do?
#!/bin/bash -eo pipefail
bundle install --jobs=4 --retry=3 --path vendor/bundle
The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java`.
Fetching gem metadata from https://rubygems.org/.......
Using rake 12.3.2
Using concurrent-ruby 1.1.5
Using builder 3.2.3
Using erubi 1.8.0
Using mini_portile2 2.4.0
Using crass 1.0.4
Using rack 2.0.6
Using nio4r 2.3.1
Using websocket-extensions 0.1.3
Using mini_mime 1.0.1
Using arel 9.0.0
Using mimemagic 0.3.3
Using public_suffix 3.0.3
Using io-like 0.3.0
Using ast 2.4.0
Using awesome_print 1.8.0
Using aws-eventstream 1.0.1
Using aws-partitions 1.129.0
Using aws-sigv4 1.0.3
Using jmespath 1.4.0
Using bcrypt 3.1.12
Using bindex 0.5.0
Using msgpack 1.2.6
Using brakeman 4.3.1
Using buftok 0.2.0
Using bundler 1.17.2
Using byebug 10.0.2
Using ffi 1.9.25
Using chunky_png 1.3.11
Using coderay 1.1.2
Using connection_pool 2.2.2
Using unicode_utils 1.4.0
Using safe_yaml 1.0.4
Using docile 1.3.1
Using minitest 5.11.3
Using dotenv 2.5.0
Using method_source 0.9.2
Using thor 0.19.4
Using multi_json 1.13.1
Using multipart-post 2.0.0
Using equalizer 0.0.11
Using execjs 2.7.0
Using sax-machine 1.3.2
Using raabro 1.1.6
Using hashdiff 0.3.8
Using http-form_data 2.1.1
Fetching unf_ext 0.0.7.6
Using thread_safe 0.3.6
Using httpauth 0.2.1
Using http_parser.rb 0.6.0
Using jaro_winkler 1.5.2
Using json 2.1.0
Using kaminari-core 1.1.1
Fetching idn-ruby 0.1.0
Using rb-fsevent 0.10.3
Using ruby_dep 1.5.0
Using metaclass 0.0.4
Using mini_magick 4.8.0
Using naught 1.1.0
Using oauth 0.5.4
Using parallel 1.12.1
Using pg 0.21.0
Using powerpack 0.1.2
Using yard 0.9.16
Using puma 3.12.0
Using rainbow 3.0.0
Using redis 4.1.0
Using ruby-progressbar 1.10.0
Using unicode-display_width 1.4.1
Using rubyzip 1.2.2
Using tilt 2.0.9
Using shoulda-context 1.2.2
Using simple_oauth 0.3.1
Using simplecov-html 0.10.2
Using timecop 0.9.1
Using turbolinks-source 5.2.0
Using i18n 1.6.0
Using nokogiri 1.10.1
Using rack-test 1.1.0
Using request_store 1.4.1
Using rack-protection 2.0.5
Using rack-proxy 0.6.5
Using sprockets 3.7.2
Using websocket-driver 0.7.0
Using mail 2.7.1
Using marcel 0.3.3
Using addressable 2.5.2
Using archive-zip 0.11.0
Using parser 2.5.3.0
Using aws-sdk-core 3.44.2
Using bootsnap 1.3.2
Using childprocess 0.9.0
Using rb-inotify 0.10.0
Using sassc 2.0.0
Using rqrcode 0.10.1
Using coolline 0.5.0
Using crack 0.4.3
Using minitest-ci 3.4.0
Using pry 0.12.2
Using foreman 0.85.0
Using elasticsearch-api 6.0.3
Using jb 0.5.0
Using faraday 0.15.4
Using uglifier 4.1.20
Using tzinfo 1.2.5
Using memoizable 0.4.2
Using mocha 1.7.0
Using redis-store 1.6.0
Using redis_rate_limiter 0.1.0
Using simplecov 0.16.1
Using turbolinks 5.2.0
Using faker 1.9.3
Using loofah 2.2.3
Using xpath 3.2.0
Using sidekiq 5.1.3
Using chromedriver-helper 2.1.0
Using down 4.7.0
Using rotp 4.0.2
Using rubocop 0.62.0
Using aws-sdk-kms 1.13.0
Using selenium-webdriver 3.141.0
Using listen 3.1.5
Using pry-coolline 0.2.5
Using webmock 3.5.1
Installing idn-ruby 0.1.0 with native extensions
Using pry-byebug 3.6.0
Using pry-doc 1.0.0
Using pry-rails 0.3.9
Using elasticsearch-transport 6.0.3
Using faraday_middleware 0.12.2
Using koala 3.0.0
Using oauth2 0.6.1
Using sentry-raven 2.7.4
Using activesupport 5.2.2.1
Using et-orbi 1.1.6
Using rails-html-sanitizer 1.0.4
Using redis-rack 2.0.5
Using capybara 2.18.0
Using sidekiq-rate-limiter 0.1.2
Using aws-sdk-s3 1.30.0
Using elasticsearch 6.0.3
Using feedjira 2.2.0
Using rails-dom-testing 2.0.3
Using globalid 0.4.2
Using activemodel 5.2.2.1
Using pundit 2.0.0
Using redis-activesupport 5.0.7
Using shoulda-matchers 2.8.0
Using spring 2.0.2
Using fugit 1.1.6
Using actionview 5.2.2.1
Using activejob 5.2.2.1
Using activerecord 5.2.2.1
Using actionpack 5.2.2.1
Using acts-as-taggable-on 6.0.0
Using ancestry 3.0.5
Using kaminari-actionview 1.1.1
Using kaminari-activerecord 1.1.1
Using paper_trail 10.0.1
Using shoulda 3.5.0
Using sidekiq-cron 1.0.4
Using spring-watcher-listen 2.0.1
Using actioncable 5.2.2.1
Using actionmailer 5.2.2.1
Using activestorage 5.2.2.1
Using railties 5.2.2.1
Using sprockets-rails 3.2.1
Using redis-actionpack 5.0.2
Using kaminari 1.1.1
Using paper_trail-globalid 0.2.0
Using dotenv-rails 2.5.0
Using web-console 3.7.0
Using webpacker 3.5.5
Using rails 5.2.2.1
Using sassc-rails 2.1.0
Using redis-rails 5.0.2
Installing unf_ext 0.0.7.6 with native extensions
Using unf 0.1.4
Using domain_name 0.5.20180417
Using http-cookie 1.0.3
Using http 3.3.0
Using twitter 6.2.0
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
current directory:
/home/circleci/repo/vendor/bundle/ruby/2.6.0/gems/idn-ruby-0.1.0/ext
/usr/local/bin/ruby -I /usr/local/lib/ruby/2.6.0 -r
./siteconf20190521-162-1p350k8.rb extconf.rb
checking for -lidn... no
ERROR: could not find idn library!
Please install the GNU IDN library or alternatively specify at least one
of the following options if the library can only be found in a non-standard
location:
--with-idn-dir=/path/to/non/standard/location
or
--with-idn-lib=/path/to/non/standard/location/lib
--with-idn-include=/path/to/non/standard/location/include
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details. You may
need configuration options.
Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=/usr/local/bin/$(RUBY_BASE_NAME)
--with-idn-dir
--without-idn-dir
--with-idn-include
--without-idn-include=${idn-dir}/include
--with-idn-lib
--without-idn-lib=${idn-dir}/lib
--with-idnlib
--without-idnlib
To see why this extension failed to compile, please check the mkmf.log which can
be found here:
/home/circleci/repo/vendor/bundle/ruby/2.6.0/extensions/x86_64-linux/2.6.0/idn-ruby-0.1.0/mkmf.log
extconf failed, exit code 1
Gem files will remain installed in
/home/circleci/repo/vendor/bundle/ruby/2.6.0/gems/idn-ruby-0.1.0 for inspection.
Results logged to
/home/circleci/repo/vendor/bundle/ruby/2.6.0/extensions/x86_64-linux/2.6.0/idn-ruby-0.1.0/gem_make.out
An error occurred while installing idn-ruby (0.1.0), and Bundler cannot
continue.
Make sure that `gem install idn-ruby -v '0.1.0' --source
'https://rubygems.org/'` succeeds before bundling.
In Gemfile:
twitter-text was resolved to 3.0.0, which depends on
idn-ruby
Exited with code 5
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment