Skip to content

Instantly share code, notes, and snippets.

Avatar

Pavel Valena pvalena

View GitHub Profile
View rubygem-ffi_gem2rpm.diff
--- rubygem-ffi/.generated.spec 2021-09-17 14:21:32.676326673 +0200
+++ rubygem-ffi/rubygem-ffi.spec 2021-09-17 14:01:48.713875457 +0200
@@ -1,30 +1,32 @@
-Downloaded ffi-1.15.4
-# Generated from ffi-1.15.4.gem by gem2rpm -*- rpm-spec -*-
%global gem_name ffi
Name: rubygem-%{gem_name}
Version: 1.15.4
Release: 1%{?dist}
View rubygem-ffi_test.log
+ [[ -n '' ]]
+ section SRPM
+ local l=###############################
+ : '############################### SRPM ###############################'
+ max=32
++ seq 32
+ for x in $(seq ${max})
+ [[ -z 1 ]]
+ mrn=7
View rubygem-ffi_update.log
NOTE: Gem::Specification#has_rdoc is deprecated with no replacement. It will be removed in Rubygems 4
Gem::Specification#has_rdoc called from /usr/share/gems/gems/gem-compare-0.0.7/lib/rubygems/comparator/utils.rb:112.
NOTE: Gem::Specification#has_rdoc is deprecated with no replacement. It will be removed in Rubygems 4
Gem::Specification#has_rdoc called from /usr/share/gems/gems/gem-compare-0.0.7/lib/rubygems/comparator/utils.rb:112.
Compared versions: ["1.13.1", "1.15.4"]
DIFFERENT require_paths:
1.13.1: ["/usr/lib64/gems/ruby/ffi-1.13.1", "lib"]
1.15.4: ["/usr/lib64/gems/ruby/ffi-1.15.4", "lib"]
View rubygem-asciidoctor-pdf_gem2rpm.diff
--- rubygem-asciidoctor-pdf/.generated.spec 2021-09-17 14:14:10.150264516 +0200
+++ rubygem-asciidoctor-pdf/rubygem-asciidoctor-pdf.spec 2021-09-17 13:53:13.078266343 +0200
@@ -1,27 +1,35 @@
-Downloaded asciidoctor-pdf-1.6.1
-# Generated from asciidoctor-pdf-1.6.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name asciidoctor-pdf
Name: rubygem-%{gem_name}
Version: 1.6.1
Release: 1%{?dist}
View rubygem-asciidoctor-pdf_test.log
+ [[ -n '' ]]
+ section SRPM
+ local l=###############################
+ : '############################### SRPM ###############################'
+ max=32
++ seq 32
+ for x in $(seq ${max})
+ [[ -z 1 ]]
+ mrn=31
View rubygem-asciidoctor-pdf_update.log
WARNING: Unsupported version specification: , skipping.
ERROR: Latest upstream version matches the version given. Nothing to compare.
commit e6063df77733ddb2239aeee875a87c810dba0b53
Author: Pavel Valena <pvalena@redhat.com>
Date: Fri Sep 17 13:51:15 2021 +0200
Enhance .spec and .gitignore files.
View rubygem-uuidtools_gem2rpm.diff
--- rubygem-uuidtools/.generated.spec 2021-09-17 14:10:31.262180099 +0200
+++ rubygem-uuidtools/rubygem-uuidtools.spec 2021-09-17 13:56:57.543307691 +0200
@@ -1,74 +1,148 @@
-Downloaded uuidtools-2.2.0
-# Generated from uuidtools-2.2.0.gem by gem2rpm -*- rpm-spec -*-
+# Generated from uuidtools-2.1.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name uuidtools
+Summary: A simple universally unique ID generation library
Name: rubygem-%{gem_name}
View rubygem-uuidtools_test.log
+ [[ -n '' ]]
+ section SRPM
+ local l=###############################
+ : '############################### SRPM ###############################'
+ max=32
++ seq 32
+ for x in $(seq ${max})
+ [[ -z 1 ]]
+ mrn=8
View rubygem-uuidtools_update.log
NOTE: Gem::Specification#has_rdoc is deprecated with no replacement. It will be removed in Rubygems 4
Gem::Specification#has_rdoc called from /usr/share/gems/gems/gem-compare-0.0.7/lib/rubygems/comparator/utils.rb:112.
NOTE: Gem::Specification#has_rdoc is deprecated with no replacement. It will be removed in Rubygems 4
Gem::Specification#has_rdoc called from /usr/share/gems/gems/gem-compare-0.0.7/lib/rubygems/comparator/utils.rb:112.
Compared versions: ["2.1.5", "2.2.0"]
DIFFERENT licenses:
2.1.5: []
2.2.0: ["Apache-2.0"]
View rubygem-bundler_ext_gem2rpm.diff
--- rubygem-bundler_ext/.generated.spec 2021-09-17 13:52:31.849177131 +0200
+++ rubygem-bundler_ext/rubygem-bundler_ext.spec 2021-09-17 13:39:35.560482800 +0200
@@ -1,23 +1,27 @@
-Downloaded bundler_ext-0.4.1
-# Generated from bundler_ext-0.4.1.gem by gem2rpm -*- rpm-spec -*-
+# Generated from bundler_ext-0.1.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name bundler_ext
+Summary: Load system gems via Bundler DSL
Name: rubygem-%{gem_name}