Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
appium logs
============================= test session starts ==============================
platform darwin -- Python 3.7.4, pytest-5.0.1, py-1.8.0, pluggy-0.12.0
rootdir: /Users/rafaelcarvalho/Desktop/projects/open-ios/open-test-automation
plugins: allure-pytest-2.7.1
collected 5 items
tests/test_login.py [HTTP] --> POST /wd/hub/session
[HTTP] {"capabilities":{"firstMatch":[{"platformName":"iOS","appium:platformVersion":"12.4","appium:deviceName":"iPhone X","appium:automationName":"XCUITest","appium:useNewWDA":true,"appium:usePrebuiltWDA":false,"appium:app":"/var/folders/sx/qwd0l4kj15g17_m1p1g1nb7r0000gn/T/__archive__388107363/hashtagopen DEV.xcarchive/Products/Applications/hashtagopen DEV.app"}]},"desiredCapabilities":{"platformName":"iOS","platformVersion":"12.4","deviceName":"iPhone X","automationName":"XCUITest","useNewWDA":true,"usePrebuiltWDA":false,"app":"/var/folders/sx/qwd0l4kj15g17_m1p1g1nb7r0000gn/T/__archive__388107363/hashtagopen DEV.xcarchive/Products/Applications/hashtagopen DEV.app"}}
[debug] [W3C] Calling AppiumDriver.createSession() with args: [{"platformName":"iOS","platformVersion":"12.4","deviceName":"iPhone X","automationName":"XCUITest","useNewWDA":true,"usePrebuiltWDA":false,"app":"/var/folders/sx/qwd0l4kj15g17_m1p1g1nb7r0000gn/T/__archive__388107363/hashtagopen DEV.xcarchive/Products/Applications/hashtagopen DEV.app"},null,{"firstMatch":[{"platformName":"iOS","appium:platformVersion":"12.4","appium:deviceName":"iPhone X","appium:automationName":"XCUITest","appium:useNewWDA":true,"appium:usePrebuiltWDA":false,"appium:app":"/var/folders/sx/qwd0l4kj15g17_m1p1g1nb7r0000gn/T/__archive__388107363/hashtagopen DEV.xcarchive/Products/Applications/hashtagopen DEV.app"}]}]
[debug] [BaseDriver] Event 'newSessionRequested' logged at 1565888968329 (14:09:28 GMT-0300 (Brasilia Standard Time))
[Appium] Appium v1.14.1 creating new XCUITestDriver (v2.117.0) session
[Appium] Capabilities:
[Appium] platformName: iOS
[Appium] platformVersion: 12.4
[Appium] deviceName: iPhone X
[Appium] automationName: XCUITest
[Appium] useNewWDA: true
[Appium] usePrebuiltWDA: false
[Appium] app: /var/folders/sx/qwd0l4kj15g17_m1p1g1nb7r0000gn/T/__archive__388107363/hashtagopen DEV.xcarchive/Products/Applications/hashtagopen DEV.app
[debug] [BaseDriver] W3C capabilities {"alwaysMatch":{"platformNa... and MJSONWP desired capabilities {"platformName":"iOS","plat... were provided
[debug] [BaseDriver] Creating session with W3C capabilities: {"alwaysMatch":{"platformNa...
[BaseDriver] Session created with session id: 8fb4ec7c-2549-423d-8d3f-4a1cf29981dd
[debug] [XCUITest] Current user: 'rafaelcarvalho'
[XCUITest] iOS SDK Version set to '12.4'
[iOSSim] Constructing iOS simulator for Xcode version 10.3 with udid '57ADEFB0-91E2-46E6-B23F-1AE7BD25563D'
[XCUITest] Determining device to run tests on: udid: '57ADEFB0-91E2-46E6-B23F-1AE7BD25563D', real device: false
[debug] [BaseDriver] Event 'xcodeDetailsRetrieved' logged at 1565888970446 (14:09:30 GMT-0300 (Brasilia Standard Time))
[BaseDriver] Using local app '/var/folders/sx/qwd0l4kj15g17_m1p1g1nb7r0000gn/T/__archive__388107363/hashtagopen DEV.xcarchive/Products/Applications/hashtagopen DEV.app'
[debug] [BaseDriver] Event 'appConfigured' logged at 1565888970451 (14:09:30 GMT-0300 (Brasilia Standard Time))
[debug] [XCUITest] Checking whether app '/var/folders/sx/qwd0l4kj15g17_m1p1g1nb7r0000gn/T/__archive__388107363/hashtagopen DEV.xcarchive/Products/Applications/hashtagopen DEV.app' is actually present on file system
[debug] [XCUITest] App is present
[debug] [iOS] Getting bundle ID from app '/var/folders/sx/qwd0l4kj15g17_m1p1g1nb7r0000gn/T/__archive__388107363/hashtagopen DEV.xcarchive/Products/Applications/hashtagopen DEV.app': 'com.hashtagopen.hashtagopen.dev'
[debug] [BaseDriver] Event 'resetStarted' logged at 1565888970459 (14:09:30 GMT-0300 (Brasilia Standard Time))
[XCUITest] Not scrubbing third party app in anticipation of uninstall
[debug] [BaseDriver] Event 'resetComplete' logged at 1565888970808 (14:09:30 GMT-0300 (Brasilia Standard Time))
[XCUITest] Continuing without capturing device logs: iOS Simulator with udid 57ADEFB0-91E2-46E6-B23F-1AE7BD25563D is not running
[XCUITest] Setting up simulator
[debug] [iOS] No reason to set locale
[debug] [iOS] No iOS / app preferences to set
[debug] [iOSSim] Setting preferences of 57ADEFB0-91E2-46E6-B23F-1AE7BD25563D Simulator to {"ConnectHardwareKeyboard":false}
[debug] [iOSSim] Setting common Simulator preferences to {"RotateWindowWhenSignaledByGuest":true,"ConnectHardwareKeyboard":false}
[debug] [iOSSim] Updated 57ADEFB0-91E2-46E6-B23F-1AE7BD25563D Simulator preferences at '/Users/rafaelcarvalho/Library/Preferences/com.apple.iphonesimulator.plist' with {"DevicePreferences":{"57ADEFB0-91E2-46E6-B23F-1AE7BD25563D":{"ConnectHardwareKeyboard":false}},"RotateWindowWhenSignaledByGuest":true,"ConnectHardwareKeyboard":false}
[iOSSim] Booting Simulator with UDID 57ADEFB0-91E2-46E6-B23F-1AE7BD25563D...
[iOSSim] Starting Simulator UI with command: open -Fn /Applications/Xcode.app/Contents/Developer/Applications/Simulator.app --args -CurrentDeviceUDID 57ADEFB0-91E2-46E6-B23F-1AE7BD25563D -ConnectHardwareKeyboard 0
[iOSSim] Simulator with UDID 57ADEFB0-91E2-46E6-B23F-1AE7BD25563D booted in 29 seconds
[debug] [IDB] Connecting idb service to '57ADEFB0-91E2-46E6-B23F-1AE7BD25563D'
[XCUITest] idb will not be used for Simulator interaction. Original error: 'idb' has not been found in PATH. Is it installed? Read https://www.fbidb.io for more details
[debug] [BaseDriver] Event 'simStarted' logged at 1565889000903 (14:10:00 GMT-0300 (Brasilia Standard Time))
[debug] [XCUITest] Starting log capture for iOS Simulator with udid '57ADEFB0-91E2-46E6-B23F-1AE7BD25563D', using 'xcrun simctl spawn 57ADEFB0-91E2-46E6-B23F-1AE7BD25563D log stream --style compact'
[debug] [BaseDriver] Event 'logCaptureStarted' logged at 1565889003542 (14:10:03 GMT-0300 (Brasilia Standard Time))
[debug] [XCUITest] Verifying application platform
[debug] [XCUITest] CFBundleSupportedPlatforms: ["iPhoneOS"]
[XCUITest] *********************************
[XCUITest] Simulator architecture appears to be unsupported by the '/var/folders/sx/qwd0l4kj15g17_m1p1g1nb7r0000gn/T/__archive__388107363/hashtagopen DEV.xcarchive/Products/Applications/hashtagopen DEV.app' application. Make sure the correct deployment target has been selected for its compilation in Xcode.
[XCUITest] Don't be surprised if the application fails to launch.
[XCUITest] *********************************
[debug] [XCUITest] Reset requested. Removing app with id 'com.hashtagopen.hashtagopen.dev' from the device
[debug] [XCUITest] Cleaning installd cache to save the disk space
[debug] [XCUITest] Installing '/var/folders/sx/qwd0l4kj15g17_m1p1g1nb7r0000gn/T/__archive__388107363/hashtagopen DEV.xcarchive/Products/Applications/hashtagopen DEV.app' on Simulator with UUID '57ADEFB0-91E2-46E6-B23F-1AE7BD25563D'...
[debug] [XCUITest] The app has been installed successfully.
[debug] [BaseDriver] Event 'appInstalled' logged at 1565889009484 (14:10:09 GMT-0300 (Brasilia Standard Time))
[XCUITest] Using WDA path: '/Users/rafaelcarvalho/.nvm/versions/node/v10.16.0/lib/node_modules/appium/node_modules/appium-webdriveragent'
[XCUITest] Using WDA agent: '/Users/rafaelcarvalho/.nvm/versions/node/v10.16.0/lib/node_modules/appium/node_modules/appium-webdriveragent/WebDriverAgent.xcodeproj'
[debug] [XCUITest] No obsolete cached processes from previous WDA sessions listening on port 8100 have been found
[debug] [XCUITest] Starting WebDriverAgent initialization with the synchronization key 'XCUITestDriver'
[debug] [XCUITest] Capability 'useNewWDA' set to true, so uninstalling WDA before proceeding
[XCUITest] Shutting down sub-processes
[debug] [XCUITest] Removing WDA application from device
[debug] [BaseDriver] Event 'wdaUninstalled' logged at 1565889011270 (14:10:11 GMT-0300 (Brasilia Standard Time))
[debug] [XCUITest] Trying to start WebDriverAgent 2 times with 10000ms interval
[debug] [XCUITest] These values can be customized by changing wdaStartupRetries/wdaStartupRetryInterval capabilities
[debug] [BaseDriver] Event 'wdaStartAttempted' logged at 1565889011272 (14:10:11 GMT-0300 (Brasilia Standard Time))
[XCUITest] Launching WebDriverAgent on the device
[WebDriverAgent] Fetching dependencies
[WebDriverAgent] Dependencies up-to-date
[debug] [XCUITest] Killing running processes 'xcodebuild.*57ADEFB0-91E2-46E6-B23F-1AE7BD25563D, iproxy 8100, 57ADEFB0-91E2-46E6-B23F-1AE7BD25563D.*XCTRunner' for the device 57ADEFB0-91E2-46E6-B23F-1AE7BD25563D...
[debug] [XCUITest] 'pgrep -ifn xcodebuild.*57ADEFB0-91E2-46E6-B23F-1AE7BD25563D' didn't detect any matching processes. Return code: 1
[debug] [XCUITest] 'pgrep -ifn iproxy 8100' didn't detect any matching processes. Return code: 1
[debug] [XCUITest] 'pgrep -ifn 57ADEFB0-91E2-46E6-B23F-1AE7BD25563D.*XCTRunner' didn't detect any matching processes. Return code: 1
[debug] [XCUITest] Beginning test with command 'xcodebuild build-for-testing test-without-building -project /Users/rafaelcarvalho/.nvm/versions/node/v10.16.0/lib/node_modules/appium/node_modules/appium-webdriveragent/WebDriverAgent.xcodeproj -scheme WebDriverAgentRunner -destination id=57ADEFB0-91E2-46E6-B23F-1AE7BD25563D IPHONEOS_DEPLOYMENT_TARGET=12.4 GCC_TREAT_WARNINGS_AS_ERRORS=0 COMPILER_INDEX_STORE_ENABLE=NO' in directory '/Users/rafaelcarvalho/.nvm/versions/node/v10.16.0/lib/node_modules/appium/node_modules/appium-webdriveragent'
[debug] [XCUITest] Output from xcodebuild will only be logged if any errors are present there. To change this, use 'showXcodeLog' desired capability
[debug] [XCUITest] Waiting up to 60000ms for WebDriverAgent to start
[debug] [WD Proxy] Matched '/status' to command name 'getStatus'
[debug] [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[WD Proxy] Got an unexpected response: {"errno":"ECONNREFUSED","code":"ECONNREFUSED","syscall":"connect","address":"127.0.0.1","port":8100}
[debug] [WD Proxy] Matched '/status' to command name 'getStatus'
[debug] [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[WD Proxy] Got an unexpected response: {"errno":"ECONNREFUSED","code":"ECONNREFUSED","syscall":"connect","address":"127.0.0.1","port":8100}
[debug] [WD Proxy] Matched '/status' to command name 'getStatus'
[debug] [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[WD Proxy] Got an unexpected response: {"errno":"ECONNREFUSED","code":"ECONNREFUSED","syscall":"connect","address":"127.0.0.1","port":8100}
[debug] [XCUITest] Log file for xcodebuild test: /Users/rafaelcarvalho/Library/Developer/Xcode/DerivedData/WebDriverAgent-ecbazsboxdvbyqgorwcggrcvjmsd/Logs/Test/Test-WebDriverAgentRunner-2019.08.15_14-10-15--0300.xcresult/2_Test/Diagnostics/WebDriverAgentRunner-48DAE514-64E0-47EF-A7A9-D8F1EE592A3E/WebDriverAgentRunner-BF3E60B5-CCA3-4605-8DF8-099D3A80FBF0/Session-WebDriverAgentRunner-2019-08-15_141016-s21zGQ.log
[debug] [WD Proxy] Matched '/status' to command name 'getStatus'
[debug] [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[WD Proxy] Got an unexpected response: {"errno":"ECONNREFUSED","code":"ECONNREFUSED","syscall":"connect","address":"127.0.0.1","port":8100}
[debug] [WD Proxy] Matched '/status' to command name 'getStatus'
[debug] [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[WD Proxy] Got an unexpected response: {"errno":"ECONNREFUSED","code":"ECONNREFUSED","syscall":"connect","address":"127.0.0.1","port":8100}
[debug] [WD Proxy] Matched '/status' to command name 'getStatus'
[debug] [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[WD Proxy] Got an unexpected response: {"errno":"ECONNREFUSED","code":"ECONNREFUSED","syscall":"connect","address":"127.0.0.1","port":8100}
[debug] [WD Proxy] Matched '/status' to command name 'getStatus'
[debug] [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[WD Proxy] Got an unexpected response: {"errno":"ECONNREFUSED","code":"ECONNREFUSED","syscall":"connect","address":"127.0.0.1","port":8100}
[debug] [WD Proxy] Matched '/status' to command name 'getStatus'
[debug] [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[WD Proxy] Got an unexpected response: {"errno":"ECONNREFUSED","code":"ECONNREFUSED","syscall":"connect","address":"127.0.0.1","port":8100}
[debug] [WD Proxy] Matched '/status' to command name 'getStatus'
[debug] [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[WD Proxy] Got an unexpected response: {"errno":"ECONNREFUSED","code":"ECONNREFUSED","syscall":"connect","address":"127.0.0.1","port":8100}
[debug] [WD Proxy] Matched '/status' to command name 'getStatus'
[debug] [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[WD Proxy] Got an unexpected response: {"errno":"ECONNREFUSED","code":"ECONNREFUSED","syscall":"connect","address":"127.0.0.1","port":8100}
[debug] [WD Proxy] Matched '/status' to command name 'getStatus'
[debug] [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[WD Proxy] Got an unexpected response: {"errno":"ECONNREFUSED","code":"ECONNREFUSED","syscall":"connect","address":"127.0.0.1","port":8100}
[debug] [WD Proxy] Matched '/status' to command name 'getStatus'
[debug] [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[WD Proxy] Got an unexpected response: {"errno":"ECONNREFUSED","code":"ECONNREFUSED","syscall":"connect","address":"127.0.0.1","port":8100}
[debug] [WD Proxy] Matched '/status' to command name 'getStatus'
[debug] [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[WD Proxy] Got an unexpected response: {"errno":"ECONNREFUSED","code":"ECONNREFUSED","syscall":"connect","address":"127.0.0.1","port":8100}
[debug] [WD Proxy] Matched '/status' to command name 'getStatus'
[debug] [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
[debug] [WD Proxy] Got response with status 200: "{\n \"value\" : {\n \"state\" : \"success\",\n \"os\" : {\n \"name\" : \"iOS\",\n \"version\" : \"12.4\",\n \"sdkVersion\" : \"12.2\"\n },\n \"ios\" : {\n \"simulatorVersion\" : \"12.4\",\n \"ip\" : \"10.0.0.100\"\n },\n \"build\" : {\n \"upgradedAt\" : \"1565801168114\",\n \"time\" : \"Aug 14 2019 15:59:00\",\n \"productBundleIdentifier\" : \"com.facebook.WebDriverAgentRunner\"\n }\n },\n \"sessionId\" : \"B02B9745-2791-4FAB-B22D-B4870A56FCC3\",\n \"status\" : 0\n}"
[debug] [WD Proxy] Determined that the downstream protocol for proxy is MJSONWP
[debug] [XCUITest] WebDriverAgent information:
[debug] [XCUITest] {
[debug] [XCUITest] "state": "success",
[debug] [XCUITest] "os": {
[debug] [XCUITest] "name": "iOS",
[debug] [XCUITest] "version": "12.4",
[debug] [XCUITest] "sdkVersion": "12.2"
[debug] [XCUITest] },
[debug] [XCUITest] "ios": {
[debug] [XCUITest] "simulatorVersion": "12.4",
[debug] [XCUITest] "ip": "10.0.0.100"
[debug] [XCUITest] },
[debug] [XCUITest] "build": {
[debug] [XCUITest] "upgradedAt": "1565801168114",
[debug] [XCUITest] "time": "Aug 14 2019 15:59:00",
[debug] [XCUITest] "productBundleIdentifier": "com.facebook.WebDriverAgentRunner"
[debug] [XCUITest] }
[debug] [XCUITest] }
[debug] [XCUITest] WebDriverAgent successfully started after 23589ms
[debug] [BaseDriver] Event 'wdaSessionAttempted' logged at 1565889034999 (14:10:34 GMT-0300 (Brasilia Standard Time))
[debug] [XCUITest] Sending createSession command to WDA
[debug] [WD Proxy] Matched '/session' to command name 'createSession'
[debug] [WD Proxy] Proxying [POST /session] to [POST http://localhost:8100/session] with body: {"desiredCapabilities":{"bundleId":"com.hashtagopen.hashtagopen.dev","arguments":[],"environment":{},"eventloopIdleDelaySec":0,"shouldWaitForQuiescence":true,"shouldUseTestManagerForVisibilityDetection":false,"maxTypingFrequency":60,"shouldUseSingletonTestManager":true}}
[debug] [WD Proxy] Determined that the downstream protocol for proxy is MJSONWP
[WD Proxy] Got an unexpected response: {"value":"Failed to launch com.hashtagopen.hashtagopen.dev application","sessionId":"B02B9745-2791-4FAB-B22D-B4870A56FCC3","status":13}
[debug] [MJSONWP] Matched JSONWP error code 13 to UnknownError
[debug] [XCUITest] Failed to create WDA session (An unknown server-side error occurred while processing the command. Original error: Failed to launch com.hashtagopen.hashtagopen.dev application). Retrying...
[debug] [BaseDriver] Event 'wdaSessionAttempted' logged at 1565889220008 (14:13:40 GMT-0300 (Brasilia Standard Time))
[debug] [XCUITest] Sending createSession command to WDA
[debug] [WD Proxy] Matched '/session' to command name 'createSession'
[debug] [WD Proxy] Proxying [POST /session] to [POST http://localhost:8100/session] with body: {"desiredCapabilities":{"bundleId":"com.hashtagopen.hashtagopen.dev","arguments":[],"environment":{},"eventloopIdleDelaySec":0,"shouldWaitForQuiescence":true,"shouldUseTestManagerForVisibilityDetection":false,"maxTypingFrequency":60,"shouldUseSingletonTestManager":true}}
[debug] [WD Proxy] Got response with status 200: {"value":"Failed to launch com.hashtagopen.hashtagopen.dev application","sessionId":"B02B9745-2791-4FAB-B22D-B4870A56FCC3","status":13}
[WD Proxy] Got an unexpected response: {"value":"Failed to launch com.hashtagopen.hashtagopen.dev application","sessionId":"B02B9745-2791-4FAB-B22D-B4870A56FCC3","status":13}
[debug] [MJSONWP] Matched JSONWP error code 13 to UnknownError
[debug] [XCUITest] Failed to create WDA session (An unknown server-side error occurred while processing the command. Original error: Failed to launch com.hashtagopen.hashtagopen.dev application). Retrying...
[debug] [BaseDriver] Event 'wdaSessionAttempted' logged at 1565889404659 (14:16:44 GMT-0300 (Brasilia Standard Time))
[debug] [XCUITest] Sending createSession command to WDA
[debug] [WD Proxy] Matched '/session' to command name 'createSession'
[debug] [WD Proxy] Proxying [POST /session] to [POST http://localhost:8100/session] with body: {"desiredCapabilities":{"bundleId":"com.hashtagopen.hashtagopen.dev","arguments":[],"environment":{},"eventloopIdleDelaySec":0,"shouldWaitForQuiescence":true,"shouldUseTestManagerForVisibilityDetection":false,"maxTypingFrequency":60,"shouldUseSingletonTestManager":true}}
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.