Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
sudo su -
# Kernels older than 3.10 lack some of the features required to run Docker containers.
uname -r
3.11.0-15-generic
apt-key adv --keyserver hkp://p80.pool.sks-keyservers.net:80 --recv-keys 58118E89F3A912897C070ADBF76221572C52609D
echo deb https://apt.dockerproject.org/repo ubuntu-trusty main > /etc/apt/sources.list.d/docker.list
apt-get update
apt-get purge lxc-docker
apt-cache policy docker-engine
apt-get install -y docker-engine linux-image-extra-$(uname -r)
usermod -aG docker ubuntu
docker run hello-world
# Install docker-compose
curl -L https://github.com/docker/compose/releases/download/1.5.2/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose
chmod +x /usr/local/bin/docker-compose
docker-compose --version
docker-compose version: 1.5.2
# Change docker storage directory
vim /etc/default/docker
# uncomment blow line -g your storage directory
#DOCKER_OPTS="--dns 8.8.8.8 --dns 8.8.4.4 -g /data"
service docker restart
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment