Skip to content

Instantly share code, notes, and snippets.

@rcugut
rcugut / guide: use puma-dev as proxy.md
Created May 7, 2020
guide: use puma-dev as proxy
View guide: use puma-dev as proxy.md
@rcugut
rcugut / GUIDE_01: macOS and bash.md
Last active Aug 6, 2019
[GUIDE] Setup macOS for development: terminals, Ruby on Rails, Node JS, react-native, mobile, DB, etc
View GUIDE_01: macOS and bash.md
@rcugut
rcugut / [GUIDE] macos yarn nvm install.md
Last active Oct 9, 2020
GUIDE for mac OS X yarn nvm node install
View [GUIDE] macos yarn nvm install.md

GUIDE to install yarn, nvm (node) on macOS

last update: Apr 6, 2020

Assumptions:

  • macOS >= 10.14 (Mojave)
  • homebrew properly installed
@rcugut
rcugut / node-npm-install.md
Last active Sep 15, 2020 — forked from DanHerbert/fix-homebrew-npm.md
Install node & npm on Mac OS X with Homebrew
View node-npm-install.md

DEPRECATED as of macOS 10.13 (High Sierra). See the new GUIDE to install nvm and yarn for macOS (updated July 2019)

Fixing npm On Mac OS X for Homebrew Users

Installing node through Homebrew can cause problems with npm for globally installed packages. To fix it quickly, use the solution below. An explanation is also included at the end of this document.

Solution

This solution fixes the error caused by trying to run npm update npm -g. Once you're finished, you also won't need to use sudo to install npm modules globally.

View gist:9156714
### Keybase proof
I hereby claim:
* I am rcugut on github.
* I am rcugut (https://keybase.io/rcugut) on keybase.
* I have the public key with fingerprint 49B2 A3CE FF95 3606 5A31  1410 DAED 56B9 5209 F839
To claim this, I am signing this object:
You can’t perform that action at this time.