public
Last active — forked from indirect/Gemfile

  • Download Gist
Gemfile
Ruby
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
# include at least one source and the rails gem
source :gemcutter
gem 'rails', '~> 2.3.5', :require => nil
gem 'sqlite3-ruby', :require => 'sqlite3'
 
# Devise 1.0.2 is not a valid gem plugin for Rails, so use git until 1.0.3
# gem 'devise', :git => 'git://github.com/plataformatec/devise.git', :ref => 'v1.0'
 
group :development do
# bundler requires these gems in development
gem 'rails-footnotes'
end
 
group :test do
# bundler requires these gems while running tests
gem 'rspec'
end
boot.rb
Ruby
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
# add this to the bottom of config/boot.rb, before the line `Rails.boot!`
 
class Rails::Boot
def run
load_initializer
 
Rails::Initializer.class_eval do
def load_gems
@bundler_loaded ||= Bundler.require :default, Rails.env
end
end
 
Rails::Initializer.run(:set_load_path)
end
end
preinitializer.rb
Ruby
1 2 3 4 5 6 7 8 9 10 11 12 13
begin
require "rubygems"
require "bundler"
 
if Gem::Version.new(Bundler::VERSION) <= Gem::Version.new("0.9.20")
raise RuntimeError, "Your bundler version is too old." +
"Run `gem install bundler` to upgrade."
end
 
# Set up load paths for all bundled gems
ENV["BUNDLE_GEMFILE"] = File.expand_path("../../Gemfile", __FILE__)
Bundler.setup
end

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.