Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
rytse@rytse-VirtualBox:~$ sudo apt install libgtk2.0-dev libgtk2.0-0
[sudo] password for rytse:
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgtk2.0-0 is already the newest version (2.24.30-1ubuntu1.16.04.2).
The following package was automatically installed and is no longer required:
libllvm5.0
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
debhelper dh-strip-nondeterminism gir1.2-gtk-2.0 libatk1.0-dev
libcairo-script-interpreter2 libcairo2-dev libfile-stripnondeterminism-perl
libfontconfig1-dev libfreetype6-dev libgdk-pixbuf2.0-dev libglib2.0-dev
libharfbuzz-dev libharfbuzz-gobject0 libice-dev libmail-sendmail-perl
libpango1.0-dev libpcre3-dev libpcre32-3 libpcrecpp0v5 libpixman-1-dev
libpng12-dev libsm-dev libsys-hostname-long-perl libxcb-shm0-dev
libxcomposite-dev libxcursor-dev libxft-dev libxi-dev libxinerama-dev
libxml2-utils libxrandr-dev libxrender-dev po-debconf x11proto-composite-dev
x11proto-randr-dev x11proto-render-dev x11proto-xinerama-dev
Suggested packages:
dh-make libcairo2-doc libglib2.0-doc libgtk2.0-doc libice-doc
libpango1.0-doc libsm-doc libmail-box-perl
The following NEW packages will be installed:
debhelper dh-strip-nondeterminism gir1.2-gtk-2.0 libatk1.0-dev
libcairo-script-interpreter2 libcairo2-dev libfile-stripnondeterminism-perl
libfontconfig1-dev libfreetype6-dev libgdk-pixbuf2.0-dev libglib2.0-dev
libgtk2.0-dev libharfbuzz-dev libharfbuzz-gobject0 libice-dev
libmail-sendmail-perl libpango1.0-dev libpcre3-dev libpcre32-3 libpcrecpp0v5
libpixman-1-dev libpng12-dev libsm-dev libsys-hostname-long-perl
libxcb-shm0-dev libxcomposite-dev libxcursor-dev libxft-dev libxi-dev
libxinerama-dev libxml2-utils libxrandr-dev libxrender-dev po-debconf
x11proto-composite-dev x11proto-randr-dev x11proto-render-dev
x11proto-xinerama-dev
0 upgraded, 38 newly installed, 0 to remove and 0 not upgraded.
Need to get 9,634 kB of archives.
After this operation, 52.4 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libpcrecpp0v5 amd64 2:8.38-3.1 [15.2 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 po-debconf all 1.0.19 [234 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libfile-stripnondeterminism-perl all 0.015-1 [10.3 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 dh-strip-nondeterminism all 0.015-1 [4,864 B]
Get:5 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 debhelper all 9.20160115ubuntu3 [739 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 gir1.2-gtk-2.0 amd64 2.24.30-1ubuntu1.16.04.2 [172 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 gir1.2-gtk-2.0 amd64 2.24.30-1ubuntu1.16.04.2 [172 kB]
Get:8 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libpcre32-3 amd64 2:8.38-3.1 [136 kB]
Get:8 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libpcre32-3 amd64 2:8.38-3.1 [136 kB]
Get:10 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libpcre3-dev amd64 2:8.38-3.1 [525 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libglib2.0-dev amd64 2.48.2-0ubuntu4 [1,375 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libatk1.0-dev amd64 2.18.0-1 [79.5 kB]
Get:13 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libcairo-script-interpreter2 amd64 1.14.6-1 [54.3 kB]
Get:14 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libpng12-dev amd64 1.2.54-1ubuntu1.1 [183 kB]
Get:15 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libfreetype6-dev amd64 2.6.1-0.1ubuntu2.3 [956 kB]
Get:16 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libxrender-dev amd64 1:0.9.9-0ubuntu1 [24.5 kB]
Get:17 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libice-dev amd64 2:1.0.9-1 [44.9 kB]
Get:18 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libsm-dev amd64 2:1.2.2-1 [16.2 kB]
Get:19 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libpixman-1-dev amd64 0.33.6-1 [248 kB]
Get:20 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libxcb-shm0-dev amd64 1.11.1-1ubuntu1 [6,604 B]
Get:21 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libcairo2-dev amd64 1.14.6-1 [590 kB]
Get:22 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libgdk-pixbuf2.0-dev amd64 2.32.2-1ubuntu1.5 [44.4 kB]
Get:23 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libharfbuzz-gobject0 amd64 1.0.1-1ubuntu0.1 [10.9 kB]
Get:24 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libharfbuzz-dev amd64 1.0.1-1ubuntu0.1 [189 kB]
Get:25 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libxft-dev amd64 2.3.2-1 [45.7 kB]
Get:26 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libpango1.0-dev amd64 1.38.1-1 [277 kB]
Get:27 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 x11proto-xinerama-dev all 1.2.1-2 [4,966 B]
Get:28 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libxinerama-dev amd64 2:1.1.3-1 [8,404 B]
Get:29 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libxi-dev amd64 2:1.7.6-1 [184 kB]
Get:30 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 x11proto-randr-dev all 1.5.0-1 [33.7 kB]
Get:31 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libxrandr-dev amd64 2:1.5.0-1 [23.7 kB]
Get:32 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libxcursor-dev amd64 1:1.1.14-1ubuntu0.16.04.2 [26.4 kB]
Get:33 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 x11proto-composite-dev all 1:0.4.2-2 [10.5 kB]
Get:34 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libxcomposite-dev amd64 1:0.4.4-1 [9,954 B]
Get:35 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libxml2-utils amd64 2.9.3+dfsg1-1ubuntu0.5 [35.0 kB]
Get:36 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libgtk2.0-dev amd64 2.24.30-1ubuntu1.16.04.2 [2,598 kB]
Get:37 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libsys-hostname-long-perl all 1.5-1 [11.7 kB]
Get:38 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libmail-sendmail-perl all 0.79.16-1 [26.5 kB]
Fetched 9,634 kB in 2min 5s (76.7 kB/s)
Extracting templates from packages: 100%
Selecting previously unselected package libpcrecpp0v5:amd64.
(Reading database ... 242456 files and directories currently installed.)
Preparing to unpack .../libpcrecpp0v5_2%3a8.38-3.1_amd64.deb ...
Unpacking libpcrecpp0v5:amd64 (2:8.38-3.1) ...
Selecting previously unselected package po-debconf.
Preparing to unpack .../po-debconf_1.0.19_all.deb ...
Unpacking po-debconf (1.0.19) ...
Selecting previously unselected package libfile-stripnondeterminism-perl.
Preparing to unpack .../libfile-stripnondeterminism-perl_0.015-1_all.deb ...
Unpacking libfile-stripnondeterminism-perl (0.015-1) ...
Selecting previously unselected package dh-strip-nondeterminism.
Preparing to unpack .../dh-strip-nondeterminism_0.015-1_all.deb ...
Unpacking dh-strip-nondeterminism (0.015-1) ...
Selecting previously unselected package debhelper.
Preparing to unpack .../debhelper_9.20160115ubuntu3_all.deb ...
Unpacking debhelper (9.20160115ubuntu3) ...
Selecting previously unselected package gir1.2-gtk-2.0.
Preparing to unpack .../gir1.2-gtk-2.0_2.24.30-1ubuntu1.16.04.2_amd64.deb ...
Unpacking gir1.2-gtk-2.0 (2.24.30-1ubuntu1.16.04.2) ...
Selecting previously unselected package libpcre32-3:amd64.
Preparing to unpack .../libpcre32-3_2%3a8.38-3.1_amd64.deb ...
Unpacking libpcre32-3:amd64 (2:8.38-3.1) ...
Selecting previously unselected package libpcre3-dev:amd64.
Preparing to unpack .../libpcre3-dev_2%3a8.38-3.1_amd64.deb ...
Unpacking libpcre3-dev:amd64 (2:8.38-3.1) ...
Selecting previously unselected package libglib2.0-dev.
Preparing to unpack .../libglib2.0-dev_2.48.2-0ubuntu4_amd64.deb ...
Unpacking libglib2.0-dev (2.48.2-0ubuntu4) ...
Selecting previously unselected package libatk1.0-dev.
Preparing to unpack .../libatk1.0-dev_2.18.0-1_amd64.deb ...
Unpacking libatk1.0-dev (2.18.0-1) ...
Selecting previously unselected package libcairo-script-interpreter2:amd64.
Preparing to unpack .../libcairo-script-interpreter2_1.14.6-1_amd64.deb ...
Unpacking libcairo-script-interpreter2:amd64 (1.14.6-1) ...
Selecting previously unselected package libpng12-dev:amd64.
Preparing to unpack .../libpng12-dev_1.2.54-1ubuntu1.1_amd64.deb ...
Unpacking libpng12-dev:amd64 (1.2.54-1ubuntu1.1) ...
Selecting previously unselected package libfreetype6-dev:amd64.
Preparing to unpack .../libfreetype6-dev_2.6.1-0.1ubuntu2.3_amd64.deb ...
Unpacking libfreetype6-dev:amd64 (2.6.1-0.1ubuntu2.3) ...
Selecting previously unselected package libfontconfig1-dev:amd64.
Preparing to unpack .../libfontconfig1-dev_2.11.94-0ubuntu1.1_amd64.deb ...
Unpacking libfontconfig1-dev:amd64 (2.11.94-0ubuntu1.1) ...
Selecting previously unselected package x11proto-render-dev.
Preparing to unpack .../x11proto-render-dev_2%3a0.11.1-2_all.deb ...
Unpacking x11proto-render-dev (2:0.11.1-2) ...
Selecting previously unselected package libxrender-dev:amd64.
Preparing to unpack .../libxrender-dev_1%3a0.9.9-0ubuntu1_amd64.deb ...
Unpacking libxrender-dev:amd64 (1:0.9.9-0ubuntu1) ...
Selecting previously unselected package libice-dev:amd64.
Preparing to unpack .../libice-dev_2%3a1.0.9-1_amd64.deb ...
Unpacking libice-dev:amd64 (2:1.0.9-1) ...
Selecting previously unselected package libsm-dev:amd64.
Preparing to unpack .../libsm-dev_2%3a1.2.2-1_amd64.deb ...
Unpacking libsm-dev:amd64 (2:1.2.2-1) ...
Selecting previously unselected package libpixman-1-dev.
Preparing to unpack .../libpixman-1-dev_0.33.6-1_amd64.deb ...
Unpacking libpixman-1-dev (0.33.6-1) ...
Selecting previously unselected package libxcb-shm0-dev:amd64.
Preparing to unpack .../libxcb-shm0-dev_1.11.1-1ubuntu1_amd64.deb ...
Unpacking libxcb-shm0-dev:amd64 (1.11.1-1ubuntu1) ...
Selecting previously unselected package libcairo2-dev.
Preparing to unpack .../libcairo2-dev_1.14.6-1_amd64.deb ...
Unpacking libcairo2-dev (1.14.6-1) ...
Selecting previously unselected package libgdk-pixbuf2.0-dev.
Preparing to unpack .../libgdk-pixbuf2.0-dev_2.32.2-1ubuntu1.5_amd64.deb ...
Unpacking libgdk-pixbuf2.0-dev (2.32.2-1ubuntu1.5) ...
Selecting previously unselected package libharfbuzz-gobject0:amd64.
Preparing to unpack .../libharfbuzz-gobject0_1.0.1-1ubuntu0.1_amd64.deb ...
Unpacking libharfbuzz-gobject0:amd64 (1.0.1-1ubuntu0.1) ...
Selecting previously unselected package libharfbuzz-dev.
Preparing to unpack .../libharfbuzz-dev_1.0.1-1ubuntu0.1_amd64.deb ...
Unpacking libharfbuzz-dev (1.0.1-1ubuntu0.1) ...
Selecting previously unselected package libxft-dev.
Preparing to unpack .../libxft-dev_2.3.2-1_amd64.deb ...
Unpacking libxft-dev (2.3.2-1) ...
Selecting previously unselected package libpango1.0-dev.
Preparing to unpack .../libpango1.0-dev_1.38.1-1_amd64.deb ...
Unpacking libpango1.0-dev (1.38.1-1) ...
Selecting previously unselected package x11proto-xinerama-dev.
Preparing to unpack .../x11proto-xinerama-dev_1.2.1-2_all.deb ...
Unpacking x11proto-xinerama-dev (1.2.1-2) ...
Selecting previously unselected package libxinerama-dev:amd64.
Preparing to unpack .../libxinerama-dev_2%3a1.1.3-1_amd64.deb ...
Unpacking libxinerama-dev:amd64 (2:1.1.3-1) ...
Selecting previously unselected package libxi-dev.
Preparing to unpack .../libxi-dev_2%3a1.7.6-1_amd64.deb ...
Unpacking libxi-dev (2:1.7.6-1) ...
Selecting previously unselected package x11proto-randr-dev.
Preparing to unpack .../x11proto-randr-dev_1.5.0-1_all.deb ...
Unpacking x11proto-randr-dev (1.5.0-1) ...
Selecting previously unselected package libxrandr-dev:amd64.
Preparing to unpack .../libxrandr-dev_2%3a1.5.0-1_amd64.deb ...
Unpacking libxrandr-dev:amd64 (2:1.5.0-1) ...
Selecting previously unselected package libxcursor-dev:amd64.
Preparing to unpack .../libxcursor-dev_1%3a1.1.14-1ubuntu0.16.04.2_amd64.deb ...
Unpacking libxcursor-dev:amd64 (1:1.1.14-1ubuntu0.16.04.2) ...
Selecting previously unselected package x11proto-composite-dev.
Preparing to unpack .../x11proto-composite-dev_1%3a0.4.2-2_all.deb ...
Unpacking x11proto-composite-dev (1:0.4.2-2) ...
Selecting previously unselected package libxcomposite-dev.
Preparing to unpack .../libxcomposite-dev_1%3a0.4.4-1_amd64.deb ...
Unpacking libxcomposite-dev (1:0.4.4-1) ...
Selecting previously unselected package libxml2-utils.
Preparing to unpack .../libxml2-utils_2.9.3+dfsg1-1ubuntu0.5_amd64.deb ...
Unpacking libxml2-utils (2.9.3+dfsg1-1ubuntu0.5) ...
Selecting previously unselected package libgtk2.0-dev.
Preparing to unpack .../libgtk2.0-dev_2.24.30-1ubuntu1.16.04.2_amd64.deb ...
Unpacking libgtk2.0-dev (2.24.30-1ubuntu1.16.04.2) ...
Selecting previously unselected package libsys-hostname-long-perl.
Preparing to unpack .../libsys-hostname-long-perl_1.5-1_all.deb ...
Unpacking libsys-hostname-long-perl (1.5-1) ...
Selecting previously unselected package libmail-sendmail-perl.
Preparing to unpack .../libmail-sendmail-perl_0.79.16-1_all.deb ...
Unpacking libmail-sendmail-perl (0.79.16-1) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for doc-base (0.10.7) ...
Processing 3 added doc-base files...
Processing triggers for libglib2.0-0:amd64 (2.48.2-0ubuntu4) ...
Setting up libpcrecpp0v5:amd64 (2:8.38-3.1) ...
Setting up po-debconf (1.0.19) ...
Setting up libfile-stripnondeterminism-perl (0.015-1) ...
Setting up gir1.2-gtk-2.0 (2.24.30-1ubuntu1.16.04.2) ...
Setting up libpcre32-3:amd64 (2:8.38-3.1) ...
Setting up libpcre3-dev:amd64 (2:8.38-3.1) ...
Setting up libglib2.0-dev (2.48.2-0ubuntu4) ...
Setting up libatk1.0-dev (2.18.0-1) ...
Setting up libcairo-script-interpreter2:amd64 (1.14.6-1) ...
Setting up libpng12-dev:amd64 (1.2.54-1ubuntu1.1) ...
Setting up libfreetype6-dev:amd64 (2.6.1-0.1ubuntu2.3) ...
Setting up libfontconfig1-dev:amd64 (2.11.94-0ubuntu1.1) ...
Setting up x11proto-render-dev (2:0.11.1-2) ...
Setting up libxrender-dev:amd64 (1:0.9.9-0ubuntu1) ...
Setting up libice-dev:amd64 (2:1.0.9-1) ...
Setting up libsm-dev:amd64 (2:1.2.2-1) ...
Setting up libpixman-1-dev (0.33.6-1) ...
Setting up libxcb-shm0-dev:amd64 (1.11.1-1ubuntu1) ...
Setting up libcairo2-dev (1.14.6-1) ...
Setting up libgdk-pixbuf2.0-dev (2.32.2-1ubuntu1.5) ...
Setting up libharfbuzz-gobject0:amd64 (1.0.1-1ubuntu0.1) ...
Setting up libharfbuzz-dev (1.0.1-1ubuntu0.1) ...
Setting up libxft-dev (2.3.2-1) ...
Setting up libpango1.0-dev (1.38.1-1) ...
Setting up x11proto-xinerama-dev (1.2.1-2) ...
Setting up libxinerama-dev:amd64 (2:1.1.3-1) ...
Setting up libxi-dev (2:1.7.6-1) ...
Setting up x11proto-randr-dev (1.5.0-1) ...
Setting up libxrandr-dev:amd64 (2:1.5.0-1) ...
Setting up libxcursor-dev:amd64 (1:1.1.14-1ubuntu0.16.04.2) ...
Setting up x11proto-composite-dev (1:0.4.2-2) ...
Setting up libxcomposite-dev (1:0.4.4-1) ...
Setting up libxml2-utils (2.9.3+dfsg1-1ubuntu0.5) ...
Setting up libgtk2.0-dev (2.24.30-1ubuntu1.16.04.2) ...
Setting up libsys-hostname-long-perl (1.5-1) ...
Setting up libmail-sendmail-perl (0.79.16-1) ...
Setting up dh-strip-nondeterminism (0.015-1) ...
Setting up debhelper (9.20160115ubuntu3) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
W: http://us.archive.ubuntu.com/ubuntu/pool/main/g/gtk+2.0/gir1.2-gtk-2.0_2.24.30-1ubuntu1.16.04.2_amd64.deb: Automatically disabled Acquire::http::Pipeline-Depth due to incorrect response from server/proxy. (man 5 apt.conf)
rytse@rytse-VirtualBox:~$ pybombs prefix init ~/prefix -a myprefix -R gnuradio-default
pybombs: command not found
rytse@rytse-VirtualBox:~$ !source
source venv/bin/activate
(venv) rytse@rytse-VirtualBox:~$ pybombs prefix init ~/prefix -a myprefix -R gnuradio-default
PyBOMBS - INFO - PyBOMBS Version 2.3.2
PyBOMBS.prefix - WARNING - There already is a prefix in `/home/rytse/prefix'.
Continue using this path Y/[N]? y
Alias `myprefix' already exists, overwrite Y/[N]? y
PyBOMBS.prefix - INFO - Installing default packages for prefix...
PyBOMBS.prefix - INFO -
- gnuradio
PyBOMBS.Packager.apt - INFO - Install python-apt to speed up apt processing.
PyBOMBS.install_manager - INFO - Phase 1: Creating install tree and installing binary packages:
Install tree:
|
\- gnuradio
PyBOMBS.install_manager - INFO - Phase 2: Recursively installing source packages to prefix:
PyBOMBS.install_manager - INFO - Installing package: gnuradio
PyBOMBS.Packager.apt - INFO - Install python-apt to speed up apt processing.
PyBOMBS.Packager.source - WARNING - Build dir already exists: /home/rytse/prefix/src/gnuradio/build
Configuring: (100%) [=========================================================]
PyBOMBS.Packager.source - WARNING - Configuration failed. Re-trying with higher verbosity.
-- Build type set to RelWithDebInfo.
-- Extracting version information from git describe...
-- Compiler Version: cc (Ubuntu 5.4.0-6ubuntu1~16.04.10) 5.4.0 20160609
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
-- Compiler Flags: /usr/bin/cc:::-O2 -g -DNDEBUG -std=gnu99 -fvisibility=hidden -Wsign-compare -Wall -Wno-uninitialized
/usr/bin/c++:::-O2 -g -DNDEBUG -fvisibility=hidden -Wsign-compare -Wall -Wno-uninitialized
-- ADDING PERF COUNTERS
-- Building Static Libraries: OFF
-- Boost version: 1.58.0
-- Found the following Boost libraries:
-- date_time
-- program_options
-- filesystem
-- system
-- regex
-- thread
-- unit_test_framework
-- chrono
-- atomic
-- Found PythonLibs: /usr/lib/x86_64-linux-gnu/libpython2.7.so (found suitable version "2.7.12", minimum required is "2.7")
--
-- Checking for module SWIG
-- Found SWIG version 2.0.12.
--
-- The build system will automatically enable all components.
-- Use -DENABLE_DEFAULT=OFF to disable components by default.
--
-- Configuring python-support support...
-- Dependency PYTHONLIBS_FOUND = TRUE
-- Dependency SWIG_FOUND = TRUE
-- Dependency SWIG_VERSION_CHECK = TRUE
-- Enabling python-support support.
-- Override with -DENABLE_PYTHON=ON/OFF
--
-- Configuring testing-support support...
-- Dependency Boost_FOUND = 1
-- Enabling testing-support support.
-- Override with -DENABLE_TESTING=ON/OFF
--
-- Configuring VOLK support...
-- Build type set to RelWithDebInfo.
-- Extracting version information from git describe...
--
-- Python checking for python >= 2.7
-- Python checking for python >= 2.7 - found
--
-- Python checking for mako >= 0.4.2
-- Python checking for mako >= 0.4.2 - found
--
-- Python checking for six - python 2 and 3 compatibility library
-- Python checking for six - python 2 and 3 compatibility library - found
-- Boost version: 1.58.0
-- Found the following Boost libraries:
-- filesystem
-- system
-- Checking for module 'orc-0.4 > 0.4.11'
-- No package 'orc-0.4' found
-- orc files (missing: ORC_LIBRARY ORC_INCLUDE_DIR ORCC_EXECUTABLE)
-- QA Testing is enabled.
-- Modify using: -DENABLE_TESTING=ON/OFF
-- System profiling is disabled.
-- Modify using: -DENABLE_PROFILING=ON/OFF
-- Compiler name: GNU
-- x86* CPU detected
-- ORC support not found, Overruled arch orc
-- CPU width is 64 bits, Overruled arch 32
-- Available architectures: generic;64;3dnow;abm;popcount;mmx;fma;sse;sse2;norc;sse3;ssse3;sse4_a;sse4_1;sse4_2;avx;avx2
-- Available machines: generic;sse2_64_mmx;sse3_64_mmx;ssse3_64_mmx;sse4_a_64_mmx;sse4_1_64_mmx;sse4_2_64_mmx;avx_64_mmx;avx2_64_mmx
-- BUILD TYPE = RELWITHDEBINFO
-- Base cflags = -O2 -g -DNDEBUG -std=gnu99 -fvisibility=hidden -Wsign-compare -Wall -Wno-uninitialized -Wall
-- BUILD INFO ::: generic ::: GNU ::: -O2 -g -DNDEBUG -std=gnu99 -fvisibility=hidden -Wsign-compare -Wall -Wno-uninitialized -Wall
-- BUILD INFO ::: sse2_64_mmx ::: GNU ::: -O2 -g -DNDEBUG -std=gnu99 -fvisibility=hidden -Wsign-compare -Wall -Wno-uninitialized -Wall -m64 -mmmx -msse -msse2
-- BUILD INFO ::: sse3_64_mmx ::: GNU ::: -O2 -g -DNDEBUG -std=gnu99 -fvisibility=hidden -Wsign-compare -Wall -Wno-uninitialized -Wall -m64 -mmmx -msse -msse2 -msse3
-- BUILD INFO ::: ssse3_64_mmx ::: GNU ::: -O2 -g -DNDEBUG -std=gnu99 -fvisibility=hidden -Wsign-compare -Wall -Wno-uninitialized -Wall -m64 -mmmx -msse -msse2 -msse3 -mssse3
-- BUILD INFO ::: sse4_a_64_mmx ::: GNU ::: -O2 -g -DNDEBUG -std=gnu99 -fvisibility=hidden -Wsign-compare -Wall -Wno-uninitialized -Wall -m64 -mmmx -msse -msse2 -msse3 -msse4a -mpopcnt
-- BUILD INFO ::: sse4_1_64_mmx ::: GNU ::: -O2 -g -DNDEBUG -std=gnu99 -fvisibility=hidden -Wsign-compare -Wall -Wno-uninitialized -Wall -m64 -mmmx -msse -msse2 -msse3 -mssse3 -msse4.1
-- BUILD INFO ::: sse4_2_64_mmx ::: GNU ::: -O2 -g -DNDEBUG -std=gnu99 -fvisibility=hidden -Wsign-compare -Wall -Wno-uninitialized -Wall -m64 -mmmx -msse -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -mpopcnt
-- BUILD INFO ::: avx_64_mmx ::: GNU ::: -O2 -g -DNDEBUG -std=gnu99 -fvisibility=hidden -Wsign-compare -Wall -Wno-uninitialized -Wall -m64 -mmmx -msse -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -mpopcnt -mavx
-- BUILD INFO ::: avx2_64_mmx ::: GNU ::: -O2 -g -DNDEBUG -std=gnu99 -fvisibility=hidden -Wsign-compare -Wall -Wno-uninitialized -Wall -m64 -mmmx -msse -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -mpopcnt -mavx -mfma -mavx2
-- Compiler Version: cc (Ubuntu 5.4.0-6ubuntu1~16.04.10) 5.4.0 20160609
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
-- c flags: -std=gnu99 -fvisibility=hidden -Wsign-compare -Wall -Wno-uninitialized -Wall;
-- asm flags:
-- Did not find liborc and orcc, disabling orc support...
-- Loading version 1.4 into constants...
-- Using install prefix: /home/rytse/prefix
--
-- Configuring volk support...
-- Enabling volk support.
-- Override with -DENABLE_VOLK=ON/OFF
-- Override with -DENABLE_INTERNAL_VOLK=ON/OFF
-- ENABLE_GR_LOG set to ON.
-- HAVE_LOG4CPP set to True.
-- LOG4CPP_LIBRARIES set to /usr/lib/liblog4cpp.so.
-- Could NOT find Sphinx (missing: SPHINX_EXECUTABLE)
--
-- Configuring doxygen support...
-- Dependency DOXYGEN_FOUND = YES
-- Disabling doxygen support.
-- Override with -DENABLE_DOXYGEN=ON/OFF
--
-- Configuring sphinx support...
-- Dependency SPHINX_FOUND = FALSE
-- Disabling sphinx support.
-- Override with -DENABLE_SPHINX=ON/OFF
--
-- Configuring gnuradio-runtime support...
-- Dependency Boost_FOUND = 1
-- Dependency ENABLE_VOLK = ON
-- Dependency PYTHONINTERP_FOUND = TRUE
-- Enabling gnuradio-runtime support.
-- Override with -DENABLE_GNURADIO_RUNTIME=ON/OFF
--
-- Configuring gr-ctrlport support...
-- Dependency Boost_FOUND = 1
-- Dependency SWIG_FOUND = TRUE
-- Dependency SWIG_VERSION_CHECK = TRUE
-- Dependency ENABLE_GNURADIO_RUNTIME = ON
-- Enabling gr-ctrlport support.
-- Override with -DENABLE_GR_CTRLPORT=ON/OFF
-- Loading build date Thu, 09 Aug 2018 15:07:52 into constants...
-- Loading version 3.7.12.0 into constants...
--
-- Python checking for Thrift
-- Python checking for Thrift - found
-- Found and enabling Thrift backend to ControlPort
-- Running thrift to build C++ bindings
-- TRY_SHM_VMCIRCBUF set to ON.
-- Found PythonLibs: /usr/lib/x86_64-linux-gnu/libpython2.7.so (found suitable version "2.7.12", minimum required is "2")
--
-- Configuring gr-blocks support...
-- Dependency Boost_FOUND = 1
-- Dependency ENABLE_VOLK = ON
-- Dependency ENABLE_GNURADIO_RUNTIME = ON
-- Enabling gr-blocks support.
-- Override with -DENABLE_GR_BLOCKS=ON/OFF
--
-- Python checking for python >= 2.5
-- Python checking for python >= 2.5 - found
--
-- Python checking for Cheetah >= 2.0.0
-- Python checking for Cheetah >= 2.0.0 - found
--
-- Python checking for lxml >= 1.3.6
-- Python checking for lxml >= 1.3.6 - found
--
-- Python checking for pygtk >= 2.10.0
-- Python checking for pygtk >= 2.10.0 - not found
--
-- Python checking for numpy
-- Python checking for numpy - found
--
-- Configuring gnuradio-companion support...
-- Dependency ENABLE_GNURADIO_RUNTIME = ON
-- Dependency ENABLE_PYTHON = ON
-- Dependency PYTHON_MIN_VER_FOUND = TRUE
-- Dependency CHEETAH_FOUND = TRUE
-- Dependency LXML_FOUND = TRUE
-- Dependency PYGTK_FOUND = FALSE
-- Dependency NUMPY_FOUND = TRUE
CMake Error at cmake/Modules/GrComponent.cmake:75 (message):
user force-enabled gnuradio-companion but configuration checked failed
Call Stack (most recent call first):
grc/CMakeLists.txt:45 (GR_REGISTER_COMPONENT)
-- Configuring incomplete, errors occurred!
See also "/home/rytse/prefix/src/gnuradio/build/CMakeFiles/CMakeOutput.log".
See also "/home/rytse/prefix/src/gnuradio/build/CMakeFiles/CMakeError.log".
PyBOMBS.Packager.source - ERROR - Configuration failed after running at least twice.
PyBOMBS.Packager.source - ERROR - Problem occurred while building package gnuradio:
Configuration failed
PyBOMBS.install_manager - ERROR - Error installing package gnuradio. Aborting.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment